Updates 4.2 stable and testing

Antworten
Benutzeravatar
fkalweit
uib-Team
Beiträge: 132
Registriert: 23 Okt 2020, 16:14

Updates 4.2 stable and testing

Beitrag von fkalweit »

Dear opsi users,

today we have released more packages for opsi 4.2 in testing and stable.

As of version 4.2.0.23-1, the opsi-client-agent installation no longer includes the Kiosk migration. If you have a very old version of opsi-client-agent (< 4.1.1.18) installed on a depot and are using the kiosk, you should install an intermediate version (>=4.1.1.18-1, <= 4.2.0.22-1) on the depot before upgrading to opsi-client-agent >=4.2.0.23-1 in order to migrate the kiosk data to the form used since 2020.

Also included in opsi-client-agent 4.2.0.25-1 and 4.2.0.26-1 are new versions of opsi-deploy-client-agent and oca-installation-helper, which bring some new options for more convenient use and customisability.


stable

linux Localboot

- l-debuntu-upgrade (4.2.0.1-1)
- l-opsi-server (4.2.0.6-3)
- opsi-linux-client-agent (4.2.0.19-1)

Linux Netboot

- mint20-* (4.2.0.1-5)
- SLES15-* (4.2.0.1-7)
- wipedisk (2.3-2)

Windows Netboot:

- wipedisk (2.3-1)

Windows Localboot:

- windows10-upgrade (21h2-2)
- windows11-upgrade (21h2-1)
- opsi-client-agent (4.2.0.25-1)

Mac:

- opsi-mac-client-agent (4.2.0.13-1)

testing:

Windows Localboot:
- opsi-client-agent (4.2.0.26-1)

Server:
- opsi-utils (4.2.0.162-1)
- opsi-server (4.2.0.65-1)



With kind regards
Fabian Kalweit

Changelogs:

Code: Alles auswählen

==============================================================================

windows10-upgrade (21h2-2) testing; urgency=low
    * IMPORTANT: Requires opsiclientd version 4.2.0.104 or higher
    * IMPORTANT: Requires opsi-script version 4.12.4.35-6 or higher
    * Added additional checks for opsiSetupUser leftovers
    * Added check for empty values in Disable UAC section
    * Added include for setupact.log
    * Updated the documentation
    * Tested on win7, win7-x64, win81, win81-x64, win10-2015, win10-x64-2015, win10-2016, win10-x64-2016, win10-2019, win10-x64-2019, win10-2021, win10-x64-2021, win10-21h1, win10-x64-21h1
-- Matthias Knauer <m.knauer@uib.de> Thu, 17 Feb 2022 11:11:11 +0000

==============================================================================

windows11-upgrade (21h2-1) testing; urgency=low
    * IMPORTANT: Requires opsiclientd version 4.2.0.104 or higher
    * IMPORTANT: Requires opsi-script version 4.12.4.35-6 or higher
    * Initial package
    * Tested on win10-21h1, win10-x64-21h1
-- Matthias Knauer <m.knauer@uib.de> Wed, 09 Feb 2022 11:11:11 +0000

==============================================================================

sles12sp4 (4.2.0.1-8) testing; urgency=low

  * added 01_lshw.sh postinst script

 -- Mathias Radtke <m.radtke@uib.de>Thu Mar 17 11:40:00 2022 +0200

==============================================================================

sles12sp3/4/5 (4.2.0.1-7) testing; urgency=low

  * changed linux-client-agent installation

 -- Mathias Radtke <m.radtke@uib.de> Wed Mar 09 08:30:00 2022 +0200

==============================================================================

sles15-1/2/3 (4.2.0.1-7) testing; urgency=low

  * added sle-module-server-applications-update repository in autoyast.xml

 -- Mathias Radtke <m.radtke@uib.de> Wed Mar 09 08:1:00 2022 +0200

==============================================================================

mint20-1/23 (4.2.0.1-5) testing; urgency=low

  * corrected behaviour when using installation_method = reboot

 -- Mathias Radtke <m.radtke@uib.de> Thu Mar 03 10:40:00 2022 +0200

==============================================================================

l-opsi-server (4.2.0.6-3); testing; urgency=low

  * made some adaptations to wotk with UCS5.0-1 Systems

 -- Mathias Radtke <m.radtke@uib.de> Tue, 01 Feb 2022 17:08:00 +0200

l-opsi-server (4.2.0.6-2); testing; urgency=low

  * opening port 445 on UCS Systems

 -- Mathias Radtke <m.radtke@uib.de> Fri, 07 Jan 2022 11:46:00 +0200

l-opsi-server (4.2.0.6-1); testing; urgency=low

  * added support for UCS 5.0 

 -- Mathias Radtke <m.radtke@uib.de> Fri, 17 Dec 2021 10:50:00 +0200
l-opsi-server (4.2.0.5-2); testing; urgency=low

  * fixed error with l-opsi-server-quick-install

 -- Mathias Radtke <m.radtke@uib.de> Thu, 30 Sep 2021 12:00:00 +0200

==============================================================================

l-debuntu-upgrade (4.2.0.1-1) stable; urgency=low

  * added support for LinuxMint upgrades

 -- Mathias Radtke <m.radtke@uib.de> Mon, 21 Feb 2021 14:00:00 +020

==============================================================================

wipedisk (2.3-1) testing; urgency=low

  * checking if NVME can be wiped
  * running sgdisk --zap-all anyway

 -- Mathias Radtke <m.radtke@uib.de> Tue Mar 01 2022 09:45:00 +0200

==============================================================================

opsi-client-agent (4.2.0.26-1) stable; urgency=low

  * Fixed version registry setting
  * Updated opsiclientd to 4.2.0.111 (collectLogfiles feature, fixed multithreaded certificate access)
  * Updated opsi-deploy-client-agent to 4.2.0.19 (improved logging, reporting failure reasons --failed-clients-file)

-- Nils Doerrer <n.doerrer@uib.de> Wed, 16 Mar 2022 10:00:00 +0100

opsi-client-agent (4.2.0.25-1) stable; urgency=low

  * Added version file opsi-client-agent.version for conditioned installation
  * Fixed postinst for first time installation
  * Updated oca-installation-helper to 4.2.0.16 (new parameter --install-condition)

-- Nils Doerrer <n.doerrer@uib.de> Thu, 24 Feb 2022 16:00:00 +0100

opsi-client-agent (4.2.0.24-1) stable; urgency=low

  * Updated opsiclientd to 4.2.0.110 (fixed jsonrpc logging)

-- Nils Doerrer <n.doerrer@uib.de> Thu, 24 Feb 2022 16:00:00 +0100

opsi-client-agent (4.2.0.23-1) stable; urgency=low

  * Updated oca-installation-helper to 4.2.0.15 (new parameters --dns-domain, --finalize, --read-conf-files)
  * Updated opsi-deploy-client-agent 4.2.0.18 (suse fix for smbclient call)
  * Updated opsiclientd to 4.2.0.109 (reworked opsi-setup-user cleanup and service connection timeouts)
  * Removed Kiosk Migration. Do not install this package over opsi-client-agent < 4.1.1.18 (serverside) if using kiosk!

-- Nils Doerrer <n.doerrer@uib.de> Tue, 08 Feb 2022 11:00:00 +0100

==============================================================================

opsi-linux-client-agent (4.2.0.19-1) testing; urgency=low

  * Added version file opsi-client-agent.version for conditioned installation
  * Fixed session-handling for Installation service calls
  * Updated oca-installation-helper to 4.2.0.16

-- Nils Doerrer <n.doerrer@uib.de> Mon, 07 Mar 2022 14:00:00 +0100

opsi-linux-client-agent (4.2.0.18-1) testing; urgency=low

  * Updated opsiclientd to 4.2.0.110 (fixed jsonrpc logging)

-- Nils Doerrer <n.doerrer@uib.de> Thu, 24 Feb 2022 16:00:00 +0100

opsi-linux-client-agent (4.2.0.17-1) testing; urgency=low

  * Updated opsiclientd to 4.2.0.109 (reworked opsi-setup-user cleanup and service connection timeouts)
  * Updated oca-installation-helper to 4.2.0.15 (new parameters --dns-domain, --finalize, --read-conf-files)
  * Updated opsi-deploy-client-agent 4.2.0.18 (suse fix for smbclient call)

-- Nils Doerrer <n.doerrer@uib.de> Thu, 24 Feb 2022 10:00:00 +0100

==============================================================================

opsi-mac-client-agent (4.2.0.13-1) stable; urgency=low

  * Added version file opsi-client-agent.version for conditioned installation
  * Fixed session-handling for Installation service calls
  * Updated oca-installation-helper to 4.2.0.16

-- Nils Doerrer <n.doerrer@uib.de> Mon, 07 Mar 2022 18:00:00 +0100

opsi-mac-client-agent (4.2.0.12-1) stable; urgency=low

  * Updated opsiclientd to 4.2.0.110 (fixed jsonrpc logging)

-- Nils Doerrer <n.doerrer@uib.de> Thu, 24 Feb 2022 16:00:00 +0100

opsi-mac-client-agent (4.2.0.11-1) stable; urgency=low

  * Updated opsiclientd to 4.2.0.109 (fixed user_logged_in check, reworked opsi-setup-user cleanup and service connection timeouts)
  * Updated oca-installation-helper to 4.2.0.15 (new parameters --dns-domain, --finalize, --read-conf-files)
  * Updated opsi-deploy-client-agent 4.2.0.18 (suse fix for smbclient call)

-- Nils Doerrer <n.doerrer@uib.de> Thu, 17 Feb 2022 16:30:00 +0100

==============================================================================
Antworten