Opsi Newbie Stuck

spar1grep
Beiträge: 4
Registriert: 05 Jun 2017, 16:20

Opsi Newbie Stuck

Beitragvon spar1grep » 23 Mär 2018, 16:35

Hello,
I am new to Opsi having used Altiris for many years, I have managed to build the server, setup the environment and I am now looking into creating a Windows 10 build, following the instructions in the user guide I am stuck on performing a hardware inventory. I have added the new client to Opsi and booted using the PXE boot image and got to the stage where I now select hwinvent (which is pre-selected I guess because of the requested action within the client Netboot product configuration). However every time I try this I get the error /mnt/opsi/hwinvent/hwinvent.py'. I have performed a search within the OS console and the hwinvent.py file exists at /var/lib/opsi/depot/hwinvent/hwinvent.py. I am guessing it is to do with Samba somehow, but I cannot see anything on the client that will allow me to identify the reason why the client is not finding the file (nb I have also ran opsi-product-update -i --vv and also opsi-setup --set-rights but with no success).

Thanks.

uncle_scrooge
Beiträge: 553
Registriert: 21 Feb 2012, 12:03
Wohnort: Mainz

Re: Opsi Newbie Stuck

Beitragvon uncle_scrooge » 26 Mär 2018, 18:59

where I now select hwinvent

Pls, post a screenshot of this stage. (Sounds strange....)

When it fails, you are presented with a login prompt. Login with root/linux123. And check /tmp/log (log is a file, not a directory)
Post the log here.

Benutzeravatar
n.wenselowski
Beiträge: 3059
Registriert: 04 Apr 2013, 12:15

Re: Opsi Newbie Stuck

Beitragvon n.wenselowski » 28 Mär 2018, 10:33

Hi,

can you give us some more information about your server, please?
What distro are you using? Could selinux be the source of this problem?


Kind regards

Niko
opsi support - uib gmbh
For productive opsi installations we recommend support contracts.