Configed not working after upgrade (Ubuntu server 18-->20)

Antworten
Julez
Beiträge: 5
Registriert: 07 Sep 2020, 15:22

Configed not working after upgrade (Ubuntu server 18-->20)

Beitrag von Julez »

Error
Error
opsierror.JPG (95.89 KiB) 248 mal betrachtet
Hi, worked like a charm past 2 years. Made OS upgrade and updates and then it stopped letting in via https, server desktop (localhost) and client. Also new client installs stuck on same screen, attached a screenshot. Are there any commands to check and validate the current configuration or run a health-check/autofix to find problems? Opsi 4.1 in use i think.Thanks in advance!
Benutzeravatar
wolfbardo
uib-Team
Beiträge: 1288
Registriert: 01 Jul 2008, 12:10

Re: Configed not working after upgrade (Ubuntu server 18-->20)

Beitrag von wolfbardo »

opsi 4.1 is not supported under Ubuntu 20.04

Please upgrade to opsi 4.2

https://download.uib.de/opsi4.2/documen ... tes-en.pdf

regards
bardo wolf


Jetzt anmelden zur
https://www.opsiconf.org/home Mainz 2./3.Juni 2022



opsi support - uib gmbh
For productive opsi installations we recommend maintainance + support contracts which are the base of opsi development.

http://www.uib.de
Julez
Beiträge: 5
Registriert: 07 Sep 2020, 15:22

Re: Configed not working after upgrade (Ubuntu server 18-->20)

Beitrag von Julez »

wolfbardo hat geschrieben: 13 Jun 2022, 14:59 opsi 4.1 is not supported under Ubuntu 20.04

Please upgrade to opsi 4.2

https://download.uib.de/opsi4.2/documen ... tes-en.pdf

regards
bardo wolf
Hi and thanks for pointing right direction. At 4.3 in manual i get errors and missing command/services in current setup while trying to upgrage. Is there any way to check current configuration and maybe autorepair about all needed services etc?

I don't mind if the server needs to be reinstalled/configured, but current settings with software and client information must stay. 2 years from last configuration change so i remember just bits about configs in opsi:/
Benutzeravatar
j.schneider
uib-Team
Beiträge: 1583
Registriert: 29 Mai 2008, 15:14

Re: Configed not working after upgrade (Ubuntu server 18-->20)

Beitrag von j.schneider »

What are the error messages?
Julez
Beiträge: 5
Registriert: 07 Sep 2020, 15:22

Re: Configed not working after upgrade (Ubuntu server 18-->20)

Beitrag von Julez »

j.schneider hat geschrieben: 14 Jun 2022, 10:22 What are the error messages?
Welcome to Ubuntu 20.04.4 LTS (GNU/Linux 5.4.0-117-generic x86_64)

* Documentation: https://help.ubuntu.com
* Management: https://landscape.canonical.com
* Support: https://ubuntu.com/advantage

0 updates can be applied immediately.

Last login: Mon Jun 13 14:06:14 2022 from 192.168.4.63
adminuser@opsi:~$ sudo apt-get install -y apt-transport-https software-properties-common wget gnupg
[sudo] password for adminuser:
Reading package lists... Done
Building dependency tree
Reading state information... Done
gnupg is already the newest version (2.2.19-3ubuntu2.1).
gnupg set to manually installed.
software-properties-common is already the newest version (0.99.9.8).
software-properties-common set to manually installed.
wget is already the newest version (1.20.3-1ubuntu2)
The following NEW packages will be installed:
apt-transport-https
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 1,704 B of archives.
After this operation, 162 kB of additional disk space will be used.
Get:1 http://de.archive.ubuntu.com/ubuntu focal-updates/universe amd64 apt-transport-https all 2.0.8 [1,704 B]
Fetched 1,704 B in 0s (7,415 B/s)
Selecting previously unselected package apt-transport-https.
(Reading database ... 281954 files and directories currently installed.)
Preparing to unpack .../apt-transport-https_2.0.8_all.deb ...
Unpacking apt-transport-https (2.0.8) ...
Setting up apt-transport-https (2.0.8) ...
adminuser@opsi:~$ wget -q -O - https://packages.grafana.com/gpg.key | sudo apt-key add -
OK
adminuser@opsi:~$ echo "deb https://packages.grafana.com/oss/deb stable main" > /etc/apt/sources.list.d/grafana.list
-bash: /etc/apt/sources.list.d/grafana.list: Permission denied
adminuser@opsi:~$ sudo echo "deb https://packages.grafana.com/oss/deb stable main" > /etc/apt/sources.list.d/grafana.list
-bash: /etc/apt/sources.list.d/grafana.list: Permission denied
adminuser@opsi:~$ echo "deb http://download.opensuse.org/repositori ... ntu_20.04/ /" > /etc/apt/sources.list.d/opsi.list
-bash: /etc/apt/sources.list.d/opsi.list: Permission denied
adminuser@opsi:~$ sudo echo "deb http://download.opensuse.org/repositori ... ntu_20.04/ /" > /etc/apt/sources.list.d/opsi.list
-bash: /etc/apt/sources.list.d/opsi.list: Permission denied
adminuser@opsi:~$ wget -q -O - https://download.opensuse.org/repositor ... elease.key | sudo apt-key add -
OK

adminuser@opsi:~$ sudo apt update
Hit:1 http://de.archive.ubuntu.com/ubuntu focal InRelease
Get:2 http://de.archive.ubuntu.com/ubuntu focal-updates InRelease [114 kB]
Get:3 http://security.ubuntu.com/ubuntu focal-security InRelease [114 kB]
Get:4 http://de.archive.ubuntu.com/ubuntu focal-backports InRelease [108 kB]
Get:5 http://de.archive.ubuntu.com/ubuntu focal-updates/main amd64 DEP-11 Metadata [278 kB]
Get:6 http://de.archive.ubuntu.com/ubuntu focal-updates/universe amd64 DEP-11 Metadata [390 kB]
Get:7 http://de.archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 DEP-11 Metadata [944 B]
Get:8 http://de.archive.ubuntu.com/ubuntu focal-backports/main amd64 DEP-11 Metadata [7,968 B]
Get:9 http://de.archive.ubuntu.com/ubuntu focal-backports/universe amd64 DEP-11 Metadata [30.5 kB]
Fetched 1,044 kB in 1s (1,425 kB/s)
Reading package lists... Done
Building dependency tree
Reading state information... Done
All packages are up to date.
adminuser@opsi:~$ sudo apt install opsi-server-full
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package opsi-server-full
adminuser@opsi:~$ sudo apt install redis-server redis-timeseries grafana
Reading package lists... Done
Building dependency tree
Reading state information... Done

No apt package "grafana", but there is a snap with that name.
Try "snap install grafana"

E: Unable to locate package redis-timeseries
E: Unable to locate package grafana
adminuser@opsi:~$ sudo snap install grafana
2022-06-14T09:54:18+02:00 INFO Waiting for automatic snapd restart...
grafana 6.7.4 from Alvaro Uría (aluria) installed
adminuser@opsi:~$ sudo apt install redis-server redis-timeseries grafana
Reading package lists... Done
Building dependency tree
Reading state information... Done

No apt package "grafana", but there is a snap with that name.
Try "snap install grafana"

E: Unable to locate package redis-timeseries
E: Unable to locate package grafana
adminuser@opsi:~$ sudo systemctl daemon-reload
adminuser@opsi:~$ sudo systemctl enable grafana-server
Failed to enable unit: Unit file grafana-server.service does not exist.
adminuser@opsi:~$ sudo systemctl start grafana-server
Failed to start grafana-server.service: Unit grafana-server.service not found.
adminuser@opsi:~$ sudo apt dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
adminuser@opsi:~$ sudo opsi-package-updater -v update
sudo: opsi-package-updater: command not found
adminuser@opsi:~$ Welcome to Ubuntu 20.04.4 LTS (GNU/Linux 5.4.0-117-generic x86_64)
Need to get 1,704 B of archives.
After this operation, 162 kB of additional disk space will be used.
Get:1 http://de.archive.ubuntu.com/ubuntu focal-updates/universe amd64 apt-transport-https all 2.0.8 [1,704 B]
-bash: syntax error near unexpected token `('
Fetched 1,704 B in 0s (7,415 B/s)
Selecting previously unselected package apt-transport-https.
adminuser@opsi:~$
adminuser@opsi:~$ * Documentation: https://help.ubuntu.com
-bash: /etc/apt/sources.list.d/grafana.list: Permission denied
adminuser@opsi:~$ sudo echo "deb https://packages.grafana.com/oss/deb stable main" > /etc/apt/sources.list.d/grafana.list
-bash: /etc/apt/sources.list.d/grafana.list: Permission denied
adminuser@opsi:~$ echo "deb http://download.opensuse.org/repositori ... ntu_20.04/ /" > /etc/apt/sources.list.d/opsi.list
-bash: /etc/apt/sources.list.d/opsi.list: Permission denied
adminuser@opsi:~$ sudo echo "deb http://download.opensuse.org/repositori ... ntu_20.04/ /" > /etc/apt/sources.list.d/opsi.list
-bash: /etc/apt/sources.list.d/opsi.list: Permission denied
adminuser@opsi:~$ wget -q -O - https://download.opensuse.org/repositor ... elease.key | sudo apt-key add -
OK
Desktop: command not found
adminuser@opsi:~$ * Management: https://landscape.canonical.com
Desktop: command not found
adminuser@opsi:~$ * Support: https://ubuntu.com/advantage
Desktop: command not found
adminuser@opsi:~$
adminuser@opsi:~$ 0 updates can be applied immediately.
0: command not found
adminuser@opsi:~$
adminuser@opsi:~$ Last login: Mon Jun 13 14:06:14 2022 from 192.168.4.63

Command 'Last' not found, did you mean:

command 'fast' from snap fast (0.0.4)
command 'ast' from deb jruby (9.1.17.0-3build6)
command 'last' from deb util-linux (2.34-0.1ubuntu9.3)
command 'nast' from deb nast (0.2.0-7build1)

See 'snap info <snapname>' for additional versions.

adminuser@opsi:~$ adminuser@opsi:~$ sudo apt-get install -y apt-transport-https software-properties-common wget gnupg
adminuser@opsi:~$: command not found
adminuser@opsi:~$ [sudo] password for adminuser:
[sudo]: command not found
adminuser@opsi:~$ Reading package lists... Done
Reading: command not found
adminuser@opsi:~$ Building dependency tree
Building: command not found
adminuser@opsi:~$ Reading state information... Done
Reading: command not found
adminuser@opsi:~$ gnupg is already the newest version (2.2.19-3ubuntu2.1).
-bash: syntax error near unexpected token `('
adminuser@opsi:~$ gnupg set to manually installed.

Command 'gnupg' not found, did you mean:

command 'gnubg' from deb gnubg (1.06.002-4build1)

Try: sudo apt install <deb name>

adminuser@opsi:~$ software-properties-common is already the newest version (0.99.9.8).
-bash: syntax error near unexpected token `('
adminuser@opsi:~$ software-properties-common set to manually installed.
software-properties-common: command not found
adminuser@opsi:~$ wget is already the newest version (1.20.3-1ubuntu2).
-bash: syntax error near unexpected token `('
adminuser@opsi:~$ The following NEW packages will be installed:

Command 'The' not found, did you mean:

command 'the' from deb the (3.3~rc1-3build1)
command 'he' from deb node-he (1.2.0-1)

Try: sudo apt install <deb name>

adminuser@opsi:~$ apt-transport-https
apt-transport-https: command not found
adminuser@opsi:~$ 0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
0: command not found
adminuser@opsi:~$ Need to get 1,704 B of archives.
Need: command not found
adminuser@opsi:~$ After this operation, 162 kB of additional disk space will be used.
After: command not found
adminuser@opsi:~$ Get:1 http://de.archive.ubuntu.com/ubuntu focal-updates/universe amd64 apt-transport-https all 2.0.8 [1,704 B]
Get:1: command not found
adminuser@opsi:~$ Fetched 1,704 B in 0s (7,415 B/s)
-bash: syntax error near unexpected token `('
adminuser@opsi:~$ Selecting previously unselected package apt-transport-https.
Selecting: command not found
adminuser@opsi:~$ (Reading database ... 281954 files and directories currently installed.)
Reading: command not found
adminuser@opsi:~$ Preparing to unpack .../apt-transport-https_2.0.8_all.deb ...
Preparing: command not found
adminuser@opsi:~$ Unpacking apt-transport-https (2.0.8) ...
-bash: syntax error near unexpected token `('
adminuser@opsi:~$ Setting up apt-transport-https (2.0.8) ...
-bash: syntax error near unexpected token `('
adminuser@opsi:~$ adminuser@opsi:~$ wget -q -O - https://packages.grafana.com/gpg.key | sudo apt-key add -
[sudo] password for adminuser:
adminuser@opsi:~$: command not found
adminuser@opsi:~$ wget -q -O - https://packages.grafana.com/gpg.key | sudo apt-key add -
adminuser@opsi:~$
Benutzeravatar
j.schneider
uib-Team
Beiträge: 1583
Registriert: 29 Mai 2008, 15:14

Re: Configed not working after upgrade (Ubuntu server 18-->20)

Beitrag von j.schneider »

Julez hat geschrieben: 15 Jun 2022, 07:47 adminuser@opsi:~$ echo "deb https://packages.grafana.com/oss/deb stable main" > /etc/apt/sources.list.d/grafana.list
-bash: /etc/apt/sources.list.d/grafana.list: Permission denied
adminuser@opsi:~$ sudo echo "deb https://packages.grafana.com/oss/deb stable main" > /etc/apt/sources.list.d/grafana.list
-bash: /etc/apt/sources.list.d/grafana.list: Permission denied
adminuser@opsi:~$ echo "deb http://download.opensuse.org/repositori ... ntu_20.04/ /" > /etc/apt/sources.list.d/opsi.list
-bash: /etc/apt/sources.list.d/opsi.list: Permission denied
adminuser@opsi:~$ sudo echo "deb http://download.opensuse.org/repositori ... ntu_20.04/ /" > /etc/apt/sources.list.d/opsi.list
-bash: /etc/apt/sources.list.d/opsi.list: Permission denied
Several commands failed due to permission errors.

Run

Code: Alles auswählen

sudo su -
to become root and repeat all the commands.
Antworten