PXE Boot funktioniert nicht

MG-Mann
Beiträge: 22
Registriert: 07 Mär 2019, 08:19

PXE Boot funktioniert nicht

Beitragvon MG-Mann » 02 Aug 2019, 10:50

Hallo Zusammen,

seit Anfang der Woche funktioniert mein PXE boot nicht mehr, an dem Netzwerk hat sich nichts verändert, eine gültige IP-Adresse bekommt der Client vom DHCP zugewiesen, die Routen stimmen auch.

Im OPSI-Manager habe ich dem Client gesagt, dass er das Setup für ein Netboot-Produkt durchfüren soll.
Diesen Vorgang habe ich mehrere male versucht, in dem ich die Anforderung wieder entzogen habe, gewartet habe und dann wieder auf Setup gestellt habe.

Ich bekomme nur die Meldungen:
PXE-T01: File not found
PXE-E3B: TFTP Error - File Not Found
PXE-M0F: Existing PXE ROM.

Wie gesagt, bis letzte Woche hat alles einwandfrei funktioniert. Ich habe die fertige OPSI-VM heruntergeladen und bereitgestellt, an
der Basiskonfiguration habe ich nichts geändert.

Hat jemand eine Idee woran das liegen könnte, oder wie ich den Dienst auf dem Server analysieren kann, ob der läuft?

Danke im Voraus

Benutzeravatar
SisterOfMercy
Beiträge: 1018
Registriert: 22 Jun 2012, 19:18

Re: PXE Boot funktioniert nicht

Beitragvon SisterOfMercy » 02 Aug 2019, 11:14

The "file not found" error makes me think the DHCP server configuration has been changed. You should check if the dhcp server has the correct stuff for network booting. Something like this:

Code: Alles auswählen

next-server 10.23.0.25;
option client-arch code 93 = array of unsigned integer 16;
if not exists client-arch {
       filename "linux/pxelinux.0";
} elsif substring (option client-arch,0,0) = option client-arch {
       filename "linux/pxelinux.0";
} elsif option client-arch = encode-int (0,16) {       # 0 x86 BIOS
       filename "linux/pxelinux.0";
} elsif option client-arch = encode-int (6,16) {       # 6 x86 UEFI
       filename "linux/pxelinux.cfg/elilo-x86.efi";
} elsif option client-arch = encode-int (7,16) {       # 7 x64 UEFI
       filename "linux/pxelinux.cfg/elilo.efi";
} elsif option client-arch = encode-int (9,16) {       # 9 UEFI ByteCode
       filename "linux/pxelinux.cfg/elilo.efi";
}


If this is all setup correctly we need to look at the opsi host, where these files should be.
Bitte schreiben Sie Deutsch, when I'm responding in the German-speaking part of the forum!

MG-Mann
Beiträge: 22
Registriert: 07 Mär 2019, 08:19

Re: PXE Boot funktioniert nicht

Beitragvon MG-Mann » 02 Aug 2019, 11:50

The DHCP-Server is correct configured.
The server-ip in option 066 is correct and the bootfilename in option 067 is correct to ( /tftpboot/linux/pxelinux.0 )

here the permissions for the folders:

adminuser@hh-app-opsi:/tftpboot/linux$ ls -la
insgesamt 533160
drwxrwxr-x 3 opsiconfd pcpatch 4096 Jul 18 13:07 .
drwxr-xr-x 3 root nogroup 4096 Feb 18 15:50 ..
-rw-rw-r-- 1 opsiconfd pcpatch 12372 Mai 22 11:06 chain.c32
lrwxrwxrwx 1 opsiconfd pcpatch 14 Mai 22 11:06 install -> vmlinuz-5.0.13
lrwxrwxrwx 1 opsiconfd pcpatch 11 Mai 22 11:06 install64 -> install-x64
lrwxrwxrwx 1 opsiconfd pcpatch 18 Mai 22 11:06 install-x64 -> vmlinuz-x64-5.0.13
-rw-rw-r-- 1 opsiconfd pcpatch 150024 Aug 23 2013 memtest86+-5.01
-rw-rw-r-- 1 opsiconfd pcpatch 52272 Mai 22 11:06 menu.c32
-rw-rw-r-- 1 opsiconfd pcpatch 263207073 Mai 22 11:06 miniroot-20190522.bz2
lrwxrwxrwx 1 opsiconfd pcpatch 21 Mai 22 11:06 miniroot.bz2 -> miniroot-20190522.bz2
-rw-rw-r-- 1 opsiconfd pcpatch 263735809 Mai 22 11:06 miniroot-x64-20190522.bz2
lrwxrwxrwx 1 opsiconfd pcpatch 25 Mai 22 11:06 miniroot-x64.bz2 -> miniroot-x64-20190522.bz2
-rw-rw-r-- 1 opsiconfd pcpatch 15710 Mai 22 11:06 pxelinux.0
drwxrwxr-x 2 opsiconfd pcpatch 4096 Aug 2 10:25 pxelinux.cfg
-rw-rw-r-- 1 opsiconfd pcpatch 7374176 Mai 22 11:06 vmlinuz-5.0.13
-rw-rw-r-- 1 opsiconfd pcpatch 11380384 Mai 22 11:06 vmlinuz-x64-5.0.13

adminuser@hh-app-opsi:/tftpboot/linux/pxelinux.cfg$ ls -la
insgesamt 304
drwxrwxr-x 2 opsiconfd pcpatch 4096 Aug 2 10:25 .
drwxrwxr-x 3 opsiconfd pcpatch 4096 Jul 18 13:07 ..
prw-r--r-- 1 opsiconfd pcpatch 0 Aug 2 10:25 01-1c-6f-65-a6-fe-92
lrwxrwxrwx 1 opsiconfd pcpatch 12 Feb 18 15:52 default -> default.menu
-rw-rw-r-- 1 opsiconfd pcpatch 931 Jul 18 13:07 default.menu
-rw-rw-r-- 1 opsiconfd pcpatch 1005 Jul 18 13:11 default.menu.opsi
-rw-rw-r-- 1 opsiconfd pcpatch 34 Jul 18 13:07 default.nomenu
-rw-rw-r-- 1 opsiconfd pcpatch 34 Mai 22 11:06 default.nomenu.opsi
-rw-rw-r-- 1 opsiconfd pcpatch 43 Jul 18 13:07 elilo.conf
-rw-rw-r-- 1 opsiconfd pcpatch 43 Mai 22 11:06 elilo.conf.opsi
-rw-rw-r-- 1 opsiconfd pcpatch 236130 Mai 22 11:06 elilo.efi
-rw-rw-r-- 1 opsiconfd pcpatch 166 Jul 18 13:07 install
-rw-rw-r-- 1 opsiconfd pcpatch 308 Jul 18 13:07 install3264
-rw-rw-r-- 1 opsiconfd pcpatch 308 Mai 22 11:06 install3264.opsi
-rw-rw-r-- 1 opsiconfd pcpatch 206 Jul 18 13:07 install-elilo-x64
-rw-rw-r-- 1 opsiconfd pcpatch 206 Mai 22 11:06 install-elilo-x64.opsi
-rw-rw-r-- 1 opsiconfd pcpatch 194 Mai 22 11:06 install-elilo-x86
-rw-rw-r-- 1 opsiconfd pcpatch 166 Mai 22 11:06 install.opsi
-rw-rw-r-- 1 opsiconfd pcpatch 182 Jul 18 13:07 install-x64
-rw-rw-r-- 1 opsiconfd pcpatch 182 Mai 22 11:06 install-x64.opsi
-rw-rw-r-- 1 opsiconfd pcpatch 60 Aug 11 2015 memtest86

MG-Mann
Beiträge: 22
Registriert: 07 Mär 2019, 08:19

Re: PXE Boot funktioniert nicht

Beitragvon MG-Mann » 02 Aug 2019, 13:21

here the var/log/opsi/opsipxeconfd.log


[5] [Aug 02 10:25:48] Starting opsipxeconfd main thread (opsipxeconfd|201)
[5] [Aug 02 10:25:48] Ignoring module 'OpsiPXEConfd', backend 'opsipxeconfd' (BackendManager.py|387)
[5] [Aug 02 10:25:51] Creating unix socket u'/var/run/opsipxeconfd/opsipxeconfd.socket' (opsipxeconfd|148)
[5] [Aug 02 10:25:51] Start setting initial boot configurations (opsipxeconfd|649)
[5] [Aug 02 10:25:52] PXE boot configuration for host 1526-pc.hhess.loc is now set at u'/tftpboot/linux/pxelinux.cfg/01-1c-6f-65-a6-fe-92' (opsipxeconfd|451)
[5] [Aug 02 10:25:52] Finished setting initial boot configurations (opsipxeconfd|674)
[5] [Aug 02 12:55:28] Got connection from client (opsipxeconfd|179)
[5] [Aug 02 12:55:29] PXE boot configuration for host u'1526-pc.hhess.loc' removed (opsipxeconfd|490)
[5] [Aug 02 12:58:56] Got connection from client (opsipxeconfd|179)
[5] [Aug 02 12:58:56] PXE boot configuration for host 1526-pc.hhess.loc is now set at u'/tftpboot/linux/pxelinux.cfg/01-1c-6f-65-a6-fe-92' (opsipxeconfd|451)
[5] [Aug 02 13:14:06] Pipe u'/tftpboot/linux/pxelinux.cfg/01-1c-6f-65-a6-fe-92' opened, piping pxe boot configuration (opsipxeconfd|812)

Benutzeravatar
ThomasT
uib-Team
Beiträge: 180
Registriert: 26 Jun 2013, 12:26

Re: PXE Boot funktioniert nicht

Beitragvon ThomasT » 02 Aug 2019, 15:47

MG-Mann hat geschrieben:The DHCP-Server is correct configured.
The server-ip in option 066 is correct and the bootfilename in option 067 is correct to ( /tftpboot/linux/pxelinux.0 )


Wenn die Option 67 tatsächlich /tftpboot/linux/pxelinux.0 sein sollte, dann ist das vermutlich der Fehler:
https://download.uib.de/opsi4.1/documen ... her-server
Kein Support per DM!
_________________________
opsi support - https://www.uib.de/
For productive opsi installations we recommend support contracts.

MG-Mann
Beiträge: 22
Registriert: 07 Mär 2019, 08:19

Re: PXE Boot funktioniert nicht

Beitragvon MG-Mann » 05 Aug 2019, 08:32

Guten Morgen,

ich habe den DHCP-Server auf der VM deinstalliert und die nötigen Einträge in der dispatch.conf angepasst wie beschrieben, das Problem besteht weiterhin. Ich habe jede menge Logs durchgeschaut, ich finde nichtmal ein hinweis darauf, dass der Computer sich via PXE meldet.
In welcher Log-Datei wären die Informationen zu erwarten?

Ich habe eher das Gefühl, das Opsi nicht die nötigen Informationen bereitstellt, sodass bei der Anfrage vom Client er die notwendigen schritte einleitet.

Benutzeravatar
n.wenselowski
uib-Team
Beiträge: 3192
Registriert: 04 Apr 2013, 12:15

Re: PXE Boot funktioniert nicht

Beitragvon n.wenselowski » 05 Aug 2019, 11:50

Hi,

existiert die Pipe für den Client denn?
Die von opsi bereitgestellten Pipes können nur einmal vom Client gelesen werden und sind dann weg.

Der Befehl opsipxeconf status zeigt wofür der Client aktuell Pipes bereitstellt und zeigt auch die Pfade dazu an. Taucht dein Client dort auf?

Ansonsten sind die Logs deine Freunde. Unter Linux loggt der DHCP-Server in der Regel ins Syslog, genaues sollte aber auf jeden Fall übers Handbuch des von dir verwendeten Servers rauszubekommen sein - oder eben eine kurze Internetsuche.


Gruß

Niko
opsi development - uib gmbh
For productive opsi installations we recommend support contracts.

MG-Mann
Beiträge: 22
Registriert: 07 Mär 2019, 08:19

Re: PXE Boot funktioniert nicht

Beitragvon MG-Mann » 30 Aug 2019, 10:33

Hallo Zusammen,

ich habe mich mit dem Problem weiter befasst, ich habe erstmal einen moment gebraucht um festzustellen

dass der Befehl "opsipxeconfd status" und nicht "opsipxeconf status" heißt.
Folgendes wird ausgegeben

opsipxeconfd status:
1 control connection(s) established
Connection 1 established at: Fri Aug 30 10:22:13 2019

1 boot configuration(s) set
Boot config for client '1526-pc.firma.loc' (path '/tftpboot/linux/pxelinux.cfg/01-1c-6f-65-a6-fe-92'; configuration {'dn': u'firma.loc', 'product': u'firma-win10-pro-x64-v1903-oem', 'hn': u'1526-pc', 'service': u'https://172.30.8.30:4447/rpc'}) set since Fri Aug 30 10:01:29 2019

Evtl. ein Berechtigungsproblem??
Der Ornder /tftpboot/linux/pxelinux.cfg/01-1c-6f-65-a6-fe-92 der angelegt wurde hat die Berechtigungen:
prw-r--r-- root root 01-1c-6f-65-a6-fe-92

Alle anderen Elemente in dem Ordner haben Opsiconfd pcpatch

Ein nachträgliches opsi-set-rights hat zwar änderungen auch am /tftpboot/* vorgenommen aber nicht an dem Client Ordner selbst.

Benutzeravatar
n.wenselowski
uib-Team
Beiträge: 3192
Registriert: 04 Apr 2013, 12:15

Re: PXE Boot funktioniert nicht

Beitragvon n.wenselowski » 30 Aug 2019, 11:08

Hi,

MG-Mann hat geschrieben:1 boot configuration(s) set
Boot config for client '1526-pc.firma.loc' (path '/tftpboot/linux/pxelinux.cfg/01-1c-6f-65-a6-fe-92'; configuration {'dn': u'firma.loc', 'product': u'firma-win10-pro-x64-v1903-oem', 'hn': u'1526-pc', 'service': u'https://172.30.8.30:4447/rpc'}) set since Fri Aug 30 10:01:29 2019

Das ist der richtige Client, ja?

MG-Mann hat geschrieben:Evtl. ein Berechtigungsproblem??
Der Ornder /tftpboot/linux/pxelinux.cfg/01-1c-6f-65-a6-fe-92 der angelegt wurde hat die Berechtigungen:
prw-r--r-- root root 01-1c-6f-65-a6-fe-92

Alle anderen Elemente in dem Ordner haben Opsiconfd pcpatch

Ein nachträgliches opsi-set-rights hat zwar änderungen auch am /tftpboot/* vorgenommen aber nicht an dem Client Ordner selbst.

Der tftpd/opsipxeconfd läuft als root und das ist in meinen Augen nicht das Problem.

n.wenselowski hat geschrieben:Ansonsten sind die Logs deine Freunde. Unter Linux loggt der DHCP-Server in der Regel ins Syslog, genaues sollte aber auf jeden Fall übers Handbuch des von dir verwendeten Servers rauszubekommen sein - oder eben eine kurze Internetsuche.

Das ist der wichtige Teil ;)


Gruß

Niko
opsi development - uib gmbh
For productive opsi installations we recommend support contracts.

MG-Mann
Beiträge: 22
Registriert: 07 Mär 2019, 08:19

Re: PXE Boot funktioniert nicht

Beitragvon MG-Mann » 30 Aug 2019, 13:18

Was mit nun noch aufgefallen ist, der Client bekommt beim PXE erfolgreich eine IP zugewiesen, aber im OPSI Config-Editor steht beim Client noch die alte IP drin.

In der /etc/opsi/opsiconfd.conf steht aber drin "update ip = yes".
Wir haben einen zentralen DHCP-Server, der für die IP-Verteilung zuständig ist, die IP ist dort ist auch korrekt. nur im OPSI-Client stimmt diese nicht.
Ich habe schon ein "systemd-resolve --flush-caches" ausgeführt, damit der DNS-Cache bereinigt wird, auch hier keine besserung.

Nachtrag: den standardmäßig mitinstallieren DHCP-Server habe ich deinstalliert, damit dieser nicht reinpfuscht.