opsi-deploy-client-agent

Julian.M
Beiträge: 1
Registriert: 10 Mai 2019, 14:11

opsi-deploy-client-agent

Beitragvon Julian.M » 10 Mai 2019, 14:19

Hallo,

ich versuche auf einen Rechner in meiner Domäne den client agent zu installieren.

Ich habe es mit diesem befehl versucht:
/opsi-deploy-client-agent -u [Localer Adminuser] -p [Passwort] -c [Rechnername.Domäne]

Aber ich bekomme immer diese Fehlermeldung:
Deployment to '[Rechnername.Domäne]' failed: Failed to execute command on host u'[Rechnername.Domäne]': winexe error: Command '/usr/bin/winexe -U '.[Localer Adminuser]%*** confidential ***' //[Rechnername.Domäne] 'cmd.exe /C "del /s /q c:\tmp\opsi-client-agent_inst && rmdir /s /q c:\tmp\opsi-client-agent_inst || echo not found"'' failed (1):
mkdir failed on directory /usr/local/samba/var/cache: No such file or directory
mkdir failed on directory /usr/local/samba/var/cache: No such file or directory
mkdir failed on directory /usr/local/samba/var/cache: No such file or directory

Kann mir bitte jemand helfen?

Benutzeravatar
ThomasT
uib-Team
Beiträge: 166
Registriert: 26 Jun 2013, 12:26

Re: opsi-deploy-client-agent

Beitragvon ThomasT » 10 Mai 2019, 15:27

Kannst du das in deinem Log angemerkte Kommando denn von Hand ausführen? Also in etwa so etwas:

Code: Alles auswählen

/usr/bin/winexe -U '.[Localer Adminuser]%*** confidential ***' //[Rechnername.Domäne] 'cmd.exe /C "del /s /q c:\tmp\opsi-client-agent_inst && rmdir /s /q c:\tmp\opsi-client-agent_inst


Zusätzlich vllt. noch -d 9 für das Debug-Level.....

Wie ist denn die Windows-Firewall eingestellt? Es wird ein SMB-Zugriff ( also TCP 445 ) auf den Client benötigt...
Kein Support per DM!
_________________________
opsi support - https://www.uib.de/
For productive opsi installations we recommend support contracts.

ostaehr
Beiträge: 1
Registriert: 11 Mai 2019, 13:31

Re: opsi-deploy-client-agent

Beitragvon ostaehr » 11 Mai 2019, 13:39

Hatte das gleiche nach einer Neuinstallation, habe das Verzeichnis einfach angelegt.
Dann ging es aber immer noch nicht, musste erst noch die UAC für Remote Zugriff konfigurieren:
https://support.microsoft.com/de-de/hel ... in-windows
oder in Kürze:

Code: Alles auswählen

reg add HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System /f /v LocalAccountTokenFilterPolicy /t REG_DWORD /d 1

danielalpha007
Beiträge: 106
Registriert: 22 Jan 2017, 22:39

Re: opsi-deploy-client-agent

Beitragvon danielalpha007 » 05 Jun 2019, 17:13

*PUSH* seit einigen Tagen habe ich dasselbe Problem wie der TE.

Starting deployment to host u'win7protest11.DOMÄNE.de'
Querying for ip address of host u'win7protest11.DOMÄNE.de'
Got ip address '10.0.1.83' from syscall
Pinging host '10.0.1.83' ...
Host 10.0.1.83 is up
Testing winexe
Deployment to 'Win7ProTest11.DOMÄNE.de' failed: Failed to execute command on host u'win7protest11': winexe error: Command '/usr/bin/winexe -U 'Administrator%*** confidential ***' //win7protest11 'cmd.exe /C "del /s /q c:\tmp\opsi-client-agent_inst && rmdir /s /q c:\tmp\opsi-client-agent_inst || echo not found"'' failed (1):
mkdir failed on directory /usr/local/samba/var/cache: Datei oder Verzeichnis nicht gefunden
mkdir failed on directory /usr/local/samba/var/cache: Datei oder Verzeichnis nicht gefunden
mkdir failed on directory /usr/local/samba/var/cache: Datei oder Verzeichnis nicht gefunden
0/1 deployments successfully
1/1 deployments failed