Seite 1 von 1

Stuck on ELILO Boot

Verfasst: 08 Jan 2018, 20:44
von ttblum
Hello,

I'm trying to boot a Dell 5580 laptop from PXE, and all I'm getting is:

Code: Alles auswählen

ELILO boot: ..................................................................................
.................................................................................................
.............


over and over.

Other laptops UEFI boot OK. I have a trial UEFI license installed.

Re: Stuck on ELILO Boot

Verfasst: 08 Jan 2018, 22:21
von ttblum
Well, I mispoke now no computers are able to PXE UEFI boot. Some are showing:

Code: Alles auswählen

near line 4: Unknown option (null)
forcing interactive mode due to config file error(s)

ELILO boot: ......................................


I made a change yesterday to try to switch the PXE language from German to English, I must have made a mistake.

I tried to take out the changes, this is my /tftpboot/linux/pxelinux.cfg/default.menu now:

Code: Alles auswählen

default menu.c32
timeout 10
prompt 0
noescape 1
 
menu title opsi boot menu
menu width 55
menu rows 3
menu helpmsgrow 10
menu timeoutrow 15
menu tabmsgrow -1
menu hshift 14
menu vshift 9

menu color tabmsg       30;40      #00000000 #00000000 std

label hd
  menu label Boot from ^local drive
  text help
                 Boot operating system from local drive.
  endtext
  localboot 0
 
label install
  menu label Start ^opsi bootimage
  text help
                 Start opsi linux bootimage from tftp server.
  endtext
  kernel install
  append initrd=miniroot.bz2 video=vesa:ywrap,mtrr vga=791 --no-log console=tty1 console=ttyS0
 
label install-x64
  menu label Start o^psi bootimage (x64)
  text help
                 Start opsi linux bootimage 64-Bit from tftp server.
  endtext
  kernel install-x64
  append initrd=miniroot-x64.bz2 video=vesa:ywrap,mtrr vga=791 --no-log console=tty1 console=ttyS0

Re: Stuck on ELILO Boot

Verfasst: 09 Jan 2018, 10:50
von m.radtke
hi

default.menu doesnt work on UEFI
when oyu boot UEFi the elilo.conf is loaded
however when you have nothing set to setup it tries to start from /dev/sda1. When you have an NVME 'disk' this will fail ans result in those dots

Please download this eililo.efi

Code: Alles auswählen

http://www68.zippyshare.com/v/rrDMN0fk/file.html

replace it with the existing one. This one is patched to only draw the dotted lines for 2 seconds, instead of infinite in the distributed elilo.efi.
After those 2 seconds the bootloader is supposed to jump into the next UEFI boot entry

Cheers
Mathias

Re: Stuck on ELILO Boot

Verfasst: 09 Jan 2018, 15:02
von ttblum
OK, I've replaced the file.

Now i'm getting:

Code: Alles auswählen

>>Checking Media Presence......
>>Media Present......
  Downloading NBP file...

    Succeed to download NBP file.

ELILO boot:
elilo.c(line 77):Kernel file  not found vmlinux

Re: Stuck on ELILO Boot

Verfasst: 09 Jan 2018, 15:20
von m.radtke
something is messed up with your config

do you have set a netboot product to setup?
if yes please post the pipe content

and also the corresponding syslog entries

Cheers

Re: Stuck on ELILO Boot

Verfasst: 09 Jan 2018, 15:38
von ttblum
I am able to deploy UEFI/GPT OS's to registered clients OK.

For example, I select 'Setup' for win10-x64 on a registered client, I get:

Code: Alles auswählen

ELILO v3.16 for EFI/x86_64
Loading kernel /linux/install64...  done
Loading file /linux/miniroot-x64.bz2...done

Then a linux kernel boots normally.

The problem is only happening when I am trying to get to the PXE menu.

Not sure what a 'pipe content' is

Re: Stuck on ELILO Boot

Verfasst: 09 Jan 2018, 15:52
von m.radtke
ok

whats the boot order of the broken client?
it seems to me like the PXE is exited after 2 seconds.
The boot order jumps to the next entry, which seems to be the local hard drive, and as there is nothing installed the vmlinux cannot be loaded

Please check your UEFi boot order to check if I am right.

There is no PXE Menu on UEFI systems with opsi. You always have to set a client to setup to install an OS, or use the current boot-cd. Use 'dd' to get it on an usb stick and then it should boot your client with UEFI

Cheers

Re: Stuck on ELILO Boot

Verfasst: 10 Jan 2018, 19:11
von ttblum
Ok, then this was just user error on my part, sorry about that.