Seite 1 von 2

opsi-deploy-client-agent

Verfasst: 08 Nov 2010, 15:55
von r.appelt
Leider lässt sich der opsi-client-agent in unserer Windows 7 64Bit Umgebung nicht verteilen. Mount.cifs zum Client funktioniert, winexe "cmd" funktioniert ebenfalls.
OPSI Server läft auf Ubuntu 10.04 Server mit aktuellem Patch Stand. Alle Windows 7 64Bit Clients sind in einer Domäne und mit den aktuellen Microsoft Patches ausgestattet. Installation mit "service_setup.cmd" funktioniert.

Fehlermeldung:

[error] ERROR: Failed to install opsi-client-agent: Command './winexe -U 'i-kmb\Administrator%*** confidential ***' //pc.dns.de 'c:\opsi_oSw8d6A8wV\files\opsi\opsi-winst\winst32.exe /batch c:\opsi_oSw8d6A8wV\files\opsi\setup.ins c:\tmp\opsi-client-agent.log /PARAMETER REMOTEDEPLOY'' failed (1):
ERROR: Failed to open connection - NT_STATUS_NO_MEMORY

Re: opsi-deploy-client-agent

Verfasst: 08 Nov 2010, 20:12
von d.oertel
Hi,

wir versuchen gerade das Problem zu verstehen.
siehe:
https://forum.opsi.org/viewtopic.php?f=6&t=1936

gruss
d.oertel

Re: opsi-deploy-client-agent

Verfasst: 16 Nov 2010, 13:40
von r.appelt
Danke erst mal für die schnelle Antwort. Auf Windows 7 32Bit (Testinstallation) funktionierte es einwandfrei. Wenn es bei euch auch mit der 64Bit Windows klappt, würde mich mal interessieren mit welchen Schalter der deploy-client-agent afgerufen wurde. Ich habe, denke ich, alle sinnvoll einsetzbaren und dokumentierten Schalter probiert.
Interesssanter Weise funktioniert bei einem von "Hand" installierten Agent die on Demand und die Popup Funktion nicht, hängt das zusammen?

gruß

r.appelt

Re: opsi-deploy-client-agent

Verfasst: 16 Nov 2010, 16:33
von d.oertel
Hi,

das hängt wohl nicht mit den Schalten zusammen, aber mit was wissen wir noch nicht
(Autentifizierung ducrh die winexec)

Interesssanter Weise funktioniert bei einem von "Hand" installierten Agent die on Demand und die Popup Funktion nicht, hängt das zusammen?


try this: http://download.uib.de/opsi4.0/experimental/opsi-client-agent_4.0-8.opsi

gruss
d.oertel

Re: opsi-deploy-client-agent

Verfasst: 18 Nov 2010, 09:57
von r.appelt
Hallo,

habe die neue Version getestet, leider keine Verbesserung. Ich habe, aufgrund der gleichen Vermutung, winexe mit den selben anmelde Informationen getestet, was anstandslos funktionierte.

gruss

r.appelt

Re: opsi-deploy-client-agent

Verfasst: 19 Nov 2010, 15:59
von Cherry
Hallo,

ich setze auch den opsi-deploy-client-agent ein und es funktioniert unter windows 7 64 bit!
ich nehme auch nur die normalen schalter -u, -p, -r, -c her.
bei uns ist datei und druckerfreigabe aktiviert und in der firewall zugelassen.
die opsi-client-agent version kann ich gerade nicht nennen, da ich nicht mehr in der arbeit bin.

schönes we!!

Re: opsi-deploy-client-agent

Verfasst: 24 Nov 2010, 08:53
von r.appelt
Hallo,

danke für den Hinweis, das lässt mich wenigstens hoffen ;-) Aber die Schalter habe ich schon alle probiert, es scheitert ja auch erst bei "winst32.exe", der ganze Kopiervorgang läuft ja noch. Deshalb kann es auch nicht an den Firewall Einstellungen liegen.

gruss
r.appelt

Re: opsi-deploy-client-agent

Verfasst: 24 Nov 2010, 09:12
von j.schneider
Bitte einmal die /opt/pcbin/install/opsi-client-agent/winexe austauschen durch:
http://download.uib.de/opsi4.0/experimental/winexe.x64
bzw.
http://download.uib.de/opsi4.0/experimental/winexe.x86

Re: opsi-deploy-client-agent

Verfasst: 24 Nov 2010, 13:44
von Cherry
Hallo,
wie ist das mit dem austauschen gemeint.
entweder die winexe.x64 oder die winexe.x32.
ich habe clients mit beiden architekturen im einsatz und wenn ich beide reinkopier, gibt der opsi-deploy-client-agent einen fehler aus.

danke

Re: opsi-deploy-client-agent

Verfasst: 24 Nov 2010, 14:00
von j.schneider
Je nach Server-Architektur Datei herunterladen und danach umbenennen in winexe.