Seite 1 von 1

opsi-client-agent verbindet sich nicht zum server

Verfasst: 06 Apr 2018, 11:57
von grobi
Hallo,

ich habe eine Testinstallation mit vier Win7 Clients. Der Server (auf Debian stretch) wurde von 4.0 auf 4.1 upgedatet.
Beim Systemstart verbinden sich die Clients nicht mehr mit dem opsi Server, die Verbindung läuft in einen Timeout.

Code: Alles auswählen

Finished: Set for id: "status" the message: "Verbindung zu Config-Server 'https://xxx.xxx.xxx.xxx:4447/rpc' fehlgeschlagen: error(10051, 'Ein Socketvorgang bezog sich auf ein nicht verf\xfcgbares Netzwerk')"


Wenn ich mich auf meinem Client anmelde, kann ich aber ohne Probleme den Server über 'https://xxx.xxx.xxx.xxx:4447 erreichen.

opsi-server 4.1.1.4-10
opsi-client-agent 4.0.7.24-3

Woran kann das liegen?

Re: opsi-client-agent verbindet sich nicht zum server

Verfasst: 06 Apr 2018, 15:08
von n.wenselowski
Hi,

liest sich als wäre zum Startzeitpunkt noch keine Netzwerkverbindung verfügbar. Ist das während der Rechner startet schon verfügbar?

Du könntest ansonsten den Timeout für Verbindungsversuche erhöhen, so dass länger versucht wird eine Verbindung herzustellen.


Gruß

Niko

Re: opsi-client-agent verbindet sich nicht zum server

Verfasst: 06 Apr 2018, 15:42
von grobi
Der Timeout steht auf 30 Sekunden. Daran habe ich noch nichts verändert. Mit opsi in Version 4.0 gab es den Fehler nicht, die Verbindung klappte direkt.
Das Netzwerk ist zu dem Zeitpunkt schon da, die Rechner sind in einer AD Domäne.

Re: opsi-client-agent verbindet sich nicht zum server

Verfasst: 10 Apr 2018, 09:44
von grobi
Hat sich erledigt. Hier waren Netzwerkprobleme die Ursache.