Fehler beim Speichern von Einstellungen

Moderator: pandel

mg_fzj
Beiträge: 13
Registriert: 03 Jul 2014, 11:44

Fehler beim Speichern von Einstellungen

Beitragvon mg_fzj » 06 Mai 2020, 10:46

Hallo,

ich habe mir auf einer Windows 10 Maschine den oPB mit der .exe hier aus dem Forum installiert. Wenn ich nun Einstellungen vor nehmen und auf Speichern klicke kommt folgende Meldung:

Code: Alles auswählen

A log has been written to "C:\Users\M9406~1.GRE\AppData\Local\Temp\opb-error-9_vs2swn.log".

Error information:
--------------------------------------------------------------------------------
2020-05-06, 10:43:10
opsi PackageBuilder version: 8.4.4
--------------------------------------------------------------------------------
<class 'IndexError'>:
string index out of range
--------------------------------------------------------------------------------
  File "oPB\controller\settings.py", line 218, in save_config
  File "oPB\controller\settings.py", line 157, in update_backend_data
  File "oPB\core\confighandler.py", line 452, in dev_dir


Hat einer eine Idee, wo das Problem liegen könnte?

Viele Grüße
Marvin

mg_fzj
Beiträge: 13
Registriert: 03 Jul 2014, 11:44

Re: Fehler beim Speichern von Einstellungen

Beitragvon mg_fzj » 06 Mai 2020, 10:50

Hat sich bereits erledigt. Ich sollte auch Pyhton installieren, dann kommt diese Meldung auch nicht mehr :shock: :oops:

pandel
Beiträge: 794
Registriert: 25 Jan 2013, 16:47

Re: Fehler beim Speichern von Einstellungen

Beitragvon pandel » 11 Mai 2020, 16:40

Hi!

Hä? Nein, du solltest kein Python installieren. Damit hat es nichts zu tun! Deine Einstellungen waren offensichtlich noch Murks. Python wird intern mitgeliefert, eine externe Pythoninstallation ist nicht nötig!

Gruß
Holger