Seite 1 von 1

[ERLEDIGT] Fehler beim installieren von mshotfix-win10-2009-x64-glb

Verfasst: 19 Apr 2021, 16:00
von mplima
Beim versuch das paket: mshotfix-win10-2009-x64-glb zu installieren bekomme ich diesen fehler:

Code: Alles auswählen

root@opsi:~# opsi-package-updater --repo uib_abo_mshotfix install mshotfix-win10-2009-x64-glb
Installation error. Not unlocking product 'mshotfix-win10-2009-x64-glb' on depot 'opsi.moll-group.local'.
Traceback:
  File "/usr/lib/python2.7/dist-packages/OPSI/Backend/Depotserver.py", line 494, in installPackage
    raise installingPackageError

Traceback:
  File "/usr/bin/opsi-package-updater", line 341, in <module>
    exitCode = main()

  File "/usr/bin/opsi-package-updater", line 312, in main
    opu.processUpdates()

  File "/usr/lib/python2.7/dist-packages/OPSI/Util/Task/UpdatePackages/Updater.py", line 348, in processUpdates
    backend.depot_installPackage(filename=packageFile, propertyDefaultValues=propertyDefaultValues, tempDir=self.config.get('tempdir', '/tmp'))

  File "<string>", line 1, in depot_installPackage

  File "/usr/lib/python2.7/dist-packages/OPSI/Backend/Backend.py", line 524, in _executeMethod
    return meth(**kwargs)

  File "<string>", line 1, in depot_installPackage

  File "/usr/lib/python2.7/dist-packages/OPSI/Backend/Backend.py", line 524, in _executeMethod
    return meth(**kwargs)

  File "<string>", line 1, in depot_installPackage

  File "/usr/lib/python2.7/dist-packages/OPSI/Backend/Backend.py", line 524, in _executeMethod
    return meth(**kwargs)

  File "/usr/lib/python2.7/dist-packages/OPSI/Backend/Depotserver.py", line 125, in depot_installPackage
    suppressPackageContentFileGeneration=suppressPackageContentFileGeneration

  File "/usr/lib/python2.7/dist-packages/OPSI/Backend/Depotserver.py", line 497, in installPackage
    raise BackendError(u"Failed to install package '%s' on depot '%s': %s" % (filename, depotId, installationError))

ERROR: Backend error: Failed to install package '/var/lib/opsi/repository/mshotfix-win10-2009-x64-glb_202104-1.opsi' on depot 'opsi.moll-group.local': Backend unaccomplishable error: Unfulfilled package dependency {'version': u'202104-1', 'condition': u'>=', 'package': u'mshotfix'} (available version: 202103-2)


PS: Beim Paket: mshotfix-win10-1909-x64-glb_202104-1.opsi auch.

Code: Alles auswählen

ERROR: Backend error: Failed to install package '/var/lib/opsi/repository/mshotfix-win10-1909-x64-glb_202104-1.opsi' on depot 'opsi.moll-group.local': Backend unaccomplishable error: Unfulfilled package dependency {'version': u'202104-1', 'condition': u'>=', 'package': u'mshotfix'} (available version: 202103-2)



Ist das ein Fehler im Paket?

Re: Fehler beim installieren von mshotfix-win10-2009-x64-glb

Verfasst: 20 Apr 2021, 11:59
von mplima
Die Produkte funktionieren wieder :)