Actualisations pour 4.2 dans stable et testing

Ce forum est dédié au nouveautés, événements autour du projet Opsi
Antworten
otto
Beiträge: 155
Registriert: 08 Aug 2017, 12:16

Actualisations pour 4.2 dans stable et testing

Beitrag von otto »

Chers utilisateurs d'opsi,

avec la version d'aujourd'hui nous publions des nouveaux paquets d'opsi dans stable et testing.

Annonces importantes concernant Secureboot:

Utiliser Secureboot avec opsi est payant depuis le développement de cette version. Le status de licence est verivié dans l'opsi-linux-bootimage. Malheureusement il y avait une erreur dans la vérification et des machines avec un Secureboot activé mais avec extensions non-licencié ne pouvaient pas être installé en mode Secureboot.
Avec l'opsi-linux-bootimage actuel cette erreur à été corrigé et la vérification fonctionne correctement à nouveau. Cela mène au problème que chez des installations Netboot en mode Secureboot et avec extension non-vérifié un message d'erreur apparaît qui indique la manque de l'attribution des licences.
La solutions est d'acheter l'extension Secureboot ou déactiver Secureboot dans UEFI


Licences opsi:

Nous sommes en train de changer le format du fichier licence opsi (/etc/opsi/modules) et dans ce contexte il y a quelques changements chez les vérifications des licences dans testing.
Des vieilles licences (fichiers modules) continuent à fonctionner.
Avec le nouveau processus de vérification les limites des licences sont controllées conformemant.
Cela implique que s'il y a pas assez de licences pour un certain module, ce module sera déactivé.
Évidemment il y a une certaine tolérance concernant le nombre des clients.
Avant que les paquets arrivent dans stable dans la prochaine version il faut vérifier s'il y a assez clients licenciés.

Dans ce cas il y a plusieurs possibilités:
- Acheter d'autres licences
- Enlever les clients qui ne sont pas utilisés
- Demander une libération temporaire pour vérifier s'il faut acquérir d'autres licences.

S'il y a des problèmes on aide volontairement.
Contactez-nous directement sous sales(at)uib.de.


stable

Linux Netboot:

- debian (4.2.0.3-2)
- ubuntu (4.2.0.3-2)
- pcmemtest (1.4-1)
- wipedisk (2.3-1)

serveur:

- opsiconfd (4.2.0.245-1)
- opsi-utils (4.2.0.161-1)
- opsi-server (4.2.0.64-1)
- opsipxeconfd (4.2.0.26)
- opsi-directory-connector (47.8-1)
- zsync-curl (0.6.2-3)

testing:

Windows Localboot:

- windows10-upgrade (21h2-1)
- windows11-upgrade (21h2-1)
- opsi-client-agent (4.2.0.25-1)

Linux Localboot:

- opsi-linux-client-agent (4.2.0.19-1)
- l-opsi-server (4.2.0.6-3)

Macos Localboot:

- opsi-mac-client-agent (4.2.0.13-1)

Linux Netboot:

- sles12sp3 (4.2.0.1-7)
- sles12sp4 (4.2.0.1-7)
- sles12sp5 (4.2.0.1-7)
- sles15-1 (4.2.0.1-6)
- sles15-2 (4.2.0.1-6)
- sles15-3 (4.2.0.1-6)
- mint20-1 (4.2.0.1-5)
- mint20-2 (4.2.0.1-5)
- mint20-3 (4.2.0.1-5)
- ucs50 (4.2.0.1-7)


serveur:

- opsiconfd (4.2.0.245-1)
- opsi-utils (4.2.0.161-1)
- opsipxeconfd (4.2.0.26)

Mit freundlichen Grüßen
Fabian Kalweit

Changelogs:

Code: Alles auswählen

sles12sp3/4/5 (4.2.0.1-7) testing; urgency=low

  * changed linux-client-agent installation

 -- Mathias Radtke <m.radtke@uib.de> Wed Mar 09 08:30:00 2022 +0200

==============================================================================

sles15-1/2/3 (4.2.0.1-7) testing; urgency=low

  * version bump for consistency

 -- Mathias Radtke <m.radtke@uib.de> Wed Mar 09 08:1:00 2022 +0200

==============================================================================

mint20-1/2/3 (4.2.0.1-5) testing; urgency=low

  * corrected behaviour when using installation_method = reboot

 -- Mathias Radtke <m.radtke@uib.de> Thu Mar 03 10:40:00 2022 +0200

==============================================================================

ucs50 (4.2.0.1-7) testing; urgency=low

  * removed script from 4.2.0.1-6, replaced with another one

 -- Mathias Radtke <m.radtke@uib.de> Tue Feb 01 17:05:00 2022 +0200

ucs50 (4.2.0.1-6) testing; urgency=low

  * using postinst script to run join scripts and make Administrator account work

 -- Mathias Radtke <m.radtke@uib.de> Tue Jan 18 09:27:00 2021 +0200

ucs50 (4.2.0.1-5) testing; urgency=low

  * updated to ucs501

 -- Mathias Radtke <m.radtke@uib.de> Wed Dec 15 10:12:00 2021 +0200

ucs50 (4.2.0.1-4) testing; urgency=low

  * changed preseed/post installation command to adapt to other clientconfig.configserver.urls

 -- Mathias Radtke <m.radtke@uib.de> Tue Nov 16 15:34:49 2021 +0200

==============================================================================

debian (4.2.0.3-2) testing; urgency=low

  * ubuntu.py: only setting locales for en and from language property

 -- Mathias Radtke <m.radtke@uib.de> Mon Feb 28 10:11:00 2022 +0200

debian (4.2.0.3-1) testing; urgency=low

  * opsipreparelib: wiping offsets when calling lcreate
  * 01_quota.sh: calling with quotaon -Pv 
  * ubunut.py: corrected quota handling
  * cleanup of unused and commented code

 -- Mathias Radtke <m.radtke@uib.de> Mon Feb 14 13:27:00 2022 +0200

debian (4.2.0.2-3) testing; urgency=low

  * installing linux-client-agent via olca-install.service
  * new property enable_quota to support quota handling

 -- Mathias Radtke <m.radtke@uib.de> Wed Feb 09 11:50:00 2022 +0200

==============================================================================

ubuntu (4.2.0.3-2) testing; urgency=low

  * ubuntu.py: only setting locales for en and from language property

 -- Mathias Radtke <m.radtke@uib.de> Mon Feb 28 10:11:00 2022 +0200

ubuntu (4.2.0.3-1) testing; urgency=low

  * opsipreparelib: wiping offsets when calling lcreate
  * 01_quota.sh: calling with quotaon -Pv
  * ubunut.py: corrected quota handling
  * cleanup of unused and commented code

 -- Mathias Radtke <m.radtke@uib.de> Mon Feb 14 13:27:00 2022 +0200

ubuntu (4.2.0.2-3) testing; urgency=low

  * installing linux-client-agent via olca-install.service
  * new property enable_quota to support quota handling

 -- Mathias Radtke <m.radtke@uib.de> Wed Feb 09 11:50:00 2022 +0200

==============================================================================

wipedisk (2.3-1) testing; urgency=low

  * checking if NVME can be wiped
  * running sgdisk --zap-all anyway

 -- Mathias Radtke <m.radtke@uib.de> Tue Mar 01 2022 09:45:00 +0200

==============================================================================

pcmemtest (1.4-1) testing

 * initial release

 -- Mathias Radtke <m.radtke@uib.de> Wed, 02 Sep 2021 15:55:00 +0200

==============================================================================

l-opsi-server (4.2.0.6-3); testing; urgency=low

  * made some adaptations to wotk with UCS5.0-1 Systems

 -- Mathias Radtke <m.radtke@uib.de> Tue, 01 Feb 2022 17:08:00 +0200

l-opsi-server (4.2.0.6-2); testing; urgency=low

  * opening port 445 on UCS Systems

 -- Mathias Radtke <m.radtke@uib.de> Fri, 07 Jan 2022 11:46:00 +0200

l-opsi-server (4.2.0.6-1); testing; urgency=low

  * added support for UCS 5.0 

 -- Mathias Radtke <m.radtke@uib.de> Fri, 17 Dec 2021 10:50:00 +0200

==============================================================================-

opsi-linux-client-agent (4.2.0.19-1) testing; urgency=low

  * Added version file opsi-client-agent.version for conditioned installation
  * Fixed session-handling for Installation service calls
  * Updated oca-installation-helper to 4.2.0.16

-- Nils Doerrer <n.doerrer@uib.de> Mon, 07 Mar 2022 14:00:00 +0100

opsi-linux-client-agent (4.2.0.18-1) testing; urgency=low

  * Updated opsiclientd to 4.2.0.110 (fixed jsonrpc logging)

-- Nils Doerrer <n.doerrer@uib.de> Thu, 24 Feb 2022 16:00:00 +0100

opsi-linux-client-agent (4.2.0.17-1) testing; urgency=low

  * Updated opsiclientd to 4.2.0.109 (reworked opsi-setup-user cleanup and service connection timeouts)
  * Updated oca-installation-helper to 4.2.0.15 (new parameters --dns-domain, --finalize, --read-conf-files)
  * Updated opsi-deploy-client-agent 4.2.0.18 (suse fix for smbclient call)

-- Nils Doerrer <n.doerrer@uib.de> Thu, 24 Feb 2022 10:00:00 +0100
opsi-mac-client-agent (4.2.0.13-1) stable; urgency=low

  * Added version file opsi-client-agent.version for conditioned installation
  * Fixed session-handling for Installation service calls
  * Updated oca-installation-helper to 4.2.0.16

-- Nils Doerrer <n.doerrer@uib.de> Mon, 07 Mar 2022 18:00:00 +0100

opsi-mac-client-agent (4.2.0.12-1) stable; urgency=low

  * Updated opsiclientd to 4.2.0.110 (fixed jsonrpc logging)

-- Nils Doerrer <n.doerrer@uib.de> Thu, 24 Feb 2022 16:00:00 +0100

opsi-mac-client-agent (4.2.0.11-1) stable; urgency=low

  * Updated opsiclientd to 4.2.0.109 (fixed user_logged_in check, reworked opsi-setup-user cleanup and service connection timeouts)
  * Updated oca-installation-helper to 4.2.0.15 (new parameters --dns-domain, --finalize, --read-conf-files)
  * Updated opsi-deploy-client-agent 4.2.0.18 (suse fix for smbclient call)

-- Nils Doerrer <n.doerrer@uib.de> Thu, 17 Feb 2022 16:30:00 +0100
opsi-client-agent (4.2.0.25-1) stable; urgency=low

  * Added version file opsi-client-agent.version for conditioned installation
  * Fixed postinst for first time installation
  * Updated oca-installation-helper to 4.2.0.16 (new parameter --install-condition)

-- Nils Doerrer <n.doerrer@uib.de> Thu, 24 Feb 2022 16:00:00 +0100

opsi-client-agent (4.2.0.24-1) stable; urgency=low

  * Updated opsiclientd to 4.2.0.110 (fixed jsonrpc logging)

-- Nils Doerrer <n.doerrer@uib.de> Thu, 24 Feb 2022 16:00:00 +0100

opsi-client-agent (4.2.0.23-1) stable; urgency=low

  * Updated oca-installation-helper to 4.2.0.15 (new parameters --dns-domain, --finalize, --read-conf-files)
  * Updated opsi-deploy-client-agent 4.2.0.18 (suse fix for smbclient call)
  * Updated opsiclientd to 4.2.0.109 (reworked opsi-setup-user cleanup and service connection timeouts)
  * Removed Kiosk Migration. Do not install this package over opsi-client-agent < 4.1.1.18 (serverside) if using kiosk!

-- Nils Doerrer <n.doerrer@uib.de> Tue, 08 Feb 2022 11:00:00 +0100

==============================================================================

windows10-upgrade (21h2-2) testing; urgency=low
    * IMPORTANT: Requires opsiclientd version 4.2.0.104 or higher
    * IMPORTANT: Requires opsi-script version 4.12.4.35-6 or higher
    * Added additional checks for opsiSetupUser leftovers
    * Added check for empty values in Disable UAC section
    * Added include for setupact.log
    * Updated the documentation
    * Tested on win7, win7-x64, win81, win81-x64, win10-2015, win10-x64-2015, win10-2016, win10-x64-2016, win10-2019, win10-x64-2019, win10-2021, win10-x64-2021, win10-21h1, win10-x64-21h1
-- Matthias Knauer <m.knauer@uib.de> Thu, 17 Feb 2022 11:11:11 +0000

windows11-upgrade (21h2-1) testing; urgency=low
    * IMPORTANT: Requires opsiclientd version 4.2.0.104 or higher
    * IMPORTANT: Requires opsi-script version 4.12.4.35-6 or higher
    * Initial package
    * Tested on win10-21h1, win10-x64-21h1
-- Matthias Knauer <m.knauer@uib.de> Wed, 09 Feb 2022 11:11:11 +0000


==============================================================================

opsiconfd (4.2.0.245-1) stable; urgency=medium

  * Improvement:  Always wait for session to be stored in redis

 -- uib GmbH <info@uib.de>  Wed, 09 Mar 2022 11:54:51 +0100

opsiconfd (4.2.0.244-1) stable; urgency=medium

  * Bugfix:  Fix reading RedisTimeSeries data

 -- uib GmbH <info@uib.de>  Fri, 25 Feb 2022 12:19:58 +0100

opsiconfd (4.2.0.243-1) stable; urgency=medium

  * Improvement:  Update python-opsi-common (4.2.0.276 -> 4.2.0.277)

 -- uib GmbH <info@uib.de>  Fri, 25 Feb 2022 00:15:52 +0000

opsiconfd (4.2.0.242-1) stable; urgency=medium

  * Improvement:  Add licensing tab
  * Improvement:  Impove grafana setup
  * Improvement:  Update python-opsi-common (4.2.0.275 -> 4.2.0.276)
  * Bugfix:  Fix creating grafana dashboard user

 -- uib GmbH <info@uib.de>  Thu, 24 Feb 2022 21:41:43 +0100

opsiconfd (4.2.0.241-1) stable; urgency=medium

  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Thu, 24 Feb 2022 10:06:04 +0000

opsiconfd (4.2.0.240-1) stable; urgency=medium

  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Wed, 23 Feb 2022 12:54:12 +0000

opsiconfd (4.2.0.239-1) stable; urgency=medium

  * Improvement:  Add config admin-interface-terminal-shell
  * Improvement:  Use configured user shell

 -- uib GmbH <info@uib.de>  Mon, 21 Feb 2022 16:25:54 +0100

opsiconfd (4.2.0.238-1) stable; urgency=medium

  * Improvement:  Update python-opsi (4.2.0.272 -> 4.2.0.273)
  * Improvement:  Update python packages
  * Bugfix:  Fix nagios disk usage check

 -- uib GmbH <info@uib.de>  Mon, 21 Feb 2022 11:44:38 +0000

opsiconfd (4.2.0.237-1) stable; urgency=medium

  * Improvement:  Update python packages
  * Improvement:  Improve terminal latency
  * Feature:  Allow to disable admin interface features
  * Improvement:  Admin page hash links
  * Feature:  Terminal file upload

 -- uib GmbH <info@uib.de>  Fri, 18 Feb 2022 15:52:01 +0000

opsiconfd (4.2.0.236-1) stable; urgency=medium

  * Feature:  Add terminal application
  * Improvement:  Log config on setup

 -- uib GmbH <info@uib.de>  Mon, 14 Feb 2022 15:56:44 +0100

opsiconfd (4.2.0.235-1) stable; urgency=medium

  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Tue, 08 Feb 2022 12:15:12 +0100

opsiconfd (4.2.0.234-1) stable; urgency=medium

  * Improvement:  Updated python packages
  * Improvement:  Show days until cert renewal in admin interface

 -- uib GmbH <info@uib.de>  Mon, 07 Feb 2022 13:13:14 +0100

opsiconfd (4.2.0.233-1) stable; urgency=medium

  * Feature:  Add WebDAV link on admin interface
  * Improvement:  Config file is optional

 -- uib GmbH <info@uib.de>  Wed, 02 Feb 2022 07:55:59 +0100

opsiconfd (4.2.0.232-1) stable; urgency=medium

  * Improvement:  Update python pacakages
  * Feature:  Add central webdav share /webdav

 -- uib GmbH <info@uib.de>  Fri, 28 Jan 2022 17:31:41 +0100

opsiconfd (4.2.0.231-1) stable; urgency=medium

  * Improvement:  Recreate server cert if ca is renewed

 -- uib GmbH <info@uib.de>  Wed, 26 Jan 2022 11:40:26 +0000

opsiconfd (4.2.0.230-1) stable; urgency=medium

  * Improvement:  Check server cert against ca
  * Improvement:  Improve ssl info in admin interface
  * Improvement:  Version 4.2.0.230 running with python 3.10
  * Improvement:  Update fastapi to 0.73
  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Tue, 25 Jan 2022 15:11:45 +0100

opsiconfd (4.2.0.229-1) stable; urgency=medium

  * No public changes

 -- uib GmbH <info@uib.de>  Fri, 21 Jan 2022 10:14:02 +0100

opsiconfd (4.2.0.228-1) stable; urgency=medium

  * No public changes

 -- uib GmbH <info@uib.de>  Wed, 12 Jan 2022 18:31:52 +0100

opsiconfd (4.2.0.227-1) stable; urgency=medium

  * Improvement:  Update python packages
  * Improvement:  Recreate server cert if key or cert unreadable
  * Improvement:  Check server cert and key mismatch

 -- uib GmbH <info@uib.de>  Wed, 12 Jan 2022 12:51:23 +0100

opsiconfd (4.2.0.226-1) stable; urgency=medium

  * Improvement:  Add lsb-release to dependencies
  * Bugfix:  Fix setting RLIMIT_NOFILE
  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Wed, 05 Jan 2022 22:23:14 +0100

opsiconfd (4.2.0.225-1) stable; urgency=medium

  * Improvement:  Log System Volume Information MKCOL error with debug level
  * Bugfix:  Make /public readonly

 -- uib GmbH <info@uib.de>  Wed, 22 Dec 2021 14:55:39 +0100

opsiconfd (4.2.0.224-1) stable; urgency=medium

  * Improvement:  Update python-opsi

 -- uib GmbH <info@uib.de>  Fri, 17 Dec 2021 18:46:56 +0100

==============================================================================

opsi-utils (4.2.0.161-1) stable; urgency=medium

  * Improvement:  Update python packages
  * Improvement:  changed logging config to always use logfile (parameter or default)

 -- uib GmbH <info@uib.de>  Mon, 07 Mar 2022 18:18:46 +0100

opsi-utils (4.2.0.160-1) stable; urgency=medium

  * Improvement:  updated python packages, added importhook for pyasn1_modules

 -- uib GmbH <info@uib.de>  Wed, 02 Mar 2022 15:32:44 +0100

opsi-utils (4.2.0.159-1) stable; urgency=medium

  * Improvement:  Update python-opsi-common (4.2.0.276 -> 4.2.0.277)

 -- uib GmbH <info@uib.de>  Fri, 25 Feb 2022 01:20:28 +0100

opsi-utils (4.2.0.158-1) stable; urgency=medium

  * Improvement:  Update python-opsi-common (4.2.0.275 -> 4.2.0.276)

 -- uib GmbH <info@uib.de>  Thu, 24 Feb 2022 15:44:59 +0100

opsi-utils (4.2.0.157-1) stable; urgency=medium

  * Improvement:  Updating python-opsi (4.2.0.274 -> 4.2.0.275)

 -- uib GmbH <info@uib.de>  Thu, 24 Feb 2022 11:02:12 +0100

opsi-utils (4.2.0.156-1) stable; urgency=medium

  * Improvement:  opsi-setup: do not create default log file /tmp/opsi-setup.log
  * Improvement:  Update python-opsi 4.2.0.272 -> 4.2.0.273

 -- uib GmbH <info@uib.de>  Tue, 22 Feb 2022 07:47:14 +0100

opsi-utils (4.2.0.155-1) stable; urgency=medium

  * Improvement:  Update python packages
  * Improvement:  Upgrade python and python packages
  * Improvement:  Build with python 3.10

 -- uib GmbH <info@uib.de>  Fri, 18 Feb 2022 16:57:21 +0100

opsi-utils (4.2.0.154-1) stable; urgency=medium

  * Improvement:  Update python packages
  * Improvement:  Change defaults for --log-file and --log-level

 -- uib GmbH <info@uib.de>  Tue, 15 Feb 2022 19:12:19 +0100

opsi-utils (4.2.0.153-1) stable; urgency=medium

  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Mon, 07 Feb 2022 13:14:40 +0100


==============================================================================

opsi-server (4.2.0.64-1) stable; urgency=medium

  * Improvement:  Auto set signed-by option in opsi.list

 -- uib GmbH <info@uib.de>  Fri, 11 Feb 2022 11:05:31 +0100

opsi-server (4.2.0.62-1) stable; urgency=medium

  * Improvement:  Install opsi-obs.gpg key on debian-like dists

 -- uib GmbH <info@uib.de>  Tue, 25 Jan 2022 20:23:21 +0100

opsi-server (4.2.0.61-1) stable; urgency=medium

  * Improvement:  Require opsiconfd >= 4.2.0.228 and opsi-utils >= 4.2.0.149
  * Improvement:  New default hostcontrol.conf for the new config format
  * Improvement:  dynamic depot by network subnetwork match

 -- uib GmbH <info@uib.de>  Thu, 20 Jan 2022 13:53:50 +0100

opsi-server (4.2.0.60-1) stable; urgency=medium

  * Improvement:  Remove methods setGeneralConfig and setGeneralConfigValue
  * Bugfix:  getHostGroupTree_hash
  * Bugfix:  Remove invalid escape sequences in opsihwaudit.conf

 -- uib GmbH <info@uib.de>  Mon, 20 Dec 2021 10:25:23 +0100

opsi-server (4.2.0.59-1) stable; urgency=medium

  * Improvement:  New default values for hostRpcTimeout and maxConnections

 -- uib GmbH <info@uib.de>  Thu, 07 Oct 2021 14:45:10 +0200

opsi-server (4.2.0.58-1) stable; urgency=medium

  * Bugfix:  ucs join script udm groups/group modify

 -- uib GmbH <info@uib.de>  Tue, 07 Sep 2021 14:16:10 +0200

opsi-server (4.2.0.57-1) stable; urgency=medium

  * Improvement:  Fix method setProductActionProgress with empty string as progress

 -- uib GmbH <info@uib.de>  Mon, 06 Sep 2021 07:22:49 +0200


==============================================================================

opsipxeconfd (4.2.0.26-1) stable; urgency=medium

  * Improvement:  New default log file /var/log/opsi/opsipxeconfd/opsipxeconfd.log

 -- uib GmbH <info@uib.de>  Fri, 18 Feb 2022 07:27:25 +0100

opsipxeconfd (4.2.0.25-1) stable; urgency=medium

  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Thu, 17 Feb 2022 14:47:52 +0100

opsipxeconfd (4.2.0.24-1) stable; urgency=medium

  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Thu, 03 Feb 2022 13:20:04 +0100

=============Sehr geehrte opsi-Anwenderinnen und -Anwender,

mit dem heutigen Release veröffentlichen wir eine Reihe von opsi Paketen in stable und testing.

[b]Wichtige Ankündigung zu Secureboot:[/b]

Die Nutzung von Secureboot mit opsi ist seit Entwicklung der Erweiterung kostenpflichtig. Der Lizenzstatus wird im opsi-linux-bootimage geprüft. Leider gab es in der Vergangenheit einen Fehler in der Prüfung und Maschinen mit aktiviertem Secureboot aber nicht lizenzierter Erweiterung konnten dennoch im Secureboot Modus installiert werden.
Mit dem aktuellen opsi-linux-bootimage wurde dieser Fehler behoben und die Prüfung arbeitet wieder korrekt. Dies führt nun dazu, dass bei Netboot Installationen im Secureboot Modus und nicht lizenzierter Erweiterung eine Fehlermeldung erscheint, welche auf die fehlende Lizenzierung hinweist.
Die Lösung für diese Fehlermeldung ist die Secureboot Erweiterung kaufen oder Secureboot im UEFI ausschalten.



[b]opsi-Lizenzen:[/b]

Wir überarbeiten gerade das Format der opsi-Lizenz-Datei (/etc/opsi/modules) und in diesem Zusammenhang gibt es einige Änderungen bei den Lizenzprüfungen in Stable und Testing.  
Alte Lizenzen (modules-Dateien) funktionieren dabei weiterhin. 
Mit dem neuen Prüfverfahren werden die Client-Grenzen der Lizenzen ordnungsgemäß kontrolliert. 
Das bedeutet, dass wenn nicht genügend Lizenzen für ein Modul vorhanden sind, das entsprechende Modul abgeschaltet wird.
Natürlich gibt es eine gewisse Kulanz bei der Anzahl der Clients. 

Sollten Sie aktuell mehr Clients haben, als Ihre Lizenz erlaubt, gibt es mehrere Möglichkeiten:
- Kaufen Sie zusätzliche Lizenzen
- Entfernen Sie nicht benötigte Clients
- Fordern Sie bei uns eine temporäre Freischaltung an, um zu klären, ob weitere Lizenzen erworben werden sollen oder nicht.

Bei Problemen helfen wir natürlich gerne weiter.
Kontaktieren Sie uns gerne direkt über sales(at)uib.de.


[b]stable[/b]

Linux Netboot:

  - debian (4.2.0.3-2)
  - ubuntu (4.2.0.3-2)
  - pcmemtest (1.4-1)
  - wipedisk (2.3-1)

Server:

  - opsiconfd (4.2.0.245-1)
  - opsi-utils (4.2.0.161-1)
  - opsi-server (4.2.0.64-1)
  - opsipxeconfd (4.2.0.26)
  - opsi-directory-connector (47.8-1)
  - zsync-curl (0.6.2-3)

[b]testing[/b]:

Windows Localboot:

  - windows10-upgrade (21h2-1)
  - windows11-upgrade (21h2-1)
  - opsi-client-agent (4.2.0.25-1)

Linux Localboot:

  - opsi-linux-client-agent (4.2.0.19-1)
  - l-opsi-server (4.2.0.6-3)

Macos Localboot:

  - opsi-mac-client-agent (4.2.0.13-1)

Linux Netboot:

  - sles12sp3 (4.2.0.1-7)
  - sles12sp4 (4.2.0.1-7)
  - sles12sp5 (4.2.0.1-7)
  - sles15-1 (4.2.0.1-6)
  - sles15-2 (4.2.0.1-6)
  - sles15-3 (4.2.0.1-6)
  - mint20-1 (4.2.0.1-5)
  - mint20-2 (4.2.0.1-5)
  - mint20-3 (4.2.0.1-5)
  - ucs50 (4.2.0.1-7)
 

Server:

  - opsiconfd (4.2.0.245-1)
  - opsi-utils (4.2.0.161-1)
  - opsipxeconfd (4.2.0.26)

Mit freundlichen Grüßen
Fabian Kalweit

Changelogs:

[code]
sles12sp3/4/5 (4.2.0.1-7) testing; urgency=low

  * changed linux-client-agent installation

 -- Mathias Radtke <m.radtke@uib.de> Wed Mar 09 08:30:00 2022 +0200

==============================================================================

sles15-1/2/3 (4.2.0.1-7) testing; urgency=low

  * version bump for consistency

 -- Mathias Radtke <m.radtke@uib.de> Wed Mar 09 08:1:00 2022 +0200

==============================================================================

mint20-1/2/3 (4.2.0.1-5) testing; urgency=low

  * corrected behaviour when using installation_method = reboot

 -- Mathias Radtke <m.radtke@uib.de> Thu Mar 03 10:40:00 2022 +0200

==============================================================================

ucs50 (4.2.0.1-7) testing; urgency=low

  * removed script from 4.2.0.1-6, replaced with another one

 -- Mathias Radtke <m.radtke@uib.de> Tue Feb 01 17:05:00 2022 +0200

ucs50 (4.2.0.1-6) testing; urgency=low

  * using postinst script to run join scripts and make Administrator account work

 -- Mathias Radtke <m.radtke@uib.de> Tue Jan 18 09:27:00 2021 +0200

ucs50 (4.2.0.1-5) testing; urgency=low

  * updated to ucs501

 -- Mathias Radtke <m.radtke@uib.de> Wed Dec 15 10:12:00 2021 +0200

ucs50 (4.2.0.1-4) testing; urgency=low

  * changed preseed/post installation command to adapt to other clientconfig.configserver.urls

 -- Mathias Radtke <m.radtke@uib.de> Tue Nov 16 15:34:49 2021 +0200

==============================================================================

debian (4.2.0.3-2) testing; urgency=low

  * ubuntu.py: only setting locales for en and from language property

 -- Mathias Radtke <m.radtke@uib.de> Mon Feb 28 10:11:00 2022 +0200

debian (4.2.0.3-1) testing; urgency=low

  * opsipreparelib: wiping offsets when calling lcreate
  * 01_quota.sh: calling with quotaon -Pv 
  * ubunut.py: corrected quota handling
  * cleanup of unused and commented code

 -- Mathias Radtke <m.radtke@uib.de> Mon Feb 14 13:27:00 2022 +0200

debian (4.2.0.2-3) testing; urgency=low

  * installing linux-client-agent via olca-install.service
  * new property enable_quota to support quota handling

 -- Mathias Radtke <m.radtke@uib.de> Wed Feb 09 11:50:00 2022 +0200

==============================================================================

ubuntu (4.2.0.3-2) testing; urgency=low

  * ubuntu.py: only setting locales for en and from language property

 -- Mathias Radtke <m.radtke@uib.de> Mon Feb 28 10:11:00 2022 +0200

ubuntu (4.2.0.3-1) testing; urgency=low

  * opsipreparelib: wiping offsets when calling lcreate
  * 01_quota.sh: calling with quotaon -Pv
  * ubunut.py: corrected quota handling
  * cleanup of unused and commented code

 -- Mathias Radtke <m.radtke@uib.de> Mon Feb 14 13:27:00 2022 +0200

ubuntu (4.2.0.2-3) testing; urgency=low

  * installing linux-client-agent via olca-install.service
  * new property enable_quota to support quota handling

 -- Mathias Radtke <m.radtke@uib.de> Wed Feb 09 11:50:00 2022 +0200

==============================================================================

wipedisk (2.3-1) testing; urgency=low

  * checking if NVME can be wiped
  * running sgdisk --zap-all anyway

 -- Mathias Radtke <m.radtke@uib.de> Tue Mar 01 2022 09:45:00 +0200

==============================================================================

pcmemtest (1.4-1) testing

 * initial release

 -- Mathias Radtke <m.radtke@uib.de> Wed, 02 Sep 2021 15:55:00 +0200

==============================================================================

l-opsi-server (4.2.0.6-3); testing; urgency=low

  * made some adaptations to wotk with UCS5.0-1 Systems

 -- Mathias Radtke <m.radtke@uib.de> Tue, 01 Feb 2022 17:08:00 +0200

l-opsi-server (4.2.0.6-2); testing; urgency=low

  * opening port 445 on UCS Systems

 -- Mathias Radtke <m.radtke@uib.de> Fri, 07 Jan 2022 11:46:00 +0200

l-opsi-server (4.2.0.6-1); testing; urgency=low

  * added support for UCS 5.0 

 -- Mathias Radtke <m.radtke@uib.de> Fri, 17 Dec 2021 10:50:00 +0200

==============================================================================-

opsi-linux-client-agent (4.2.0.19-1) testing; urgency=low

  * Added version file opsi-client-agent.version for conditioned installation
  * Fixed session-handling for Installation service calls
  * Updated oca-installation-helper to 4.2.0.16

-- Nils Doerrer <n.doerrer@uib.de> Mon, 07 Mar 2022 14:00:00 +0100

opsi-linux-client-agent (4.2.0.18-1) testing; urgency=low

  * Updated opsiclientd to 4.2.0.110 (fixed jsonrpc logging)

-- Nils Doerrer <n.doerrer@uib.de> Thu, 24 Feb 2022 16:00:00 +0100

opsi-linux-client-agent (4.2.0.17-1) testing; urgency=low

  * Updated opsiclientd to 4.2.0.109 (reworked opsi-setup-user cleanup and service connection timeouts)
  * Updated oca-installation-helper to 4.2.0.15 (new parameters --dns-domain, --finalize, --read-conf-files)
  * Updated opsi-deploy-client-agent 4.2.0.18 (suse fix for smbclient call)

-- Nils Doerrer <n.doerrer@uib.de> Thu, 24 Feb 2022 10:00:00 +0100
opsi-mac-client-agent (4.2.0.13-1) stable; urgency=low

  * Added version file opsi-client-agent.version for conditioned installation
  * Fixed session-handling for Installation service calls
  * Updated oca-installation-helper to 4.2.0.16

-- Nils Doerrer <n.doerrer@uib.de> Mon, 07 Mar 2022 18:00:00 +0100

opsi-mac-client-agent (4.2.0.12-1) stable; urgency=low

  * Updated opsiclientd to 4.2.0.110 (fixed jsonrpc logging)

-- Nils Doerrer <n.doerrer@uib.de> Thu, 24 Feb 2022 16:00:00 +0100

opsi-mac-client-agent (4.2.0.11-1) stable; urgency=low

  * Updated opsiclientd to 4.2.0.109 (fixed user_logged_in check, reworked opsi-setup-user cleanup and service connection timeouts)
  * Updated oca-installation-helper to 4.2.0.15 (new parameters --dns-domain, --finalize, --read-conf-files)
  * Updated opsi-deploy-client-agent 4.2.0.18 (suse fix for smbclient call)

-- Nils Doerrer <n.doerrer@uib.de> Thu, 17 Feb 2022 16:30:00 +0100
opsi-client-agent (4.2.0.25-1) stable; urgency=low

  * Added version file opsi-client-agent.version for conditioned installation
  * Fixed postinst for first time installation
  * Updated oca-installation-helper to 4.2.0.16 (new parameter --install-condition)

-- Nils Doerrer <n.doerrer@uib.de> Thu, 24 Feb 2022 16:00:00 +0100

opsi-client-agent (4.2.0.24-1) stable; urgency=low

  * Updated opsiclientd to 4.2.0.110 (fixed jsonrpc logging)

-- Nils Doerrer <n.doerrer@uib.de> Thu, 24 Feb 2022 16:00:00 +0100

opsi-client-agent (4.2.0.23-1) stable; urgency=low

  * Updated oca-installation-helper to 4.2.0.15 (new parameters --dns-domain, --finalize, --read-conf-files)
  * Updated opsi-deploy-client-agent 4.2.0.18 (suse fix for smbclient call)
  * Updated opsiclientd to 4.2.0.109 (reworked opsi-setup-user cleanup and service connection timeouts)
  * Removed Kiosk Migration. Do not install this package over opsi-client-agent < 4.1.1.18 (serverside) if using kiosk!

-- Nils Doerrer <n.doerrer@uib.de> Tue, 08 Feb 2022 11:00:00 +0100

==============================================================================

windows10-upgrade (21h2-2) testing; urgency=low
    * IMPORTANT: Requires opsiclientd version 4.2.0.104 or higher
    * IMPORTANT: Requires opsi-script version 4.12.4.35-6 or higher
    * Added additional checks for opsiSetupUser leftovers
    * Added check for empty values in Disable UAC section
    * Added include for setupact.log
    * Updated the documentation
    * Tested on win7, win7-x64, win81, win81-x64, win10-2015, win10-x64-2015, win10-2016, win10-x64-2016, win10-2019, win10-x64-2019, win10-2021, win10-x64-2021, win10-21h1, win10-x64-21h1
-- Matthias Knauer <m.knauer@uib.de> Thu, 17 Feb 2022 11:11:11 +0000

windows11-upgrade (21h2-1) testing; urgency=low
    * IMPORTANT: Requires opsiclientd version 4.2.0.104 or higher
    * IMPORTANT: Requires opsi-script version 4.12.4.35-6 or higher
    * Initial package
    * Tested on win10-21h1, win10-x64-21h1
-- Matthias Knauer <m.knauer@uib.de> Wed, 09 Feb 2022 11:11:11 +0000


==============================================================================

opsiconfd (4.2.0.245-1) stable; urgency=medium

  * Improvement:  Always wait for session to be stored in redis

 -- uib GmbH <info@uib.de>  Wed, 09 Mar 2022 11:54:51 +0100

opsiconfd (4.2.0.244-1) stable; urgency=medium

  * Bugfix:  Fix reading RedisTimeSeries data

 -- uib GmbH <info@uib.de>  Fri, 25 Feb 2022 12:19:58 +0100

opsiconfd (4.2.0.243-1) stable; urgency=medium

  * Improvement:  Update python-opsi-common (4.2.0.276 -> 4.2.0.277)

 -- uib GmbH <info@uib.de>  Fri, 25 Feb 2022 00:15:52 +0000

opsiconfd (4.2.0.242-1) stable; urgency=medium

  * Improvement:  Add licensing tab
  * Improvement:  Impove grafana setup
  * Improvement:  Update python-opsi-common (4.2.0.275 -> 4.2.0.276)
  * Bugfix:  Fix creating grafana dashboard user

 -- uib GmbH <info@uib.de>  Thu, 24 Feb 2022 21:41:43 +0100

opsiconfd (4.2.0.241-1) stable; urgency=medium

  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Thu, 24 Feb 2022 10:06:04 +0000

opsiconfd (4.2.0.240-1) stable; urgency=medium

  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Wed, 23 Feb 2022 12:54:12 +0000

opsiconfd (4.2.0.239-1) stable; urgency=medium

  * Improvement:  Add config admin-interface-terminal-shell
  * Improvement:  Use configured user shell

 -- uib GmbH <info@uib.de>  Mon, 21 Feb 2022 16:25:54 +0100

opsiconfd (4.2.0.238-1) stable; urgency=medium

  * Improvement:  Update python-opsi (4.2.0.272 -> 4.2.0.273)
  * Improvement:  Update python packages
  * Bugfix:  Fix nagios disk usage check

 -- uib GmbH <info@uib.de>  Mon, 21 Feb 2022 11:44:38 +0000

opsiconfd (4.2.0.237-1) stable; urgency=medium

  * Improvement:  Update python packages
  * Improvement:  Improve terminal latency
  * Feature:  Allow to disable admin interface features
  * Improvement:  Admin page hash links
  * Feature:  Terminal file upload

 -- uib GmbH <info@uib.de>  Fri, 18 Feb 2022 15:52:01 +0000

opsiconfd (4.2.0.236-1) stable; urgency=medium

  * Feature:  Add terminal application
  * Improvement:  Log config on setup

 -- uib GmbH <info@uib.de>  Mon, 14 Feb 2022 15:56:44 +0100

opsiconfd (4.2.0.235-1) stable; urgency=medium

  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Tue, 08 Feb 2022 12:15:12 +0100

opsiconfd (4.2.0.234-1) stable; urgency=medium

  * Improvement:  Updated python packages
  * Improvement:  Show days until cert renewal in admin interface

 -- uib GmbH <info@uib.de>  Mon, 07 Feb 2022 13:13:14 +0100

opsiconfd (4.2.0.233-1) stable; urgency=medium

  * Feature:  Add WebDAV link on admin interface
  * Improvement:  Config file is optional

 -- uib GmbH <info@uib.de>  Wed, 02 Feb 2022 07:55:59 +0100

opsiconfd (4.2.0.232-1) stable; urgency=medium

  * Improvement:  Update python pacakages
  * Feature:  Add central webdav share /webdav

 -- uib GmbH <info@uib.de>  Fri, 28 Jan 2022 17:31:41 +0100

opsiconfd (4.2.0.231-1) stable; urgency=medium

  * Improvement:  Recreate server cert if ca is renewed

 -- uib GmbH <info@uib.de>  Wed, 26 Jan 2022 11:40:26 +0000

opsiconfd (4.2.0.230-1) stable; urgency=medium

  * Improvement:  Check server cert against ca
  * Improvement:  Improve ssl info in admin interface
  * Improvement:  Version 4.2.0.230 running with python 3.10
  * Improvement:  Update fastapi to 0.73
  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Tue, 25 Jan 2022 15:11:45 +0100

opsiconfd (4.2.0.229-1) stable; urgency=medium

  * No public changes

 -- uib GmbH <info@uib.de>  Fri, 21 Jan 2022 10:14:02 +0100

opsiconfd (4.2.0.228-1) stable; urgency=medium

  * No public changes

 -- uib GmbH <info@uib.de>  Wed, 12 Jan 2022 18:31:52 +0100

opsiconfd (4.2.0.227-1) stable; urgency=medium

  * Improvement:  Update python packages
  * Improvement:  Recreate server cert if key or cert unreadable
  * Improvement:  Check server cert and key mismatch

 -- uib GmbH <info@uib.de>  Wed, 12 Jan 2022 12:51:23 +0100

opsiconfd (4.2.0.226-1) stable; urgency=medium

  * Improvement:  Add lsb-release to dependencies
  * Bugfix:  Fix setting RLIMIT_NOFILE
  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Wed, 05 Jan 2022 22:23:14 +0100

opsiconfd (4.2.0.225-1) stable; urgency=medium

  * Improvement:  Log System Volume Information MKCOL error with debug level
  * Bugfix:  Make /public readonly

 -- uib GmbH <info@uib.de>  Wed, 22 Dec 2021 14:55:39 +0100

opsiconfd (4.2.0.224-1) stable; urgency=medium

  * Improvement:  Update python-opsi

 -- uib GmbH <info@uib.de>  Fri, 17 Dec 2021 18:46:56 +0100

==============================================================================

opsi-utils (4.2.0.161-1) stable; urgency=medium

  * Improvement:  Update python packages
  * Improvement:  changed logging config to always use logfile (parameter or default)

 -- uib GmbH <info@uib.de>  Mon, 07 Mar 2022 18:18:46 +0100

opsi-utils (4.2.0.160-1) stable; urgency=medium

  * Improvement:  updated python packages, added importhook for pyasn1_modules

 -- uib GmbH <info@uib.de>  Wed, 02 Mar 2022 15:32:44 +0100

opsi-utils (4.2.0.159-1) stable; urgency=medium

  * Improvement:  Update python-opsi-common (4.2.0.276 -> 4.2.0.277)

 -- uib GmbH <info@uib.de>  Fri, 25 Feb 2022 01:20:28 +0100

opsi-utils (4.2.0.158-1) stable; urgency=medium

  * Improvement:  Update python-opsi-common (4.2.0.275 -> 4.2.0.276)

 -- uib GmbH <info@uib.de>  Thu, 24 Feb 2022 15:44:59 +0100

opsi-utils (4.2.0.157-1) stable; urgency=medium

  * Improvement:  Updating python-opsi (4.2.0.274 -> 4.2.0.275)

 -- uib GmbH <info@uib.de>  Thu, 24 Feb 2022 11:02:12 +0100

opsi-utils (4.2.0.156-1) stable; urgency=medium

  * Improvement:  opsi-setup: do not create default log file /tmp/opsi-setup.log
  * Improvement:  Update python-opsi 4.2.0.272 -> 4.2.0.273

 -- uib GmbH <info@uib.de>  Tue, 22 Feb 2022 07:47:14 +0100

opsi-utils (4.2.0.155-1) stable; urgency=medium

  * Improvement:  Update python packages
  * Improvement:  Upgrade python and python packages
  * Improvement:  Build with python 3.10

 -- uib GmbH <info@uib.de>  Fri, 18 Feb 2022 16:57:21 +0100

opsi-utils (4.2.0.154-1) stable; urgency=medium

  * Improvement:  Update python packages
  * Improvement:  Change defaults for --log-file and --log-level

 -- uib GmbH <info@uib.de>  Tue, 15 Feb 2022 19:12:19 +0100

opsi-utils (4.2.0.153-1) stable; urgency=medium

  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Mon, 07 Feb 2022 13:14:40 +0100


==============================================================================

opsi-server (4.2.0.64-1) stable; urgency=medium

  * Improvement:  Auto set signed-by option in opsi.list

 -- uib GmbH <info@uib.de>  Fri, 11 Feb 2022 11:05:31 +0100

opsi-server (4.2.0.62-1) stable; urgency=medium

  * Improvement:  Install opsi-obs.gpg key on debian-like dists

 -- uib GmbH <info@uib.de>  Tue, 25 Jan 2022 20:23:21 +0100

opsi-server (4.2.0.61-1) stable; urgency=medium

  * Improvement:  Require opsiconfd >= 4.2.0.228 and opsi-utils >= 4.2.0.149
  * Improvement:  New default hostcontrol.conf for the new config format
  * Improvement:  dynamic depot by network subnetwork match

 -- uib GmbH <info@uib.de>  Thu, 20 Jan 2022 13:53:50 +0100

opsi-server (4.2.0.60-1) stable; urgency=medium

  * Improvement:  Remove methods setGeneralConfig and setGeneralConfigValue
  * Bugfix:  getHostGroupTree_hash
  * Bugfix:  Remove invalid escape sequences in opsihwaudit.conf

 -- uib GmbH <info@uib.de>  Mon, 20 Dec 2021 10:25:23 +0100

opsi-server (4.2.0.59-1) stable; urgency=medium

  * Improvement:  New default values for hostRpcTimeout and maxConnections

 -- uib GmbH <info@uib.de>  Thu, 07 Oct 2021 14:45:10 +0200

opsi-server (4.2.0.58-1) stable; urgency=medium

  * Bugfix:  ucs join script udm groups/group modify

 -- uib GmbH <info@uib.de>  Tue, 07 Sep 2021 14:16:10 +0200

opsi-server (4.2.0.57-1) stable; urgency=medium

  * Improvement:  Fix method setProductActionProgress with empty string as progress

 -- uib GmbH <info@uib.de>  Mon, 06 Sep 2021 07:22:49 +0200


==============================================================================

opsipxeconfd (4.2.0.26-1) stable; urgency=medium

  * Improvement:  New default log file /var/log/opsi/opsipxeconfd/opsipxeconfd.log

 -- uib GmbH <info@uib.de>  Fri, 18 Feb 2022 07:27:25 +0100

opsipxeconfd (4.2.0.25-1) stable; urgency=medium

  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Thu, 17 Feb 2022 14:47:52 +0100

opsipxeconfd (4.2.0.24-1) stable; urgency=medium

  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Thu, 03 Feb 2022 13:20:04 +0100

==============================================================================

opsi-directory-connector (47.8-1) stable; urgency=medium

  * Improvement:  use new license check

 -- uib GmbH <info@uib.de>  Thu, 17 Feb 2022 13:24:16 +0000

opsi-directory-connector (47.7-1) stable; urgency=medium

  * Feature:  config delete_empty_groups

 -- uib GmbH <info@uib.de>  Tue, 25 Jan 2022 12:56:19 +0000

==============================================================================
[/quote]

=================================================================

opsi-directory-connector (47.8-1) stable; urgency=medium

* Improvement: use new license check

-- uib GmbH <info@uib.de> Thu, 17 Feb 2022 13:24:16 +0000

opsi-directory-connector (47.7-1) stable; urgency=medium

* Feature: config delete_empty_groups

-- uib GmbH <info@uib.de> Tue, 25 Jan 2022 12:56:19 +0000

==============================================================================
[/code]
Antworten