Actualisations pour opsi 4.2 dans stable et testing

Ce forum est dédié au nouveautés, événements autour du projet Opsi
Antworten
otto
Beiträge: 154
Registriert: 08 Aug 2017, 12:16

Actualisations pour opsi 4.2 dans stable et testing

Beitrag von otto »

Chers utilisateurs d'opsi,

nous publions d'autres paquets pour opsi 4.2 dans testing et stable.


stable
opsi-server:
  • opsi-utils (4.2.0.144)
  • opsiconfd (4.2.0.221)
  • redis-timeseries (1.4.11.0)
  • opsi-linux-bootimage_20211119-1
localboot linux
  • opsi-script (4.12.4.32-3)
  • opsi-linux-client-agent 4.2.0.11-1 (linux)
  • l-debunut-upgrade (4.2.0.0-3)
localboot windows
  • opsi-script (4.12.4.32-3)
  • opsi-client-agent 4.2.0.17-2 (windows)
localboot mac
  • opsi-script (4.12.4.32-3)
netboot linux:
  • alma8 (4.2.0.2-3)
  • centos70 (4.2.0.2-3)
  • centos8 (4.2.0.2-3)
  • redhat70 (4.2.0.2-3)
  • redhat8 (4.2.0.2-3)
  • rocky8 (4.2.0.2-3)
  • debian (4.2.0.1-3)
  • debian9 (4.2.0.1-6)
  • debian10 (4.2.0.1-6)
  • debian11 (4.2.0.1-6)
  • mint20-1 (4.2.0.1-4)
  • mint20-2 (4.2.0.1-4)
  • opensusel15-2 (4.2.0.1-5)
  • opensusel15-3 (4.2.0.1-5)
  • sles12sp3 (4.2.0.1-5)
  • sles12sp4 (4.2.0.1-5)
  • sles15-1 (4.2.0.1-5)
  • sles15-2 (4.2.0.1-5)
  • sles15-3 (4.2.0.1-5)
  • ubuntu (4.2.0.1-4)
  • ubuntu18-04 (4.2.0.1-6)
  • ubuntu20-04 (4.2.0.1-6)
  • ucs44 (4.2.0.1-4)
netboot windows
  • win* (4.2.0.1-5)
netboot opsi-local-image:
  • opsi-local-image-win* (4.2.0.1-5)
testing:
opsi-server:
  • opsi-utils (4.2.0.144)
  • opsi-linux-bootimage 20211214-1
  • opsi-directory-connector 47.5
localboot linux
  • opsi-script (4.12.4.33-3)
  • l-debuntu-upgrade (4.2.0.0-4)
localboot windows
  • opsi-script (4.12.4.33-3)
localboot mac
  • opsi-script (4.12.4.33-3)
netboot linux
  • alma8 (4.2.0.2-5)
  • centos70 (4.2.0.2-5)
  • centos8 (4.2.0.2-5)
  • redhat70 (4.2.0.2-5)
  • redhat8 (4.2.0.2-5)
  • rocky8 (4.2.0.2-5)
  • opensusel15-2 (4.2.0.1-6)
  • opensusel15-3 (4.2.0.1-6)
  • sles12sp3 (4.2.0.1-6)
  • sles12sp4 (4.2.0.1-6)
  • sles12sp5 (4.2.0.1-6)
  • sles15-1 (4.2.0.1-6)
  • sles15-2 (4.2.0.1-6)
  • sles15-3 (4.2.0.1-6)
  • ubuntu18-04 (4.2.0.1-7)
  • ubuntu20-04 (4.2.0.1-7)
opsi-local-image netboot
  • opsi-local-image-prepare (4.2.0.0-1)

    Cordialement
    Fabian Kalweit

    Code: Alles auswählen

    
    opsi-script (4.12.4.33) stable; urgency=low
    
      osparser: more debug logs in getFileInfoMap
      osparser: getFileInfoMap: catch exceptions
      versionx: catch exceptions in GetString
    
    -- d.oertel d.oertel@uib.de Fri, 03 Dec 2021 15:00
    
    -------------------------------------------------------------------
    
    opsi-client-agent (4.2.0.17-1) stable; urgency=low
    
      * Fix: old opsiclientd version does not handle restart marker
      * Updated opsiclientd to 4.2.0.99 (WAN mode - fix modules handling)
    
    -- Jan Schneider <j.schneider@uib.de> Mon, 06 Dec 2021 15:45:00 +0100
    
    opsi-client-agent (4.2.0.16-1) stable; urgency=low
    
      * Improved checking for Powershell restrictions
      * Update opsi-notifier to 4.2.0.3 (timepicker fix)
      * Update opsiclientd to 4.2.0.98
        - feature: temporary popup notifications
        - fix: event config inheritance
        - fix: only save current custom skin if it is nonempty
        - fix: update choices in time select notifier while running
      * Workaround for access denied on rename of bin folder
      * Installing opsi-script if not present (ahead of update_action_processor)
      * Updated oca-installation-helper to 4.2.0.6
      * Add parameter /u to service_setup.cmd
    
    -- Nils Doerrer <n.doerrer@uib.de> Tue, 01 Dec 2021 13:30:00 +0100
    
    opsi-client-agent (4.2.0.15-1) stable; urgency=low
    
      * Update vcredist to 2015-2022 14.30.30528.0
      * Update opsiclientd to 4.2.0.96 (reworked event-handling, minor fixes)
      * Update oca-installation-helper to 4.2.0.5
      * Update opsi-script to 4.12.4.31
      * Update opsi-deploy-client-agent to 4.2.0.15 (isolated from opsicommon python module)
    
    -- Nils Doerrer <n.doerrer@uib.de> Thu, 18 Nov 2021 17:30:00 +0100
    
    -------------------------------------------------------------------
    
    opsi-linux-client-agent (4.2.0.11-1) testing; urgency=low
    
      * Update opsi-notifier to 4.2.0.3 (timepicker fix)
      * Update opsiclientd to 4.2.0.99
        - feature: temporary popup notifications
        - fix: event config inheritance
        - fix: only save current custom skin if it is nonempty
        - fix: update choices in time select notifier while running
      * Updated oca-installation-helper to 4.2.0.6
      * Updated opsi-script to 4.12.4.32
    
    -- Nils Doerrer <n.doerrer@uib.de> Thu, 06 Dec 2021 17:30:00 +0100
    
    opsi-linux-client-agent (4.2.0.10-1) testing; urgency=low
    
      * updated opsiclientd 4.2.0.96 (reworked event-handling, minor fixes)
      * updated oca-installation-helper 4.2.0.5 (fixed ssl-lib problem on old RPM-based linux)
      * updated opsi-script 4.12.4.31
      * updated opsi-deploy-client-agent 4.2.0.15 (isolated from opsicommon python module)
    
    -- Nils Doerrer <n.doerrer@uib.de> Thu, 18 Nov 2021 17:30:00 +0100
    
    opsi-linux-client-agent (4.2.0.9-1) testing; urgency=low
    
      * updated opsiclientd 4.2.0.95 (fixed proxy environment handling)
    
    -- Nils Doerrer <n.doerrer@uib.de> Tue, 02 Nov 2021 14:30:00 +0100
    
    -------------------------------------------------------------------
    
    opsi-linux-bootimage (20211210-1) testing; urgency=low
    
      * run-master: fixing non working configserver-url when starting without service address
    
     -- Mathias Radtke <m.radtke@uib.de> Fri, 10 Dec 2021 13:00:00 +0200
    
    opsi-linux-bootimage (20211209-1) testing; urgency=low
    
      * kernel 5.15.7
      * modularized ARCNET driver
      * updated grubx64.efi to 2.0.6
      * grub.cfg: added UEFI Firmware entry
    
     -- Mathias Radtke <m.radtke@uib.de> Thu, 09 Dec 2021 11:13:00 +0200
    
    opsi-linux-bootimage (20211119-1) testing; urgency=low
    
      * added CONFIG_VMD
    
     -- Mathias Radtke <m.radtke@uib.de> Fri, 19 Nov 2021 11:20:00 +0200
    
    -----------------------------
    
    alma8/centos8/redhat8/centos70/redhat70 (4.2.0.2-5) testing; urgency=low
    
      * Corrected EPEL repo installation
    
     -- Terry Strooband <t.strooband@dgip.nl> Tue Dec  7 12:16:49 2021 +0200
    
    alma8/centos8/redhat8/centos70/redhat70 (4.2.0.2-4) testing; urgency=low
    
      * Added UEFI firmware settings to intermediate grub menu
      * Fix installation of opsi-linux-client-agent with minimal installation ISOs
    
     -- Terry Strooband <t.strooband@dgip.nl> Sat Dec  4 03:22:45 2021 +0200
    
    alma8/centos8/redhat8/centos70/redhat70 (4.2.0.2-3) testing; urgency=low
    
      * changed preseed/post installation command to adapt to other clientconfig.configserver.urls
    
     -- Mathias Radtke <m.radtke@uib.de> Tue Nov 16 15:34:48 2021 +0200
    
    alma8/centos8/redhat8/centos70/redhat70 (4.2.0.2-2) testing; urgency=low
    
      * Removed unneeded variable from setup.py
    
     -- Terry Strooband <t.strooband@dgip.nl> Tue Nov 16 12:49:06 2021 +0200
    
    alma8/centos8/redhat8/centos70/redhat70 (4.2.0.2-1) testing; urgency=low
    
      * Split kernel_boot_options, the kernel_boot_options_installer property is only for options for the installer.
      * Installation from nfs should also use the signed linux/initrd.
      * Default packages in kickstart file can now be changed via a productproperty.
      * Added productproperty to select custom partition scheme.
      * Changed method of not installing opsi-client-agent, if productproperty is set to false.
      * Packages needed for opsi-client-agent are now in setup.py
      * Added wget as requirement for opsi-client-agent
      * Moved opsi-client-agent installation to setup.py
    
     -- Terry Strooband <t.strooband@dgip.nl> Fri Nov 05 18:30:00 2021 +0100
    
    alma8/centos8/redhat8/centos70/redhat70 (4.2.0.1-4) testing; urgency=low
    
      * corrected configserver ip address patching
    
     -- Mathias Radtke <m.radtke@uib.de> Mon Oct 25 12:27:33 2021 +0200
    
    -------------------------
    debian (4.2.0.1-3) testing; urgency=low
    
      * corrected path to opsi-linux-client-agent.log
    
     -- Mathias Radtke <m.radtke@uib.de> Thu Oct 28 08:44:00 2021 +0200
    ------------------------
    debian9/10/11 (4.2.0.1-6) testing; urgency=low
    
      * changed preseed/post installation command to adapt to other clientconfig.configserver.urls
    
     -- Mathias Radtke <m.radtke@uib.de> Tue Nov 16 15:34:48 2021 +0200
    
    
    debian9/10/11 (4.2.0.1-5) testing; urgency=low
    
      * corrected configserver ip address patching
    
     -- Mathias Radtke <m.radtke@uib.de> Mon Oct 25 12:27:33 2021 +0200
    
    -------------------------
    
    mint20-1/2 (4.2.0.1-4) testing; urgency=low
    
      * changed preseed/post installation command to adapt to other clientconfig.configserver.urls
    
     -- Mathias Radtke <m.radtke@uib.de> Tue Nov 16 15:34:48 2021 +0200
    
    
    mint20-1/2 (4.2.0.1-3) testing; urgency=low
    
      * corrected configserver ip address patching
    
     -- Mathias Radtke <m.radtke@uib.de> Mon Oct 25 12:27:33 2021 +0200
    [*] ---------------------------
    
    sles12sp3/4/5 (4.2.0.1-6) testing; urgency=low
    
      * autoyast xml: added LTSS repository
    
     -- Mathias Radtke <m.radtke@uib.de> Wed Dec 08 13:14:00 2021 +0200
    
    sles12sp3/4/5 (4.2.0.1-5) testing; urgency=low
    
      * changed preseed/post installation command to adapt to other clientconfig.configserver.urls
    
     -- Mathias Radtke <m.radtke@uib.de> Tue Nov 16 15:34:48 2021 +0200
    
    
    sles12sp3/4/5 (4.2.0.1-4) testing; urgency=low
    
      * corrected configserver ip address patching
    
     -- Mathias Radtke <m.radtke@uib.de> Mon Oct 25 12:27:33 2021 +0200
    
    ----------------------------------
    
    sles15-1/2/3 (4.2.0.1-6) testing; urgency=low
    
      * setting final-reboot to false to stabilize olca installation
    
     -- Mathias Radtke <m.radtke@uib.de> Thu Dec 01 10:10:48 2021 +0200
    
    sles15-1/2/3 (4.2.0.1-5) testing; urgency=low
    
      * changed preseed/post installation command to adapt to other clientconfig.configserver.urls
    
     -- Mathias Radtke <m.radtke@uib.de> Tue Nov 16 15:34:49 2021 +0200
    
    
    sles15-1/2/3 (4.2.0.1-4) testing; urgency=low
    
      * corrected configserver ip address patching
    
     -- Mathias Radtke <m.radtke@uib.de> Mon Oct 25 12:27:33 2021 +0200
    
    ----------------------------
    
    ubuntu (4.2.0.1-4) testing; urgency=low
    
      * using nosplash on focal release to prevent blackscreen
    
     -- Mathias Radtke <m.radtke@uib.de> Thu Nov 11 12:04:00 2021 +0200
    
    ubuntu (4.2.0.1-3) testing; urgency=low
    
      * corrected path to opsi-linux-client-agent.log
    
     -- Mathias Radtke <m.radtke@uib.de> Thu Oct 28 08:44:00 2021 +0200
    
    ---------------------------
    
    ubuntu18-04/20-04 (4.2.0.1-7) testing; urgency=low
    
      * fixed keymap when using different locale
    
     -- Mathias Radtke <m.radtke@uib.de> Tue, Nov 30 14:40:00 2021 +0200
    
    ubuntu18-04/20-04 (4.2.0.1-6) testing; urgency=low
    
      * changed preseed/post installation command to adapt to other clientconfig.configserver.urls
    
     -- Mathias Radtke <m.radtke@uib.de> Tue Nov 16 15:34:49 2021 +0200
    
    ubuntu18-04/20-04 (4.2.0.1-5) testing; urgency=low
    
      * corrected configserver ip address patching
    
     -- Mathias Radtke <m.radtke@uib.de> Mon Oct 25 12:27:33 2021 +0200
    
    --------------------------------
    
    ucs44 (4.2.0.1-4) testing; urgency=low
    
      * changed preseed/post installation command to adapt to other clientconfig.configserver.urls
    
     -- Mathias Radtke <m.radtke@uib.de> Tue Nov 16 15:34:49 2021 +0200
    
    
    ucs44 (4.2.0.1-3) testing; urgency=low
    
      * corrected configserver ip address patching
    
     -- Mathias Radtke <m.radtke@uib.de> Mon Oct 25 12:27:33 2021 +0200
    
    -------------------------------------
    
    l-debunut-upgrade (4.2.0.0-4) stable; urgency=low
    
     * patchung security repo when upgrading from buster to bullseye
    
     -- Mathias Radtke <m.radtke@uib.de> Thu, 07 Oct 2021 11:11:00 +0200
    
    l-debunut-upgrade (4.2.0.0-3) stable; urgency=low
    
      * quitting of target OS version is current OS version
    
     -- Mathias Radtke <m.radtke@uib.de> Thu, 30 Sep 2021 14:00:00 +0200
    l-debunut-upgrade (4.2.0.0-2) stable; urgency=low
    
      * fixed possible error with confnew/confdev when upgrading to bullseye
    
     -- Mathias Radtke <m.radtke@uib.de> Mon, 27 Sep 2021 09:32:00 +0200
    
    l-debuntu-upgrade (4.2.0.0-1) stable; urgency=low
    
      * buster to bullseye upgrade added
    
     -- Mathias Radtke <m.radtke@uib.de> Thu, 09 Sep 2021 14:15:00 +0200
    
    ------------------------------------------
    
    windows (4.2.0.1-5) testing; urgency=low
    
      * setup.opsiscript: detecting win11 product and performing registry changes for a successful installation
    
     -- Mathias Radtke <m.radtke@uib.de> Wed Oct 27 09:50:08 2021 +0200
    
    ------------------------------------------
    
    opsi-local-image-windows (4.2.0.1-5) testing; urgency=low
    
      * setup.opsiscript: detecting win11 product and performing registry changes for a successful installation
    
     -- Mathias Radtke <m.radtke@uib.de> Wed Oct 27 09:50:08 2021 +0200
    
    -------------------------------------------
    
    opsi-local-image-prepare (4.2.0.0-1) stable; urgency=low
    
      * add capture products to start_os_installation
      * remove win7 and win81 from start_os_installation
    
    -- detlef oertel <d.oertel@uib.de>  Wed, 23 Jun 2018 15:00:00 +0200
    
    -------------------------------------------
    
    
    opsiconfd (4.2.0.221-1) stable; urgency=medium
    
      * Improvement:  Disable max session per ip for depot servers
      * Bugfix:  Fix webdav handling of special characters in filenames
    
     -- uib GmbH <info@uib.de>  Mon, 13 Dec 2021 09:58:58 +0100
    
    opsiconfd (4.2.0.220-1) stable; urgency=medium
    
      * Improvement:  monitoring test if depot exists and if clients match
    
     -- uib GmbH <info@uib.de>  Fri, 10 Dec 2021 08:36:27 +0000
    
    opsiconfd (4.2.0.219-1) stable; urgency=medium
    
      * Bugfix:  Fix login for recent grafana version
    
     -- uib GmbH <info@uib.de>  Fri, 03 Dec 2021 11:44:32 +0100
    
    opsiconfd (4.2.0.218-1) stable; urgency=medium
    
      * Improvement:  Update opsi packages
    
     -- uib GmbH <info@uib.de>  Wed, 01 Dec 2021 13:37:47 +0000
    
    opsiconfd (4.2.0.217-1) stable; urgency=medium
    
      * No public changes
    
     -- uib GmbH <info@uib.de>  Fri, 26 Nov 2021 10:28:37 +0100
    
    -------------------------------------------
    
    opensusel15-2 (4.2.0.1-6) testing; urgency=low
    
      * setting final-reboot to false to stabilize olca installation
    
     -- Mathias Radtke <m.radtke@uib.de> Thu Dec 01 10:10:48 2021 +0200
    
    opensusel15-2 (4.2.0.1-5) testing; urgency=low
    
      * changed preseed/post installation command to adapt to other clientconfig.configserver.urls
    
     -- Mathias Radtke <m.radtke@uib.de> Tue Nov 16 15:34:48 2021 +0200
    
    
    opensusel15-2 (4.2.0.1-4) testing; urgency=low
    
      * corrected configserver ip address patching
    
     -- Mathias Radtke <m.radtke@uib.de> Mon Oct 25 12:27:33 2021 +0200
    
    -------------------------------------------------
    
    opsi-linux-bootimage (20211214-1) testing; urgency=low
    
      * run-master: fixed error after wrong one-time-password was entered
    
     -- Mathias Radtke <m.radtke@uib.de> Tue, 14 Dec 2021 15:36:00 +0200
    
     ---------------------------------------------------
    
    opsi-utils (4.2.0.144-1) stable; urgency=medium
    
      * Improvement:  Add dependency to cpio
    
     -- uib GmbH <info@uib.de>  Mon, 13 Dec 2021 10:31:10 +0100
    
    opsi-utils (4.2.0.143-1) stable; urgency=medium
    
      * Improvement:  incremented version number to 4.2.0.143, fixed error logging in opsi-setup
    
     -- uib GmbH <info@uib.de>  Wed, 01 Dec 2021 16:50:19 +0100
    
    opsi-utils (4.2.0.142-1) stable; urgency=medium
    
      * Improvement:  updated python-opsi, added depot_getMD5Sum to methods with long rpc timeout
    
     -- uib GmbH <info@uib.de>  Tue, 30 Nov 2021 15:04:45 +0100
    
    opsi-utils (4.2.0.141-1) stable; urgency=medium
    
      * No public changes
    
     -- uib GmbH <info@uib.de>  Tue, 30 Nov 2021 09:37:14 +0100
    
    opsi-utils (4.2.0.140-1) stable; urgency=medium
    
      * Feature:  added function to list packages unique (over all repos) with their newest version number
      * Improvement:  Make crypt available in opsi-python
      * Improvement:  Add --h, -V and -c
    
     -- uib GmbH <info@uib.de>  Mon, 29 Nov 2021 11:20:38 +0000
    
     ---------------------------------------------------
    
    
Antworten