Updated Netboot Packages in preperation for a new opsi-linux-bootimage

Benutzeravatar
m.radtke
uib-Team
Beiträge: 923
Registriert: 10 Jun 2015, 12:19

Updated Netboot Packages in preperation for a new opsi-linux-bootimage

Beitragvon m.radtke » 10 Sep 2020, 12:50

Dear opsi users,

hereby we release Updates inopsi 4.1 netboot packages in testing and some in stable.
This update is important in context to a new opsi-linux-bootimage and to ensure compatibility between the current and the upcoming bootimage.

Especially those new netboo packages are python3 and python2 compatible and will ensure a compatibility to the upcoming Ubuntu 20-04 based bootimage.

updates in Testing:

Windows Netboot packages:
* Windows-NT6 (4.1.0.2-1)

opsi-local-image Produkte:
* opsi-local-image-NT6 (4.1.0.2-1)
* opsi-local-image-prepare (4.1.0.1-1)
* opsi-local-image-backup (4.1.0.1-1)
* opsi-local-image-delimage (4.1.0.1-1)
* opsi-local-image-restore (4.1.0.1-1)
* opsi-vhd-win10-x64 (4.1.0.2-1)

Linux Netboot packages:
* centos70 (4.1.0.1-1)
* debian (4.1.0.3-1)
* debiab9 (4.1.0.4-1)
* debian10 (4.1.0.5-1)
* opensusel15-1 (4.1.0.2-1)
* opensusel15-2 (4.1.0.2-1)
* opsi-clonezilla (4.1.0.2-1)
* redhat70 (4.1.0.1-1)
* sles12(sp*) (4.1.0.1-1)
* ubuntu (4.1.0.4-1)
* ubuntu16-04 (4.1.0.2-1)
* ubuntu18-04 (4.1.0.4-1)
* ubuntu20-04 (4.1.0.4-1)
* ucs44 (4.1.0.2-1)

updates in stable:

Windows Netboot packages:
*win-NT6 (4.1.0.1-16)

opsi-local-image Netboot packages:
* opsi-local-image-NT6 (4.1.0.1-16)
* opsi-vhd-win10-x64 (4.1.0.1-16)

Linux Netboot packages:
* debian9 (4.1.0.3-4)
* debian10 (4.1.0.4-4)
* ubuntu18-04 (4.1.0.3-4)
* ubutnu20-04 (4.1.0.3-6)

Changelogs:

Code: Alles auswählen

windows (4.1.0.2-1) testing; urgency=low

  * python3 compatible code base

 -- Mathias Radtke <m.radtke@uib.de> Mon Jul 20 18:32:16 2020 +0200

windows (4.1.0.1-16) stable; urgency=low

  * new property: force_del_winpe_boot_entry
  * nt6.opsiscript: on pe-preserve=false do remove opsitempwinpe from display order

 -- detlef oertel <d.oertel@uib.de>  Mon, 31 Jul 2020 15:00:00 +0200

-------------------------------------------------

opsi-local-image (4.1.0.2-1) testing; urgency=low

  * python3 compatible code base

 -- Mathias Radtke <m.radtke@uib.de> Mon Jul 20 18:32:16 2020 +0200

windows (4.1.0.1-16) stable; urgency=low

  * new property: force_del_winpe_boot_entry
  * nt6.opsiscript: on pe-preserve=false do remove opsitempwinpe from display order

 -- detlef oertel <d.oertel@uib.de>  Mon, 31 Jul 2020 15:00:00 +0200

windows (4.1.0.1-15) testing; urgency=low

  * supplied boot devices to fix broken HP UEFIs
  * merged and packed by do

 -- Mathias Radtke <m.radtke@uib.de> Thu Jul  23 15:00:00 2020 +0200

opsi-local-image (4.1.0.1-14) skipped

opsi-local-image (4.1.0.1-13) skipped

-------------------------------------------------


centos70 (4.1.0.1-1) stable; urgency=low

  * python3 compatible code base

 -- Mathias Radtke <m.radtke@uib.de> Mon Jul 20 18:31:44 2020 +0200
 -------------------------------------------------
 
 debian (4.1.0.3-1) stable; urgency=low

  * python3 compatible code base

 -- Mathias Radtke <m.radtke@uib.de> Mon Jul 20 18:31:44 2020 +0200
 -------------------------------------------------
 
 debian9 (4.1.0.4-1) stable; urgency=low

  * python3 compatible code base

 -- Mathias Radtke <m.radtke@uib.de> Mon Jul 20 18:31:44 2020 +0200

debian9 (4.1.0.3-4) testing; urgency=low

  * reworked corde when usign local repository
  * removed opsiclientd deletion in setup.py

-- Mathias Radtke <m.radtke@uib.de> Mon 25 May 2020 16:10:00 +0200
-------------------------------------------------

debian10 (4.1.0.5-1) stable; urgency=low

  * python3 compatible code base

 -- Mathias Radtke <m.radtke@uib.de> Mon Jul 20 18:31:44 2020 +0200

debian10 (4.1.0.4-4) testing; urgency=low

  * reworked corde when usign local repository
  * removed opsiclientd deletion in setup.py

-- Mathias Radtke <m.radtke@uib.de> Mon 25 May 2020 16:10:00 +0200
-------------------------------------------------

opensusel15-1 (4.1.0.2-1) stable; urgency=low

  * python3 compatible code base

 -- Mathias Radtke <m.radtke@uib.de> Mon Jul 20 18:31:44 2020 +0200

opensusel15-1 (4.1.0.1-1) testing; urgency=low

  * installing net-tools-deprecated in installation

-- Mathias Radtke <m.radtke@uib.de> TueA Aug 26 10:25:00 +0200

-------------------------------------------------


opensusel15-2 (4.1.0.2-1) stable; urgency=low

  * python3 compatible code base

 -- Mathias Radtke <m.radtke@uib.de> Mon Jul 20 18:31:44 2020 +0200


opensusel15-2 (4.1.0.1-2) testing; urgency=low

  * forked from opensusel15-1

-- Mathias Radtke <m.radtke@uib.de> Tue May 19 2020 17:25:00 +0200
-------------------------------------------------

redhat70 (4.1.0.1-1) stable; urgency=low

  * python3 compatible code base

 -- Mathias Radtke <m.radtke@uib.de> Mon Jul 20 18:31:44 2020 +0200
 -------------------------------------------------
 sles12 (4.1.0.1-1) stable; urgency=low

  * python3 compatible code base

 -- Mathias Radtke <m.radtke@uib.de> Mon Jul 20 18:31:44 2020 +0200
 -------------------------------------------------
 ubuntu (4.1.0.4-1) stable; urgency=low

  * python3 compatible code base

 -- Mathias Radtke <m.radtke@uib.de> Mon Jul 20 18:31:44 2020 +0200

ubuntu (4.1.0.3-3) stable; urgency=low

  * corrected usage of deleted files on opsi-client-agent

-- Mathias Radtke <m.radtke@uib.de> Tue 18 Aug 2020 09:00:00 +0200
-------------------------------------------------

ubuntu16-04 (4.1.0.2-1) stable; urgency=low

  * python3 compatible code base

 -- Mathias Radtke <m.radtke@uib.de> Mon Jul 20 18:31:44 2020 +0200
 -------------------------------------------------
 ubuntu18-04 (4.1.0.4-1) stable; urgency=low

  * python3 compatible code base

 -- Mathias Radtke <m.radtke@uib.de> Mon Jul 20 18:31:44 2020 +0200

ubuntu18-04 (4.1.0.3-4) testing; urgency=low

  * reworked corde when usign local repository
  * removed opsiclientd deletion in setup.py

-- Mathias Radtke <m.radtke@uib.de> Mon 25 May 2020 16:10:00 +0200

-------------------------------------------------

 ubuntu20-04 (4.1.0.4-1) stable; urgency=low

  * python3 compatible code base

 -- Mathias Radtke <m.radtke@uib.de> Mon Jul 20 18:31:44 2020 +0200

ubuntu20-04 (4.1.0.3-6) testing; urgency=low

  * reworked corde when usign local repository
  * removed opsiclientd deletion in setup.py

-- Mathias Radtke <m.radtke@uib.de> Mon 25 May 2020 16:10:00 +0200

-------------------------------------------------

 ucs44 (4.1.0.2-1) stable; urgency=low

  * python3 compatible code base

 -- Mathias Radtke <m.radtke@uib.de> Mon Jul 20 18:31:44 2020 +0200
 -------------------------------------------------
 
 opsi-local-image-backup (4.1.0.1-1) stable; urgency=low

  * python3 compatible code base

 -- Mathias Radtke <m.radtke@uib.de> Mon 20 Jul 2020 18:35:00 +0200
 -------------------------------------------------
 opsi-local-image-delimage (4.1.0.1-1) stable; urgency=low

  * python3 compatible code base

 -- Mathias Radtke <m.radtke@uib.de> Mon 20 Jul 2020 18:35:00 +0200
 -------------------------------------------------
 opsi-local-image-restore (4.1.0.1-1) stable; urgency=low

  * python3 compatible code base

 -- Mathias Radtke <m.radtke@uib.de> Mon 20 Jul 2020 18:35:00 +0200
 -------------------------------------------------
 opsi-local-image-prepare (4.1.0.1-1) stable; urgency=low

  * python3 compatible code base

 -- Mathias Radtke <m.radtke@uib.de> Mon 20 Jul 2020 18:35:00 +0200
 -------------------------------------------------
 
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.