opsi 4.1 updates in stable and testing

Benutzeravatar
m.radtke
uib-Team
Beiträge: 783
Registriert: 10 Jun 2015, 12:19

opsi 4.1 updates in stable and testing

Beitragvon m.radtke » 29 Nov 2019, 11:16

Dear opsi users,

hereby we release updates in opsi 4.1 stable and testing

The bootimage has a reduced size. Due to added wifi drivers the bootimage gained a lot of size. We deviced to split the bootimage into the PXE/UEFI Netboot variant without WiFi drivers and include WiFi drivers in the locally installable bootimage.

opsi server packages:

stable:
* python-opsi 4.1.1.83-1

testing:
* opsi-linux-bootimage 20191114-1
* python-opsi 4.1.1.85-1

Windows localboot packages:

stable:
* config-win10 4.1.1-8
* opsi-configed 4.1.4.3.3-2

testing:
* opsi-bootimage-local 20191114-1
* windows10-upgrade 19.09-6

Windows netboot packages

stable:
* win* 4.1.0.1-9
* opsi-local-image* 4.1.0.1-7
* opsi-vhd-win10-x64 4.1.0.1-11

testing:
* win* 4.1.0.1-11
* opsi-local-image* 4.1.0.1-9
* opsi-vhd-win10-x64 4.1.0.1-13

Linux netboot packages :

stable:
* debian10 4.1.0.3-2
* ubuntu18-04 4.1.0.2-2

Linux localboot packages:

testing:
* opsi-bootimage-local 20191114-1
* l-opsi-server 4.1.1.14-3
* l-desktop 4.1.0.5-5
* opsi-linux-client-agent 4.1.0.19-11

Regards
Mathias

Changelogs:

Code: Alles auswählen

opsi-linux-bootimage (20191114-1) testing; urgency=medium

  * removed WiFi firmware
  * added IOMMU drivers
  * Use User-Agent HTTP header as described in RFC 2616

 -- Mathias Radtke <m.radtke@uib.de>  Thu, 14 Nov 2019 09:06:04 +0100
 
 -------------------------------------------
 
 l-desktop 4.1.0.5-5; stable ; urgency=low

  * Fix installation of hunspell package for libreoffice.

 -- Niko Wenselowski <n.wenselowski@uib.de> Mon 18 Nov 2019 15:16:32 +0200
 
  -------------------------------------------
 
python-opsi (4.1.1.85-1) testing; urgency=medium

  * OPSI.Util.Task.UpdatePackages.Updater: throwing exception when md5sum
    missmatched an no zsync is available

 -- Mathias Radtke <m.radtke@uib.de>  Wed, 20 Nov 2019 13:37:21 +0100

python-opsi (4.1.1.84-1) testing; urgency=medium

  * OPSI.Util.File.InfFile: Small refactoring in device type detection.
  * OPSI.System.Posix: Support for using the 'ip' command to parse network
    information. By default 'ifconfig' is tried but in case of absence 'ip'
    will be used.
    This requires iproute2 4.15 or newer.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Thu, 14 Nov 2019 13:13:56 +0100

python-opsi (4.1.1.83-1) testing; urgency=medium

  * Fix regular expression pattern of HD audio device drivers.
    This has been broken since 4.1.1.63-1.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Mon, 04 Nov 2019 14:51:34 +0100

python-opsi (4.1.1.82-1) testing; urgency=medium

  * 30_kiosk.conf: Getting the product groups now works with broken configs.
  * MySQL backend: Changed SOFTWARE_CONFIG.config_id to bigint to allow for
    more entries. An update routine has been added that can be executed by
    running opsi-setup --update-mysql.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Thu, 17 Oct 2019 13:19:31 +0200
 
  -------------------------------------------
 
 l-opsi-server (4.1.1.14-3); experimental; urgency=low

  * added isFatalError if no valid IP can be found
  * code cleanup

 -- matthias knauer <m.knauer@uib.de> Wed, 20 Nov 2019 09:18:00 +0100
 
  -------------------------------------------
 
windows10-upgrade (19.09-6) stable; urgency=low
        * Changed $Setup.exe.version$ for 19.09 to "10.0.18362.1". Microsoft reused the version that was already used for 19.03.
        * Added includeLog "%SYSTEMDRIVE%\$WINDOWS.~BT\Sources\Panther\setuperr.log" to update.opsiscript
-- Matthias Knauer <m.knauer@uib.de> Tue 12 Nov 2019 13:00:00 +0200

windows10-upgrade (19.09-5) stable; urgency=low
        * when upgrading from a windows version <win10 opsi-client-agent will be added to setup-after-install to guarantee a clean reinstallation
-- Matthias Knauer <m.knauer@uib.de> Tue 12 Nov 2019 13:00:00 +0200

windows10-upgrade (19.09-4) stable; urgency=low
        * fixed path in opsiclientd_checker.ps1
        * fixed error handling in opsiclientd_checker.ps1
-- Matthias Knauer <m.knauer@uib.de> Wed 06 Nov 2019 13:00:00 +0200

windows10-upgrade (19.09-3) stable; urgency=low
        * cleaned up all scripts
        * detects and fixes broken opsiclientd when upgrading from a windows version <win10
        * fixed condition for running Registry_del_run
-- Matthias Knauer <m.knauer@uib.de> Mon  31 Oct 2019 13:00:00 +0200

 -------------------------------------------
 
 "4.1.4.3.3" (2019/10/15)
 use configured default for workbench everywhere

 "4.1.4.3.2" (2019/10/14)
 there was yet a thread problem with set rights
 logging connection header
 
 opsi-configed (4.1.4.3.3-1) STABLE; urgency=medium
*  using configured default for workbench
-- r.roeder <r.roeder@uib.de> Tue, 15 Oct 2019 12:11:46 +0100

opsi-configed (4.1.4.3.2-1) STABLE; urgency=medium
*  yet a thread problem handled
*  logging connection header
-- r.roeder <r.roeder@uib.de> Mon, 14 Oct 2019 12:11:46 +0100

opsi-configed (4.1.4.3.1-1) STABLE; urgency=medium
*  handled some problems with threading in ssh functions
-- r.roeder <r.roeder@uib.de> Fri, 11 Oct 2019 12:11:46 +0100

opsi-configed (4.1.4.2.2-1) STABLE; urgency=medium
* When starting or reloading, the possible values for user host groups, product groups, ... are supplemented not only for the loggedin user, but for all users
-- r.roeder <r.roeder@uib.de> Tue, 02 Oct 2019 12:11:46 +0100

opsi-configed (4.1.4.2.1-1) STABLE; urgency=medium
* ssh connection to loginserver is offered if ssh is allowed (the allowed depotservers only add to this offer)
-- r.roeder <r.roeder@uib.de> Fri, 27 Sep 2019 12:11:46 +0100

opsi-configed (4.1.4.1.1-1) STABLE; urgency=medium
*  running action icon implemented
-- r.roeder <r.roeder@uib.de> Tue, 23 Sep 2019 12:11:46 +0100

opsi-configed (4.1.4.1.0-1) STABLE; urgency=medium
* compatibility with opsi 4.2
-- r.roeder <r.roeder@uib.de> Tue, 23 Sep 2019 12:11:46 +0100

opsi-configed (4.1.3.3.2-1) STABLE; urgency=medium
* bugfix in building path for driver upload
-- r.roeder <r.roeder@uib.de> Tue, 03 Sep 2019 12:11:46 +0100

opsi-configed (4.1.3.3.1-1) STABLE; urgency=medium
* info if products are required but do not exist on the depot
-- r.roeder <r.roeder@uib.de> Wed, 29 Aug 2019 12:11:46 +0100

opsi-configed (4.1.3.2.1-1) STABLE; urgency=medium
* bugfix if addressed group has null parentgroup
-- r.roeder <r.roeder@uib.de> Wed, 28 Aug 2019 16:11:46 +0100

opsi-configed (4.1.3.2.0-1) STABLE; urgency=medium
* new command line option --definegroupbysearch
-- r.roeder <r.roeder@uib.de> Wed, 28 Aug 2019 16:11:46 +0100

opsi-configed (4.1.3.1.1-1) STABLE; urgency=medium
* background update of session data, bugfix: working-icon war running only once
-- r.roeder <r.roeder@uib.de> Wed, 21 Aug 2019 12:11:46 +0100

opsi-configed (4.1.3.1.0-1) STABLE; urgency=medium
* background update of session data
-- r.roeder <r.roeder@uib.de> Fri, 16 Aug 2019 12:11:46 +0100

opsi-configed (4.1.2.1.0-4) STABLE; urgency=medium
* bug fix in Linux part
-- r.roeder <r.roeder@uib.de> Thu, 15 Aug 2019 12:11:46 +0100

opsi-configed (4.1.2.1.0-1) STABLE; urgency=medium
* if the opsi server is addressed via cli host parameter, even if not connected,
the server name is included in the log file name  (for distinguishing several log file contexts)
-- r.roeder <r.roeder@uib.de> Fri, 09 Aug 2019 12:11:46 +0100

opsi-configed (4.1.2.0.9-2) STABLE; urgency=medium
* new product property for creating additional start menu links for several opsi servers
-- r.roeder <r.roeder@uib.de> Thu, 08 Aug 2019 13:11:46 +0100

opsi-configed (4.1.2.0.9-1) EXPERIMENTAL; urgency=medium
* button for transfer the client selection in hardware overview to the client list
-- r.roeder <r.roeder@uib.de> Tue , 30 Jul 2019 13:11:46 +0100

opsi-configed (4.1.2.0.8-1) EXPERIMENTAL; urgency=medium
* display of opsi host key
-- r.roeder <r.roeder@uib.de> Wed , 26 Jul 2019 13:11:46 +0100

opsi-configed (4.1.2.0.7-2) EXPERIMENTAL; urgency=medium
* changed linkfolder entry name for Linux (now simply opsi-configed)
-- r.roeder <r.roeder@uib.de> Wed , 24 Jul 2019 13:11:46 +0100

opsi-configed (4.1.2.0.7-1) EXPERIMENTAL; urgency=medium
* for green/red unawareness : supplement (≠) to product version if versions are not equal.
-- r.roeder <r.roeder@uib.de> Fri , 12 Jul 2019 13:11:46 +0100

opsi-configed (4.1.2.0.6-1) STABLE; urgency=medium
* fixed hard coded "/home/opsiproducts" in product installation special call
-- r.roeder <r.roeder@@uib.de>  Mon, 08 Jun 2019 13:11:46 +0100

 -------------------------------------------
 
 config-win10 (4.1.1-8);. stable; urgency=low
  * new property oobeDisablePrivacyExperience
        https://www.tenforums.com/tutorials/118840-enable-disable-privacy-settings-experience-sign-windows-10-a.html
        https://winaero.com/blog/disable-privacy-experience-windows-10/
        https://forum.opsi.org/viewtopic.php?t=11191

-- Bardo Wolf <b.wolf@uib.de> Wed, 16 Oct 2019

 -------------------------------------------
 
 ubuntu18-04 (4.1.0.2-2) stable; urgency=low

  * Working on older bootimages not providing secure boot functionality.

-- Niko Wenselowski <n.wenselowski@uib.de> Thu Oct 31 12:50:59 2019 +0200
 -------------------------------------------
 debian10 (4.1.0.3-2) stable; urgency=low

  * Working on older bootimages not providing secure boot functionality.

-- Niko Wenselowski <n.wenselowski@uib.de> Thu Oct 31 12:50:59 2019 +0200
 -------------------------------------------
 windows (4.1.0.1-11) experimental; urgency=low

  * Fix syntax error in show_drivers.py.

 -- Niko Wenselowski <n.wenselowski@uib.de> Mon Nov 18 19:58:19 2019 +0200


windows (4.1.0.1-10) experimental; urgency=low

  * create_driver_links.py and show_drivers.py are now compatible to opsi 4.2.

 -- Niko Wenselowski <n.wenselowski@uib.de> Mon Nov 18 19:31:55 2019 +0200


windows (4.1.0.1-9) stable; urgency=low

  * Working on older bootimages not providing secure boot functionality.

-- Niko Wenselowski <n.wenselowski@uib.de> Thu Oct 31 12:51:06 2019 +0200

 -------------------------------------------
 
 opsi-local-image (4.1.0.1-9) experimental; urgency=low

  * Fix syntax error in show_drivers.py.

 -- Niko Wenselowski <n.wenselowski@uib.de> Mon Nov 18 19:58:10 2019 +0200


opsi-local-image (4.1.0.1-8) experimental; urgency=low

  * create_driver_links.py and show_drivers.py are now compatible to opsi 4.2.

 -- Niko Wenselowski <n.wenselowski@uib.de> Mon Nov 18 19:32:09 2019 +0200


opsi-local-image (4.1.0.1-7) stable; urgency=low

  * Working on older bootimages not providing secure boot functionality.

 -- Niko Wenselowski <n.wenselowski@uib.de> Thu Oct 31 15:32:50 2019 +0200

 -------------------------------------------
 
 windows (4.1.0.1-13) experimental; urgency=low

  * Fix syntax error in show_drivers.py.

 -- Niko Wenselowski <n.wenselowski@uib.de> Mon Nov 18 19:58:19 2019 +0200


windows (4.1.0.1-12) experimental; urgency=low

  * create_driver_links.py and show_drivers.py are now compatible to opsi 4.2.

 -- Niko Wenselowski <n.wenselowski@uib.de> Mon Nov 18 19:31:55 2019 +0200


windows (4.1.0.1-11) stable; urgency=low

  * Working on older bootimages not providing secure boot functionality.

-- Niko Wenselowski <n.wenselowski@uib.de> Thu Oct 31 12:51:06 2019 +0200

 -------------------------------------------
 
 
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.