Installation Microsoft Surface Pro 7 fails

dark alex
Beiträge: 296
Registriert: 11 Mär 2015, 10:09

Re: Installation Microsoft Surface Pro 7 fails

Beitragvon dark alex » 24 Feb 2020, 13:25

needs to be appended to the boot commandline for the pxe boot entry. But this is experimental until now.

@Mathias: Is this expected?
I just tried to setup one of our HP 250 G7 notebooks (using the testing bootimage in uefi mode without special flags):
Bild

Benutzeravatar
m.radtke
uib-Team
Beiträge: 891
Registriert: 10 Jun 2015, 12:19

Re: Installation Microsoft Surface Pro 7 fails

Beitragvon m.radtke » 25 Feb 2020, 08:47

Hi Alex

Well somone at HP messed up UEFI.

EFI reports device 2004 as bootable device but when trying to change the boot order, EFI reports this device as non existant.
I just love this crappy UEFI implementation from HP.

Can you send me the bootimage log?
I will try to workout a bypass for this.

Cheers
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

dark alex
Beiträge: 296
Registriert: 11 Mär 2015, 10:09

Re: Installation Microsoft Surface Pro 7 fails

Beitragvon dark alex » 25 Feb 2020, 09:09

Oh! So thats not an issue of this all-new bootimage but an HP issue... wow... I'll mail you the log asap

dark alex
Beiträge: 296
Registriert: 11 Mär 2015, 10:09

Re: Installation Microsoft Surface Pro 7 fails

Beitragvon dark alex » 26 Feb 2020, 09:23

So finally I got some results.

With the module blacklist set, the opsi scripts run smoothly. It feels a bit slower than usual but that could be false as usually we are running setups as side work.

BUT

As soon as the bootimage reboots the tablet, it gets stuck at the windows logo screen (the one with secure boot disabled banner - so in fact its the efi boot sequence which hangs).
After a manual power cycle the WinPE starts and the setup is running smoothly...

I'll mail you the bootimage logs for reference

ineedhelp
Beiträge: 7
Registriert: 07 Nov 2019, 08:56

Re: Installation Microsoft Surface Pro 7 fails

Beitragvon ineedhelp » 07 Jul 2020, 15:43

m.radtke hat geschrieben:Ok I might have found something.

A new bootimage is currently being build internally and if it succeeds a new version (20200205-1) will be uploaded later in the experimental repository at download.opensuse.org.

please add

Code: Alles auswählen

modprobe.blacklist=intel_lpss_pci

to the grub.cfg line if you install the new opsi-linux-bootimage package.
At least this works on surface models when starting from USB.

The new build is needed as the required blacklisted module is currently compiled into the kernel instead of being modular and therefore cannot get blacklisted with the current bootimages.

Regards
Mathias


Hello Mr. Radtke,

we opened this thread long time ago. Unfortunately we weren't able to work progressive on this topic. But now we want to take a next try. :-)

I quoted your suggestion because we are not that deep into this opsi configuration stuff. Are you able to explain us how we can add this command line step by step? We would really appreciate it so we can deploy our Surface 7 Models correctly.

Best regards

Benutzeravatar
m.radtke
uib-Team
Beiträge: 891
Registriert: 10 Jun 2015, 12:19

Re: Installation Microsoft Surface Pro 7 fails

Beitragvon m.radtke » 07 Jul 2020, 17:48

ineedhelp hat geschrieben:
Hello Mr. Radtke,

we opened this thread long time ago. Unfortunately we weren't able to work progressive on this topic. But now we want to take a next try. :-)

I quoted your suggestion because we are not that deep into this opsi configuration stuff. Are you able to explain us how we can add this command line step by step? We would really appreciate it so we can deploy our Surface 7 Models correctly.

Best regards


Hi,

you have to enter it as a opsi-linux.bootimage.append parameter, which is displayed here
Bild

Then again set a netboot product to setup and start the device via IPv4 UEFI Netboot

Regards
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

ineedhelp
Beiträge: 7
Registriert: 07 Nov 2019, 08:56

Re: Installation Microsoft Surface Pro 7 fails

Beitragvon ineedhelp » 08 Jul 2020, 12:17

Hi,

thanks for the quick answer.

We added the line and tried booting via Microsoft Network USB Dongle.

But it doesn't work. Also, we used the recommended bootimage and the newest experimental.

So we would appreciate further assistance. Thanks in advance.

Just for your information i attached again where it stops.

https://ibb.co/8YptNWW

Best regards

Benutzeravatar
m.radtke
uib-Team
Beiträge: 891
Registriert: 10 Jun 2015, 12:19

Re: Installation Microsoft Surface Pro 7 fails

Beitragvon m.radtke » 08 Jul 2020, 13:23

Hi

you should change your configuration a little bit.
Please refer to this part of the manual
https://download.uib.de/opsi4.1/documen ... secureboot

You have to change the DHCP filename and the UEFI netboot template ion the opsipxeconfd, restart the services and try again.

You don't need the secureboot extension to use this combination, it is only needed if the client is started in secureboot mode.

Regards
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

ineedhelp
Beiträge: 7
Registriert: 07 Nov 2019, 08:56

Re: Installation Microsoft Surface Pro 7 fails

Beitragvon ineedhelp » 14 Jul 2020, 11:19

Hello Mr. Radtke,

after we changed the config as u suggested, we are able to install the Surface Pro 7.

We create a new client now directly via the device and dont create it on the opsi server anymore.

But that's fine for us. Thanks a lot for your help.

Best regards,
Sebastian