Installation Microsoft Surface Pro 7 fails

ineedhelp
Beiträge: 3
Registriert: 07 Nov 2019, 08:56

Installation Microsoft Surface Pro 7 fails

Beitragvon ineedhelp » 07 Nov 2019, 09:38

Hey all together,

we are currently having an issue to install the new Surface Pro 7 devices.

There is no problem with previous generations like Surface 6 for example. This works completely fine.

What should happen?
First situation: Trying PXE boot. I can see that the device loads the kernel successfully. (install-x64... done)
Afterwards the device loads the file (miniroot-x64.bz2...done) But after that, no further steps take action.
It seems like it runs in a timeout?! or something like that.

Second situation: Trying to boot from USB. Therefore i attach a screenshot i took.

Bild

https://ibb.co/yWD555M

What happened?
Are error messages visible in the log?

Logs don't show anything special, it just loads the previous steps and then it just stops without any error message.

Nov 7 13:29:47 OPSINAME in.tftpd[8924]: RRQ from XXX filename linux/pxelinux.cfg/elilo.efi
Nov 7 13:29:47 OPSINAME in.tftpd[8925]: RRQ from XXX filename linux/pxelinux.cfg/AC1E0A13.conf
Nov 7 13:29:47 OPSINAME in.tftpd[8926]: RRQ from XXX filename linux/pxelinux.cfg/AC1E0A-x86_64.conf
Nov 7 13:29:47 OPSINAME in.tftpd[8927]: RRQ from XXX filename linux/pxelinux.cfg/AC1E0A.conf
Nov 7 13:29:47 OPSINAME in.tftpd[8928]: RRQ from XXX filename linux/pxelinux.cfg/AC1E-x86_64.conf
Nov 7 13:29:47 OPSINAME in.tftpd[8929]: RRQ from XXX filename linux/pxelinux.cfg/AC1E.conf
Nov 7 13:29:47 OPSINAME in.tftpd[8930]: RRQ from XXX filename linux/pxelinux.cfg/AC-x86_64.conf
Nov 7 13:29:47 OPSINAME in.tftpd[8931]: RRQ from XXX filename linux/pxelinux.cfg/AC.conf
Nov 7 13:29:47 OPSINAME in.tftpd[8932]: RRQ from XXX filename linux/pxelinux.cfg/01-b8-31-b5-2e-29-07
Nov 7 13:29:48 OPSINAME in.tftpd[8935]: RRQ from XXX filename /linux/install-x64
Nov 7 13:29:52 OPSINAME in.tftpd[8948]: RRQ from XXX filename /linux/pxelinux.cfg/miniroot-x64.bz2


With what version of the used components does the problem occur?
Everything is up2date. Newest OPSI version and newest .iso from stable branches.

Any ideas or solutions are much appreciated. If you need any further informations, i will post it asap.

Best regards

Benutzeravatar
n.wenselowski
uib-Team
Beiträge: 3195
Registriert: 04 Apr 2013, 12:15

Re: Installation Microsoft Surface Pro 7 fails

Beitragvon n.wenselowski » 11 Nov 2019, 09:54

Hi,

did you try waiting some more before trying anything else?
After waiting some time can you change the tty (e.g. by ctrl + f3) and get a prompt to login?

ineedhelp hat geschrieben:With what version of the used components does the problem occur?
Everything is up2date. Newest OPSI version and newest .iso from stable branches.

We want exact versions as they do make a difference and we don't want to waste our time by hunting down bugs that are already fixed.


ineedhelp hat geschrieben:Any ideas or solutions are much appreciated. If you need any further informations, i will post it asap.

Do they require a hardware dongle for booting over the network again? You could switch to another model.
Could they be UEFI by default? If so you should make sure you use opsi in UEFI mode for that client.

I know that we worked with customers to get opsi running in older models of the Surface family. For this customers send us their devices and we worked directly on them to get things to work.
If you have a support contract it probably is the fasted way to get into direct contact.

Code: Alles auswählen

import OPSI

ineedhelp
Beiträge: 3
Registriert: 07 Nov 2019, 08:56

Re: Installation Microsoft Surface Pro 7 fails

Beitragvon ineedhelp » 11 Nov 2019, 10:29

Hey,

did you try waiting some more before trying anything else?
After waiting some time can you change the tty (e.g. by ctrl + f3) and get a prompt to login?


No, we did not try that yet. We will have the next try at wednesday.


We want exact versions as they do make a difference and we don't want to waste our time by hunting down bugs that are already fixed.


https://ibb.co/34M1JFp

We also tried the experimental version without success.

Do they require a hardware dongle for booting over the network again? You could switch to another model.
Could they be UEFI by default? If so you should make sure you use opsi in UEFI mode for that client.


Currently, we connect the surface to the network port which is from the original docking station. We will try to install via network dongle/adapter if this may work better in your opinion.

Also, the surfaces use UEFI by default, that's why "UEFI Boot" is selected in the config editor.

FYI: We bought the UEFI module.

Thanks for your help so far.

Best regards.

dark alex
Beiträge: 280
Registriert: 11 Mär 2015, 10:09

Re: Installation Microsoft Surface Pro 7 fails

Beitragvon dark alex » 09 Jan 2020, 12:59

Have you been able to resolve the issue?

ineedhelp
Beiträge: 3
Registriert: 07 Nov 2019, 08:56

Re: Installation Microsoft Surface Pro 7 fails

Beitragvon ineedhelp » 09 Jan 2020, 14:13

Unfortunately the issue still exists.

We tried all new boot images also from the experimental repository.

At the moment, we have to install the Surface Pro 7 manually without OPSI.

Afterwards, we install the OPSI client but just as a workaround.

Do we have the possibility to move this thread to the german area?

It seems like the german community is bigger. Maybe a german user has a idea.

But i ask before we double this thread.

Best regards

Benutzeravatar
m.radtke
uib-Team
Beiträge: 804
Registriert: 10 Jun 2015, 12:19

Re: Installation Microsoft Surface Pro 7 fails

Beitragvon m.radtke » 09 Jan 2020, 17:54

Hi

can you Install Ubuntu in the surface and give the output of

Code: Alles auswählen

lspci -v
lsusb -v
lsmod


Have you turned off SecureBoot?

Have you tried an USB2Ethernet Dongle for UEFI Netboot?

Regards
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.