Updates in stable and testing

Benutzeravatar
n.wenselowski
uib-Team
Beiträge: 3148
Registriert: 04 Apr 2013, 12:15

Updates in stable and testing

Beitragvon n.wenselowski » 05 Sep 2019, 16:30

Dear opsi users,

updates have been released for opsi 4.1 in stable & testing.

News for testing:

* Support for Debian 10.
* Support for openSUSE Leap 15.1.
* Support for UEFI secureboot: This release prepares opsi to support UEFI secureboot.
* Please be aware that dependencies of python-opsi have been changed. You should make an extended upgrade, e.g. 'apt dist-upgrade' under Ubuntu.
* Univention Corporate Server: With the release of opsi-linux-bootimage and opsipxeconfd the default directory for the opsi netboot is changing.
Previously this was '/var/lib/univention-client-boot'.
This changes to '/tftpboot/linux', the default on Debian and Ubuntu.
For this change it is important to adjust the DHCP boot policy accordingly.
Previously the entry for the filename was 'pxelinux.0' and has to be changed to 'linux/pxelinux.0'.
Should you be using a switch for UEFI netboot on your DHCP server the leading 'linux/' has to be added aswell.
Additionally all paths under '/etc/opsi/opxipxeconfd.conf' should be checked and adjusted where necessary.
You might find an updated configuration file on your system under 'opsipxeconfd.conf.dpkg-dist'.
This file isn't in use because changed configuration files aren't replaced without confirmation.


Updated packages in stable:

Server packages opsi 4.1:

* opsi-server 4.1.1.8-1
* opsi-utils 4.1.1.33-2
* opsi4ucs 4.1.1.10-1
* python-opsi 4.1.1.72-1


Linux netboot packages:

* redhat70 4.1.0.0-2
* ucs44 4.1.0.1-1


Windows localboot packages:

* config-win10 4.1.1-7


Windows netboot packages:

* win10 4.1.0.0-15
* win10-captured 4.1.0.0-15
* win10-x64 4.1.0.0-15
* win10-x64-captured 4.1.0.0-15
* win2008-r2 4.1.0.0-15
* win2012 4.1.0.0-15
* win2012-r2 4.1.0.0-15
* win2016 4.1.0.0-15
* win2019 4.1.0.0-15
* win7 4.1.0.0-15
* win7-captured 4.1.0.0-15
* win7-x64 4.1.0.0-15
* win7-x64-captured 4.1.0.0-15
* win81 4.1.0.0-15
* win81-captured 4.1.0.0-15
* win81-x64 4.1.0.0-15
* win81-x64-captured 4.1.0.0-15

opsi-local-image / opsi-vhd packages:

* opsi-local-image-backup 4.1.0.0-5
* opsi-local-image-delimage 4.1.0.0-3


Updated packages in testing:

Server packages opsi 4.1:

* opsi-linux-bootimage 20190829-4
* opsi-tftp-hpa 5.2.8-51
* opsiconfd 4.1.1.20-1
* opsipxeconfd 4.1.1.17-1
* python-opsi 4.1.1.77-1

Linux localboot packages:

* opsi-configed 4.1.3.3.2-1
* l-opsi-server 4.1.1.14-1
* l-debuntu-upgrade 4.1.0.0-5

Linux netboot packages:

* debian 4.1.0.2-2
* debian10 4.1.0.2-5
* opensusel15 4.1.0.1-1
* opensusel15-1 4.1.0.1-1
* ubuntu 4.1.0.2-3

Windows netboot packages:

* hwinvent 4.1.0.1-1
* win7 4.1.0.1-6
* win7-x64 4.1.0.1-6
* win7-captured 4.1.0.1-6
* win7-x64-captured 4.1.0.1-6
* win81 4.1.0.1-6
* win81-x64 4.1.0.1-6
* win81-captured 4.1.0.1-6
* win81-x64-captured 4.1.0.1-6
* win10 4.1.0.1-6
* win10-x64 4.1.0.1-6
* win10-captured 4.1.0.1-6
* win10-x64-captured 4.1.0.1-6
* win2008-r2 4.1.0.1-6
* win2012 4.1.0.1-6
* win2012-r2 4.1.0.1-6
* win2016 4.1.0.1-6
* win2019 4.1.0.1-6


Windows localboot packages:

* opsi-bootimage-local 20190829-1
* opsi-configed 4.1.3.3.2-1
* windows10-upgrade 19.03-2
* windomain 1.0-11


opsi-local-image / opsi-vhd packages:

* opsi-vhd-auto-upgrade 4.1.0.0-8
* dom_cred_reset 1-1
* opsi-vhd-win10-x64 4.1.0.1-6
* opsi-local-image-win10 4.1.0.1-6
* opsi-local-image-win10-x64 4.1.0.1-6
* opsi-local-image-win10-capture 4.1.0.1-6
* opsi-local-image-win10-x64-capture 4.1.0.1-6
* opsi-local-image-win7 4.1.0.1-6
* opsi-local-image-win7-x64 4.1.0.1-6
* opsi-local-image-win7-capture 4.1.0.1-6
* opsi-local-image-win7-x64-capture 4.1.0.1-6
* opsi-local-image-win81 4.1.0.1-6
* opsi-local-image-win81-x64 4.1.0.1-6
* opsi-local-image-win81-capture 4.1.0.1-6
* opsi-local-image-win81-x64-capture 4.1.0.1-6


With kind regards

Niko Wenselowski


PS: Changelogs:

Code: Alles auswählen

config-win10 (4.1.1-7); stable; urgency=low

  * added new property: local_wsus_available
  * corrected behaviour when disabling updates
  * deleting key "DisableDualScan" instead of disabling option to prevent problems with 1607 LTSB

 -- Mathias Radtke <m.radtke@uib.de> Thu, 15 Aug 2019 11:15:00 +0200

-----------------------------

redhat70 (4.1.0.0-2) testing; urgency=low

  * not using --multilib in kickstart

-- Mathias Radtke <m.radtke@uib.de> Fri Aug 16 13:50:00

-----------------------------

ucs44 (4.1.0.1-2) testing; urgency=low

  * corrected upgrade version in temporary rc.local

-- Mathias Radtke <m.ratdke@uib.de> Thu Jun 06 2019 10:00:00 +0200

ucs44 (4.1.0.1-1) testing; urgency=low

  * forked from ucs43

-- Mathias Radtke <m.radtke@uib.de> Mon Apr 01 14:50:00 2018 +0200

-----------------------------

opsi-local-image-backup (4.1.0.0-5) stable; urgency=low

  * added property "architecture"

 -- Mathias Radtke <m.radtke@uib.de> Thu 22 Aug 2019 09:00:00 +0200

-----------------------------

opsi-local-image-delimage (4.1.0.0-3) stable; urgency=low

  * added property "architecture"

 -- Mathias Radtke <m.radtke@uib.de> Thu 22 Aug 2019 09:00:00 +0200

-------------------------------------------

opsi-server (4.1.1.8-1) stable; urgency=medium

  * opsi-setup: patching the service url into default.menu and grub.cfg
    when the current configuration is applied.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Mon, 19 Aug 2019 17:41:07 +0200

-------------------------------------------

opsi-tftp-hpa (5.2.8-51) testing; urgency=medium

  * corrected RPM licensing

 -- Mathias Radtke <m.radtke@uib.de>  Fri, 30 Aug 2019 08:23:27 +0200

-------------------------------------------

opsi-utils (4.1.1.33-2) stable; urgency=medium

  * opsi-package-updater: It is now possible to configure a global proxy in
    opsi-package-updater.conf. It can be overriden per repo.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Wed, 07 Aug 2019 14:18:06 +0200

opsi-utils (4.1.1.33-1) stable; urgency=medium

  * opsi-package-manager: Delta file creation uses the configured temp dir.
  * opsi-package-manager: Use functionality from python-opsi for creating a
    librsync delta file.
  * Use an RFC 2616 compatible User-Agent in opsi-admin, opsi-convert and
    opsi-package-manager.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Mon, 22 Jul 2019 10:04:28 +0200

-------------------------------------------

opsi4ucs (4.1.1.10-1) stable; urgency=medium

  * opsi-setup: patching the service url into default.menu and grub.cfg
    when the current configuration is applied.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Mon, 19 Aug 2019 17:32:04 +0200

-------------------------------------------

opsiconfd (4.1.1.20-1) stable; urgency=medium

  * Do not depend on twisted.conch anymore.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Wed, 28 Aug 2019 10:28:17 +0200

opsiconfd (4.1.1.19-1) stable; urgency=medium

  * Removed debug shell.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Tue, 27 Aug 2019 14:19:27 +0200

-------------------------------------------

opsipxeconfd (4.1.1.17-1) testing; urgency=medium

  * postinst: UCS replacing /var/lib/univention-client-boot with /tftpboot/linux

 -- Mathias Radtke <m.radtke@uib.de>  Thu, 05 Sep 2019 13:44:23 +0200

opsipxeconfd (4.1.1.16-1) stable; urgency=medium

  * Removed dependency to twisted.conch.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Wed, 28 Aug 2019 10:48:03 +0200

opsipxeconfd (4.1.1.15-1) testing; urgency=medium

  * Added support for UEFI secure boot.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Fri, 09 Aug 2019 13:21:33 +0200

-------------------------------------------

python-opsi (4.1.1.77-2) testing; urgency=medium

  * OPSI.Util.Task:Samba: corrected typo on opsi_logs SMB share creation

 -- Mathias Radtke <m.radtke@uib.de>  Mon, 02 Sep 2019 16:29:40 +0200

python-opsi (4.1.1.77-1) testing; urgency=medium

  * OPSI.Util.Task.Rights: Cache the path of the workbench once this has been read.
  * OPSI.util.Task.Samba: Added opsi_logs SMB share

 -- Mathias Radtke <m.radtke@uib.de>  Mon, 02 Sep 2019 13:24:05 +0200

python-opsi (4.1.1.76-2) stable; urgency=medium

  * RPM: patch the correct filename into /etc/opsi/backends/dhcpd.conf if
    running on a SUSE distribution.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Wed, 28 Aug 2019 16:09:47 +0200

python-opsi (4.1.1.76-1) stable; urgency=medium

  * OPSI.Backend.MySQL: The lifetime for DB connections can now be configured
    through the backend parameter 'ConnectionPoolRecycling'.
  * Removed module OPSI.Util.Debug.
  * Removed dependency to twisted.conch.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Wed, 28 Aug 2019 09:49:08 +0200

python-opsi (4.1.1.75-1) stable; urgency=medium

  * OPSI.Util.Task.ConfigureBackend.DHCPD: checking for SLES and OpenSUSE to
    set dhcpd boot file properly

 -- Mathias Radtke <m.radtke@uib.de>  Tue, 27 Aug 2019 13:50:17 +0200

python-opsi (4.1.1.74-1) stableD; urgency=medium

  * OPSI.Util.HTTP.HTTPResponse: Removed parts of experimental curl support.
  * OPSI.Util.HTTP.HTTPResponse: HTTP headers are now handle case-insensitive.

 -- Mathias Radtke <m.radtke@uib.de>  Tue, 27 Aug 2019 12:27:32 +0200

python-opsi (4.1.1.73-1) stable; urgency=medium

  * RPM/spec: installing net-tools-deprecated on Leap >= 15.0

 -- Mathias Radtke <m.radtke@uib.de>  Tue, 27 Aug 2019 10:23:31 +0200

python-opsi (4.1.1.72-1) stable; urgency=medium

  * OPSI.Util.Task.UpdatePackages.Notifier: Fix setting up EmailNotifier.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Mon, 12 Aug 2019 10:52:55 +0200

python-opsi (4.1.1.71-1) stable; urgency=medium

  * OPSI.Util.Task.UpdatePackages.Config: Use RFC 2616 compatible user agent.
  * OPSI.Util.Task.UpdatePackages.Config: Make it possible to configure a
    global proxy in the general config that will be applied to all repos
    that do not use their own proxy.
  * OPSI.Util.Task.UpdatePackages: Lower the loglevel for the used proxy.
  * OPSI.Util.Task.UpdatePackages.Updater: Simplify notifier handling.
  * OPSI.Util: librsync functions now provide more information about used
    files in the log.
  * Added new module OPSI.Util.Task.ConfigureBootimage.
  * Backend.backend_getOptions now returns a copy instead of a reference.
    This leads to temporaryBackendOptions behaving as expected.
  * OPSI.Service.Worker.WorkerOpsiJsonRpc: If a client sends gzip and deflate
    in the 'Accept-Encoding' HTTP header we prefer gzip for the response.
  * 30_kiosk.conf: getKioskProductInfosForClient: added new parameter
    addConfigs for the new version of the Kiosk client.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Tue, 06 Aug 2019 17:47:54 +0200

python-opsi (4.1.1.70-1) stable; urgency=medium

  * OPSI.System.Posix: Add support for retrieving the currently used
    distribution through the "distro" module.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Wed, 10 Jul 2019 14:30:26 +0200

python-opsi (4.1.1.69-1) testing; urgency=medium

  * 20_easy.conf: Added new method: getClientsWithActionRequest.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Mon, 08 Jul 2019 13:59:45 +0200

python-opsi (4.1.1.68-2) testing; urgency=medium

  * 45_deprecated.conf: Fix deprecation warning for getClients_listOfHashes
    and getClientIds_list.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Fri, 28 Jun 2019 17:50:27 +0200

python-opsi (4.1.1.68-1) testing; urgency=medium

  * OPSI.Util.File.DHCPDConfFile: Small refactoring to improve parse time.
  * OPSI.Backend.DHCPD: Errors are now logged with their traceback.
  * OPSI.Util.File.DHCPDConfFile: Support parsing data structures consisting
    of a sequence of data types (a.k.a. record types).
  * OPSI.Backend.JSONRPC.JSONRPCBackend: Added support for 'gzip' compression.
    For a seamless integration the new option 'compress' has been added to the
    constructor. It accepts either the values 'deflate', 'gzip' or a boolean.
    In case the boolean is selected the compression to use will be chosen
    by the implementation.
    This also adds the new function setCompression to instances of the class.
    This method should be used instead of the now deprecated 'setDeflate'.
    If compression is used can be checked with isCompressionUsed.
  * Added 20_easy.conf with the following methods: getClients, getClientIDs,
    getClientsOnDepot and getClientsWithProducts.
  * API: Deprecated the methods backend_searchIdents, getClients_listOfHashes
    and getClientIds_list.
    To replace their commonly used functionality use the methods getClients,
    getClientIDs, getClientsOnDepot and getClientsWithProducts respectively.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Fri, 28 Jun 2019 15:57:19 +0200

python-opsi (4.1.1.67-1) stable; urgency=medium

  * OPSI.Backend.File.FileBackend: raise an error when executing getData.
  * OPSI.System.Posix: Cache the service names of DHCPD and Samba after lookup.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Wed, 29 May 2019 16:52:29 +0200

-------------------------------------------

dom_cred_reset (1-1) stable; urgency=low

  * Initial Package

-- detlef oertel <d.oertel@uib.de> Mon, 19 Aug 2019 15:00:00 +0200

-------------------------------------------

opsi-vhd-auto-upgrade (4.1.0.0-8) stable; urgency=low

  * remove fix from 4.1.0.0-6 (set $upgradeproducts$ in property exclude_from_meta_data_restore in opsi-vhd-control)

-- detlef oertel <d.oertel@uib.de>  Fri, 23 Aug 2019 15:00:00 +0200

opsi-vhd-auto-upgrade (4.1.0.0-7) stable; urgency=low

  * new property: products_to_uninstall (Which opsi product(s) should be uninstalled via upgrade ? (List will be cleared after run))
  * new property: products_to_run_always (Which opsi product(s) should be installed via every upgrade ? (List will not be cleared after run))
  * new property: setup_after_install (Which opsi product(s) should we switch to setup after vhd upgrade is done ?)

-- detlef oertel <d.oertel@uib.de>  Fr, 22 Aug 2019 15:00:00 +0200

opsi-vhd-auto-upgrade (4.1.0.0-6) stable; urgency=low

  * set $upgradeproducts$ in property exclude_from_meta_data_restore in opsi-vhd-control

-- detlef oertel <d.oertel@uib.de>  Tue, 30 Feb 2019 15:00:00 +0200

opsi-vhd-auto-upgrade (4.1.0.0-5) stable; urgency=low

  * remove empty strings from $upgradeproducts$
  * new property: products_to_exclude: Which opsi product(s) should be excluded from upgrade ?

-- detlef oertel <d.oertel@uib.de>  Thu, 25 Feb 2019 15:00:00 +0200

opsi-vhd-auto-upgrade (4.1.0.0-4) stable; urgency=low

  * syntax fix

-- detlef oertel <d.oertel@uib.de>  Wed, 24 Feb 2019 15:00:00 +0200

opsi-vhd-auto-upgrade (4.1.0.0-3) stable; urgency=low

  * new property: products_to_install: Which opsi product(s) should be installed via upgrade ?

-- detlef oertel <d.oertel@uib.de>  Wed, 24 Feb 2019 15:00:00 +0200

opsi-vhd-auto-upgrade (4.1.0.0-2) stable; urgency=low

  * own changelog file

-- detlef oertel <d.oertel@uib.de>  Mon, 05 Feb 2018 15:00:00 +0200

-------------------------------------------

opsi-local-image-delimage (4.1.0.0-3) stable; urgency=low

  * added property "architecture"

 -- Mathias Radtke <m.radtke@uib.de> Thu 22 Aug 2019 09:00:00 +0200

-------------------------------------------

opsi-local-image-backup (4.1.0.0-5) stable; urgency=low

  * added property "architecture"

 -- Mathias Radtke <m.radtke@uib.de> Thu 22 Aug 2019 09:00:00 +0200

-------------------------------------------

opsi-linux-bootimage (20190829-4) testing; urgency=medium

  * debian/rules: moving grubx64.efi to correct place

 -- Mathias Radtke <m.radtke@uib.de>  Thu, 05 Sep 2019 11:13:15 +0200

opsi-linux-bootimage (20190829-3) testing; urgency=medium

  * debian/rules: corrected file install action

 -- Mathias Radtke <m.radtke@uib.de>  Wed, 04 Sep 2019 08:48:22 +0200

opsi-linux-bootimage (20190829-2) testing; urgency=medium

  * corrected spec file licensing

 -- Mathias Radtke <m.radtke@uib.de>  Fri, 30 Aug 2019 09:01:27 +0200

opsi-linux-bootimage (20190829-1) testing; urgency=medium

  * master.py: initially set inLocalBootimage = False

 -- Mathias Radtke <m.radtke@uib.de>  Thu, 29 Aug 2019 15:09:54 +0200

opsi-linux-bootimage (20190819-3) testing; urgency=medium

  * removed getting servicentry on RPM systems

 -- Mathias Radtke <m.radtke@uib.de>  Thu, 22 Aug 2019 14:17:04 +0200

opsi-linux-bootimage (20190819-2) testing; urgency=medium

  * fixed logical error when checking for locally installed bootimage

 -- Mathias Radtke <m.radtke@uib.de>  Mon, 19 Aug 2019 16:09:29 +0200

opsi-linux-bootimage (20190819-1) testing; urgency=medium

  * master.py rechecking tftp pipe if no product on setup
  * rebooting machine when in local installed opsi-linux-bootimage and no product on setup

 -- Mathias Radtke <m.radtke@uib.de>  Mon, 19 Aug 2019 12:36:23 +0200

opsi-linux-bootimage (20190805-4) testing; urgency=medium

  * added new file for UEFI TFTP Pipe template

 -- Mathias Radtke <m.radtke@uib.de>  Mon, 12 Aug 2019 13:31:20 +0200

-------------------------------------------

debian (4.1.0.2-2) stable; urgency=low

  * debian buster can now be installed

-- Mathias Radtke <m.radtke@uib.de> Mon, 09 Jul 2019 11:45:00 +0200

-----------------------------

debian10 (4.1.0.2-5) testing; urgency=low

  * initial release

-- Mathias Radtke <m.radtke@uib.de> Mon 08 Jul 2019 10:42:00 +0100

-----------------------------

opensusel15 (4.1.0.1-1) testing; urgency=low

  * using correct network device in autoyast.xml

-- Mathias Radtke <m.radtke@uib.de> Wed Sep 19 08:08:00 +0200

opensusel15 (4.1.0.0-2) testing; urgency=low

  * added libopenssl-1.0 dependency

-- Mathias Radtke <m.radtke@uib.de> Mon Jul 16 12:20:00 +0200

opensusel15 (4.1.0.0-1) testing; urgency=low

  * product forked from opensusel42-3

-- Mathias Radtke <m.radtke@uib.de> Mon May 28 10:38:00 +0200

-----------------------------

opensusel15-1 (4.1.0.1-1) testing; urgency=low

  * installing net-tools-deprecated in installation

-- Mathias Radtke <m.radtke@uib.de> TueA Aug 26 10:25:00 +0200

opensusel15-1 (4.1.0.1-1) testing; urgency=low

  * forked from opensusel15
  * using correct network device in autoyast.xml

-- Mathias Radtke <m.radtke@uib.de> Tue Jun 19 08:08:00 +0200

-----------------------------

windows (4.1.0.1-6) stable; urgency=low

  * Downloading PCI and USB Ids on package postinst

-- Mathias Radtke <m.radtke@uib.de> Mon Sep  2 14:22:22 2019 +0200


windows (4.1.0.1-5) stable; urgency=low

  * added 'os_install_by_wlan' modules check

-- Mathias Radtke <m.radtke@uib.de> Tue Aug 27 10:45:13 2019 +0200


windows (4.1.0.1-4) stable; urgency=low

  * removing product=PRODUCTID when patching grub cmdline for local installed bootimage
  * show_drivers fix for mainboard fallback

-- Mathias Radtke <m.radtke@uib.de> Fri Aug 23 15:22:37 2019 +0200


windows (4.1.0.1-3) testing; urgency=low

  * nt6.py: fix for: multi_disk_mode= '0_ignore_anything_else'

-- Detlef Oertel <d.oertel@uib.de> Wed Jun 19 09:05:24 2019 +0200

windows (4.1.0.1-2) stable; urgency=low

  * multi_disk_mode: possible to use first disk and ignore any other disk

 -- Mathias Radtke <m.radtke@uib.de> Tue 11 Jun 2019 15:30:00 +0200

-----------------------------

opsi-local-image (4.1.0.1-4) stable; urgency=low

  * Downloading PCI and USB Ids on package postinst

-- Mathias Radtke <m.radtke@uib.de> Mon Sep  2 14:22:32 2019 +0200


opsi-local-image (4.1.0.1-3) stable; urgency=low

  * added 'os_install_by_wlan' modules check

-- Mathias Radtke <m.radtke@uib.de> Tue Aug 27 10:57:57 2019 +0200


opsi-local-image (4.1.0.1-2) stable; urgency=low

  * removing product=PRODUCTID when patching grub cmdline for local installed bootimage
  * show_drivers fix for mainboard fallback

-- Mathias Radtke <m.radtke@uib.de> Fri Aug 23 15:22:40 2019 +0200

-----------------------------

ubuntu (4.1.0.2-3) stable; urgency=low

  * removing import it twisted.conch libraries

-- Mathias Radtke <m.radtke@uib.de> Fri 30 Aug 2019 13:33:00 +0200

-----------------------------

opsi-bootimage-local (20190829-1) testing; urgency=low

  * updated to opsi-linux-bootimage_20190829-1

 -- Mathias Radtke <m.radtke@uib.de> Mon, 29 Aug 2019 17:00:00 +0200

opsi-bootimage-local (20190819-2) testing; urgency=low

  * updated to opsi-linux-bootimage_20190819-2
  * added update script to update locally installed bootimage on machine

 -- Mathias Radtke <m.radtke@uib.de> Mon, 19 Aug 2019 17:00:00 +0200

opsi-bootimage-local (20190819-1) testing; urgency=low

  * updated to opsi-linux-bootimage_20190819-1
  * added update script to update locally installed bootimage on machine

 -- Mathias Radtke <m.radtke@uib.de> Mon, 19 Aug 2019 14:00:00 +0200

-----------------------------

hwinvent (4.1.0.1-1) stable; urgency=low

  * added property architecture

 -- Mathias Radtke <m.radtke@uib.de> Tue Aug 27 2019 10:20:00 +0200

-----------------------------

l-opsi-server (4.1.1.14-1); experimental; urgency=low

  * Working on support for opsi 4.2 installation.
  * Dropped support for opsi 4.0 installation.

 -- Niko Wenselowski <n.wenselowski@uib.de> Tue, 13 Aug 2019 17:05:56 +0200

l-opsi-server (4.1.1.13-1); stable; urgency=low

  * removed opsi-configed package

 -- Mathias Radtke <m.radtke@uib.de> Wed, 24 Jul 2019 12:15:00 +0200

l-opsi-server (4.1.1.12-2); stable; urgency=low

  * corrected typo on Debian

 -- Mathias Radtke <m.radtke@uib.de> Mon, 22 Jul 2019 09:15:00 +0200

l-opsi-server (4.1.1.12-1); stable; urgency=low

  * opsi 4.1: support for debian 10 added
  * added new properties:
        download_patched_elilo_efi
        patch_default_link_for_bootimage

 -- Mathias Radtke <m.radtke@uib.de> Tue, 09 Jul 2019 08:20:00 +0200

l-opsi-server (4.1.1.11-1); stable; urgency=low

  *  opsi 4.1: support for opensuse Leap 15.1 added

 -- Mathias Radtke <m.radtke@uib.de> Tue, 02 Jul 2019 14:20:00 +0200

-----------------------------

opsi-linux-client-agent (4.1.0.19-4) stable; urgency=medium

  * systemd on Debian 10: Use a combination of service with timer.

 -- Niko Wenselowski <n.wenselowski@uib.de> Wed, 09 Aug 2019 12:38:57 +0100

opsi-linux-client-agent (4.1.0.19-3) stable; urgency=medium

  * opsiscriptstarter will use systemd on Debian 10.

 -- Niko Wenselowski <n.wenselowski@uib.de> Wed, 07 Aug 2019 08:10:43 +0100

opsi-linux-client-agent (4.1.0.19-2) stable; urgency=medium

  * now also 32 bit binaries as 4.12.2
  * fix syntaxcheck in setup.opsiscript (mr)

-- d.oertel <d.oertel@uib.de> Tue, 06 Aug 2019 15:00:00 + 0100

opsi-linux-client-agent (4.1.0.19-1) stable; urgency=medium

  * update opsi-script to 4.12.2.0 with ssl 1.1 support
  * get own ip from 'ip route get' fixed ; fixes #4096
  * fix if ldconfig is not in path (openSuse Leap 15.1)
  * fix for lbssl.so.10 (centos 9)
  * added support for opensuse Leap 15.1

-- d.oertel <d.oertel@uib.de> Mon, 22 Jul 2019 15:00:00 + 0100

-----------------------------

* bugfix in building path for driver upload
-- r.roeder <r.roeder@uib.de> Tue, 03 Sep 2019 12:11:46 +0100

opsi-configed (4.1.3.3.1-1) STABLE; urgency=medium
* info if products are required but do not exist on the depot
-- r.roeder <r.roeder@uib.de> Wed, 29 Aug 2019 12:11:46 +0100

opsi-configed (4.1.3.2.1-1) STABLE; urgency=medium
* bugfix if addressed group has null parentgroup
-- r.roeder <r.roeder@uib.de> Wed, 28 Aug 2019 16:11:46 +0100

opsi-configed (4.1.3.2.0-1) STABLE; urgency=medium
* new command line option --definegroupbysearch
-- r.roeder <r.roeder@uib.de> Wed, 28 Aug 2019 16:11:46 +0100

opsi-configed (4.1.3.1.1-1) STABLE; urgency=medium
* background update of session data, bugfix: working-icon war running only once
-- r.roeder <r.roeder@uib.de> Wed, 21 Aug 2019 12:11:46 +0100

opsi-configed (4.1.3.1.0-1) STABLE; urgency=medium
* background update of session data
-- r.roeder <r.roeder@uib.de> Fri, 16 Aug 2019 12:11:46 +0100

opsi-configed (4.1.2.1.0-4) STABLE; urgency=medium
* bug fix in Linux part
-- r.roeder <r.roeder@uib.de> Thu, 15 Aug 2019 12:11:46 +0100

opsi-configed (4.1.2.1.0-1) STABLE; urgency=medium
* if the opsi server is addressed via cli host parameter, even if not connected,
the server name is included in the log file name  (for distinguishing several log file contexts)
-- r.roeder <r.roeder@uib.de> Fri, 09 Aug 2019 12:11:46 +0100

opsi-configed (4.1.2.0.9-2) STABLE; urgency=medium
* new product property for creating additional start menu links for several opsi servers
-- r.roeder <r.roeder@uib.de> Thu, 08 Aug 2019 13:11:46 +0100

opsi-configed (4.1.2.0.9-1) EXPERIMENTAL; urgency=medium
* button for transfer the client selection in hardware overview to the client list
-- r.roeder <r.roeder@uib.de> Tue , 30 Jul 2019 13:11:46 +0100

opsi-configed (4.1.2.0.8-1) EXPERIMENTAL; urgency=medium
* display of opsi host key
-- r.roeder <r.roeder@uib.de> Wed , 26 Jul 2019 13:11:46 +0100

opsi-configed (4.1.2.0.7-2) EXPERIMENTAL; urgency=medium
* changed linkfolder entry name for Linux (now simply opsi-configed)
-- r.roeder <r.roeder@uib.de> Wed , 24 Jul 2019 13:11:46 +0100

opsi-configed (4.1.2.0.7-1) EXPERIMENTAL; urgency=medium
* for green/red unawareness : supplement (≠) to product version if versions are not equal.
-- r.roeder <r.roeder@uib.de> Fri , 12 Jul 2019 13:11:46 +0100

opsi-configed (4.1.2.0.6-1) STABLE; urgency=medium
* fixed hard coded "/home/opsiproducts" in product installation special call
-- r.roeder <r.roeder@@uib.de>  Mon, 08 Jun 2019 13:11:46 +0100

-----------------------------

windows10-upgrade (19.03-2) stable; urgency=low
  * https://forum.opsi.org/viewtopic.php?f=5&t=11102
    added property encryption_driver
-- bardo wolf <b.wolf@uib.de> Tue  02 Jul 2019 13:00:00 +0200

-----------------------------

windomain (1.0-11) stable; urgency=low
        * removed wsitch for smbv1
        * fixes ou-syntax for method powershell #2019080510000021

 -- bardo wolf <b.wolf@uib.de>  Tue,  13 Aug 2019 14:00:00 +0200

windomain (1.0-10) stable; urgency=low

        * option for using a password only one time

 -- rupert roeder <r.roeder@uib.de>  Mon,  10 Apr 2017 17:00:00 +0200


windomain (1.0-9) stable; urgency=low

        * possibly switch to SMB1 with Win10

 -- detlef oertel <d.oertel@uib.de>  Fri,  28 Aug 2015 17:00:00 +0200

-----------------------------

l-opsi-server (4.1.1.14-1); experimental; urgency=low

  * Working on support for opsi 4.2 installation.
  * Dropped support for opsi 4.0 installation.

 -- Niko Wenselowski <n.wenselowski@uib.de> Tue, 13 Aug 2019 17:05:56 +0200

l-opsi-server (4.1.1.13-1); stable; urgency=low

  * removed opsi-configed package

 -- Mathias Radtke <m.radtke@uib.de> Wed, 24 Jul 2019 12:15:00 +0200

l-opsi-server (4.1.1.12-2); stable; urgency=low

  * corrected typo on Debian

 -- Mathias Radtke <m.radtke@uib.de> Mon, 22 Jul 2019 09:15:00 +0200

l-opsi-server (4.1.1.12-1); stable; urgency=low

  * opsi 4.1: support for debian 10 added
  * added new properties:
  download_patched_elilo_efi
  patch_default_link_for_bootimage

 -- Mathias Radtke <m.radtke@uib.de> Tue, 09 Jul 2019 08:20:00 +0200

l-opsi-server (4.1.1.11-1); stable; urgency=low

  *  opsi 4.1: support for opensuse Leap 15.1 added

 -- Mathias Radtke <m.radtke@uib.de> Tue, 02 Jul 2019 14:20:00 +0200

-----------------------------

l-debuntu-upgrade (4.1.0.0-5) stable; urgency=low

  * stretch to buster upgrade added

-- Mathias Radtke <m.radtke@uib.de> Mon, 08 Jul 2019 12:20:00 +0200
opsi development - uib gmbh
For productive opsi installations we recommend support contracts.

lukas.e
Beiträge: 0
Registriert: 18 Sep 2019, 14:29

Re: Updates in stable and testing

Beitragvon lukas.e » 18 Sep 2019, 14:49

> * Support for Debian 10.

There is no dedicated Debian 10 Repository, right? Does that mean that the Debain 9 one works for Buster Systems as well?

Benutzeravatar
m.radtke
uib-Team
Beiträge: 730
Registriert: 10 Jun 2015, 12:19

Re: Updates in stable and testing

Beitragvon m.radtke » 18 Sep 2019, 16:16

lukas.e hat geschrieben:> * Support for Debian 10.

There is no dedicated Debian 10 Repository, right? Does that mean that the Debain 9 one works for Buster Systems as well?


Well Niko stated it clearly

n.wenselowski hat geschrieben:News for testing:

* Support for Debian 10.
* Support for openSUSE Leap 15.1.


Regards
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.