Problem opsi-package-updater...

thomas.besser
Beiträge: 315
Registriert: 09 Sep 2009, 09:40

Problem opsi-package-updater...

Beitragvon thomas.besser » 09 Aug 2019, 14:50

Hi,

nach der gestrigen Ankündigung (viewtopic.php?f=1&t=11324) habe ich unseren OPSI-Server aktualisiert, auf dem wir alle OPSI-Pakete bauen und testen. Den betreiben wir bewusst mit "Testing", um auch einen kleinen Beitrag leisten und Feedback geben zu können.

Seit dem Update funktioniert der 'opsi-package-updater' nicht mehr:

Code: Alles auswählen

opsi-package-updater update
Traceback:
  File "/usr/bin/opsi-package-updater", line 341, in <module>
    exitCode = main()

  File "/usr/bin/opsi-package-updater", line 312, in main
    opu.processUpdates()

  File "/usr/lib/python2.7/dist-packages/OPSI/Util/Task/UpdatePackages/Updater.py", line 157, in processUpdates
    notifier = self._getNotifier()

  File "/usr/lib/python2.7/dist-packages/OPSI/Util/Task/UpdatePackages/Updater.py", line 481, in _getNotifier
    subject=self.config["subject"],

  File "/usr/lib/python2.7/dist-packages/OPSI/Util/Task/UpdatePackages/Notifier.py", line 81, in __init__
    super().__init__()

     ==>>> super() takes at least 1 argument (0 given)
ERROR: super() takes at least 1 argument (0 given)


Läuft unter Debian Stretch 9.9 und hier die Paketliste:

Code: Alles auswählen

dpkg -l "*opsi*" | grep ii
ii  opsi-configed           4.0.7.6.34-2 all          OPSI config editor
ii  opsi-depotserver        4.1.0.0-3    all          transitional package
ii  opsi-linux-bootimage    20190805-3   all          opsi bootimage for netboot tasks.
ii  opsi-server             4.1.1.7-1    all          opsi server configuration package
ii  opsi-tftpd-hpa          5.2.8-50     amd64        HPA's tftp server
ii  opsi-utils              4.1.1.33-2   all          utilites for working with opsi.
ii  opsi-windows-support    4.1.1-8      all          Install utilities useful for deploying Windows with opsi.
ii  opsiconfd               4.1.1.18-4   all          opsi configuration service
ii  opsipxeconfd            4.1.1.14-2   all          opsi pxe configuration daemon
ii  python-opsi             4.1.1.71-1   all          opsi python library


Gruß
Thomas

Benutzeravatar
n.wenselowski
uib-Team
Beiträge: 3195
Registriert: 04 Apr 2013, 12:15

Re: Problem opsi-package-updater...

Beitragvon n.wenselowski » 12 Aug 2019, 10:12

Hallo Thomas,

vielen Dank für den Bugreport!

Fix ist ein Arbeit, ich sage Bescheid, sobald er zur Verfügung steht.


Viele Grüße

Niko

Code: Alles auswählen

import OPSI

Benutzeravatar
n.wenselowski
uib-Team
Beiträge: 3195
Registriert: 04 Apr 2013, 12:15

Re: Problem opsi-package-updater...

Beitragvon n.wenselowski » 12 Aug 2019, 10:56

Hi Thomas,

kannst du das bitte mal mit python-opsi 4.1.1.72 testen?
Builds davon sollten in ein paar Minuten in experimental bereitstehen.


Viele Grüße

Niko

Code: Alles auswählen

import OPSI

thomas.besser
Beiträge: 315
Registriert: 09 Sep 2009, 09:40

Re: Problem opsi-package-updater...

Beitragvon thomas.besser » 12 Aug 2019, 11:24

Hi Nico,

mit python-opsi 4.1.1.72 läuft der opsi-package-updater wieder.

Danke und Gruß
Thomas