[SOLVED] opsi-linux-bootimage very slow link I-219-V only on gigabit port

nicolaslebrun
Beiträge: 86
Registriert: 18 Apr 2011, 11:43

[SOLVED] opsi-linux-bootimage very slow link I-219-V only on gigabit port

Beitragvon nicolaslebrun » 03 Mai 2019, 12:32

Hi,

We have a new bug with Lenovo M720q with I-219-V network card.

When those workstations are connected to a Gigabit port on HPE sitch, under linux bootimage, the link is very slow : About 30% packet loss and the response time is about 500ms !! The Winpe transfer lasts about 8 hours !! when it doesn't fail...

If we force the port speed to 100Mb, the deployment is OK.

We tried with bootimage 20180813-1 and 20181213-1.

Any hint to avoid this problem ?

Nico
Zuletzt geändert von nicolaslebrun am 22 Mai 2019, 22:39, insgesamt 1-mal geändert.

Benutzeravatar
n.wenselowski
uib-Team
Beiträge: 3167
Registriert: 04 Apr 2013, 12:15

Re: opsi-linux-bootimage very slow link I-219-V only on gigabit port

Beitragvon n.wenselowski » 06 Mai 2019, 15:32

Hi Nico,

this could be a problem with the driver used by the Linux kernel.

You could try newer bootimages from testing or experimental as these usually ship with newer kernels which increases the change to get better drivers for your hardware.


Kind regards

Niko
opsi development - uib gmbh
For productive opsi installations we recommend support contracts.

nicolaslebrun
Beiträge: 86
Registriert: 18 Apr 2011, 11:43

Re: [SOLVED] opsi-linux-bootimage very slow link I-219-V only on gigabit port

Beitragvon nicolaslebrun » 22 Mai 2019, 22:46

Strange case, but to solve this problem:

Either
- Force the speed of the switch port to 100 Mbps
Or
- Update the bios and apply the nolapic to linux bootimage (property opsi-linux-bootimage.append)

Regards,
Nico