New concepts for Java

Benutzeravatar
r.roeder
uib-Team
Beiträge: 446
Registriert: 02 Jul 2008, 10:08

New concepts for Java

Beitragvon r.roeder » 25 Jan 2019, 15:17

Dear opsi users,

Oracle has announced a dramatic change in update policy and license conditions of the java product. This has consequences for the usage of Java in the opsi context as well as for the java product in the abo package.

Regarding java in opsi we can state:


-The opsi configed runs perfectly with the current free openjdk version (openjdk 11) as released by Oracle, but as well with Java 8 or 10. The java versions >= 10 have high dpi support, i.e. the configed running with these java versions support the Microsoft Windows scaling functions.

- To get independent from the system context we recommend to use the opsi-configed with the bundled java runtime

- Since the webstart function is no longer supported by Oracle we remove the webstart configed from the opsi server. Instead of the web start links we provided we will offer links to setup programs for the configed which install it on the local system.

- The opsi product jedit which is the free editor jEdit supplemented by syntax highlighting for opsiscript still requires a java version (1.) 8 . We will publish a new package bundled with a Java (1.) runtime.

What is the future of the opsi Java packages which we distribute in our abo?

A good overview on the state of Java can be found in https://blog.joda.org/2018/09/time-to-l ... s-jdk.html

We supply the current free version (only delivered by Oracle for a short period) in the experimental package

https://download.uib.de/opsi4.1/experim ... 0.2-1.opsi

For the future, we draw the following consequences:

- The current javavm package, which contains the last free release of Java 1.8 by Oracle, will bei moved to our archive (javavm_1.8.0.201or1.8.0.202-1)

- Future javavm package in the standard abo will contain the supported openjdk versions of

* SAP and
* Amazon (amazon corretto, promised for april 2019).

A first package for testing purposes is

https://download.uib.de/opsi4.1/experim ... 0.2-1.opsi

- Additionally, we include a new package javavm8 into our standard abo. It will contain a supported Java 8 version, which should continue the support of Java webstart, by the distributions

* Amazon coretto
* ojdkbuild

A package for testing can be drawn from

https://download.uib.de/opsi4.1/experim ... 191-1.opsi


We hope that we react adequately to the new version, and hope for feedback.

Kind Regards
opsi support - uib gmbh
For productive opsi installations we recommend maintainance + support contracts which are the base of opsi development.


Wondering who's using opsi? Have a look at the opsi map: http://opsi.org/opsi-map/.

Benutzeravatar
SisterOfMercy
Beiträge: 989
Registriert: 22 Jun 2012, 19:18

Re: New concepts for Java

Beitragvon SisterOfMercy » 03 Apr 2019, 10:42

Other distributions/builds of openJDK: Azul and AdoptOpenJDK.
AdoptOpenJDK also supplies a JRE11 in 32-bit.

jEdit works with AdoptOpenJDK 11.0.2 without problems. I read somewhere it is the installer that is complaining. As I'm not using the installer, and starting jedit.jar with javaw.exe it all works without a hitch.
Bitte schreiben Sie Deutsch, when I'm responding in the German-speaking part of the forum!