Informations et paquets pour opsi 4.0/4.1 dans testing et stable

Ce forum est dédié au nouveautés, événements autour du projet Opsi
otto
Beiträge: 62
Registriert: 08 Aug 2017, 12:16

Informations et paquets pour opsi 4.0/4.1 dans testing et stable

Beitragvon otto » 04 Jan 2019, 00:09

Chers utilisateurs,

avant les vacances nous avons encore publié des paquets pour opsi 4.0 et opsi 4.1 dans testing et stable.

En outre les documentations sont été actualisées.

Des innovations importantes dans ce release:

* Une nouvelle version winexe qui fonctionnera aussi avec les nouvelles versions de Windows 10 est maintenant
disponible comme paquet serveur.

* Avec le nouveau paquet serveur opsi-script l'interpréteur opsiscript est aussi disponible pour Linux
(à partir de maintenant aussi sans installer l'opsi-linux-client).

JAVA:

Considérant les changements des conditions de licence pour le Java JRE d'Oracle nous sommes
demandés très souvent: Quelle est la suite avec Java dans opsi et avec le paquet javavm de l'abonnement?

Java dans opsi:

L'opsi-configed fonctionne sans aucun problème avec l'openJDK gratuit et est donc (pour Windows)
combiné avec les versions gratiutes.
Plus précisement l'opsi-configed est combiné pour Windows avec jre-11 (soutient High-DPI)
ou avec jre-8, mais fonctionne aussi avec un autre open JDK.

L'utilisation de WebStart avec OpenJDK est problématique et donc ne sera pas soutenu. Avec le nouveau
release début janvier tous liens WebStart à l'opsi-configed seront abandonnés et ils vont référer aux
paquets setup de l'installation locale de l'opsi-configed.

* Le paquet jEdit publié dans stable fonctionne seulement avec java1.8.
Nous allons publier un paquet adapté et qui sera combiné avec un JRE approprié.
Le produit l-jEdit (pour Linux) fonctionne avec OpenJDK.

Vous trouverez un paquet pour installer l'Oracle openJDK (gratuit) sur:
https://download.uib.de/opsi4.1/experim ... 0.1-5.opsi

Avenir des paquets opsi Java (cancernant l'abonnement):

Nous allons - aussi à l'avenir - vous fournir les versions Java libres:

* Le paquet actuel (javavm_1.8.0.191or1.8.0.192-1) est archivé et sera disponible sur:
https://download.uib.de/opsi4.1/archive ... 192-1.opsi

* Des paquets futurs javavm de l'abonnement standard vont contenir les OpenJDK actuels des producteurs suivants:
* Oracle
* RedHat/IBM (ja - auch für Windows)
* SAP

* Supplémentaire au paquet javam nous allons introduire le paquet javavm8 pour l'abonnement standard.
Ce paquet devrait aider des clients qui ont de software qui a besoin de Java 1.8 respectivement Webstart.
Ce paquet contient des versions maintenues de Java 1.8 des producteurs suivants:
* RedHat/IBM (ja - auch für Windows)
* Amazon

Nous planifions de vous rendre disponible ces paquet dans la troisième semaine de 2019.

La situation autour de l'environnement d'exécution est maintenant un peu confuse.
Nous esperons d'avoir trouvé les variants justes pour votre activité.
Nous allons suivre avec attention comment la situations va se déveloper et adapter nos offres adéquatement.


#####################################
Comme testing nous publions:

Windows Netboot:

* windows Nt6 (4.1.0.0-14)

Paquets Windows LocalBoot:

* opsi-configed 4.0.7.8.6-1
* windows10-upgrade 18.09-1
* opsi-client-agent 4.1.0.0-24
* config-win10 4.1.1-5

Paquets opsi-linux:

Paquets Linux Netboot:

* centos70 4.1.0.0-2

Paquets Linux LocalBoot:

* opsi-configed 4.0.7.8.6-1

opsi-local-image / opsi-vhd:

* opsi-local-image Windows Nt6 (4.1.0.0-14)
* opsi-vhd Windows Nt6 (4.1.0.0-14)


Paquets serveur:
opsi 4.0:

aucun

opsi 4.1:

* opsi-utils 4.1.1.28-1
* opsi4ucs 4.1.1.7-1
* winexe 4.8.0.0-15
* opsi-script 4.12.0.31-2

Documentation:

* opsi-manual (4.0/4.1)
* opsi-script-manual
* opsi-getting-started (4.0/4.1)


#####################################
Comme stable nous publions:

Windows Netboot:

* windows Nt6 (4.1.0.0-12)

Paquets Windows LocalBoot:

* opsi-winst 4.12.0.32
* opsi-client-agent 4.1.0.0-22
* jedit 5.5.0-1

Paquetsopsi-linux:

Paquets Linux Netboot:

* debian8 4.1.0.1-3
* debian9 4.1.0.2-4
* ubuntu 4.1.0.1-2
* ubuntu18-10 4.1.0.1-2

Paquets Linux LocalBoot:

* l-debuntu-upgrade 4.1.0.0-4
* l-hwaudit 4.1.0.0-1
* opsi-linux-client-agent 4.1.0.9-1

opsi-local-image / opsi-vhd:

* opsi-local-image-prepare 4.1.0.0-12
* opsi-local-image Windows Nt6 (4.1.0.0-12)
* opsi-vhd Windows Nt6 (4.1.0.0-12)


Paquets serveurs:
opsi 4.0:

aucun

opsi 4.1

* opsi4ucs 4.1.1.5-5
* opsiconfd 4.1.1.16-2
* opsipxeconfd 4.1.1.14-1
* opsi-nagios-plugins 4.1.1.4-1
* opsi-server 4.1.1.6-1
* opsi-utils 4.1.1.27-1
* python-opsi 4.1.1.53-1

Documentation:

* opsi-manual (4.0/4.1)
* opsi-script-manual
* opsi-getting-started (4.0/4.1)

########################

cordialement
detlef oertel


Changelogs:
=============================
opsi-winst/opsi-script (4.12.0.32) stable; urgency=low

* osconf: no more OpsiServiceConfigs: in log

-- Detlef Oertel <d.oertel@uib.de> Thu, 25 10 2018:15:00:00 +0200

opsi-winst/opsi-script (4.12.0.31) stable; urgency=low

* new paths for Linux:
osconf: opsiscriptconfinit = '/etc/opsi-script/opsi-script.conf';
osbatchgui: skindirectoryDefault = '/usr/share/opsi-script/skin';
osbatchgui: skindirectoryCustomWin = '/usr/share/opsi-script/customskin';
osparser: // search in /usr/share/opsi-script/lib
osparser: '%opsiLogDir%' = '/var/log/opsi-script'
oslog: StandardLogPath := '/var/log/opsi-script/';
* osencoding: do not write out supported encodings; fixes #3700

-- Detlef Oertel <d.oertel@uib.de> Wed, 17 10 2018:15:00:00 +0200

opsi-winst/opsi-script (4.12.0.30) stable; urgency=low

* osparser: fix for close log file after script finished:
(only in interactive mode)
* oslog: all loglines trimright; fixes #3708

-- Detlef Oertel <d.oertel@uib.de> Mon, 15 10 2018:15:00:00 +0200

opsi-winst/opsi-script (4.12.0.29) stable; urgency=low

* osparser: doRegitryHack*: remove HKCU on flag_all_usrclass

-- Detlef Oertel <d.oertel@uib.de> Tue, 25 Sep 2018:15:00:00 +0200

opsi-winst/opsi-script (4.12.0.28) stable; urgency=low

* osconf: (fix): get ScriptErrorMessages, AutoActivityDisplay
* osparser: move log message 'line is starting with' to log_prog
* osinteractivegui: radiobutton 'NewFile' visible
* osinteractivegui: at execute viewlist: use CreateTheLogfile
* osinteractivegui: at execute_button: use CreateTheLogfile
* osparser: close log file after script finished
* switch to lazarus 1.8.4.

-- Detlef Oertel <d.oertel@uib.de> Fri, 14 Sep 2018:15:00:00 +0200

=============================
windows (4.1.0.0-14) stable; urgencly=low

* nt6.py: localize admin only if winver >= 10

-- detlef oertel <d.oertel@uib.de> Wed, 12 Dec 2018 15:00:00 +0200

windows (4.1.0.0-13) stable; urgency=low

* corrected behaviour on NVME devices

-- Mathias Radtke <m.radtke@uib.de> Mon Dec 3 14:01:07 2018 +0200

windows (4.1.0.0-12) stable; urgencly=low

* soft raid 1 (/dev/md) / bios-soft raid 1 (dev/mapper) support:
* property multi_disk_mode: new option: prefer_raid
* nt6.py: after "collect disk and partition infos" retry set and get disk uuid
* opsisetuplib.py: new def isRaidDisk(diskDevice = ""):
* opsisetuplib.py: new def isRaidMember(diskDevice = ""):
* opsisetuplib.py: in getDiskIndexFromMultiDiskMode: check for prefer_raid
* opsisetuplib.py: fix in isRotationalDisk
* update usb.ids and pci.ids
* nt6.py: Do not try to analyze Raid Member disks for diskinfo.ini
* nt6.py: Do not add RaidMember disks to unusedPartitionIdBackup
* nt6.py: call sgdisk --zap-all with os.system and '>> /dev/null 2>&1'
* nt6.py: fix handling of property winpe_debug_cmd_exe
* nt6.py: call bcdboot.exe x:\windows /v im work.cmd to repair bcd and make bcdedit useable
* nt6.opsiscript: on preserve_winpe_partition=false:
#Crash winpe uefi boot by converting to ntfs to help broken bioses; fixes #1651
if uefi: remove opsi win pe bootentry
* nt6.py: use ms-sys --mbr7 if int(bootimageVersion) >= 20181022:

-- detlef oertel <d.oertel@uib.de> Thu, 20 Sep 2018 15:00:00 +0200

windows (4.1.0.0-11) stable; urgencly=low

* postinst: 90_cleanup.cmd: no powershell on NT5
* postinst: postinst.cmd: no powershell on NT5

-- detlef oertel <d.oertel@uib.de> Tue, 25 Jul 2018 15:00:00 +0200

=============================
opsi-client-agent (4.1.0.0-24) stable; urgency=low

* opsiclientd 4.0.94: win10 fix.

-- Erol Ueluekmen <e.ueluekmen@uib.de> Wed, 05 Dec 2018:10:25:00 +0200


opsi-client-agent (4.1.0.0-23) stable; urgency=low

* opsiclientd 4.0.94

-- Erol Ueluekmen <e.ueluekmen@uib.de> Tue, 04 Dec 2018:17:25:00 +0200

opsi-client-agent (4.1.0.0-22) stable; urgency=low

* Check if vcredist 2008 is installed for more versions (9.0.x)

-- Detlef Oertel <d.oertel@uib.de> Tue, 18 Oct 2018:17:20:00 +0200

=============================
opsi-configed (4.0.7.8.6-1) STABLE; urgency=medium

* now it is possible to use a value for uefi (and it is shown)

-- Rupert <r.roeder@uib.de> Tue, 30 Oct 2018 16:11:46 +0100

opsi-configed (4.0.7.8.5-1) STABLE ; urgency=medium

* Working code for multi host editing of WAN and UEFI was commented out
* default values for UEFI were not taken into account

-- roeder <r.roeder@uib.de> Wed, 24 Oct 2018 13:14:20 +0200

opsi-configed (4.0.7.8.4-1) STABLE ; urgency=medium

* changed name of an exception class taken into account when filtering exceptions to ignore
* more java version info

-- roeder <r.roeder@uib.de> Thu, 11 Oct 2018 13:14:20 +0200

=============================

windows10-upgrade (18.09-1) stable; urgency=low

* windows 10 1809

-- bardo wolf <b.wolf@uib.de> Thu 18. Oct 12:08:25 CEST 2018

=============================

config-win10 (4.1.1-5); stable; urgency=low

* try to fix errors in Registry_hkcu_enable_settings_sync
* removed ;Registry_hklm_update_enable_search /sysnative
* added (see https://docs.microsoft.com/en-us/window ... igure-wufb)
property DeferFeatureUpdatesPeriodInDays
property DeferQualityUpdatesPeriodInDays

-- Bardo Wolf <b.wolf@uib.de> Wed, 30 Nov 2018

config-win10 (4.1.1-4); stable; urgency=low

* Property name: disable_smbv1 default set to true
* remove in Login Mode erroneouasly /ALLNTUSERDATS
* split minimize_recommendation in hkcu and hklm, add hkcu to Login Mode
* change show_all_folder_in_navbar to /ALLNTUSERDATS and add to Login mode
* change show_thispc_instead_of_quicklaunch to /ALLNTUSERDATS and add to Login mode
* change hide_known_file_extensions to /ALLNTUSERDATS and add to Login mode
* change disable_app_suggestion_in_startmenu to /ALLNTUSERDATS and add to Login mode
* change disable_recent_apps to /ALLNTUSERDATS and add to Login mode
* change disable_suggested_silent_app_installation to /ALLNTUSERDATS and add to Login mode
* change disable_error_report to /ALLNTUSERDATS and add to Login mode

* Registry_hklm_disable_push added 32AND 64Bit
* Registry_hklm_do_publish added 32AND 64Bit

-- Bardo Wolf <b.wolf@uib.de> Wed, 28 Nov 2018

config-win10 (4.1.1-3); stable; urgency=low

* fixed double initialization of disable_update_service

-- Mathias Radtke <m.radtke@uib.de> Wed, 21 Nov 2018 11:20:00 +0200

config-win10 (4.1.1-2); stable; urgency=low

* corrected userlogin script behaviour

-- Mathias Radtke <m.radtke@uib.de> Wed, 14 Nov 2018 14:00:00 +0100

config-win10 (4.1.1-1); stable; urgency=low

* added new properties:
* disable_push_install
* disable_error_report
* disable_suggested_silent_app_installation
* disable_app_suggestion_in_startmenu
* minimize_recommendations
* hide_known_file_extensions
* allow_useractivity_publishing
* remove_edge_from_desktop
* show_thispc_instead_of_quicklaunch
* show_drive_letter_first
* show_all_folder_in_navbar

-- Mathias Radtke <m.radtke@uib.de> Tue, 25 Sep 2018 13:40:00 +0200

=============================

jedit_5.5.0-1 stable; urgency=low

* fixes failed install with jre 10

-- b.wolf <b.wolf@uib.de> Tue, 11 Sep 2018 15:00:00 + 0100

=============================
debian8 (4.1.0.1-3) testing; urgency=low

* new property: user_name

-- Mathias Radtke <m.radtke@uib.de> Mon 29 Oct 2018 10:30:00 +0100

=============================
debian9 (4.1.0.2-4) testing; urgency=low

* kernel/initrd update

-- Mathias Radtke <m.radtke@uib.de> Wed 14 Nov 2018 07:42:00 +0100

debian9 (4.1.0.2-3) testing; urgency=low

* new property: user_name

-- Mathias Radtke <m.radtke@uib.de> Mon 29 Oct 2018 10:30:00 +0100
=============================
ubuntu (4.1.0.1-2) stable; urgency=low

* added cosmic cuttlefish to releases

-- Mathias Radtke <m.radtke@uib.de> Fri, 26 Oct 2018 11:26:00 +0200

=============================
ubuntu18-10 (4.1.0.1-2) testing; urgency=low

* forked from ubuntu18-04
* removing unndeeded opsicliend binaries

-- Mathias Radtke <m.radtke@uib.de> Fri Oct 19 2018 14:14:00

=============================

centos70 (4.1.0.0-2); testing; urgency=low

* corrected installation when using a proxy

-- Mathias Radtke <m.radtke@uib.de> Wed Dec 05 2018 08:57:00 +0100

centos70 (4.1.0.0-1) testing; urgency=low

* removing unndeeded opsicliend binaries

-- Mathias Radtke <m.radtke@uib.de> Wed Aug 22 13:50:00

=============================

l-debubuntu-upgrade (4.1.0.0-4) stable; urgency=low

* debian: sub_modify_repo_deb: avoid multiple identic lines
* debian: backup old *.list files to /etc/apt/backup/
* debian: try to find new opsi source and get release.key for it
* fixes #3373
* some code cleanup

-- detlef oertel <d.oertel@uib.de> Thu, 25 Oct 2018 15:00:00 +0000

l-debubuntu-upgrade (4.1.0.0-3) stable; urgency=low

* check for free space
* include logs from /var/log/dist-upgrade if do-upgrade failed

-- detlef oertel <d.oertel@uib.de> Mon, 03 Sep 2018 15:00:00 +0000

=============================

opsi-linux-client-agent (4.1.0.9-1) stable; urgency=medium

* opsi-script 4.12.0.31:
* new paths for Linux:
* osconf: opsiscriptconfinit = '/etc/opsi-script/opsi-script.conf';
* osbatchgui: skindirectoryDefault = '/usr/share/opsi-script/skin';
* osbatchgui: skindirectoryCustomWin = '/usr/share/opsi-script/customskin';
* osparser: // search in /usr/share/opsi-script/lib
* osparser: '%opsiLogDir%' = '/var/log/opsi-script'
* oslog: StandardLogPath := '/var/log/opsi-script/';
* copy opsi-script lib files
* copy opsi-script po files modified

-- d.oertel <d.oertel@uib.de> Thu, 18 Oct 2018 15:00:00 + 0100

=============================
l-hwaudit 4.0.0.1-1; stable; urgency=low

* changed from opsi 40 to opsi 4.1 repos

-- d.oertel <d.oertel@uib.de> Fri, 14 Sep 2018 15:00:00 + 0200
=============================
opsi-local-image-prepare (4.1.0.0-12) stable; urgencly=low

* soft raid 1 (/dev/md) / bios-soft raid 1 (dev/mapper) support:
* property multi_disk_mode: new option: prefer_raid
* nt6.py: after "collect disk and partition infos" retry set and get disk uuid
* opsisetuplib.py: new def isRaidDisk(diskDevice = ""):
* opsisetuplib.py: new def isRaidMember(diskDevice = ""):
* opsisetuplib.py: in getDiskIndexFromMultiDiskMode: check for prefer_raid
* opsisetuplib.py: fix in isRotationalDisk
* update usb.ids and pci.ids
* nt6.py: Do not try to analyze Raid Member disks for diskinfo.ini
* nt6.py: Do not add RaidMember disks to unusedPartitionIdBackup
* nt6.py: call sgdisk --zap-all with os.system and '>> /dev/null 2>&1'
* nt6.py: fix handling of property winpe_debug_cmd_exe
* nt6.py: call bcdboot.exe x:\windows /v im work.cmd to repair bcd and make bcdedit useable
* nt6.opsiscript: on preserve_winpe_partition=false:
#Crash winpe uefi boot by converting to ntfs to help broken bioses; fixes #1651
if uefi: remove opsi win pe bootentry
* nt6.py: use ms-sys --mbr7 if int(bootimageVersion) >= 20181022:

-- detlef oertel <d.oertel@uib.de> Thu, 20 Sep 2018 15:00:00 +0200

opsi-local-image-prepare (4.1.0.0-6) to (4.1.0.0-11) not used

=============================
=============================
opsi-script-linux:

opsi-script (4.12.0.31-2) stable; urgency=medium

* corrected installation routine in debian based systems

-- Mathias Radtke <m.radtke@uib.de> Wed, 05 Dec 2018 14:57:03 +0100

=============================
opsi4ucs (4.1.1.7-1) stable; urgency=medium

* Remove more translation leftovers.

-- Niko Wenselowski <n.wenselowski@uib.de> Mon, 26 Nov 2018 15:31:34 +0100

opsi4ucs (4.1.1.6.1-1) stable; urgency=medium

* Make the message nicer to read.
* Remove unsupported translation functions.

-- Niko Wenselowski <n.wenselowski@uib.de> Fri, 23 Nov 2018 18:14:10 +0100

opsi4ucs (4.1.1.6-1) stable; urgency=medium

* Registering a depot will now provide the user with the option to delete an
existing client if the ID of the server to register and the client at the
destination server are the same.

-- Niko Wenselowski <n.wenselowski@uib.de> Fri, 23 Nov 2018 18:02:14 +0100

opsi4ucs (4.1.1.5-5) stable; urgency=medium

* postinst: Accept non-zero exit codes.
call_joinscript may return 1 if the join script in question has already
been executed before.

-- Niko Wenselowski <n.wenselowski@uib.de> Mon, 15 Oct 2018 14:16:13 +0200

=============================
opsipxeconfd (4.1.1.14-1) stable; urgency=medium

* Make print Python 3 compatible.

-- Niko Wenselowski <n.wenselowski@uib.de> Wed, 21 Nov 2018 09:42:41 +0100

=============================
opsiconfd (4.1.1.16-2) stable; urgency=medium

* Removed rotating /var/log/opsi/package.log.
This logfile is used by opsi-package-manager and logrotate config for this
file is part of the package opsi-utils.

-- Niko Wenselowski <n.wenselowski@uib.de> Thu, 22 Nov 2018 10:55:44 +0100

opsiconfd (4.1.1.16-1) stable; urgency=medium

* New module for config parsing: opsiconfd.config.
* opsiconfd.monitoring: checkProductStatus: Improving readability in output.
* opsiconfd.monitoring: checkProductStatus: in case a product is not to be
found on a depot the check of productOnClient will be skipped.

-- Niko Wenselowski <n.wenselowski@uib.de> Tue, 13 Nov 2018 13:22:06 +0100

opsiconfd (4.1.1.15-1) stable; urgency=medium

* opsiconfd.monitoring: Removed getOpsiClientsForGroup as this check is not
runnable through check_opsi and does not return a response in the format
expected for Nagios-compatible plugins.
* opsiconfd.workers: WorkerOpsiconfdJsonRpc._decodeQuery is implemented the
way it is in python-opsi.
* opsiconfd.monitoring: only collect performance data if this is requested.
* opsiconfd.monitoring: checkProductLocks shows a summary in the first line.

-- Niko Wenselowski <n.wenselowski@uib.de> Tue, 06 Nov 2018 13:55:56 +0100

opsiconfd (4.1.1.14-1) stable; urgency=medium

* opsiconfd.workers: small modification in errormessage for usage with fail2ban

-- Erol Ueluekmen <e.ueluekmen@uib.de> Wed, 31 Oct 2018 14:42:33 +0100

opsiconfd (4.1.1.13-1) stable; urgency=medium

* opsiconfd.monitoring: implemented exclusion of productIds for
checkClientStatus.
* opsiconfd.monitoring: Small changes to make the output easier to read.
* opsiconfd.monitoring: checkProductStatus ignores action request 'always'.

-- Niko Wenselowski <n.wenselowski@uib.de> Mon, 29 Oct 2018 18:18:48 +0100

opsiconfd (4.1.1.12-1) stable; urgency=medium

* opsiconfd.monitoring: Fixed a bug where executing task checkProductLocks
would lead to "unknown task".

-- Niko Wenselowski <n.wenselowski@uib.de> Thu, 18 Oct 2018 11:51:53 +0200

=============================
opsi-nagios-plugins (4.1.1.4-1) stable; urgency=medium

* Internal refactoring.
* .deb: Make more use of debhelper for easy installation.

-- Niko Wenselowski <n.wenselowski@uib.de> Thu, 31 Oct 2018 15:48:45 +0100

opsi-nagios-plugins (4.1.1.3-1) stable; urgency=medium

* Fix handling for --state.

-- Niko Wenselowski <n.wenselowski@uib.de> Thu, 18 Oct 2018 17:18:45 +0200

opsi-nagios-plugins (4.1.1.2-1) stable; urgency=medium

* Switched argument parsing to argparse.
* Fixed a bug where an problem with creating the connection would not be
visible because it would be shadowed by another exception.
* Internal refactorings.

-- Niko Wenselowski <n.wenselowski@uib.de> Thu, 18 Oct 2018 14:26:47 +0200
=============================
python-opsi (4.1.1.53-1) stable; urgency=medium

* OPSI.System.Posix: isOpenSuse will return False if not running on openSuse.

-- Niko Wenselowski <n.wenselowski@uib.de> Fri, 30 Nov 2018 11:26:37 +0100

python-opsi (4.1.1.52-2) testing; urgency=medium

* OPSI.System.Posix: isOpenSUSE refactored to not use platform

-- Mathias Radtke <m.radtke@uib.de> Mon, 26 Nov 2018 12:07:10 +0100

python-opsi (4.1.1.52-1) testing; urgency=medium

* OPSI.System.Posix: correctly detecting openSUSE Leap 15.0 and above
* OPSI.System.Posix: using isOpenSUSE() to determine Leap, isOpenSUSELeap()
is obsolete
* OPSI.Util.Task.Rights: replaced isOpenSUSELeap() with isOpenSUSE()

-- Mathias Radtke <m.radtke@uib.de> Fri, 23 Nov 2018 09:58:13 +0100

python-opsi (4.1.1.51-3) stable; urgency=medium

* RPM: openSUSE Leap 15 needs net-tools-deprecated to work with 'ifconfig'

-- Mathias Radtke <m.radtke@uib.de> Thu, 22 Nov 2018 15:30:36 +0100

python-opsi (4.1.1.51-2) stable; urgency=medium

* RPM: requires python-mysqlclient on openSUSE Leap 15.0

-- Mathias Radtke <m.radtke@uib.de> Mon, 19 Nov 2018 15:43:29 +0100

python-opsi (4.1.1.51-1) stable; urgency=medium

* Fixed opsiDepotId Usage for opsi-package-updater

-- Erol Ueluekmen <e.ueluekmen@uib.de> Mon, 19 Nov 2018 14:48:57 +0100

python-opsi (4.1.1.50-1) stable; urgency=medium

* OPSI.Util.Task.UpdatePackages: Certificate authentication implemented
for opsi-package-updater.

-- Erol Ueluekmen <e.ueluekmen@uib.de> Fri, 16 Nov 2018 12:38:45 +0100

python-opsi (4.1.1.49-1) stable; urgency=medium

* OPSI.Service.Worker: HTTP headers are set according to RFC 2616.
If a header with Content-Type starting with "gzip" is encountered a
backwards-compatible answer is made.
* OPSI.Object: Adding a property read-only property version to Product,
ProductOnClient and ProductOnDepot. It is a string combining the values of
productVersion and packageVersion. This property is not present in the API.

-- Niko Wenselowski <n.wenselowski@uib.de> Tue, 06 Nov 2018 12:16:49 +0100

python-opsi (4.1.1.48-1) stable; urgency=medium

* OPSI.System.Windows: Fixed some reference bugs.
* OPSI.Util.Task.UpdatePackages: Added missing reference.

-- Niko Wenselowski <n.wenselowski@uib.de> Wed, 17 Oct 2018 14:36:41 +0200

=============================
opsi-utils (4.1.1.28-1) stable; urgency=medium

* opsi-package-manager: Propagate problems when executing tasks instead
of an direct exit.

-- Niko Wenselowski <n.wenselowski@uib.de> Tue, 04 Dec 2018 12:12:56 +0100

opsi-utils (4.1.1.27-1) stable; urgency=medium

* opsi-package-manager: Reference the used logfile if tasks failed instead
of always using the default path.
* Logrotate configuration for opsi-package-manager references the correct
default logfile (/var/log/opsi/package.log).

-- Niko Wenselowski <n.wenselowski@uib.de> Mon, 05 Nov 2018 18:00:49 +0100

opsi-utils (4.1.1.26-1) testing; urgency=medium

* opsi-package-updater: Make use of OPSI.Util.Task.UpdatePackages from
python-opsi.
* Various small changes in opsi-admin, opsi-backup, opsi-convert,
opsi-makepackage, opsi-newprod and opsi-package-manager to make the
switch to Python 3 easier.

-- Niko Wenselowski <n.wenselowski@uib.de> Thu, 18 Oct 2018 17:30:26 +0200

opsi-utils (4.1.1.25-1) stable; urgency=medium

* Based on opsi-utils 4.0.7.20.

-- Niko Wenselowski <n.wenselowski@uib.de> Mon, 10 Sep 2018 17:01:48 +0200

=============================
opsi-server (4.1.1.6-1) stable; urgency=medium

* Fix unattended setup.

-- Niko Wenselowski <n.wenselowski@uib.de> Mon, 26 Nov 2018 15:11:44 +0100

opsi-server (4.1.1.5.1-1) stable; urgency=medium

* Remove unsupported translation functions.

-- Niko Wenselowski <n.wenselowski@uib.de> Fri, 23 Nov 2018 18:17:00 +0100

opsi-server (4.1.1.5-1) stable; urgency=medium

* Registering a depot will now provide the user with the option to delete an
existing client if the ID of the server to register and the client at the
destination server are the same.

-- Niko Wenselowski <n.wenselowski@uib.de> Fri, 23 Nov 2018 17:39:22 +0100

=============================

winexe (4.8.0.0-15) experimental; urgency=medium

* SLES/OpenSUSE: using mingw64-cross-gcc as dep

-- Mathias Radtke <m.radtke@uib.de> Wed, 01 Aug 2018 13:24:56 +0200

winexe (4.8.0.0-14) experimental; urgency=medium

* rpm/spec: added mingw32-cross-gcc if SLES/openSUSE

-- Mathias Radtke <m.radtke@uib.de> Tue, 31 Jul 2018 14:06:40 +0200

winexe (4.8.0.0-13) experimental; urgency=medium

* rpm/spec: added debug ls commands

-- Mathias Radtke <m.radtke@uib.de> Mon, 30 Jul 2018 10:53:09 +0200

winexe (4.8.0.0-12) experimental; urgency=medium

* debian/control: added Maintainer

-- Mathias Radtke <m.radtke@uib.de> Fri, 27 Jul 2018 14:26:38 +0200

winexe (4.8.0.0-11) experimental; urgency=medium

* debian/compat: added
* rpm/spec: corrected file copy

-- Mathias Radtke <m.radtke@uib.de> Fri, 27 Jul 2018 13:57:38 +0200

winexe (4.8.0.0-10) experimental; urgency=medium

* control: added debhelper
* spec: copy file edited

-- Mathias Radtke <m.radtke@uib.de> Fri, 27 Jul 2018 10:33:28 +0200

winexe (4.8.0.0-9) experimental; urgency=medium

* debian/rules: exporting basic DH_OPTIONS
* rpm/spec: added python-xml as dependency

-- Mathias Radtke <m.radtke@uib.de> Fri, 27 Jul 2018 09:47:07 +0200

winexe (4.8.0.0-8) experimental; urgency=medium

* spec. mingw changed for non SLES

-- Mathias Radtke <m.radtke@uib.de> Wed, 25 Jul 2018 15:10:53 +0200

winexe (4.8.0.0-7) experimental; urgency=medium

* control: python-devel added
* spec: libacl1-dev added

-- Mathias Radtke <m.radtke@uib.de> Wed, 25 Jul 2018 15:02:54 +0200

winexe (4.8.0.0-6) experimental; urgency=medium

* spec: changed RPM dependency
* rules: removed dh_clean references

-- Mathias Radtke <m.radtke@uib.de> Wed, 25 Jul 2018 14:45:39 +0200

winexe (4.8.0.0-5) experimental; urgency=medium

* depencency changes

-- Mathias Radtke <m.radtke@uib.de> Wed, 25 Jul 2018 14:32:13 +0200

winexe (4.8.0.0-4) experimental; urgency=medium

* rpm/spec: corrected additional else

-- Mathias Radtke <m.radtke@uib.de> Wed, 25 Jul 2018 13:57:13 +0200

winexe (4.8.0.0-3ubuntu1) experimental; urgency=medium

* rpm/spec: corrected buildRequires

-- Mathias Radtke <m.radtke@uib.de> Wed, 25 Jul 2018 13:49:50 +0200

winexe (4.8.0.0-2) experimental; urgency=medium

* rpm/spec: corrected pckage naming for different RPM distributions

-- Mathias Radtke <m.radtke@uib.de> Wed, 25 Jul 2018 13:26:13 +0200

winexe (4.8.0.0-1) experimental; urgency=medium

* initial package creation*

-- Mathias Radtke <m.radtke@uib.de> Wed, 25 Jul 2018 12:25:12 +0200

=============================