opsi 4.0 & opsi 4.1: Updates in stable & testing

Benutzeravatar
n.wenselowski
Beiträge: 2898
Registriert: 04 Apr 2013, 12:15

opsi 4.0 & opsi 4.1: Updates in stable & testing

Beitragvon n.wenselowski » 18 Okt 2018, 16:25

Dear opsi users,

updates have been released for opsi 4.0 and opsi 4.1 in stable and testing.


Available for opsi 4.0 and 4.1 in stable:
Windows localboot packages:
* hwaudit 4.1.0.8-1
* opsi-client-agent 4.1.0.0-21
* opsi-wim-capture 4.1.0.1-7

Linux netboot packages:
* ucs43 4.1.0.1-1

Linux localboot packages:
* opsi-script-test 4.12.0.27-2
* l-opsi-server 4.1.1.7-9

opsi-local-image / opsi-vhd packages:
* opsi-local-image-wim-capture 4.1.0.1-7


Available for opsi 4.1 in stable:
Server packages:
* opsi4ucs 4.1.1.5-4
* opsi-utils 4.1.1.25-1
* opsi-utils-deprecated 4.0.7.20-1
* python-opsi 4.1.1.47-1


Available for opsi 4.0 in stable:
Server packages:
* opsi-utils 4.0.7.20
* python-opsi 4.0.7.69-1


Available for opsi 4.0 and 4.1 in testing:
Windows localboot packages:
* opsi-configed 4.0.7.8.3-1
* opsi-winst/opsi-script 4.12.0.30

Available for opsi 4.1 in testing:
Server packages:
* opsipxeconfd 4.1.1.13-2
* opsi4ucs 4.1.1.5-5


With kind regards

Niko Wenselowski


PS: Changelogs:

--------------------------------

hwaudit (4.1.0.8-1) stable; urgency=low

* Improve handling of --help.

-- Niko Wenselowski <n.wenselowski@uib.de> Wed, 20 Sep 2018 15:22:24 +0200

hwaudit (4.1.0.7-2) stable; urgency=low

* Re-packaged.

-- Niko Wenselowski <n.wenselowski@uib.de> Wed, 20 Sep 2018 14:57:53 +0200

hwaudit (4.1.0.7-1) stable; urgency=low

* Fix bug in commandline parsing.

-- Niko Wenselowski <n.wenselowski@uib.de> Wed, 19 Sep 2018 10:06:12 +0200

hwaudit (4.1.0.6-2) stable; urgency=low

* Refactored installation script.

-- Niko Wenselowski <n.wenselowski@uib.de> Tue, 18 Sep 2018 12:14:52 +0200

hwaudit (4.1.0.6-1) stable; urgency=low

* Refactored handling of commandline arguments.

-- Niko Wenselowski <n.wenselowski@uib.de> Tue, 18 Sep 2018 12:14:52 +0200

hwaudit (4.1.0.5-1) stable; urgency=low

* Logging improvements.
* Fixed typo in log.
* Binary will tell it s version before each run.

-- Niko Wenselowski <n.wenselowski@uib.de> Fri, 14 Sep 2018 14:52:47 +0200

--------------------------------

l-opsi-server (4.1.1.7-9); stable; urgency=low

* calling opsi4(0/1).opsiscript as sub

-- Mathias Radtke <m.radtke@uib.de> Fri 21 Sep 2018 16:11:00 +0200

l-opsi-server (4.1.1.7-8); stable; urgency=low

* importLib changed to include_insert to beautify log reading

-- Mathias Radtke <m.radtke@uib.de> Tue, 18 Sep 2018 12:36:00 +0200

l-opsi-server (4.1.1.7-7); stable; urgency=low

* UCS4.3: disabling update cron jobs prior installing opsi to prevent
timing problems

--Mathias Radtke <m.radtke@uib.de> Wed, 15 Aug 2018 08:37:00 +0200

l-opsi-server (4.1.1.7-6); stable; urgency=low

* Use setProductActionRequestWithDependencies for setup after install.

-- Niko Wenselowski <n.wenselowski@uib.de> Tue, 06 Aug 2018 09:48:44 +0200

l-opsi-server (4.1.1.7-5); stable; urgency=low

* UCS 4.3: patching smb.conf with actual network device instead of eth0
* UCS 4.3: waiting for package lock prior installing packages

--Mathias Radtke <m.radtke@uib.de> Wed, 01 Aug 2018 10:51:00 +0200

--------------------------------

opsi4ucs (4.1.1.5-5) stable; urgency=medium

* postinst: Accept non-zero exit codes.
call_joinscript may return 1 if the join script in question has already
been executed before.

-- Niko Wenselowski <n.wenselowski@uib.de> Mon, 15 Oct 2018 14:16:13 +0200

opsi4ucs (4.1.1.5-4) stable; urgency=medium

* Based on opsi4ucs 4.0.7.5-13.

-- Niko Wenselowski <n.wenselowski@uib.de> Thu, 20 Sep 2018 16:27:51 +0200

opsi4ucs (4.1.1.5-3) stable; urgency=medium

* Based on opsi4ucs 4.0.7.5-12.

-- Niko Wenselowski <n.wenselowski@uib.de> Tue, 28 Aug 2018 13:24:18 +0200

--------------------------------

opsipxeconfd (4.1.1.13-2) stable; urgency=medium

* Merged opsipxeconfd 4.0.7.9-4.

-- Niko Wenselowski <n.wenselowski@uib.de> Mon, 20 Aug 2018 16:06:38 +0200

opsipxeconfd (4.0.7.9-4) stable; urgency=medium

* UCS: postinst: patching tftpboot directory

-- Mathias Radtke <m.radtke@uib.de> Mon, 20 Aug 2018 14:03:28 +0200

--------------------------------

opsi-client-agent (4.1.0.0-21) stable; urgency=low

* opsi_client_systray 4.1.0.1: fix logging to c:\opsi.org\applog
* opsiclientkiosk 4.1.0.1: fix logging to c:\opsi.org\applog
* update to opsi-winst/opsi-script 4.12.0.28
* More messages in oca_write_configuration()
* uninstall: remove kiosk start menue and desktop entries

-- Detlef Oertel <d.oertel@uib.de> Tue, 25 Aug 2018:15:00:00 +0200

opsi-client-agent (4.1.0.0-20) stable; urgency=low

* fixes #3649 uninstall dont remove [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Run]"opsi_systray_start"

-- Bardo Wolf <b.wolf@uib.de> Mon, 20 Aug 2018:15:00:00 +0200

--------------------------------

opsi-configed (4.0.7.8.3-1) stable; urgency=medium

* avoiding a NPW in the search modul if a SW entry is not found, improved logging

-- roeder <r.roeder@uib.de> Thu, 11 Oct 2018 13:14:20 +0200

opsi-configed (4.0.7.8.2-1) STABLE; urgency=medium

* default path of opsi-set-rights changed to empty
* fixed comparing opsi version method
* deleting product properties by wildcard when resetting a client

-- roeder <roeder@asusvivo01.uib.local> Tue, 04 Sept 2018 16:44:52 +0200

--------------------------------

opsi-script-test (4.12.0.27-1) stable; urgency=low

* registry: Registry_hkcu_userclasses_test /AllUsrClassDats
from Terry Strooband
small fix

-- detlef oertel <d.oertel@uib.de> Mon, 10 Sep 2018 15:00:00 +0200

opsi-script-test (4.12.0.26-1) stable; urgency=low

* registry: Registry_hkcu_userclasses_test /AllUsrClassDats
from Terry Strooband

-- detlef oertel <d.oertel@uib.de> Thu, 06 Sep 2018 15:00:00 +0200

opsi-script-test (4.12.0.25-1) stable; urgency=low

* json: array functions for array like "[true]"

-- detlef oertel <d.oertel@uib.de> Tue, 07 Aug 2018 15:00:00 +0200

--------------------------------

opsi-utils (4.1.1.25-1) stable; urgency=medium

* Based on opsi-utils 4.0.7.20.

-- Niko Wenselowski <n.wenselowski@uib.de> Mon, 10 Sep 2018 17:01:48 +0200

opsi-utils (4.1.1.24-1) stable; urgency=medium

* opsi-package-updater: Do not install packages with "force" parameter.
This will lead to installations not being made if a product is locked.

-- Niko Wenselowski <n.wenselowski@uib.de> Tue, 28 Aug 2018 16:42:05 +0200

opsi-utils (4.1.1.23-2) stable; urgency=medium

* Updated manpage for opsi-backup.

-- Niko Wenselowski <n.wenselowski@uib.de> Tue, 21 Aug 2018 13:10:11 +0200

opsi-utils (4.1.1.23-1) stable; urgency=medium

* opsi-admin: Internal refactoring to avoid usage of eval.

-- Niko Wenselowski <n.wenselowski@uib.de> Fri, 17 Aug 2018 12:33:40 +0200

opsi-utils (4.0.7.20-1) stable; urgency=medium

* opsi-product-updater: Fix detection of running opsi-product-updater.

-- Niko Wenselowski <n.wenselowski@uib.de> Mon, 10 Sep 2018 16:33:47 +0200

--------------------------------

opsi-utils-deprecated (4.0.7.20-1) stable; urgency=medium

* Updated opsi-product-updater to 4.0.7.20.

-- Niko Wenselowski <n.wenselowski@uib.de> Mon, 10 Sep 2018 16:34:49 +0200

--------------------------------

opsi-wim-capture (4.1.0.1-7) stable; urgency=low

* capture.opsiscript: put hostkey from opsi-script-infos.ini to config.ini for net mount
* capture.opsiscript: call end routines after mount failed

-- detlef oertel <d.oertel@uib.de> Tue, 25 Sep 2018 15:00:00 +0000

opsi-wim-capture (4.1.0.1-6) stable; urgency=low

* capture.opsiscript: get hostkey not from config.ini but from opsi-script-infos.ini
* capture.opsiscript: send log before fatal at mount shares

-- detlef oertel <d.oertel@uib.de> Mon, 24 Sep 2018 15:00:00 +0000

--------------------------------

opsi-winst/opsi-script (4.12.0.30) stable; urgency=low

* osparser: fix for close log file after script finished:
(only in interactive mode)
* oslog: all loglines trimright; fixes #3708

-- Detlef Oertel <d.oertel@uib.de> Mon, 15 10 2018:15:00:00 +0200

opsi-winst/opsi-script (4.12.0.29) stable; urgency=low

* osparser: doRegitryHack*: remove HKCU on flag_all_usrclass

-- Detlef Oertel <d.oertel@uib.de> Tue, 25 Sep 2018:15:00:00 +0200

opsi-winst/opsi-script (4.12.0.28) stable; urgency=low

* osconf: (fix): get ScriptErrorMessages, AutoActivityDisplay
* osparser: move log message 'line is starting with' to log_prog
* osinteractivegui: radiobutton 'NewFile' visible
* osinteractivegui: at execute viewlist: use CreateTheLogfile
* osinteractivegui: at execute_button: use CreateTheLogfile
* osparser: close log file after script finished
* switch to lazarus 1.8.4.

-- Detlef Oertel <d.oertel@uib.de> Fri, 14 Sep 2018:15:00:00 +0200

--------------------------------

python-opsi (4.1.1.47-1) stable; urgency=medium

* Based on python-opsi 4.0.7.69.

-- Niko Wenselowski <n.wenselowski@uib.de> Thu, 20 Sep 2018 17:17:14 +0200

python-opsi (4.1.1.46-1) stable; urgency=medium

* OPSI.Backend.File: Fix reading extended attributes of LocalbootProduct and
NetbootProduct.

-- Niko Wenselowski <n.wenselowski@uib.de> Tue, 11 Sep 2018 14:59:21 +0200

python-opsi (4.1.1.45-1) testing; urgency=medium

* Added OPSI.Util.Task.UpdatePackages. This makes parts of
opsi-package-updater reusable.

-- Niko Wenselowski <n.wenselowski@uib.de> Tue, 04 Sep 2018 13:56:55 +0200

python-opsi (4.1.1.44-1) stable; urgency=medium

* OPSI.Backend.Depotserver: Small internal refactorings.
* OPSI.Backend.Depotserver: depot_installPackage: Log messages show exactly
what product / depot is involved.
* OPSI.Backend.HostControl: Refactored lookup for custom opsiclientd port.
* OPSI.Backend.HostControlSafe: Added support for custom opsiclientd port.
* OPSI.Backend.OpsiPXEConfd: Added support for connection to a different
external opsi server.

-- Niko Wenselowski <n.wenselowski@uib.de> Mon, 03 Sep 2018 13:34:03 +0200

python-opsi (4.0.7.69-1) stable; urgency=medium

* OPSI.Util.File.Opsi.parseFilename now works with absolute and relative
paths.

-- Niko Wenselowski <n.wenselowski@uib.de> Thu, 13 Sep 2018 14:19:24 +0200

python-opsi (4.0.7.68-1) stable; urgency=medium

* OpsiBackup: Internal refactorings for restore handling.
* OpsiBackup: Fix restore when backends are "auto" and the backup
does not contain data for a backend.

-- Niko Wenselowski <n.wenselowski@uib.de> Thu, 26 Jul 2018 14:25:19 +0200

--------------------------------

ucs43 (4.1.0.1-1) testing; urgency=low

* fixed bug where interfaces/primary is set to eth0

-- Mathias Radtke <m.radtke@uib.de> Mon Sep 17 12:00:00 2018 +0200

ucs43 (4.1.0.0-2) testing; urgency=low

* installing UCS 4.3-1

-- Mathias Radtke <m.radtke@uib.de> Tue Jun 26 07:43:00 2018 +0200

ucs43 (4.1.0.0-1) testing; urgency=low

* initial release

-- Mathias Radtke <m.radtke@uib.de> Wed Mar 14 14:50:00 2018 +0100

--------------------------------
Kein Support per DM!
_________________________
opsi support - uib gmbh
For productive opsi installations we recommend support contracts.