Fehler im mshotfix_201807-1.opsi ?

Anregungen, Fragen zu den Abo-Paketen
dslthomas
Beiträge: 58
Registriert: 26 Mär 2012, 15:49

Fehler im mshotfix_201807-1.opsi ?

Beitragvon dslthomas » 16 Jul 2018, 08:10

Hallo,

nachdem ich nun fast das ganze Wochenende krampfhaft versucht habe das aktuelle Update-Package zu installieren, stehe ich heute Morgen vor der Katastrophe. Kann es sein, dass das mshotfix_201807-1.opsi nicht zum Inhalt und dem aktuellem Update-Package passt? Wenn ich dieses Paket versuche zu installieren (was schon gar nicht geht da die Versionsnummer im Paket identisch zum Vormonat ist) dann erhalte ich einen Fehler. Wenn ich das mshotfix_201806-1.opsi lösche und dann das mshotfix_201807-1.opsi installiere, klappt das zwar,- mir wird aber trotz dem die Version mshotfix_201806-1.opsi in OPSI angezeigt. Der Versuch das Paket neu zu Packen und die Versionsnummer zu ändern schlägt mit dem Package-Builder fehl. Entsprechend kann ich auch nicht die aktuellen Patches einspielen weil diese Installation dann aufgrund der fehlenden Abhängigkeit fehl schlägt.:

Code: Alles auswählen

root@opsilabor:/var/lib/opsi/repository# opsi-package-manager --force -i mshotfix_201807-1.opsi
root@opsilabor:/var/lib/opsi/repository# opsi-package-manager --force -i mshotfix-win10-x86-glb_201807-1.opsi
Ein Fehler ist aufgetreten:
   Fehler beim Bearbeiten von Install of package(s) /var/lib/opsi/repository/mshotfix-win10-x86-glb_201807-1.opsi on depot 'opsilabor.pier-rz.de':
      Opsi rpc error: Backend error: Failed to install package '/var/lib/opsi/repository/mshotfix-win10-x86-glb_201807-1.opsi' on depot 'opsilabor.pier-rz.de':Backend unaccomplishable error: Unfulfilled package dependency {'version': u'201807-1', 'condition': u'>=', 'package': u'mshotfix'} (available version: 201806-1)


Da wir 12 Standorte damit versorgen müssen und die Badbreite am Tag eingeschränkt werden muss damit das Tagesgeschäft nicht gestört wird, dauert jeder Versuch min. 2 Stunden.

Was läuft hier schief???????? Ich brauche hier dringend Hilfe!

ITAlex
Beiträge: 7
Registriert: 05 Jul 2018, 12:41

Re: Fehler im mshotfix_201807-1.opsi ?

Beitragvon ITAlex » 16 Jul 2018, 08:40

Hallo,

ich habe einen ähnlichen Fehler, denke aber er kommt durch den selben Fehler.

Bild

dslthomas
Beiträge: 58
Registriert: 26 Mär 2012, 15:49

Re: Fehler im mshotfix_201807-1.opsi ?

Beitragvon dslthomas » 16 Jul 2018, 08:52

Ja, diese hatte ich auch! Ich habe halt alle möglichen Wege versucht, das ganze zum laufen zu bekommen. Blöd ist halt, dass hier jetzt wirklich die Telefone nicht still stehen, da halt Updates eingespielt werden sollen die es nicht gibt. Zudem bin ich immer davon aus gegangen dass dies getestet wird

Benutzeravatar
m.radtke
Beiträge: 573
Registriert: 10 Jun 2015, 12:19

Re: Fehler im mshotfix_201807-1.opsi ?

Beitragvon m.radtke » 16 Jul 2018, 15:02

Hi

sollte wieder laufen
bitte die pakete erneut ziehen, nicht die bereits heruntergeladenen benutzen
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

ITAlex
Beiträge: 7
Registriert: 05 Jul 2018, 12:41

Re: Fehler im mshotfix_201807-1.opsi ?

Beitragvon ITAlex » 17 Jul 2018, 08:29

Hallo,

super ja jetzt laufen die Pakete wieder.

Danke

dslthomas
Beiträge: 58
Registriert: 26 Mär 2012, 15:49

Re: Fehler im mshotfix_201807-1.opsi ?

Beitragvon dslthomas » 17 Jul 2018, 12:12

Jep,- kann ich bestätigen,- es läuft wieder