opsi 4.0 & opsi 4.1 Aktualisierungen in Stable & Testing

Neuigkeiten und Ankündigungen
Benutzeravatar
m.radtke
Beiträge: 607
Registriert: 10 Jun 2015, 12:19

opsi 4.0 & opsi 4.1 Aktualisierungen in Stable & Testing

Beitragvon m.radtke » 28 Jun 2018, 13:39

Sehr geehrte opsi Anwender/innen,

mit dem heutigen Tag veröffentlichen wir aktualisierte Pakete in Stable und Testing, sowohl opsi 4.0, als auch opsi 4.1.

opsi Pakete in Stable (4.0 & 4.1)
Windows:
    opsi-configed (4.0.7.7.6-8)

opsi Pakete in Testing (4.0 & 4.1)
Windows:
    opsi-configed (4.0.7.7.6-8 )
    opsi-clonezilla (4.1.0.0-1)
    windows Netboot Produkte (4.1.0.0-9)
    Windows 10 Upgrade (18.03-4)

Linux:
    l-opsi-server (4.1.1.7-1)
    ubuntu16-04 (4.1.0.0-3)
    ubuntu18-04 (4.1.0.0-3)
    l-debubuntu-upgrade (4.1.0.0-1)
    opsi-linux-client-agent (4.1.0.5-1)

opsi-local-image:
    opsi-local-image-windows (4.1.0.0-8)
    opsi-vhd-win10-x64 (4.1.0.0-9)

opsi Server Pakete in 4.0 Testing:
    opsi-atftpd (0.7.dfsg-9)
    opsi-linux-bootimage (20180621-1)
    python-opsi (4.0.7.67-1)

opsi Server Pakete in 4.1 Testing:
    opsi-linux-bootimage (20180621-1)
    python-opsi (4.1.1.40-1)
    opsipxeconfd (4.1.1.13-1)

Hinweis:Nach der Aktualisierung von python-opsi bietet es sich an ein

Code: Alles auswählen

opsi-setup --update-mysql

bzw.

Code: Alles auswählen

opsi-setup --update-file

je nach gewähltem Backend zu machen.

Changelogs:

Code: Alles auswählen

opsi-configed (4.0.7.7.6-8) stable; urgency=medium

  * typo in script variable name corrected

-- roeder <r.roeder@uib.de>  Wed, 07 June 2018 14:51:45 +0200

opsi-configed (4.0.7.7.6-7) stable; urgency=medium

  * if tlsv1 fallback is activated ignore cipher choice

-- roeder <r.roeder@uib.de>  Tue, 05 June 2018 14:51:45 +0200

opsi-configed (4.0.7.7.6-3) stable; urgency=medium

* new packaging: included bundled oracle jre version 8.x (longterm, 32 bit) and 10.x (has high dpi support)
* can be installed with opsi java package or with bundled java runtime

-- roeder <roeder@asusvivo01.uib.local> Tue, 29 May 2018 14:45:43 +0200

-- roeder <roeder@asusvivo01.uib.local> Tue, 29 May 2018 14:45:43 +0200

opsi-configed (4.0.7.7.6-1) stable; urgency=medium

* added a selection menu option

-- roeder <r.roeder@uib.de> Tue, 22 May 2018 14:51:45 +0200

opsi-configed (4.0.7.7.5-1) stable; urgency=medium

* added font sizing buttons and Ctrl-+, Ctrl-- in logpanes
* local saving and setting again of last selected shown log level

-- roeder <r.roeder@uib.de> Wed, 16 May 2018 16:16:00 +0200

opsi-configed (4.0.7.7.4-1) stable; urgency=medium

* UTF8 repaired for java version >= 9

-- roeder <r.roeder@uib.de> Fri, 20 Apr 2018 12:26:38 +0200

opsi-configed (4.0.7.7.3-1) stable; urgency=medium

* hardware table for all or selected clients (more than 1) with configuration of columns

-- roeder <roeder@uib.de> Fri, 13 Apr 2018 11:33:29 +0200

opsi-configed (4.0.7.7.2-1) experimental; urgency=medium

* new command line option for choosing a directory for keeping saved states
* excluding java.awt.IllegalComponentStateException from errors via UncaughtExceptionHandler according to https://bugs.openjdk.java.net/browse/JDK-8179665
* restart button in clientselection form in order to rebuild comboboxes after a data change
* trying to eliminate a hanging loading message frame

-- Rupert Roeder <r.roeder@uib.de> Wed, 07 Mar 2018 11:36:08 +0100

opsi-configed (4.0.7.7.1-1) experimental; urgency=medium

* trying to eliminate a further bad location exception

-- Rupert Roeder <r.roeder@uib.de> Thu, 06 Feb 2018 11:36:08 +0100

opsi-configed (4.0.7.7.0-1) experimental; urgency=medium

* multi-client hw overview

-- Rupert Roeder <r.roeder@uib.de> Mon, 05 Feb 2018 10:48:50 +0100

===================================

opsi-clonezilla (4.1.0.0-1) testing; urgency=low

  * imageName property has new value: auto; sets imagename to client FQDN

-- Mathias Radtke <m.radtke@uib.de> Fri, 22 Jun 2018 14:45:00 +0200

===================================

windows (4.1.0.0-9) stable; urgency=low

  * added command to block admin access during client-agent installation

-- Mathias Radtke <m.radtke@uib.de> Wed Jun 20 09:38:16 2018 +0200

===================================

windows10-upgrade (18.03-4) stable; urgency=low
  * added Property oobe Fixes #3561 telemetry-questions during oobe
-- bardo wolf <b.wolf@uib.de> Tue  12 Jun 2018

windows10-upgrade (18.03-3) stable; urgency=low
  * property temp_dir_for_edventstarter
  * added wimlib info
  * try to suspend Upgrade if no logged in user
-- bardo wolf <b.wolf@uib.de> Thu  07 Jun 2018

windows10-upgrade (18.03-2) stable; urgency=low

  * fix Restore shutdown warning time in ($RebootFlag$ = "4")

-- detlef oertel <d.oertel@uib.de> Thu  24 May 2018 15:00:00 +0200

windows10-upgrade (18.03-1) stable; urgency=low
-- bardo wolf <b.wolf@uib.de>   02 May 2018

===================================

l-opsi-server (4.1.1.7-1); stable; urgency=low

  * product now installs opsi 4.0 and 4.1 with importlib functionality, depending on selected repository address

 -- Mathias Radtke <m.radtke@uib.de> Thu, 24 May 2018 14:26:00 +0200

l-opsi-server (4.1.1.6-1); stable; urgency=low

  * Improve UCS 4.3 support.
  * Drop support for UCS 4.1.

 -- Niko Wenselowski <n.wenselowski@uib.de> Fri, 04 May 2018 15:19:00 +0200

l-opsi-server (4.1.1.5-1); stable; urgency=low

  * UCS: Added 4.3 support
  * Ubuntu: added 18.04 support

 -- Mathias Radtke <m.radtke@uib.de> Fri, 04 May 2018 08:16:00 +0200

l-opsi-server (4.1.1.4-1); stable; urgency=low

  * UCS: Do not install opsi-linux-support.

 -- Niko Wenselowski <n.wenselowski@uib.de> Thu, 23 Jan 2018 13:22:44 +0100

===================================

ubuntu16-04 (4.1.0.0-3) testing; urgency=low

  * corrected opsi-linux-client-agent installation

-- Mathias Radtke <m.radtke@uib.de> Mon Jun 25 09:45:00 +0200

ubuntu16-04 (4.1.0.0-2) testing; urgency=low

  * corrected proxy behaviour

ubuntu16-04 (4.1.0.0-1) testing; urgency=low

  * only copying opsi-linux-client-agent when property is set true

-- Mathias Radtke <m.radtke@uib.de> Wed Jun 13 08:54:00 +0200

===================================

ubuntu18-04 (4.1.0.0-3) testing; urgency=low

  * corrected log writing behaviour
  * only copying opsi-linux-client-agent if property is set to true

-- Mathias Radtke <m.radtke@uib.de> Wed Jun 13 06:52:00 +0200

ubuntu18-04 (4.1.0.0-2) testing; urgency=low

  * setting global Variable HTTP(S)_PROXY when proxy is set

-- Mathias Radtke <m.radtke@uib.de> Wed May 23 09:45:00 +0200

===================================

l-debubuntu-upgrade (4.1.0.0-1) stable; urgency=low

  * new support for xenial_bionic
  * new property force_newest_ubuntu
  * code cleanup

-- detlef oertel <d.oertel@uib.de>  Tue, 26 Jun 2018 15:00:00 +0000

===================================

opsi-linux-client-agent (4.1.0.5-1) stable; urgency=medium

  * ubuntu 18.04 bionic support

-- d.oertel <d.oertel@uib.de> Wed, 27 Jun 2018 15:00:00 + 0100

===================================

opsi-local-image (4.1.0.0-8) stable; urgency=low

  * added command to block admin access during client-agent installation

-- Mathias Radtke <m.radtke@uib.de> Mon Jun 25 14:27:55 2018 +0200

===================================

opsi-vhd-win10-x64 (4.1.0.0-9) stable; urgency=low

  * postinst: added command to block admin access during client-agent installation

-- Mathias Radtke <m.radtke@uib.de> Mon, 25 Jun 2018 14:37:00 +0200

===================================

opsi-atftp (0.7.dfsg-9) experimental; urgency=medium

  * had to readd stdc89 standard usage

 -- Mathias Radtke <m.radtke@uib.de>  Tue, 05 Dec 2017 14:20:22 +0100

opsi-atftp (0.7.dfsg-8) experimental; urgency=medium

  * adapted rollover patch, provided by https://github.com/opsi-org/opsi-atftpd/pull/1

 -- Mathias Radtke <m.radtke@uib.de>  Tue, 05 Dec 2017 13:48:40 +0100
 
 ===================================
 
 opsi-linux-bootimage (20180621-1) experimental; urgency=medium

  * added smartpqi driver
  * modularized most SCSI drivers

 -- Mathias Radtke <m.radtke@uib.de>  Thu, 21 Jun 2018 09:48:31 +0200

opsi-linux-bootimage (20180618-1) experimental; urgency=medium

  * kernel 4.17.1
  * python-opsi 4.1.1.37-1

 -- Mathias Radtke <m.radtke@uib.de>  Wed, 13 Jun 2018 09:32:20 +0200

===================================

python-opsi (4.1.1.40-1) testing; urgency=medium

  * OpsiPXEConfd backend: improve performance by precollecting the
    required data that then can be used by opsipxeconfd.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Tue, 19 Jun 2018 14:38:25 +0200

python-opsi (4.1.1.39-1) stable; urgency=medium

  * SQL-based backends: Increased length of inventoryNumber of a host to 64
    characters.
  * OPSI.Backend.Backend.ModificationTrackingBackend: small speedup.
  * Various small internal refactorings.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Mon, 11 Jun 2018 11:44:15 +0200

python-opsi (4.1.1.38-1) stable; urgency=medium

  * Based on python-opsi 4.0.7.66.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Thu, 07 Jun 2018 22:35:19 +0200

===================================

opsipxeconfd (4.1.1.13-1) testing; urgency=medium

  * Fix problem accessing product element.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Sat, 23 Jun 2018 15:49:43 +0200

opsipxeconfd (4.1.1.12-1) testing; urgency=medium

  * Make it possible to hand over the path to a cache file when updating a
    client. Data will be read from the cache file and only if the required
    data isn't there data will be read from the backend.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Tue, 19 Jun 2018 13:22:43 +0200

===================================

python-opsi (4.0.7.67-1) stable; urgency=medium

  * OpsiBackup: File backend: improve handling of hostkeys file.
    Most noticable the restore will restore the file to the path
    configured in the backup.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Mon, 11 Jun 2018 09:51:42 +0200

python-opsi (4.0.7.66-1) stable; urgency=medium

  * MySQL-Backend: Improve handling of very large changelogs containing
    unicode characters.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Thu, 07 Jun 2018 22:07:32 +0200

Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.