opsi 4.0 & opsi 4.1: Updates in stable & testing, support for Ubuntu 18.04

Benutzeravatar
n.wenselowski
Beiträge: 2772
Registriert: 04 Apr 2013, 12:15

opsi 4.0 & opsi 4.1: Updates in stable & testing, support for Ubuntu 18.04

Beitragvon n.wenselowski » 06 Jun 2018, 14:53

Dear opsi users,

updates have been released for opsi 4.0 and opsi 4.1 in stable and testing.

Available for opsi 4.0 and 4.1 in stable:
Windows localboot packages:
  • opsi-winst 4.12.0.21
  • opsi-client-agent 4.1.0.0-8
  • windows10-upgrade 18.03-2

Linux localboot packages:
  • opsi-linux-client-agent 4.1.0.4-1

opsi-local-image / opsi-vhd:
  • opsi-vhd-win10-x64 4.1.0.0-8


Available for opsi 4.0 and 4.1 in testing:
Localboot packages:
  • opsi-configed 4.0.7.7.6-7
  • opsi-logviewer 3.1-7


For opsi 4.1 available in testing:
Server packages:
  • opsi-linux-bootimage 20180314-5
  • opsipxeconfd 4.1.1.11-1
  • python-opsi 4.1.1.37-1


Für opsi 4.0 ist in Testing verfügbar:
Server packages:
  • python-opsi 4.0.7.65-1


opsi 4.1 supports Ubuntu 18.04 for opsi-Server in testing. Feedback is welcome!

To add the testing repositories to your Ubuntu 18.04 machine use the following command:

Code: Alles auswählen

echo "deb http://download.opensuse.org/repositories/home:/uibmz:/opsi:/4.1:/testing/xUbuntu_18.04/ /" > /etc/apt/sources.list.d/opsi.list


After that you need to add the repository key:

Code: Alles auswählen

wget -nv https://download.opensuse.org/repositories/home:uibmz:opsi:4.1:testing/xUbuntu_18.04/Release.key -O Release.key
apt-key add - < Release.key


For further installation advice please refer to the Getting Started at https://download.uib.de/opsi4.1/stable/ ... n-base-deb


With kind regards

Niko Wenselowski


PS: Changelogs:

--------------------------------

opsi-configed (4.0.7.7.6-7) stable; urgency=medium

* if tlsv1 fallback is activated ignore cipher choice

-- roeder <r.roeder@uib.de> Tue, 05 June 2018 14:51:45 +0200

opsi-configed (4.0.7.7.6-6) stable; urgency=medium

* locating desktop link in folder opsi.org

* install 64 Bit jre on 64 Bit systems


-- roeder <r.roeder@uib.de> Mon, 04 June 2018 14:51:45 +0200

--------------------------------

opsi-logviewer (3.1-7) STABLE; urgency=medium

* bundling java 8 and 10

* locating desktop link in folder opsi.org

* removed dependency, instead installation by opsiservicerequest
* logging in opsi default log directories

-- r.roeder <r.roeder@uib.de> Mon, 04 June 2018 14:51:45 +0200

opsi-logviewer (3.0-0) STABLE; urgency=medium

* options for font sizing

-- r.roeder <r.roeder@uib.de> Mon, 16 Apr 12:00:00 + 0100

--------------------------------

opsi-linux-bootimage (20180314-5) experimental; urgency=medium

* debian/postinst: Correct fix for link correction.
* rpm postinst: Implement linking without directory change.

-- Niko Wenselowski <n.wenselowski@uib.de> Tue, 08 May 2018 16:28:10 +0200

opsi-linux-bootimage (20180314-4) experimental; urgency=medium

* debian/postinst: Correct wrong, absolute link to default.

-- Niko Wenselowski <n.wenselowski@uib.de> Tue, 08 May 2018 15:53:25 +0200

opsi-linux-bootimage (20180314-3) experimental; urgency=medium

* debian/postinst: corrected syntax error

-- Mathias Radtke <m.radtke@uib.de> Thu, 03 May 2018 07:30:07 +0200

opsi-linux-bootimage (20180314-2) experimental; urgency=medium

* corrected handling on UCS systems

-- Mathias Radtke <m.radtke@uib.de> Wed, 02 May 2018 11:06:41 +0200

opsi-linux-bootimage (20180314-1) experimental; urgency=medium

* kernel 4.15.9
* updated python-opsi

-- Mathias Radtke <m.radtke@uib.de> Wed, 14 Mar 2018 09:24:22 +0100

opsi-linux-bootimage (20180309-1) experimental; urgency=medium

* spec: corrected syntax error

-- Mathias Radtke <m.radtke@uib.de> Fri, 09 Mar 2018 11:17:44 +0100

opsi-linux-bootimage (20180306-1) experimental; urgency=medium

* spec file: correctly patching install-elilo-x* template file for UEFI
* opsi.init: waiting 60 seconds max on non existing link

-- Mathias Radtke <m.radtke@uib.de> Tue, 06 Mar 2018 11:25:42 +0100

--------------------------------

opsi-winst/opsi-script (4.12.0.21) stable; urgency=low

* osconf: default for debuglib = true
* osparser: doAktionen: additional log for indefFunc3
* osparser: doAktionen: inc/dec indefFunc3 only if keyword is at begining of line

-- Detlef Oertel <d.oertel@uib.de> Thu, 17 May 2018:15:00:00 +0200

--------------------------------

opsi-client-agent (4.1.0.0-8) stable; urgency=low

* upgrade to opsi-winst 4.12.0.21

-- Detlef Oertel <d.oertel@uib.de> Wed, 23 May 2018:15:00:00 +0200

--------------------------------

windows10-upgrade (18.03-2) stable; urgency=low

* fix Restore shutdown warning time in ($RebootFlag$ = "4")

-- detlef oertel <d.oertel@uib.de> Thu 24 May 2018 15:00:00 +0200

windows10-upgrade (18.03-1) stable; urgency=low
-- bardo wolf <b.wolf@uib.de> 02 May 2018

--------------------------------

opsi-vhd-win10-x64:
windows (4.1.0.0-8) stable; urgency=low

* //nt6.opsiscript: if uefi remove opsiwinpe bootentry
* nt6.py: canged property: debug_cmd_inpe to winpe_debug_cmd_exe
* nt6.py: vhdmode: fix use of windowspartitionsize

-- Detlef Oertel <d.oertel@uib.de> Wed, 09 May 2018:15:00:00 +0200

windows (4.1.0.0-7) stable; urgency=low

* nt6.opsiscript: do not stop if network drive is ready even if there is no opsiservice
* nt6.opsiscript: switch setup call from shellCall to processCall
* nt6.py: addtional property: winpe_debug_cmd_exe
* nt6.opsiscript copy opsi-script log to winpe-partition (c:)

-- Detlef Oertel <d.oertel@uib.de> Wed, 09 May 2018:15:00:00 +0200

windows (4.1.0.0-6) stable; urgency=low

* postinst: 99_cleanup: 64 bit switch fix: viewtopic.php?f=6&t=10016
* nt6.opsiscript: get and log winPE version from registry ; fixes #3403
* nt6.opsiscript: stopinpe on errors

-- Detlef Oertel <d.oertel@uib.de> Fri, 16 Mar 2018:15:00:00 +0200

--------------------------------

opsi-linux-client-agent (4.1.0.4-1) stable; urgency=medium

* opsi-script 4.12.0.21

-- d.oertel <d.oertel@uib.de> Mon, 28 May 2018 15:00:00 + 0100
Kein Support per DM!
_________________________
opsi support - uib gmbh
For productive opsi installations we recommend support contracts.