Hallo,
bei uns hat sowohl das neue Setzen des pcpatch-Passworts als auch die Änderungen in der smb.conf keine Besserung gebracht.
Viele Grüße
Andreas
[Gelöst] Das angegebene Netzwerkkennwort ist falsch
Re: [Gelöst] Das angegebene Netzwerkkennwort ist falsch
Hallo,
ich habe jetzt die logs auf einem Client durchgeschaut. Dabei ist mir aufgefallen, dass seit dem letzten Update versucht wird, das Netzlaufwerk mit dem Nutzer "LOCALDOMAIN\pcpatch" zu verbinden. Bisher wurde laut logs "pcpatch" verwendet. Den Nutzer "LOCALDOMAIN\pcpatch" gibt es aber in unserer Domain nicht, sondern nur den lokalen Nutzer pcpatch auf dem OPSI-Server. Könnte das das Problem sein? Es würde zumindest den Anmeldefehler erklären.
Viele Grüße
Andreas
bisher in opsiclientd.log auf den Clients
seit dem Update:
ich habe jetzt die logs auf einem Client durchgeschaut. Dabei ist mir aufgefallen, dass seit dem letzten Update versucht wird, das Netzlaufwerk mit dem Nutzer "LOCALDOMAIN\pcpatch" zu verbinden. Bisher wurde laut logs "pcpatch" verwendet. Den Nutzer "LOCALDOMAIN\pcpatch" gibt es aber in unserer Domain nicht, sondern nur den lokalen Nutzer pcpatch auf dem OPSI-Server. Könnte das das Problem sein? Es würde zumindest den Anmeldefehler erklären.
Viele Grüße
Andreas
bisher in opsiclientd.log auf den Clients
Code: Alles auswählen
[6] [2021-08-09 11:12:05.271] [action_processor_starter.exe ] Impersonating network account 'pcpatch' (actionprocessorstarter.py:92)
[5] [2021-08-09 11:12:05.275] [action_processor_starter.exe ] Mounting depot share smb://opsiserver/opsi_depot (actionprocessorstarter.py:97)
[6] [2021-08-09 11:12:05.276] [action_processor_starter.exe ] JSONRPC request to https://127.0.0.1:4441/opsiclientd: ip_version=4, id=2, method=setStatusMessage, Content-Type=application/json, Content-Encoding= (jsonrpc.py:345)
[6] [2021-08-09 11:12:05.278] [control server ] Worker <opsiclientd.ControlServer.WorkerOpsiclientdJsonRpc object at 0x05E80EF0> started processing (Worker.py:227)
[6] [2021-08-09 11:12:05.279] [control server ] Reusing session for client '127.0.0.1', application 'opsi-jsonrpc-client/4.2.0.179' (Worker.py:360)
[5] [2021-08-09 11:12:05.282] [ ] -----> Executing: setStatusMessage('1', 'Mounting depot share smb://opsiserver/opsi_depot') (JsonRpc.py:109)
[6] [2021-08-09 11:12:05.285] [ ] Using session id of user 'ahauffe': 1 (EventProcessing.py:157)
[5] [2021-08-09 11:12:05.286] [ ] rpc setStatusMessage: Setting status message to 'Mounting depot share smb://opsiserver/opsi_depot' (ControlServer.py:942)
[6] [2021-08-09 11:12:05.286] [ ] Got result for setStatusMessage (JsonRpc.py:117)
[6] [2021-08-09 11:12:05.288] [action_processor_starter.exe ] Got response status=200, Content-Type=application/json; charset=utf-8, Content-Encoding=gzip (jsonrpc.py:352)
[5] [2021-08-09 11:12:05.290] [action_processor_starter.exe ] Mounting '\\opsiserver\opsi_depot' to 'p:' (Windows.py:820)
[5] [2021-08-09 11:12:05.315] [action_processor_starter.exe ] Starting action processor (actionprocessorstarter.py:106)
Code: Alles auswählen
[6] [2021-08-12 08:51:48.163] [action_processor_starter.exe ] Impersonating network account 'LOCALDOMAIN\pcpatch' (actionprocessorstarter.py:92)
[5] [2021-08-12 08:51:48.172] [action_processor_starter.exe ] Mounting depot share smb://opsiserver/opsi_depot (actionprocessorstarter.py:97)
[6] [2021-08-12 08:51:48.173] [action_processor_starter.exe ] JSONRPC request to https://127.0.0.1:4441/opsiclientd: ip_version=4, id=2, method=setStatusMessage, Content-Type=application/json, Content-Encoding= (jsonrpc.py:345)
[6] [2021-08-12 08:51:48.175] [control server ] Worker <opsiclientd.ControlServer.WorkerOpsiclientdJsonRpc object at 0x05CBDE10> started processing (Worker.py:227)
[6] [2021-08-12 08:51:48.175] [control server ] Reusing session for client '127.0.0.1', application 'opsi-jsonrpc-client/4.2.0.179' (Worker.py:360)
[5] [2021-08-12 08:51:48.179] [ ] -----> Executing: setStatusMessage('1', 'Mounting depot share smb://opsiserver/opsi_depot') (JsonRpc.py:109)
[6] [2021-08-12 08:51:48.181] [ ] Using session id of user 'ahauffe': 1 (EventProcessing.py:157)
[5] [2021-08-12 08:51:48.181] [ ] rpc setStatusMessage: Setting status message to 'Mounting depot share smb://opsiserver/opsi_depot' (ControlServer.py:942)
[6] [2021-08-12 08:51:48.181] [ ] Got result for setStatusMessage (JsonRpc.py:117)
[6] [2021-08-12 08:51:48.183] [action_processor_starter.exe ] Got response status=200, Content-Type=application/json; charset=utf-8, Content-Encoding=gzip (jsonrpc.py:352)
[5] [2021-08-12 08:51:48.185] [action_processor_starter.exe ] Mounting '\\opsiserver\opsi_depot' to 'p:' (Windows.py:820)
[3] [2021-08-12 08:51:49.396] [action_processor_starter.exe ] Failed to mount '\\opsiserver\opsi_depot': (1326, 'WNetAddConnection2', 'Der Benutzername oder das Kennwort ist falsch.') (Windows.py:833)
[3] [2021-08-12 08:51:49.396] [action_processor_starter.exe ] Failed to mount '\\opsiserver\opsi_depot': (1326, 'WNetAddConnection2', 'Der Benutzername oder das Kennwort ist falsch.') (actionprocessorstarter.py:117)
Traceback (most recent call last):
File "OPSI\System\Windows.py", line 829, in mount
pywintypes.error: (1326, 'WNetAddConnection2', 'Der Benutzername oder das Kennwort ist falsch.')
The above exception was the direct cause of the following exception:
Traceback (most recent call last):
File "opsiclientd\actionprocessorstarter.py", line 103, in main
File "OPSI\System\Windows.py", line 834, in mount
RuntimeError: Failed to mount '\\opsiserver\opsi_depot': (1326, 'WNetAddConnection2', 'Der Benutzername oder das Kennwort ist falsch.')Re: [Gelöst] Das angegebene Netzwerkkennwort ist falsch
Hallo,
das war bei mir tatsächlich das Problem. Irgendwie wurde beim Benutzernamen die lokale Domain hinzugefügt. Ich habe im opsi-configed bei den Server-Konfiguration -> Host-Parametern -> clientconfig -> clientconfig.depot.user den Nutzernamen wieder auf den lokalen Nutzer gesetzt und alles geht wird.
Viele Grüße
Andreas
das war bei mir tatsächlich das Problem. Irgendwie wurde beim Benutzernamen die lokale Domain hinzugefügt. Ich habe im opsi-configed bei den Server-Konfiguration -> Host-Parametern -> clientconfig -> clientconfig.depot.user den Nutzernamen wieder auf den lokalen Nutzer gesetzt und alles geht wird.
Viele Grüße
Andreas
Re: [Gelöst] Das angegebene Netzwerkkennwort ist falsch
Hello,
ich möchte zu dieser Thematik folgende Dinge ergänzen, die trivial und/oder logisch erscheinen mögen, die ich aber tatsächlich bei der Fehlersuche bei mir zuerst übersehen bzw. vergessen habe und die auch nirgends in den etlichen Threads zu diesem Thema erwähnt werden:
Gruß
kinzi
ich möchte zu dieser Thematik folgende Dinge ergänzen, die trivial und/oder logisch erscheinen mögen, die ich aber tatsächlich bei der Fehlersuche bei mir zuerst übersehen bzw. vergessen habe und die auch nirgends in den etlichen Threads zu diesem Thema erwähnt werden:
- Das Setzen des Passwortes für das Depot mit "opsiconfd setup --set-depot-user-password" ist nur die halbe Miete. Man muss natürlich auch dafür sorgen, dass der User "pcpatch" im System tatsächlich dieses Passwort gesetzt hat. GGf. wäre also ein "smbpasswd pcpatch" nachzuschießen, bzw. wäre es vielleicht eine Überlegung, das gleich beim ersten Kommando autoamtisch mit erledigen zu lassen (UIB?). Bei einem AD-verwalteten pcpatch-User muss das Passwort natürlich im AD stimmen.
- Das Passwort muss entgegen den Hinweisen, die hier im Forum zu lesen sind, in einer Multi-Depot-Umgebung nicht auf allen Depots gleich sein, man kann durchaus pro Depotserver ein eigenes vergeben, so lange der lokale pcpacth-User das gleiche hat. (Bei einem AD-verwalteten pcpatch-User geht das natürlich nicht.)
Gruß
kinzi