Updates für 4.2 stable und testing

Neuigkeiten und Ankündigungen
Antworten
Benutzeravatar
fkalweit
uib-Team
Beiträge: 142
Registriert: 23 Okt 2020, 16:14

Updates für 4.2 stable und testing

Beitrag von fkalweit »

Sehr geehrte opsi-Anwenderinnen und -Anwender,


mit dem heutigen Release veröffentlichen wir eine Reihe von opsi Paketen in stable und testing.

Mit dem heute veröffentlichten opsi-linux-bootimage verwendet wir Ubuntu 22-04 als Basis und Kernel 6.0+. Dieser Kernel verwendet nicht mehr das efivars Kernel Modul. Wir haben in den Netboot Paketen dieses Modul genutzt um zu prüfen ob wir uns im UEFI Modus befinden. Diese Prüfung wird mit alten Netboot Paketen fehlschlagen. Wir empfehlen daher dringlichst die Windows, Linux und opsi-local-image Netboot Pakete auf den aktuellen opsi 4.2 stable Stand zu aktualisieren.


stable

Linux Localboot

- l-opsi-server (4.2.0.8-4)



Server:
- opsiconfd (4.2.0.296)
- opsi-utils (4.2.0.192-1)
- opsipxeconfd (4.2.0.32-1)
- opsi-linux-bootimage (20221128-2)
- opsi-server (4.2.0.72)



testing:

Linux Localboot
- opsi-setup-detector (4.2.1.11-1)
- opsi-script (4.12.7.2-3)


Mac:

- opsi-setup-detector (4.2.1.11-1)
- opsi-script (4.12.7.2-3)


Windows Localboot

- opsi-setup-detector (4.2.1.11-1)
- opsi-script (4.12.7.2-3)
- opsi-winst (4.12.7.2-3)


opsi-local-image:

- opsi-vhd-control (4.2.0.4-1)

Server:
- opsi-script (4.12.7.2-3)



Mit freundlichen Grüßen
Fabian Kalweit

Changelogs:

Code: Alles auswählen

----------------------

opsi-vhd-control (4.2.0.4-1) stable; urgency=low

  * uib_bootutils : new: hidePartition2, noAutomountPartition
  * setup.opsiscript: fixes for MBR BIOS
  * fix fouble declaration of $list§
    
-- detlef oertel <d.oertel@uib.de>  Tue, 29 Nov 2022 15:00:00 +0000
-------------------------------------
opsi-setup-detector (4.2.1.11-1) stable; urgency=low

   * template fixes for 'with user': using new msi del style
   * osdcreate: createClientFiles: with user:
     support msi variant for del 

-- Detlef Oertel <d.oertel@uib.de>  Mon,  05 Dec 2022 : 15:00:00 +0200

opsi-setup-detector (4.2.1.10-1) stable; urgency=low

   * osparserhelper:
      function opsiquotestr(s1, s2: string): string;
      // returns s1 quoted with s2 (if it is quoted right now, nothing will be changed)
      // s2 may be two chars long. Then the first char is the start mark
      // and the second char is the end mark
      // used by opsiquotelist

      procedure opsiquotelist(var list1 : TStringlist; s2: string);
      // returns list1 with every element quoted with s2 (if it is quoted right now, nothing will be changed)
      // s2 may be two chars long. Then the first char is the start mark
      // and the second char is the end mark

   * osdcreate: createopsifiles: use opsiquotelist before stringListToJsonArray
     because quoting is removed from stringListToJsonArray

-- Detlef Oertel <d.oertel@uib.de>  Fri,  25 Nov 2022 : 15:00:00 +0200


----------------------

opsi-linux-bootimage (20221128-2) testing; urgency=low

 * added qede network driver

 -- Mathias Radtke <m.radtke@uib.de> Mon, Nov 28 2022 15:15:00 +0100

opsi-linux-bootimage (20221128-1) testing; urgency=low

 * fixed error in webDAV file transfer
 * logging python-opsi version

 -- Jan Schneider <j.schneider@uib.de> Mon, Nov 28 2022 09:46:00 +0100

opsi-linux-bootimage (20221109-1) testing; urgency=low

  * kernel 6.0.6
  * ubuntu 22-04 base

 -- Mathias Radtke <m.radtke@uib.de> Wed, Nov 09 2022 09:55:00 +0100

opsi-linux-bootimage (20221027-1) testing; urgency=low

  * kernel 6.0.5

 -- Mathias Radtke <m.radtke@uib.de> Thu, Oct 27 2022 24:23:00 +0200

opsi-linux-bootimage (20221026-1) testing; urgency=low

  * added host package
  * kernel 6.0.3
  * changed uefi mode detection
  * update poetry

 -- Mathias Radtke <m.radtke@uib.de> Wed, Oct 26 2022 11:24:00 +0200

----------------------

l-opsi-server (4.2.0.8-4); testing; urgency=low

  * corrected LEAP directory where packages are downloaded

 -- Thomas Trapp <t.trapp@uib.de> Mon, 28 Nov 2022 10:40:00 +0100

l-opsi-server (4.2.0.8-3); testing; urgency=low

  * added new property: grafana_online_repository

 -- Mathias Radtke <m.radtke@uib.de> Tue, 08 Nov 2022 11:36:00 +0100


----------------------

opsiconfd (4.2.0.296-1) stable; urgency=medium

  * Improvement:  add check_opsi_licenses
  * Improvement:  Update python packages
  * Improvement:  New file permissions for opsi CA key

 -- uib GmbH <info@uib.de>  Mon, 28 Nov 2022 15:51:52 +0000

opsiconfd (4.2.0.295-1) stable; urgency=medium

  * Improvement:  server health check
  * Improvement:  config allow host key only auth
  * Improvement:  add server health check

 -- uib GmbH <info@uib.de>  Fri, 25 Nov 2022 12:20:50 +0000

opsiconfd (4.2.0.294-1) stable; urgency=medium

  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Fri, 11 Nov 2022 13:32:41 +0100

opsiconfd (4.2.0.293-1) stable; urgency=medium

  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Thu, 03 Nov 2022 11:33:48 +0100

opsiconfd (4.2.0.292-1) stable; urgency=medium

  * Bugfix:  python-opsi dependencies

 -- uib GmbH <info@uib.de>  Mon, 31 Oct 2022 11:44:44 +0000

opsiconfd (4.2.0.291-1) stable; urgency=medium

  * No public changes

 -- uib GmbH <info@uib.de>  Fri, 21 Oct 2022 13:50:56 +0000

----------------------

opsipxeconfd (4.2.0.32-1) stable; urgency=medium

  * Feature:  Add "remove" command

 -- uib GmbH <info@uib.de>  Mon, 28 Nov 2022 09:12:27 +0100

opsipxeconfd (4.2.0.31-1) stable; urgency=medium

  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Thu, 25 Aug 2022 09:14:55 +0200

----------------------

opsi-utils (4.2.0.192-1) stable; urgency=medium

  * Improvement:  updated opsi-cli to 4.2.0.1

 -- uib GmbH <info@uib.de>  Thu, 17 Nov 2022 14:25:52 +0100

opsi-utils (4.2.0.191-1) stable; urgency=medium

  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Fri, 11 Nov 2022 13:30:24 +0100

opsi-utils (4.2.0.190-1) stable; urgency=medium

  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Thu, 03 Nov 2022 11:34:15 +0100

opsi-utils (4.2.0.189-1) stable; urgency=medium

  * Bugfix:  python-opsi dependencies

 -- uib GmbH <info@uib.de>  Mon, 31 Oct 2022 11:32:37 +0000

opsi-utils (4.2.0.188-1) stable; urgency=medium

  * Improvement:  updated opsi-cli to 4.2.0.0

 -- uib GmbH <info@uib.de>  Fri, 28 Oct 2022 13:07:44 +0200

----------------------

opsi-script (4.12.7.2-3) urgency=medium
  New:  
    Parser [W/L/M]: 
    - Syntax Check: if testsyntax is set (via config or opsi-script-gui -> Button Test Syntax) 
      only the syntax of the script is tested. The script is not excecuted.
  Fixes: 
    Parser [W/L/M]: 
     - fix in OpsiServiceCall section
    xml2 [W]: 
     - attribute sequence
     - makeNodePathWithTextContent: 
       - additional parameter for strictmode
       - use strictmode parameter for node creation
    LinkFolder [W/L/M]: 
     - In DeleteShellLink use GetSpecialFolderPath instead of hard-coded path to handle all kinds of base folders

-- j.werner <j.werner@uib.de> 05 Dec 2022
Antworten