Updates für opsi 4.2 in testing und stable

Neuigkeiten und Ankündigungen
Antworten
Benutzeravatar
n.doerrer
uib-Team
Beiträge: 120
Registriert: 23 Okt 2020, 16:11

Updates für opsi 4.2 in testing und stable

Beitrag von n.doerrer »

Sehr geehrte opsi-Anwenderinnen und -Anwender,

mit diesem Release haben wir weitere Pakete für opsi 4.2 in Testing und Stable veröffentlicht.
Wichtige Neuerungen bei diesem Release:

opsi-client-agent 4.2.0.37-1 und neuer beinhalten ein neues opsi-deploy-client-agent, welches nicht mehr auf die winexe angewiesen ist. Das Starten des Installationsprozesses auf dem Ziel-Client wird durch einen Scheduled Task durchgeführt, welcher über einen RPC-Aufruf and die Windows-API angelegt wird. Damit soll die Problematik fälschlich anschlagender Virenscanner (die häufig der winexesvc.exe misstrauen) umgangen werden.

In opsi-configed 4.2.15.1.2 sind einige Features dazugekommen, siehe viewtopic.php?t=13047

=====================================
Aktualisierte Pakete in Testing:
=====================================

Windows Localboot:

* opsi-client-agent 4.2.0.37-2

Linux Localboot:

* opsi-linux-client-agent 4.2.0.26-1

macOS Localboot:

* opsi-mac-client-agent 4.2.0.19-1

Sonstiges:

* opsi-quickinstall 4.2.0.7-21

=====================================
Aktualisierte Pakete in Stable:
=====================================

Windows Localboot:

* opsi-configed 4.2.15.1.3-1
* opsi-wim-capture 4.2.0.1-9

Linux Localboot:

* opsi-configed 4.2.15.1.3-1

Macos Localboot:

* opsi-configed 4.2.15.1.3-1

opsi-local-image Localboot:

* opsi-local-image-wim-capture 4.2.0.1-9

opsi-local-image Netboot:

* opsi-local-image-win11-x64 4.2.0.3-1
* opsi-local-image-win11-x64-capture 4.2.0.3-1

opsi Server:

* opsi-utils 4.2.0.182
* opsiconfd 4.2.0.282


Mit freundlichen Grüßen
Nils Dörrer


Changelogs:

Code: Alles auswählen

opsi-wim-capture / oli-wim-capture(4.2.0.1-9) stable; urgency=low

  * setup.opsiscript: check first for opsi 4.2 opsiclientd and thant for opsiclientd <= 4.1

-- detlef oertel <d.oertel@uib.de>  Tue, 12 Jul 2022 15:00:00 +0000

----------

windows (4.2.0.3-1) testing; urgency=low

  * added fixes for broken mac passthrough implementations

 -- detlef oertel <d.oertel@uib.de> Tue, May 17 09:30:00 2022 +0200

----------

opsi-mac-client-agent (4.2.0.19-1) stable; urgency=low

  * Updated opsiclientd to 4.2.0.124 (using alternatives for deprecated methods)
  * Updated opsi-script to 4.12.5.5
  * Updated opsi-deploy-client-agent to 4.2.0.22 (removed deprecated options, implementation working without winexe)
  * Updated oca-installation-helper to 4.2.0.21

-- Nils Doerrer <n.doerrer@uib.de> Thu, 15 Jul 2022 15:00:00 +0100

----------

opsi-linux-client-agent (4.2.0.26-1) stable; urgency=low

  * Updated opsiclientd to 4.2.0.124 (using alternatives for deprecated methods)
  * Updated opsi-script to 4.12.5.5
  * Updated opsi-deploy-client-agent to 4.2.0.22 (removed deprecated options, implementation working without winexe)
  * Updated oca-installation-helper to 4.2.0.21

 -- Nils Doerrer <n.doerrer@uib.de> Fri, 15 Jul 2022 14:00:00 +0100

----------

opsi-client-agent (4.2.0.37-2) stable; urgency=low

  * Fixed setup opsiscript for netboot-context
  * Updated opsiclientd to 4.2.0.125 (no relevant changes)

-- Nils Doerrer <n.doerrer@uib.de> Wed, 19 Jul 2022 09:00:00 +0100

opsi-client-agent (4.2.0.37-1) stable; urgency=low

  * Updated opsi-deploy-client-agent to 4.2.0.22 (removed deprecated options, implementation working without winexe)
  * Updated oca-installation-helper to 4.2.0.21
  * Improved cleanup from very old opsi-client-agent remains
  * Updated opsiclientd to 4.2.0.124 (using alternatives for deprecated methods)
  * Updated opsi-script to 4.12.5.5

-- Nils Doerrer <n.doerrer@uib.de> Wed, 13 Jul 2022 11:00:00 +0100

----------

opsi-configed (4.2.15.1.2) TESTING; urgency=medium

 * bugfix, NPE if no configState exists for client and the WAN config entry is edited
 
-- r.roeder <r.roeder@uib.de> Mon, 05 May 2022 14:10:40 +0100

opsi-configed (4.2.15.1.1) TESTING; urgency=medium

 * role configuring seems to be ready for production
 
-- r.roeder <r.roeder@uib.de> Thu, 05 May 2022 14:10:40 +0100

opsi-configed (4.2.14.1.1) EXPERIMENTAL; urgency=medium

 * released as experimental from branch command-with-option-selection
 
-- r.roeder <r.roeder@uib.de> Wed, 20 Apr 2022 12:10:40 +0100

opsi-configed (4.2.13.4.1)  TESTING; urgency=medium

 * merging with branch for exporting to CSV restructured
 
-- r.roeder <r.roeder@uib.de> Wed, 23 Mar 2022 12:10:40 +0100

opsi-configed (4.2.13.3.2)  TESTING; urgency=medium

 * Frendh localizations of new text
 * replace some Strings by the defined constants
 
-- r.roeder <r.roeder@uib.de> Wed, 16 Mar 2022 12:10:40 +0100


opsi-configed (4.2.13.3.1)  TESTING; urgency=medium

 * IP address editable
 
-- r.roeder <r.roeder@uib.de> Wed, 16 Mar 2022 12:10:40 +0100

opsi-configed (4.2.13.2.1)  TESTING; urgency=medium

 * init bug for host and product groups resolved
 * wrong for followConfiguredRole corrected
 
-- r.roeder <r.roeder@uib.de> Wed, 09 Mar 2022 12:10:40 +0100


opsi-configed (4.2.13.1.1)  TESTING; urgency=medium

 * the user roles seem now to work with role usage as well
 
-- r.roeder <r.roeder@uib.de> Mon, 07 Mar 2022 08:10:40 +0100

opsi-configed (4.2.12.2.5)  TESTING; urgency=medium

 * it seems to work that without activated user roles
 	behaviour can be ruled by configuring default
 			

opsi-configed (4.2.12.2.3-1)  TESTING; urgency=medium

 * commenting out the construction area of an additional product tab for the server


opsi-configed (4.2.12.2.1-1)  TESTING; urgency=medium 

 * patch for new start options for depley client agent includes
 * patch for header X-opsi-session-lifetime

-- r.roeder <r.roeder@uib.de> Mon, 17 Jan 2022 15:10:40 +0100


opsi-configed (4.2.12.1.2-1)  TESTING; urgency=medium 
 * user role prototypes implemented

-- r.roeder <r.roeder@uib.de> Fri, 14 Jan 2022 15:10:40 +0100

opsi-configed (4.2.11.4.4)  TESTING; urgency=medium
 * install by shutdown. handled in session configuration 

opsi-configed (4.2.11.4.2)  TESTING; urgency=medium
 * install by shutdown, handle in create client dialog with observing default value

opsi-configed (4.2.11.4.1)  TESTING; urgency=medium
 * install by shutdown config got correct id
 * global install by shutdown config used as default for clients 

opsi-configed (4.2.11.4)  TESTING; urgency=medium
 * create and use a config for search by sql

opsi-configed (4.2.11.3)  TESTING; urgency=medium
 * configs handling a little bit cleared 
 
opsi-configed (4.2.11.2)  TESTING; urgency=medium
 * install by shutdown config handling integrated

opsi-configed (4.2.11.1)  TESTING; urgency=medium
 * in deploy opsi client-agent dialog the current options for starting it are offered (Patch Nils)

opsi-configed (4.2.10.4)  TESTING; urgency=medium
 * repaired that the depot selection for opsi-package-manager -i was not included

opsi-configed (4.2.10.2)  TESTING; urgency=medium
 * starting to adapt to new opsi-clientagent
 * repairing client move dialog
 * repairing WakeOnLan dialog

opsi-configed (4.2.3.7)  TESTING; urgency=medium
 * reintegrating lz4 compression

opsi-configed (4.2.3.6)  TESTING; urgency=medium
 * export of swaudit-table, saving local target configuration

opsi-configed (4.2.3.5)  EXPERIMENTAL; urgency=medium
 * CSV export extended to SWaudit
 
opsi-configed (4.2.3.4)  EXPERIMENTAL; urgency=medium
 * repaired some minor errors
 
opsi-configed (4.2.3.2)  EXPERIMENTAL; urgency=medium
 * CSV export extended to non standard tables

opsi-configed (4.2.3.1)  EXPERIMENTAL; urgency=medium
 * added a synchronisation of locally saved data with backenddate for UEFI and WAN

opsi-configed (4.2.3.0)  EXPERIMENTAL; urgency=medium
 * merged with extended search via sql
 * dash display configurable
 * improved display of product dependencies table

opsi-configed (4.2.2.0)  EXPERIMENTAL; urgency=medium
 * CSV export in standard tables activated

opsi-configed (4.2.1.3.0)  EXPERIMENTAL; urgency=medium
 * including change in  4.1.9.9.2 in this branch: on specific wan client config setting set global configs only if not existing

opsi-configed (4.2.1.2.0)  EXPERIMENTAL; urgency=medium
 * warning and action options if user registration has vanished
 
opsi-configed (4.2.1.1.0)  EXPERIMENTAL; urgency=medium
 * defining a hierarchy of user roles
 * defining a set of dash configs
 
opsi-configed (4.2.0.1.2-1) EXPERIMENTAL; urgency=medium
 * hopefully avoiding a thread problem on start  

opsi-configed (4.2.0.1.1-2) EXPERIMENTAL; urgency=medium
 * removed experimental post-script  

opsi-configed (4.2.0.1.1-1) EXPERIMENTAL; urgency=medium
 * improvements for editing dates and notes

opsi-configed (4.2.0.1-1) EXPERIMENTAL; urgency=medium
 * notes for license contracts offer file links 

----------

 opsi-quickinstall (4.2.0.7-21) experimental; urgency=low
  * fix reading hostname from command line and checking it for valid fqdn
    (delete line break at end of hostname)
  * use generalized OpsiPackageDownloader instead of LOpsiServerDownloader
  * gui: set sudo as default in password query
  * gui: exit Opsi-QuickInstall in case of an unsupported distribution
    
-- Anja-Melanie Schmitz <a.schmitz@uib.de>  Wed,  13 Jul 2022 14:00


opsi-quickinstall (4.2.0.7-3) experimental; urgency=low
  * openSUSE 15.4 added as supported distribution
  * warning in case of invalid local dns hostname added
  * check of ip name and ip number added in nogui query
  * nogui query code revised
    
-- Anja-Melanie Schmitz <a.schmitz@uib.de>  Fri,  01 Jul 2022 11:00

----------

opsi-utils (4.2.0.182-1) stable; urgency=medium

  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Thu, 21 Jul 2022 22:31:32 +0200

opsi-utils (4.2.0.181-1) stable; urgency=medium

  * Improvement:  Update python-opsi (4.2.0.304 -> 4.2.0.305)
  * Improvement:  properly closing repository connection after upload to repository

 -- uib GmbH <info@uib.de>  Mon, 18 Jul 2022 19:35:40 +0200

opsi-utils (4.2.0.180-1) stable; urgency=medium

  * Improvement:  Update python packages
  * Bugfix:  Close process handle

 -- uib GmbH <info@uib.de>  Fri, 15 Jul 2022 20:52:53 +0200

opsi-utils (4.2.0.179-1) stable; urgency=medium

  * Improvement:  Update python-opsi (4.2.0.302 -> 4.2.0.303)

 -- uib GmbH <info@uib.de>  Fri, 15 Jul 2022 08:45:41 +0200

opsi-utils (4.2.0.178-1) stable; urgency=medium

  * Improvement:  Update python packages
  * Bugfix:  Close command handle

 -- uib GmbH <info@uib.de>  Thu, 14 Jul 2022 13:41:12 +0200

opsi-utils (4.2.0.177-1) stable; urgency=medium

  * Bugfix:  Fix opsi-package-manager warning

 -- uib GmbH <info@uib.de>  Wed, 13 Jul 2022 13:27:04 +0200

opsi-utils (4.2.0.176-1) stable; urgency=medium

  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Wed, 13 Jul 2022 11:56:13 +0200

opsi-utils (4.2.0.175-1) stable; urgency=medium

  * Improvement:  Update python packages
  * Improvement:  Check if smb.conf exists before samba config update
  * Improvement:  Update packages

 -- uib GmbH <info@uib.de>  Tue, 12 Jul 2022 18:58:49 +0200

opsi-utils (4.2.0.174-1) stable; urgency=medium

  * Improvement:  Remove dependency to lsb_release
  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Tue, 05 Jul 2022 11:57:29 +0200

opsi-utils (4.2.0.173-1) stable; urgency=medium

  * Feature:  Add --file-to-mysql
  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Mon, 27 Jun 2022 12:06:57 +0000

----------

opsiconfd (4.2.0.282-1) stable; urgency=medium

  * Improvement:  Allow access to /boot for hosts

 -- uib GmbH <info@uib.de>  Fri, 22 Jul 2022 13:17:27 +0200

opsiconfd (4.2.0.281-1) stable; urgency=medium

  * Improvement:  Update python packages
  * Bugfix:  Always ignore max sessions for depot servers

 -- uib GmbH <info@uib.de>  Thu, 21 Jul 2022 20:44:10 +0000

opsiconfd (4.2.0.280-1) stable; urgency=medium

  * Improvement:  Update python-opsi (4.2.0.301 -> 4.2.0.305)
  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Mon, 18 Jul 2022 17:41:22 +0000

opsiconfd (4.2.0.279-1) stable; urgency=medium

  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Thu, 14 Jul 2022 14:21:47 +0200

opsiconfd (4.2.0.278-1) stable; urgency=medium

  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Wed, 13 Jul 2022 09:59:28 +0000

opsiconfd (4.2.0.277-1) stable; urgency=medium

  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Tue, 12 Jul 2022 17:00:36 +0000

opsiconfd (4.2.0.276-1) stable; urgency=medium

  * Improvement:  Send WWW-Authenticate header but not on XMLHttpRequest

 -- uib GmbH <info@uib.de>  Thu, 07 Jul 2022 10:14:40 +0000

opsiconfd (4.2.0.275-1) stable; urgency=medium

  * Bugfix:  error in rest api with dict response

 -- uib GmbH <info@uib.de>  Wed, 06 Jul 2022 13:44:02 +0000

opsiconfd (4.2.0.274-1) stable; urgency=medium

  * No public changes

 -- uib GmbH <info@uib.de>  Wed, 06 Jul 2022 09:27:08 +0000

opsiconfd (4.2.0.273-1) stable; urgency=medium

  * Improvement:  Update python packages
  * Improvement:  Use /etc/os-release instead of lsb_release

 -- uib GmbH <info@uib.de>  Tue, 05 Jul 2022 10:01:11 +0000
Benutzeravatar
Beiper
Beiträge: 0
Registriert: 07 Feb 2022, 15:40

Re: Updates für opsi 4.2 in testing und stable

Beitrag von Beiper »

Hallo,

nach dem opsiconfd-Update auf 4.2.0.282 bekommen wir beim Aufruf
vom opsi-package-updater oder auch opsi-set-rights immer Warnungen
bezüglich 'invalid escape sequence".

Code: Alles auswählen

[4] [2022-08-09 09:07:22.948] [               ] Warning 'invalid escape sequence '\d'' in file '<string>', line 175   (logging.py:848)
[4] [2022-08-09 09:07:22.950] [               ] Warning 'invalid escape sequence '\%'' in file '<string>', line 796   (logging.py:848)
[4] [2022-08-09 09:07:22.951] [               ] Warning 'invalid escape sequence '\%'' in file '<string>', line 811   (logging.py:848)
[4] [2022-08-09 09:07:23.003] [               ] Warning 'invalid escape sequence '\d'' in file '<string>', line 175   (logging.py:848)
[4] [2022-08-09 09:07:23.005] [               ] Warning 'invalid escape sequence '\%'' in file '<string>', line 796   (logging.py:848)
[4] [2022-08-09 09:07:23.005] [               ] Warning 'invalid escape sequence '\%'' in file '<string>', line 811   (logging.py:848)
Was kann ich tun, um das zu beheben?
Gruß
Beiper
Benutzeravatar
n.doerrer
uib-Team
Beiträge: 120
Registriert: 23 Okt 2020, 16:11

Re: Updates für opsi 4.2 in testing und stable

Beitrag von n.doerrer »

Hallo und willkommen im Forum,

mit opsiconfd >=4.2.0.282 werden generell mehr Warnungen gelogt - auch zu potentiellen Problemen, die ihren Ursprung gar nicht im opsiconfd selbst haben.
In diesem Fall sind es Escape-Sequenzen in der opsihwaudit.conf, die nicht standardkonform sind. Ein fix ist im Paket opsi-server >=4.2.0.60 (in stable ist aktuell 4.2.0.69). Mit upgrade dieses Pakets sollte die Warnung weg sein.
Falls die Datei "/etc/opsi/hwaudit/opsihwaudit.conf" manuell anpasst wurde, wird sie nicht automatisch ausgetauscht. In dem Fall müssten die Änderungen dann manuell in die bestehende opsihwaudit.conf integriert werden. (https://github.com/opsi-org/opsi-server ... 4bd2bf1693)
Benutzeravatar
Beiper
Beiträge: 0
Registriert: 07 Feb 2022, 15:40

Re: Updates für opsi 4.2 in testing und stable

Beitrag von Beiper »

Danke für die Hilfe, es lag tatsächlich an der nicht aktualisierten hwaudit.conf.
Die Warnungen erscheinen nicht mehr. :)
Gruß
Beiper
Antworten