Actualisations pour opsi 4.2 dans stable et testing

Ce forum est dédié au nouveautés, événements autour du projet Opsi
Antworten
otto
Beiträge: 154
Registriert: 08 Aug 2017, 12:16

Actualisations pour opsi 4.2 dans stable et testing

Beitrag von otto »

Chers utilisateurs d'opsi,

nous publions des nouveaux paquets pour opsi 4.2 dans stable et testing. Les points plus essentiels dans cette version:

On peut désormais facilement créer et modifier des produit opsi-meta avec le nouveau opsi-setup-detector.



opsi-script 4.12.4.37 (Windows, Linux and MacOS) contient (parmi d'autres) des perfectionnements dans le Parser (p.ex. l'instruction ELSEIF est maintenant disponible, améliorations concernant syntax JSON et opsiservicecall) ainsi que des nouvelles fonctions (z.B. Handling des certificats SSL), améliorations en mode GUI interactif (opsi-logviewer sera lancé parmi le bouton "View Log", seulement Windows et Linux) et corrections. Veuillez considérer le changelog et le manue opsi-script pour trouver plus d'informations.

=====================================
Paquets actualisés dans Testing:
=====================================

Windows Localboot:

* opsi-client-agent 4.2.0.29-1
* opsi-setup-detector 4.2.0.10-2
* opsi-script 4.12.4.37-1
* opsi-script-test 4.12.4.37-1

Linux Localboot:

* opsi-linux-client-agent 4.2.0.21-1
* opsi-setup-detector 4.2.0.10-2
* opsi-script 4.12.4.37-1
* opsi-script-test 4.12.4.37-1

Macos Localboot:

* opsi-mac-client-agent 4.2.0.15-1
* opsi-setup-detector 4.2.0.10-2
* opsi-script 4.12.4.37-1
* opsi-script-test 4.12.4.37-1

opsi-local-image Localboot:

* opsi-vhd-control 4.2.0.0-1

Linux Netboot:

* sles12sp3/4/5 4.2.0.1-8

opsi-local-image Netboot:

* opsi-vhd-win11-x64 4.2.0.2-1

opsi serveur:

* opsi-utils 4.2.0.164
* opsiconfd 4.2.0.248

=====================================
Paquets actualisés dans Stable:
=====================================

opsi serveur:

* opsi-server 4.2.0.66
* opsi-utils 4.2.0.162

* opsi-quickinstall 4.2.0.6-3

Cordialement
Nils Dörrer


Changelogs:

Code: Alles auswählen

sles12sp3/4/5 (4.2.0.1-8) testing; urgency=low

  * added 01_lshw.sh postinst script

 -- Mathias Radtke <m.radtke@uib.de>Thu Mar 17 11:40:00 2022 +0200

----------

opsi-vhd-win11-x64 (4.2.0.2-1) testing; urgency=low

  * forked from opsi-vhd-win10-x64

 -- Mathias Radtke <m.radtke@uib.de> Mon Mar 28 11:00:00 2022 +0100

----------

opsi-setup-detector (4.2.0.10-2) stable; urgency=low

   * fix wrong case in setup script(linux webdav)

-- Detlef Oertel <d.oertel@uib.de>  Tue,  29 Mar 2022 : 15:00:00 +0200

opsi-setup-detector (4.2.0.10-1) stable; urgency=low

   * update innounp.exe to 0.50
   * meta-product dependency: allow required action
   * win setup / uninstall templ: no importlib "uib_lin_install.opsiscript"
   * win 32+64: #@MinimumSpace3*# is the sum of both minimum spaces

-- Detlef Oertel <d.oertel@uib.de>  Fri,  25 Mar 2022 : 15:00:00 +0200

opsi-setup-detector (4.2.0.9-1) stable; urgency=low

   * Modified templates
   * Optional connection to opsi web service
   * Possibility to choose dependency products via dropdown from opsi web service
   * Store connection data to service in configuration (pass encrypted)
   * Include the install/uinstall log fileles from installer to the opsi-script log
     on failed installations ; references: #4700
     Marker #@installErrorHandlingLines*# in templates
     installErrorHandlingLines.Add('includelog "%opsiLogDir%\"+$ProductId$+".install_log.txt" "50" "utf16le"');
   * fix edit productId field with arrow and backspace, fixes: #4698
   * fix edit propertyId always lowercase, fixes: #4699
   * checked is fixed: msi-Id with leading spaces, fixes: #4664
   * if no installer is detected new dialog to select well known installer type manually; fixes: #4701
   * new main task create meta product (contains dependencies, install nothing)
   * remove libraries: uib_macosinstalllib, uib_lin_install, uib_exitcode
   * requiredOpsiscriptVersion >= "4.12.4.23"

   * added ssl libraries for all plattforms
   * Linux: moved to /opt/opsi-setup-detector

-- Detlef Oertel <d.oertel@uib.de>  Fri,  25 Feb 2022 : 15:00:00 +0200

----------

opsi-vhd-control (4.2.0.0-1) stable; urgency=low

  * adapt to change from winst to opsiscript

-- detlef oertel <d.oertel@uib.de>  Fr, 25 Mar 2022 15:00:00 +0000

----------

opsi-script (4.12.4.37) stable; urgency=low

  * osparser: new global constant %opsiUsertmpDir%; implements #4496
  * osparser: allow json value syntax in params in opsiServiceCall:
    i.e. numeric/boolean values, arrays, objects and null without quotes; implements #4705
  * oscertificates: finalize function for linux /mac:
    function pemfileToSystemStore(filename: string): boolean;
    function removeCertFromSystemStore(labelstr: string): boolean;
    function listCertificatesFromSystemStore(): TStringList;
    function isCertInstalledInSystemStore(labelstr: string): boolean;
  * new function isCertInstalledInSystem(<label>): boolean; [WLM]
  * new function importCertToSystem(<filename>): noresult;  [WLM]
  * new function removeCertFromSystem(<label>): noresult;  [WLM]
  * new function listCertificatesFromSystem: stringlist;  [WLM]
  * new command ELSEIF <condition>  [WLM]
  * opsparser: implement elseif
  * opsparser: A more detailed description how the If / ELSE / ELSEIF / ENDIF parser works
  * interacticve GUI: Button "View Log" now shows the log in the opsi-logviewer [W/L]
  * killtask (fix): a process of another user can be killed if opsi-script is running as SYSTEM [W]
  * osnetworkcalculator: fixes at cidrToNetmask
  * osnetworkcalculator: new function netmaskToCidr(netmask: string): string;
  * new function cidrToNetmask(<string>): string;  [WLM]
  * new function netmaskToCidr(<string>): string;  [WLM]
  * osparser: new global constant %FQDN% for fqdn in network (not opsi service) context; implements #4554
  * osparser: fix occasionally access violation when using getReturnListFromSection/getOutStreamFromSection

-- d.oertel <d.oertel@uib.de> Tue, 01 Feb 2022 15:00

----------

opsi-quickinstall (4.2.0.6-3) experimental; urgency=low
  * RHEL8 added to supported distributions
  * openSUSE 15.1 removed from supported distributions (discontinued)
  * opsi-quickinstall version from now on synchronized with latest released l-opsi-server
  * default l-opsi-server of quickinstall from now on synchronized with latest released l-opsi-server
  * improved l-opsi-server installation process:
    1) Try downloading latest released l-opsi-server.
    2) If 1) worked then compare versions of downloaded and default l-opsi-server.
      2a) Try to install the newer l-opsi-server.
      2b) If 2a) failed then try to install the older l-opsi-server.
  * logging improved

-- Anja-Melanie Schmitz <a.schmitz@uib.de>  Tue,  15 Mar 2022 11:40

----------

opsi-script-test (4.12.4.37-1) stable; urgency=low

  * new property certificate_test
  * new if elseif test at Flag_winst_controls
  * networkcalc tests: test for netmaskToCidr / cidrToNetmask
  * opsiservicecall tests outsourced in subscript "opsiServiceCalls"
  * new subscript "opsiServiceCall_jsonSyntaxParams" added for json syntax in params of opsiservicecall
  * new standalone test "zip_unzip_file" for showing a progressbar while zipping/unzipping

-- detlef oertel <d.oertel@uib.de>  Mon,  07 Feb 2022 15:00:00 +0200

----------

opsi-client-agent (4.2.0.29-1) stable; urgency=low

  * Updated opsiclientd to 4.2.0.113
  * Updated opsi-notifier to 4.2.0.5

-- Jan Schneider <j.schneider@uib.de> Tue, 29 Mar 2022 11:07:00 +0100

opsi-client-agent (4.2.0.28-1) stable; urgency=low

  * Updated oca-installation-helper to 4.2.0.17 (new option --no-set-mac-address, fixed evaluation of files/custom/install.conf)
  * Changed installation to finalize reboot in case of systray installation
  * Changed uninstallation to not reboot as final action

-- Nils Doerrer <n.doerrer@uib.de> Tue, 22 Mar 2022 10:50:00 +0100

opsi-client-agent (4.2.0.27-1) stable; urgency=low

  * Updated opsiclientd to 4.2.0.112 (cleanup registry uninstall, fix shutdown warning repetition after standby)

-- Jan Schneider <j.schneider@uib.de> Mon, 21 Mar 2022 15:50:00 +0100

----------

opsi-linux-client-agent (4.2.0.21-1) testing; urgency=low

  * Updated opsiclientd to 4.2.0.113
  * Updated opsi-notifier to 4.2.0.5

-- Nils Doerrer <n.doerrer@uib.de> Wed, 30 Mar 2022 12:00:00 +0100

opsi-linux-client-agent (4.2.0.20-1) testing; urgency=low

  * Updated oca-installation-helper to 4.2.0.17 (new option --no-set-mac-address, fixed evaluation of files/custom/install.conf)
  * Updated opsiclientd to 4.2.0.112 (fix shutdown warning repetition after standby)
  * Updated opsi-deploy-client-agent to 4.2.0.19 (improved logging, reporting failure reasons --failed-clients-file)
  * Added check for too old glibc versions (<2.18 as for centos7, redhat7)

-- Nils Doerrer <n.doerrer@uib.de> Wed, 23 Mar 2022 18:00:00 +0100

----------

opsi-mac-client-agent (4.2.0.15-1) testing; urgency=low

  * Updated opsiclientd to 4.2.0.113
  * Updated opsi-notifier to 4.2.0.5

-- Nils Doerrer <n.doerrer@uib.de> Wed, 30 Mar 2022 12:00:00 +0100

opsi-mac-client-agent (4.2.0.14-1) testing; urgency=low

  * Updated oca-installation-helper to 4.2.0.17 (new option --no-set-mac-address, fixed evaluation of files/custom/install.conf)
  * Updated opsiclientd to 4.2.0.112 (fix shutdown warning repetition after standby)
  * Updated opsi-deploy-client-agent to 4.2.0.19 (improved logging, reporting failure reasons --failed-clients-file)

-- Nils Doerrer <n.doerrer@uib.de> Wed, 23 Mar 2022 18:00:00 +0100

----------

opsiconfd (4.2.0.248-1) stable; urgency=medium

  * Improvement:  Update python packages
  * Improvement:  Update cookie via websocket message
  * Improvement:  Rework admin interface log viewer
  * Improvement:  Improve layout, maximize tab
  * Feature:  Terminal resize

 -- uib GmbH <info@uib.de>  Mon, 28 Mar 2022 16:37:51 +0000

opsiconfd (4.2.0.247-1) stable; urgency=medium

  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Wed, 23 Mar 2022 14:21:04 +0100

----------

opsi-server (4.2.0.66-1) stable; urgency=medium

  * Bugfix:  ucs join script 4.4

 -- uib GmbH <info@uib.de>  Tue, 22 Mar 2022 08:32:45 +0100

opsi-server (4.2.0.65-1) stable; urgency=medium

  * Improvement:  ucs opsi adminpage open in new tab
  * Improvement:  Do not install obs repo key with opsi-server-expert

 -- uib GmbH <info@uib.de>  Fri, 18 Mar 2022 14:25:56 +0000

----------

opsi-utils (4.2.0.164-1) stable; urgency=medium

  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Wed, 29 Mar 2022 12:00:00 +0100

opsi-utils (4.2.0.163-1) stable; urgency=medium

  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Wed, 23 Mar 2022 14:16:18 +0100

opsi-utils (4.2.0.162-1) stable; urgency=medium

  * Improvement:  update python modules

 -- uib GmbH <info@uib.de>  Thu, 17 Mar 2022 16:41:42 +0100
[/quote]
Antworten