Actualisations pour 4.2 stable et testing

Ce forum est dédié au nouveautés, événements autour du projet Opsi
Antworten
otto
Beiträge: 154
Registriert: 08 Aug 2017, 12:16

Actualisations pour 4.2 stable et testing

Beitrag von otto »

Chers utilisateurs d'opsi,

nous publions des nouvelles versions de quelques paquets opsi dans stable et testing.

licences opsi

Nous sommes en train de changer le format du fichier licence opsi (/etc/opsi/modules) et dans ce contexte il y a quelques changements chez les vérifications des licences dans testing.
Des vieilles licences (fichiers modules) continuent à fonctionner.
Avec le nouveau processus de vérification les limites des licences sont controllées conformemant.
Cela implique que s'il y a pas assez de licences pour un certain module, ce module sera déactivé.
Évidemment il y a une certaine tolérance concernant le nombre des clients.
Avant que les paquets arrivent dans stable dans la prochaine version il faut vérifier s'il y a assez clients licenciés.

Dans ce cas il y a plusieurs possibilités:
- Acheter d'autres licences
- Enlever les clients qui ne sont pas utilisés
- Demander une libération temporaire pour vérifier s'il faut acquérir d'autres licences.

S'il y a des problèmes on aide volontairement.
Contactez-nous directement sous sales(at)uib.de.

Installation opsi-client-agent

Comme autre option pour l'installation initiale de l'opsi-client-agent sous windows il y a l'opsi-client-agent comme MSI.
Cela connaît les mêmes paramètres comme service_setup.cmd, oca-installation-helper.exe et l'installer et travaille de façon analogue.
Ce paquet se trouve sous https://download.uib.de/4.2/stable/misc ... -agent.msi


stable

windows localboot:
- opsi-script 4.12.4.36-2
- opsipackagebuilder_wlm 8.5.0-1
- opsi-winst 4.12.4.36-2
- opsi-client-agent 4.2.0.22-1


linux localboot:
- opsi-script 4.12.4.36-2
- opsipackagebuilder_wlm 8.5.0-1
- l-desktop 4.2.0.2-1
- opsi-linux-client-agent 4.2.0.16-1

macos localboot:
- opsi-script 4.12.4.36-2
- opsipackagebuilder_wlm 8.5.0-1
- opsi-mac-client-agent 4.2.0.10-1

Linux Netboot:
- debian (4.2.0.2-2)
- ubuntu (4.2.0.2-2)
- mint20-3 (4.2.01-4)

opsi-local-image netboot:
- opsi-local-image-NT6 (4.2.0.2-1)
- opsi-vhd-win10-x64 (4.2.0.2-1)
- opsi-local-image-restore 4.2.0.4-1

windows netboot:
- windows NT6 (4.2.0.2-1)

serveur:
- opsi-linux-bootimage 20220124-2
- opsi-directory-connector 47.7

manual:
- opsi-script-manual (4.12.4.35)

misc:
- opsi-client-agent.msi

testing:

Linux Netboot:
- debian9 (4.2.0.1-7)
- debian10 (4.2.0.1-7)
- debian11 (4.2.0.1-7)

serveur:
- opsipxeconfd 4.2.0.25
- opsi-utils 4.2.0.154
- opsiconfd 4.2.0.236
- opsi-directory-connector 48.0

Cordialement,
Fabian Kalweit

Changelogs

Code: Alles auswählen

###########################################

opsi-script (4.12.4.36-2) stable; urgency=low

  * library uib_lin_install: remove "--no-install-recommends" from debinstall

-- d.oertel <d.oertel@uib.de> Tue, 08 Feb 2022 15:00    

###########################################

opsi-local-image-restore (4.2.0.4-1) stable; urgency=low

  * opsisetuplib new:
     * removeFromUefiBootOrder(label)
     * removeFromUefiBootNext(label)
     * deleteUefiBootNext()
  * add removeFromUefiBootOrder('opsitempwinpe')
  * add removeFromUefiBootNext('opsitempwinpe')
  * if ntfs uefiFirstBootLabel = "Windows Boot Manager"
            setFirstUefiBoot(uefiFirstBootLabel)
-- detlef oertel <d.oertel@uib.de>  Fri, 29 Jan 2022 15:00:00 +0200

###########################################

opsipackagebuilder_wlm (8.5.0-1) stable; urgency=medium
  * opsiPackageBuilder-v8.5.0.exe (https://forum.opsi.org/viewtopic.php?p=55485#p55485 8.5.0 online)
-- b.wolf <b.wolf@uib.de> fri, 28 Jan 2022 15:00:00 +0200

###########################################

l-desktop 4.2.0.2-1 ; stable ; urgency=low

  * fixes for debian (general part)

 -- d.oertel <d.oertel@uib.de> Wed, 02 Feb 2022 15:00:00 + 0100

###########################################

opsi-client-agent (4.2.0.22-1) stable; urgency=low

  * Updated opsi-login-blocker to 4.2.0.2
  * Updated opsiclientd to 4.2.0.107 (improved logging output, possibility to skip firewall setup, updated packages)
  * Updated oca-installation-helper to 4.2.0.13 (fix for macos, new parameter --force-recreate-client)
  * Avoid duplicate permission setting if not neccessary.

-- Nils Doerrer <n.doerrer@uib.de> Tue, 08 Feb 2022 11:00:00 +0100

opsi-client-agent (4.2.0.21-2) stable; urgency=low

  * exit with error if permissions cant be set.

-- Nils Doerrer <n.doerrer@uib.de> Fri, 04 Feb 2022 09:00:00 +0100

opsi-client-agent (4.2.0.21-1) stable; urgency=low

  * Updated opsiclientd to 4.2.0.105
  * Updated opsi-deploy-client-agent to 4.2.0.17 (set timeouts, added parameter --install-timeout)
  * Updated oca-installation-helper to 4.2.0.12
  * On reinstallation via netboot, keep pending actionRequests (like always)

-- Nils Doerrer <n.doerrer@uib.de> Thu, 03 Feb 2022 15:00:00 +0100

###########################################

opsi-linux-client-agent (4.2.0.16-1) testing; urgency=low

  * Updated opsiclientd to 4.2.0.107 (improved logging output, possibility to skip firewall setup, updated packages)
  * Updated oca-installation-helper to 4.2.0.13 (fix for macos, new parameter --force-recreate-client)

-- Nils Doerrer <n.doerrer@uib.de> Wed, 09 Feb 2022 15:40:00 +0100

opsi-linux-client-agent (4.2.0.15-1) testing; urgency=low

  * Added check in service_setup.sh to stop with error on 32bit systems
  * Updated opsi-deploy-client-agent to 4.2.0.17
  * Updated opsiclientd to 4.2.0.105
  * Updated oca-isntallation-helper to 4.2.0.12
  * On reinstallation via netboot, keep pending actionRequests (like always)

-- Nils Doerrer <n.doerrer@uib.de> Mon, 07 Feb 2022 15:40:00 +0100

###########################################

opsi-mac-client-agent (4.2.0.10-1) stable; urgency=low

  * Added check in service_setup.sh to stop with error on 32bit systems
  * Updated opsiclientd to 4.2.0.107
  * Updated oca-installation-helper to 4.2.0.13
  * Updated opsi-deploy-client-agent to 4.2.0.17

-- Nils Doerrer <n.doerrer@uib.de> Wed, 09 Feb 2022 16:00:00 +0100

opsi-mac-client-agent (4.2.0.9-1) stable; urgency=low

  * Adjust to opsi-windows-client-agent
  * Updated opsiclientd to 4.2.0.104
  * Updated opsi-script to 4.12.4.35
  * Updated oca-isntallation-helper to 4.2.0.11

-- Jan Schneider <j.schneider@uib.de> Mon, 06 Jan 2022 14:40:00 +0100

opsi-mac-client-agent (4.2.0.8-1) testing; urgency=low

  * Update opsiclientd to 4.2.0.101
    - fix: notifier handling on gui_startup
    - fix: event cancellation denied in case of reboot during installation
  * Update opsi-script to 4.12.4.33
  * Update oca-installation-helper to 4.2.0.7
  * Update opsi-notifier to 4.2.0.3

-- Nils Doerrer <n.doerrer@uib.de> Wed, 15 Dec 2021 14:30:00 +0100

opsi-mac-client-agent (4.2.0.7-1) testing; urgency=low

  * updated opsiclientd 4.2.0.96 (reworked event-handling, minor fixes)
  * updated oca-installation-helper 4.2.0.5
  * updated opsi-script 4.12.4.31
  * updated opsi-deploy-client-agent 4.2.0.15 (isolated from opsicommon python module)

-- Nils Doerrer <n.doerrer@uib.de> Thu, 18 Nov 2021 17:30:00 +0100

###########################################

mint20-2 (4.2.0.1-4) testing; urgency=low

  * changed preseed/post installation command to adapt to other clientconfig.configserver.urls

 -- Mathias Radtke <m.radtke@uib.de> Tue Nov 16 15:34:48 2021 +0200

###########################################

debian9/10/11 (4.2.0.1-7) testing; urgency=low

  * updated desktop packages in property desktop_package
  * preseed: adding user to wheel

 -- Mathias Radtke <m.radtke@uib.de> Tue Feb 15 09:20:00 +0200

###########################################

windows (4.2.0.2-1) testing; urgency=low

  * product property installfiles

 -- Fabian Kalweit <f.kalweit@uib.de> Wed Dec 22 09:50:08 2021 +0200

windows (4.2.0.1-7) testing; urgency=low

  * corrected behaviour when using data_partition_preserve
  * modified unattend.xml to prevent device encryption on installation

 -- Mathias Radtke <m.radtke@uib.de> Wed Jan 12 13:39:37 2022 +0200

###########################################


debian (4.2.0.2-2) testing; urgency=low

  * calling update-grub after setting ifnames in /etf/default/grub

 -- Mathias Radtke <m.radtke@uib.de> Wed Jan 09:50:00 2022 +0200

###########################################

opsi-linux-bootimage (20220124-2) testing; urgency=low

  * run-master: fixed typo

 -- Mathias Radtke <m.radtke@uib.de> Mon, 24 Jan 2022 13:37:00 +0200

opsi-linux-bootimage (20220124-1) testing; urgency=low

  * run-master: corrected SecureBoot check when using backend_getLicensingInfo()

 -- Mathias Radtke <m.radtke@uib.de> Mon, 24 Jan 2022 07:56:00 +0200

opsi-linux-bootimage (20210117-2) testing; urgency=low

  * run-master: corrected behaviour when using backend_getLicensingInfo

 -- Mathias Radtke <m.radtke@uib.de> Mon, 17 Jan 2022 16:22:00 +0200

opsi-linux-bootimage (20220117-1) testing; urgency=low

  * run-master: using backend_getLicensingInfo for new modular licneses
  * kernel 5.15.15

 -- Mathias Radtke <m.radtke@uib.de> Mon, 17 Jan 2022 12:17:00 +0200

###########################################

opsiconfd (4.2.0.236-1) stable; urgency=medium

  * Feature:  Add terminal application
  * Improvement:  Log config on setup

 -- uib GmbH <info@uib.de>  Mon, 14 Feb 2022 15:56:44 +0100

opsiconfd (4.2.0.235-1) stable; urgency=medium

  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Tue, 08 Feb 2022 12:15:12 +0100

opsiconfd (4.2.0.234-1) stable; urgency=medium

  * Improvement:  Updated python packages
  * Improvement:  Show days until cert renewal in admin interface

 -- uib GmbH <info@uib.de>  Mon, 07 Feb 2022 13:13:14 +0100

###########################################

opsi-utils (4.2.0.154-1) stable; urgency=medium

  * Improvement:  Update python packages
  * Improvement:  Change defaults for --log-file and --log-level

 -- uib GmbH <info@uib.de>  Tue, 15 Feb 2022 19:12:19 +0100

opsi-utils (4.2.0.153-1) stable; urgency=medium

  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Mon, 07 Feb 2022 13:14:40 +0100

opsi-utils (4.2.0.152-1) stable; urgency=medium

  * Improvement:  Update python-opsi-common to 4.2.0.270
  * Improvement:  Set repository timeout to 24h
  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Thu, 03 Feb 2022 18:48:26 +0100

###########################################

opsipxeconfd (4.2.0.25-1) stable; urgency=medium

  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Thu, 17 Feb 2022 14:47:52 +0100

opsipxeconfd (4.2.0.24-1) stable; urgency=medium

  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Thu, 03 Feb 2022 13:20:04 +0100

###########################################

opsi-directory-connector (47.8-1) stable; urgency=medium

  * Improvement:  use new license check

 -- uib GmbH <info@uib.de>  Thu, 17 Feb 2022 13:24:16 +0000

opsi-directory-connector (47.7-1) stable; urgency=medium

  * Feature:  config delete_empty_groups

 -- uib GmbH <info@uib.de>  Tue, 25 Jan 2022 12:56:19 +0000

###########################################
Antworten