Win10, ubuntu18 und 20 lassen sich nicht installieren

Antworten
wKovacs
Beiträge: 91
Registriert: 14 Aug 2020, 12:29

Win10, ubuntu18 und 20 lassen sich nicht installieren

Beitrag von wKovacs »

Moin,

nach einem Update von opsi (4.2.0.283) und sämtlichen Pakten lassen sich weder Win10-x64 (4.2.02-2), ubuntu18-04 (4.2.0.1-8) und ubuntu20-04 (4.2.0.1-8) installieren.

Es wird erfolgreich via PXE gebootet doch können dann anscheinend die Setup-Dateien nicht übertragen werden.

Windows
Bild

Linux
Bild

Ich habe auch einmal einen Server komplett von null aufgesetzt. Mit selben Ergebnis.

Aktuell können wir daher keine Laptops installieren

VG
Benutzeravatar
m.radtke
uib-Team
Beiträge: 1231
Registriert: 10 Jun 2015, 12:19

Re: Win10, ubuntu18 und 20 lassen sich nicht installieren

Beitrag von m.radtke »

Moin,

grundsätzlich funktionieren die Installationen.

Zu windows: die Fehlermeldung kenne ich im Kontext wenn der Festplattentreiber nicht im WinPe ist

Zu Linux:
Ich gehe mal davon aus das du installation_method auf reboot gestellt hast. Grundsätzlich funktioniert auch das.

In beiden Fällen kannst du nochmals in Bootimage starten und die entsprechenden Partitionen Mounten und sehen was auf ihnen liegt. Die Daten sind vorhanden.
Nochmals zu Linux:
Im grun kannst du auch in der Auswahl 'e' drücken und schauen wie die Config aussieht bzw welche Dateien erwartet werden. In der grub shell kann man auch in die partitionen schauen und sehen was vorhanden ist.

EDIT: Bei Linux habe ich, glaube ich den Fehler gefunden. Ich werde mich am Montag darum kümmern

Gruß
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.
wKovacs
Beiträge: 91
Registriert: 14 Aug 2020, 12:29

Re: Win10, ubuntu18 und 20 lassen sich nicht installieren

Beitrag von wKovacs »

Moin,

ich war in der Lage das Update zurückzurollen. Installationen sind nun wieder möglich.

Für das Update hatte ich lediglich folgende Anweisungen ausgeführt:

Code: Alles auswählen

apt-get update
apt-get upgrade
opsi-package-updater -v --no-zsync update
Ich sah keine Fehlermeldungen. Beim nächsten Installationsversuch dann obig beschriebenes Verhalten.

Auf dem zusätzlich erstellten Server zum Testen ob der Fehler bei mir lag, habe ich die instfiles\ und winpe\ Verzeichnisse kopiert, welche ursprünglich funktioniert hatten (wie sie auf unserem Produktivserver liegen). Daher bin ich sehr zuversichtlich, dass hier alle notwendigen Treiber verfügbar sind.

Gruß
wKovacs
Benutzeravatar
m.radtke
uib-Team
Beiträge: 1231
Registriert: 10 Jun 2015, 12:19

Re: Win10, ubuntu18 und 20 lassen sich nicht installieren

Beitrag von m.radtke »

Hi

Das Problem mit dem Linux Teil ist im jetzt verschobenen Bootimage in osi 4.2 experimental behoben.

Betreffend Windows: Ich kenne den Fehler nur wenn der Storage Treiber nicht in der Boot.wim des WinPE vorhanden ist. Ist die VM die du verwendets genau so konfiguriert wie immer? Windows ist da sehr pingelig wenn es um den verwendeten Controller geht.

Gruß
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.
Benutzeravatar
SisterOfMercy
Beiträge: 1354
Registriert: 22 Jun 2012, 19:18

Re: Win10, ubuntu18 und 20 lassen sich nicht installieren

Beitrag von SisterOfMercy »

Also show the output of opsi-show-drivers.py for that client.
Bitte schreiben Sie Deutsch, when I'm responding in the German-speaking part of the forum!
Antworten