Updates für 4.2 stable und testing

Neuigkeiten und Ankündigungen
Antworten
Benutzeravatar
n.doerrer
uib-Team
Beiträge: 84
Registriert: 23 Okt 2020, 16:11

Updates für 4.2 stable und testing

Beitrag von n.doerrer »

Sehr geehrte opsi-Anwenderinnen und -Anwender,

mit diesem Release haben wir weitere Pakete für opsi 4.2 in Testing und Stable veröffentlicht.
Wichtige Neuerungen bei diesem Release:

Wir veröffentlichen die erste Version des Produktes Ubuntu22-04 in stable. Anders als bei den Vorgängerprodukten ist es bei diesem Netboot Paket nun nötig ein ISO Abbild in den Produktunterordner iso abzulegen um die Installation zu vollziehen. Intern hat sich der Installer geändert, was diesen Schritt nötig macht.

Noch eine Anmerkung bezogen auf opsi-client-agent 4.2 (alle 4.2er betreffend): Das directory c:\tmp wird von uns nicht mehr genutzt und entsprechend auch nicht mehr automatisch angelegt.
Für Ablage von opsi-spezifischen temporären Dateien sollte unter windows c:\opsi.org\tmp genutzt werden.

=====================================
Aktualisierte Pakete in Testing:
=====================================

Windows Localboot:

* opsi-client-agent 4.2.0.32-3

macOS Localboot:

* opsi-mac-client-agent 4.2.0.16-1

Linux Netboot:

* opensusel15-3 4.2.0.1-7

opsi Server:

* opsiconfd 4.2.0.259-1
* opsipxeconfd 4.2.0.30-1
* opsi-utils 4.2.0.167-1
* opsi-linux-bootimage_20220428-1

=====================================
Aktualisierte Pakete in Stable:
=====================================

Windows Localboot:

* opsi-client-agent 4.2.0.31-1

Linux Localboot:

* opsi-linux-client-agent 4.2.0.22-1

Macos Localboot:

* opsi-mac-client-agent 4.2.0.16-1

Windows Netboot:

* windows NT6 4.2.0.2-2

Linux Netboot:

* alma8 4.2.0.2-6
* debian 4.2.0.3-3
* debian9 4.2.0.1-8
* debian10 4.2.0.1-8
* debian11 4.2.0.1-8
* mint20-1 4.2.0.1-6
* mint20-2 4.2.0.1-6
* mint20-3 4.2.0.1-6
* redhat8 4.2.0.2-6
* rocky8 4.2.0.2-6
* sles12sp3 4.2.0.1-9
* sles12sp4 4.2.0.1-9
* sles12sp5 4.2.0.1-9
* sles15-1 4.2.0.1-8
* sles15-2 4.2.0.1-8
* sles15-3 4.2.0.1-8
* ubuntu18-04 4.2.0.1-8
* ubuntu20-04 4.2.0.1-8
* ubuntu22-04 4.2.0.1-8

opsi-local-image Netboot:

* opsi-local-image NT6 4.2.0.2-2
* opsi-vhd-win10-x64 4.2.0.2-2
* opsi-vhd-win11-x64 4.2.0.2-2

opsi Server:

* opsi-nagios-plugins 4.2.0.0-1
* opsi-tftp-hpa 5.2.8-77

Mit freundlichen Grüßen
Nils Dörrer


Changelogs:

Code: Alles auswählen

 opsi-tftp-hpa (5.2.8-77) testing; urgency=low

  * debian/rules: removed dh-systemd dependency for Ubuntu 22.04 support

 -- Mathias Radtke <m.radtke@uib.de> Thu, 17 Mar 2022 14:55:00 +0200

----------

opsi-linux-bootimage (20220428-1) testing; urgency=low

  * mac address spoofing only when enx* device is used
  * kernel 5.17.5

 -- Mathias Radtke <m.radtke@uib.de> Thu, 28 Apr 2022 11:40:00 +0100

opsi-linux-bootimage (20220425-1) testing; urgency=low

  * updated python-opsi
  * kernel 5.17.4

 -- Mathias Radtke <m.radtke@uib.de> Mon, 25 Apr 2022 10:28:00 +0100

----------

 alma/rocky/redhat8 (4.2.0.2-6) testing; urgency=low

  * corrected usage of source for opsi-linux-client-agent installation

 -- Mathias Radtke <m.radtke@uib.de> Thu Apr  7 09:45:16 2022 +0200

----------

 debian (4.2.0.3-3) testing; urgency=low

  * corrected usage of source for opsi-linux-client-agent installation

 -- Mathias Radtke <m.radtke@uib.de> Thu Apr  7 09:45:16 2022 +0200

----------

  debian9/10/11 (4.2.0.1-8) testing; urgency=low

  * corrected usage of source for opsi-linux-client-agent installation

 -- Mathias Radtke <m.radtke@uib.de> Thu Apr  7 09:45:16 2022 +0200

----------

 mint20-1/2/3 (4.2.0.1-6) testing; urgency=low

  * corrected usage of source for opsi-linux-client-agent installation

 -- Mathias Radtke <m.radtke@uib.de> Thu Apr  7 09:45:16 2022 +0200

----------

  sles12sp3/4/5 (4.2.0.1-9) testing; urgency=low

  * corrected usage of source for opsi-linux-client-agent installation

 -- Mathias Radtke <m.radtke@uib.de> Thu Apr  7 09:45:16 2022 +0200

----------

  sles15-1/2/3 (4.2.0.1-8) testing; urgency=low

  * corrected usage of source for opsi-linux-client-agent installation

 -- Mathias Radtke <m.radtke@uib.de> Thu Apr  7 09:45:16 2022 +0200

----------

   ubuntu18-04/20-04/22-04 (4.2.0.1-8) testing; urgency=low

  * corrected usage of source for opsi-linux-client-agent installation

 -- Mathias Radtke <m.radtke@uib.de> Thu Apr  7 09:45:16 2022 +0200

----------

opensusel15-3 (4.2.0.1-7) testing; urgency=low

  * corrected usage of source for opsi-linux-client-agent installation

 -- Mathias Radtke <m.radtke@uib.de> Thu Apr  7 09:45:16 2022 +0200


opsi-client-agent (4.2.0.32-3) stable; urgency=low

  * Installing WebDAV-Redirector for windows server systems.

-- Nils Doerrer <n.doerrer@uib.de> Tue, 28 Apr 2022 14:00:00 +0100

opsi-client-agent (4.2.0.32-2) stable; urgency=low

  * Fixed handling of opsiclientdguard in case of installing over 4.1.x opsi-client-agent

-- Nils Doerrer <n.doerrer@uib.de> Tue, 27 Apr 2022 12:00:00 +0100

opsi-client-agent (4.2.0.32-1) stable; urgency=low

  * Add api-ms-win-core-path-l1-1-0.dll
  * Updated opsiclientd to 4.2.0.118

-- Jan Schneider <j.schneider@uib.de> Tue, 26 Apr 2022 18:48:00 +0100

opsi-client-agent (4.2.0.31-1) stable; urgency=low

  * Updated opsiclientd to 4.2.0.117 (fix win7 compatibility)
  * Updated oca-installation-helper to 4.2.0.18 (view logfiles on failure)
  * Updated opsi-deploy-client-agent to 4.2.0.20 (updated python dependencies)

-- Nils Doerrer <n.doerrer@uib.de> Mon, 12 Apr 2022 16:15:00 +0100

opsi-client-agent (4.2.0.30-1) stable; urgency=low

  * Updated opsi-notifier to 4.2.0.6
  * Improved error handling in case of unreachable configserver
  * Updated opsiclientd to 4.2.0.116

-- Jan Schneider <j.schneider@uib.de> Fri, 01 Apr 2022 16:17:00 +0100

opsi-client-agent (4.2.0.29-1) stable; urgency=low

  * Updated opsiclientd to 4.2.0.113
  * Updated opsi-notifier to 4.2.0.5

-- Jan Schneider <j.schneider@uib.de> Tue, 29 Mar 2022 11:07:00 +0100

opsi-client-agent (4.2.0.28-1) stable; urgency=low

  * Updated oca-installation-helper to 4.2.0.17 (new option --no-set-mac-address, fixed evaluation of files/custom/install.conf)
  * Changed installation to finalize reboot in case of systray installation
  * Changed uninstallation to not reboot as final action

-- Nils Doerrer <n.doerrer@uib.de> Tue, 22 Mar 2022 10:50:00 +0100

opsi-client-agent (4.2.0.27-1) stable; urgency=low

  * Updated opsiclientd to 4.2.0.112 (cleanup registry uninstall, fix shutdown warning repetition after standby)

-- Jan Schneider <j.schneider@uib.de> Mon, 21 Mar 2022 15:50:00 +0100

opsi-client-agent (4.2.0.26-1) stable; urgency=low

  * Fixed version registry setting
  * Updated opsiclientd to 4.2.0.111 (collectLogfiles feature, fixed multithreaded certificate access)
  * Updated opsi-deploy-client-agent to 4.2.0.19 (improved logging, reporting failure reasons --failed-clients-file)

-- Nils Doerrer <n.doerrer@uib.de> Wed, 16 Mar 2022 10:00:00 +0100

----------

opsi-mac-client-agent (4.2.0.16-1) testing; urgency=low

  * Updated opsiclientd to 4.2.0.117
  * Updated oca-installation-helper to 4.2.0.18 (view logfiles on failure)
  * Updated opsi-deploy-client-agent to 4.2.0.20 (updated python dependencies)

-- Nils Doerrer <n.doerrer@uib.de> Wed, 20 Apr 2022 11:00:00 +0100

opsi-mac-client-agent (4.2.0.15-1) testing; urgency=low

  * Updated opsiclientd to 4.2.0.113
  * Updated opsi-notifier to 4.2.0.5

-- Nils Doerrer <n.doerrer@uib.de> Wed, 30 Mar 2022 12:00:00 +0100

opsi-mac-client-agent (4.2.0.14-1) testing; urgency=low

  * Updated oca-installation-helper to 4.2.0.17 (new option --no-set-mac-address, fixed evaluation of files/custom/install.conf)
  * Updated opsiclientd to 4.2.0.112 (fix shutdown warning repetition after standby)
  * Updated opsi-deploy-client-agent to 4.2.0.19 (improved logging, reporting failure reasons --failed-clients-file)

-- Nils Doerrer <n.doerrer@uib.de> Wed, 23 Mar 2022 18:00:00 +0100

----------

opsi-linux-client-agent (4.2.0.22-1) testing; urgency=low

  * Updated opsiclientd to 4.2.0.117
  * Updated oca-installation-helper to 4.2.0.18 (view logfiles on failure)
  * Updated opsi-deploy-client-agent to 4.2.0.20 (updated python dependencies)

-- Nils Doerrer <n.doerrer@uib.de> Wed, 20 Apr 2022 11:00:00 +0100

opsi-linux-client-agent (4.2.0.21-1) testing; urgency=low

  * Updated opsiclientd to 4.2.0.113
  * Updated opsi-notifier to 4.2.0.5

-- Nils Doerrer <n.doerrer@uib.de> Wed, 30 Mar 2022 12:00:00 +0100

opsi-linux-client-agent (4.2.0.20-1) testing; urgency=low

  * Updated oca-installation-helper to 4.2.0.17 (new option --no-set-mac-address, fixed evaluation of files/custom/install.conf)
  * Updated opsiclientd to 4.2.0.112 (fix shutdown warning repetition after standby)
  * Updated opsi-deploy-client-agent to 4.2.0.19 (improved logging, reporting failure reasons --failed-clients-file)
  * Added check for too old glibc versions (<2.18 as for centos7, redhat7)

-- Nils Doerrer <n.doerrer@uib.de> Wed, 23 Mar 2022 18:00:00 +0100

----------

opsi-utils (4.2.0.167-1) stable; urgency=medium

  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Mon, 02 May 2022 07:48:01 +0200

opsi-utils (4.2.0.166-1) stable; urgency=medium

  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Wed, 27 Apr 2022 10:04:35 +0200

----------

opsiconfd (4.2.0.259-1) stable; urgency=medium

  * Feature:  Show JSONRPC method documentation in Admin interface if available
  * Improvement:  Update python packages
  * Improvement:  Add buttons to change terminal font size

 -- uib GmbH <info@uib.de>  Wed, 04 May 2022 12:11:50 +0000

opsiconfd (4.2.0.258-1) stable; urgency=medium

  * Improvement:  Update python packages
  * Bugfix:  Fix grafana auto login / set-cookie

 -- uib GmbH <info@uib.de>  Fri, 29 Apr 2022 12:42:15 +0000

opsiconfd (4.2.0.257-1) stable; urgency=medium

  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Tue, 26 Apr 2022 21:24:52 +0200

opsiconfd (4.2.0.256-1) stable; urgency=medium

  * No public changes

 -- uib GmbH <info@uib.de>  Fri, 22 Apr 2022 11:42:54 +0200

----------

opsipxeconfd (4.2.0.30-1) stable; urgency=medium

  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Mon, 02 May 2022 08:17:48 +0200

opsipxeconfd (4.2.0.29-1) stable; urgency=medium

  * Improvement:  revert change to backend_getLicensingInfo call

 -- uib GmbH <info@uib.de>  Tue, 26 Apr 2022 16:00:57 +0200

opsipxeconfd (4.2.0.28-1) stable; urgency=medium

  * Improvement:  fix bug with backend_getLicensingInfo

 -- uib GmbH <info@uib.de>  Tue, 19 Apr 2022 14:13:24 +0200
SirTux
Beiträge: 489
Registriert: 05 Feb 2011, 18:37

Re: Updates für 4.2 stable und testing

Beitrag von SirTux »

Der Login unter UCS 4 (Testing) ist kaputt:

Code: Alles auswählen

[4] [2022-05-04 17:53:11.733] [CLIENTIP  ] Backend authentication error: Backend authentication error: Authentication failed for user 'Administrator': Backend authentication error: PAM authentication failed for user 'Administrator': Error in service module (auth_type=auth-module)   (session.py:272)
Benutzeravatar
fkalweit
uib-Team
Beiträge: 89
Registriert: 23 Okt 2020, 16:14

Re: Updates für 4.2 stable und testing

Beitrag von fkalweit »

Hallo,

vielen Dank für den Hinweis.
Auf dem experimental Repo ist jetzt ein Fix für das Problem in opsi-server.
https://download.opensuse.org/repositor ... ntion_4.4/

Evt muss noch das join script 99opsi4ucs manuell ausgeführt werden.

Der Fix kommt dann so schnell wie möglich nach testing.

Viele Grüße aus Mainz
Fabian
SirTux
Beiträge: 489
Registriert: 05 Feb 2011, 18:37

Re: Updates für 4.2 stable und testing

Beitrag von SirTux »

Hallo,

vielen Dank für den schnellen Fix. Er funktioniert :)

Viele Grüße,
Stefan
Patrick89bvb
Beiträge: 28
Registriert: 05 Nov 2015, 11:26

Re: Updates für 4.2 stable und testing

Beitrag von Patrick89bvb »

Guten Morgen,

Ganz doofe Frage :oops: Wann ist es geplant, die Funktion, "encrypt-password" und "partition_method:crypto" in ubuntu22.04 einzubauen?

Viele Grüße!
Patrick
Benutzeravatar
m.radtke
uib-Team
Beiträge: 1231
Registriert: 10 Jun 2015, 12:19

Re: Updates für 4.2 stable und testing

Beitrag von m.radtke »

Guten Morgen,

leider ist dieser default, den es bei der preseed Methode gab, aus dem Standart im neuen Autoinstall Verfahren nicht mehr vorhanden.
Was du machen kannst: installier ein Gerät von Hand. Unter /var/log/installer/ sollte es eine Datei autoinstall-user-data geben.
Davon kannst du das Partitionierungsschema und die Verschlüsselung übernehmen und eine neue autoinstall.yml unter dem Produktunterverzeichnis custom im Depot ablegen und im property autoinstall den Namen ändern.

Ich persönlich finde es auch sehr schade, dass Canonical sich dagegen entschieden haben ein default Partitionierungsschema mit Verschlüsselung anzubieten.

Gruß
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.
Patrick89bvb
Beiträge: 28
Registriert: 05 Nov 2015, 11:26

Re: Updates für 4.2 stable und testing

Beitrag von Patrick89bvb »

Mhm, schade und vielen dank für diesen Tipp!
Benutzeravatar
m.radtke
uib-Team
Beiträge: 1231
Registriert: 10 Jun 2015, 12:19

Re: Updates für 4.2 stable und testing

Beitrag von m.radtke »

Ja das ist echt schade, das es nicht mehr im default angeboten wird.

Du kannst aber auch einfach mit LVM installieren und dann laut https://jumpcloud.com/blog/how-to-encry ... stallation die Kiste verschlüsseln. Da kann man bestimmt ein opsi Produkt drauf machen.

Vielleicht habe ich auch einen Umweg gefunden. Stay tuned

Gruß
Mathias

EDIT: Ja ich habe was :D
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.
Benutzeravatar
m.radtke
uib-Team
Beiträge: 1231
Registriert: 10 Jun 2015, 12:19

Re: Updates für 4.2 stable und testing

Beitrag von m.radtke »

Patrick89bvb hat geschrieben: 12 Mai 2022, 16:17 Mhm, schade und vielen dank für diesen Tipp!
Es ist zwar sehr simpel und es gibt nur eine Partition auf der alle Daten gespeichert werden, aber here you go.

https://download.uib.de/4.2/experimenta ... 0.1-9.opsi

Feedback gerne gesehen

Gruß
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.
Patrick89bvb
Beiträge: 28
Registriert: 05 Nov 2015, 11:26

Re: Updates für 4.2 stable und testing

Beitrag von Patrick89bvb »

Danke Herr Radtke! Ich werde ab nächste Woche melden können! :D

Die Autoinstall-File findet man nur im server-edition, nicht im desktop-edition. :idea:
Antworten