Updates opsi 4.1 / 4.2 stable und testing

Antworten
Benutzeravatar
fkalweit
uib-Team
Beiträge: 57
Registriert: 23 Okt 2020, 16:14

Updates opsi 4.1 / 4.2 stable und testing

Beitrag von fkalweit »

Dear opsi users,

today we have released more packages for opsi 4.1 and 4.2 in testing and stable.

The opsi-linux-bootimage in opsi 4.2 has become smaller. We have changed the compression algorithm from BZ2 to ZSTD. This not only results in a smaller bootimage, but also in a factor of 3 faster unpacking time.
The template files provided by the opsi-linux-bootimage (default.menu, grub.cfg etc.) are automatically adapted during the update. If you still have your own template files in which the opsi-linux-bootimage miniroot-x64.bz2 is called, please change this in these files to miniroot-x64.zstd.

With the Rehat-like netboot packages in version 8 (alma8, redhat8 etc.) the kernel has been updated. For a successful installation with these netboot packages, a current installation medium in version 8.5 is required.


## stable

### opsi-server:
- opsi-linux-bootimage 20211102-1 (4.1 und 4.2)

## testing:

### Linux Netboot:
- alma 8 (4.2.0.2-3)
- centos70 (4.2.0.2-3)
- centos8 (4.2.0.2-3)
- redhat70 (4.2.0.2-3)
- redhat8 (4.2.0.2-3)
- rocky8 (4.2.0.2-3)
- debian (4.2.0.1-3)
- debian9 (4.2.0.1-6)
- debian10 (4.2.0.1-6)
- debian11 (4.2.0.1-6)
- mint20-1 (4.2.0.1-4)
- mint20-2 (4.2.0.1-4)
- opensusel15-2 (4.2.0.1-5)
- opensusel15-3 (4.2.0.1-5)
- sles12 (4.2.0.1-5)
- sles12sp1 (4.2.0.1-5)
- sles12sp2 (4.2.0.1-5)
- sles12sp3 (4.2.0.1-5)
- sles12sp4 (4.2.0.1-5)
- sles15-1 (4.2.0.1-5)
- sles15-2 (4.2.0.1-5)
- sles15-3 (4.2.0.1-5)
- ubuntu (4.2.0.1-4)
- ubuntu18-04 (4.2.0.1-6)
- ubutnu20-04 (4.2.0.1-6)
- ucs44 (4.2.0.1-4)

### Windows Netboot:
- win7 (4.2.0.1-5)
- win7-x64 (4.2.0.1-5)
- win7-captured (4.2.0.1-5)
- win7-x64 -captured (4.2.0.1-5)
- win81 (4.2.0.1-5)
- win81-x64 (4.2.0.1-5)
- win81-captured (4.2.0.1-5)
- win81-x64-captured (4.2.0.1-5)
- win10 (4.2.0.1-5)
- win10-x64 (4.2.0.1-5)
- win10-captured (4.2.0.1-5)
- win10-x64-captured (4.2.0.1-5)
- win11-x64 (4.2.0.1-5)
- win11-x64-captured (4.2.0.1-5)
- win-2008-r2 (4.2.0.1-5)
- win2012 (4.2.0.1-5)
- win2012-r2 (4.2.0.1-5)
- win2016 (4.2.0.1-5)
- win2019 (4.2.0.1-5)
- win2022 (4.2.0.1-5)

### opsi-local-image:
- opsi-local-image-win7 (4.2.0.1-5)
- opsi-local-image-win7-x64 (4.2.0.1-5)
- opsi-local-image-win7-capture (4.2.0.1-5)
- opsi-local-image-win7-x64-capture (4.2.0.1-5)
- opsi-local-image-win81 (4.2.0.1-5)
- opsi-local-image-win81-x64 (4.2.0.1-5)
- opsi-local-image-win81-capture (4.2.0.1-5)
- opsi-local-image-win81-x64-capture (4.2.0.1-5)
- opsi-local-image-win10 (4.2.0.1-5)
- opsi-local-image-win10-x64 (4.2.0.1-5)
- opsi-local-image-win10-capture (4.2.0.1-5)
- opsi-local-image-win10-x64-capture (4.2.0.1-5)
- opsi-local-image-win10-x64 (4.2.0.1-5)
- opsi-local-image-win11-x64-capture (4.2.0.1-5)
- opsi-vhd-win10-x64 (4.2.0.1-5)

### opsi-server:
- opsipxeconfd 4.2.0.21
- opsi-directory-connector 47.4-1
- opsi-utils 4.2.0.139
- opsiconfd 4.2.0.214

With kind regards
Fabian Kalweit

changelogs:

Code: Alles auswählen

alma8/rocky8/redhat/centos (4.2.0.2-3) testing; urgency=low

  * changed preseed/post installation command to adapt to other clientconfig.configserver.urls

 -- Mathias Radtke <m.radtke@uib.de> Tue Nov 16 15:34:48 2021 +0200


alma8/rocky8/redhat/centos (4.2.0.2-2) testing; urgency=low

  * Removed unneeded variable from setup.py

 -- Terry Strooband <t.strooband@dgip.nl> Tue Nov 16 12:49:06 2021 +0200

alma8/rocky8/redhat/centos (4.2.0.2-1) testing; urgency=low

  * Split kernel_boot_options, the kernel_boot_options_installer property is only for options for the installer.
  * Installation from nfs should also use the signed linux/initrd.
  * Default packages in kickstart file can now be changed via a productproperty.
  * Added productproperty to select custom partition scheme.
  * Changed method of not installing opsi-client-agent, if productproperty is set to false.
  * Packages needed for opsi-client-agent are now in setup.py
  * Added wget as requirement for opsi-client-agent
  * Moved opsi-client-agent installation to setup.py

 -- Terry Strooband <t.strooband@dgip.nl> Fri Nov 05 18:30:00 2021 +0100

alma8/rocky8/redhat/centos (4.2.0.1-4) testing; urgency=low

  * corrected configserver ip address patching

 -- Mathias Radtke <m.radtke@uib.de> Mon Oct 25 12:27:33 2021 +0200

debian (4.2.0.1-3) testing; urgency=low

  * corrected path to opsi-linux-client-agent.log

 -- Mathias Radtke <m.radtke@uib.de> Thu Oct 28 08:44:00 2021 +0200

debian9/10/11 (4.2.0.1-6) testing; urgency=low

  * changed preseed/post installation command to adapt to other clientconfig.configserver.urls

 -- Mathias Radtke <m.radtke@uib.de> Tue Nov 16 15:34:48 2021 +0200


debian9/10/11 (4.2.0.1-5) testing; urgency=low

  * corrected configserver ip address patching

 -- Mathias Radtke <m.radtke@uib.de> Mon Oct 25 12:27:33 2021 +0200


mint20-1/2 (4.2.0.1-4) testing; urgency=low

  * changed preseed/post installation command to adapt to other clientconfig.configserver.urls

 -- Mathias Radtke <m.radtke@uib.de> Tue Nov 16 15:34:48 2021 +0200


mint20-1/2 (4.2.0.1-3) testing; urgency=low

  * corrected configserver ip address patching

 -- Mathias Radtke <m.radtke@uib.de> Mon Oct 25 12:27:33 2021 +0200

opensusel15*/sles12*/sles15* (4.2.0.1-5) testing; urgency=low

  * changed preseed/post installation command to adapt to other clientconfig.configserver.urls

 -- Mathias Radtke <m.radtke@uib.de> Tue Nov 16 15:34:48 2021 +0200


opensusel15*/sles12*/sles15* (4.2.0.1-4) testing; urgency=low

  * corrected configserver ip address patching

 -- Mathias Radtke <m.radtke@uib.de> Mon Oct 25 12:27:33 2021 +0200

ubuntu (4.2.0.1-4) testing; urgency=low

  * using nosplash on focal release to prevent blackscreen

 -- Mathias Radtke <m.radtke@uib.de> Thu Nov 11 12:04:00 2021 +0200

ubuntu (4.2.0.1-3) testing; urgency=low

  * corrected path to opsi-linux-client-agent.log

 -- Mathias Radtke <m.radtke@uib.de> Thu Oct 28 08:44:00 2021 +0200

ubuntu18-04/20-04 (4.2.0.1-6) testing; urgency=low

  * changed preseed/post installation command to adapt to other clientconfig.configserver.urls

 -- Mathias Radtke <m.radtke@uib.de> Tue Nov 16 15:34:49 2021 +0200

ubuntu18-04/20-04 (4.2.0.1-5) testing; urgency=low

  * corrected configserver ip address patching

 -- Mathias Radtke <m.radtke@uib.de> Mon Oct 25 12:27:33 2021 +0200

ucs44 (4.2.0.1-4) testing; urgency=low

  * changed preseed/post installation command to adapt to other clientconfig.configserver.urls

 -- Mathias Radtke <m.radtke@uib.de> Tue Nov 16 15:34:49 2021 +0200


ucs44 (4.2.0.1-3) testing; urgency=low

  * corrected configserver ip address patching

 -- Mathias Radtke <m.radtke@uib.de> Mon Oct 25 12:27:33 2021 +020

windows (4.2.0.1-5) testing; urgency=low

  * setup.opsiscript: detecting win11 product and performing registry changes for a successful installation

 -- Mathias Radtke <m.radtke@uib.de> Wed Oct 27 09:50:08 2021 +0200

opsi-local-image-windows (4.2.0.1-5) testing; urgency=low

  * setup.opsiscript: detecting win11 product and performing registry changes for a successful installation

 -- Mathias Radtke <m.radtke@uib.de> Wed Oct 27 09:50:08 2021 +0200

opsi-vhd-win10-x64 (4.2.0.1-5) testing; urgency=low

  * setup.opsiscript: detecting win11 product and performing registry changes for a successful installation

 -- Mathias Radtke <m.radtke@uib.de> Wed Oct 27 09:50:08 2021 +0200

opsi-linux-bootimage 4.2:
opsi-linux-bootimage (20211102-1) testing; urgency=medium

  * using noserverino SMB mount option

 -- Mathias Radtke <m.radtke@uib.de> Tue, 02 Oct 2021 14:46:00 +0200

opsi-linux-bootimage (20211008-2) testing; urgency=low

  * fixed build error on SLES systems

 -- Mathias Radtke <m.radtke@uib.de> Fri, 08 Oct 2021 10:52::00 +0200

opsi-linux-bootimage (20211008-1) testing; urgency=low

  * kernel 5.14.9
  * miniroot using zstd compression

 -- Mathias Radtke <m.radtke@uib.de> Fri, 08 Oct 2021 09:20:00 +0200


opsi-linux-bootimage 4.1:
opsi-linux-bootimage (20211102-1) testing; urgency=medium

  * using noserverino SMB mount option

 -- Mathias Radtke <m.radtke@uib.de> Mon, 02 Nov 2021 14:43:00 +0200

---------------------------------------------------------------------

opsiconfd (4.2.0.214-1) stable; urgency=medium

  * Bugfix:  added postinst fix for SSL library incompatibility of SLES15-X

 -- uib GmbH <info@uib.de>  Thu, 18 Nov 2021 15:51:04 +0000

opsiconfd (4.2.0.213-1) stable; urgency=medium

  * Bugfix:  Update python-opsi to fix onetime password auth

 -- uib GmbH <info@uib.de>  Mon, 15 Nov 2021 18:24:06 +0100

opsiconfd (4.2.0.212-1) stable; urgency=medium

  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Mon, 15 Nov 2021 11:43:00 +0100

opsiconfd (4.2.0.211-1) stable; urgency=medium

  * Bugfix:  Fix addon reload

 -- uib GmbH <info@uib.de>  Wed, 10 Nov 2021 15:36:22 +0100

opsiconfd (4.2.0.210-1) stable; urgency=medium

  * Feature:  List and install addons via admin interface

 -- uib GmbH <info@uib.de>  Mon, 08 Nov 2021 14:38:19 +0100

opsiconfd (4.2.0.209-1) stable; urgency=medium

  * Feature:  Show sessions on admin page

 -- uib GmbH <info@uib.de>  Fri, 29 Oct 2021 20:34:25 +0200

opsiconfd (4.2.0.208-1) stable; urgency=medium

  * Feature:  Show routes on info page

 -- uib GmbH <info@uib.de>  Tue, 26 Oct 2021 16:34:58 +0200

opsiconfd (4.2.0.207-1) stable; urgency=medium

  * Improvement:  updated python-opsi to 4.2.0.247 (minor cleanup)
  * Feature:  Reload button on admininterface
  * Feature:  Implement AddonManager

 -- uib GmbH <info@uib.de>  Mon, 11 Oct 2021 11:33:26 +0200

opsiconfd (4.2.0.206-1) stable; urgency=medium

  * Bugfix:  Fix ipv6 client session handling

 -- uib GmbH <info@uib.de>  Wed, 06 Oct 2021 11:15:37 +0200

opsiconfd (4.2.0.205-1) stable; urgency=medium

  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Fri, 01 Oct 2021 12:22:54 +0200

opsiconfd (4.2.0.204-1) stable; urgency=medium

  * Improvement:  add debug option: rpc error log

 -- uib GmbH <info@uib.de>  Tue, 28 Sep 2021 08:11:57 +0000

-------------------------------------------------------------

opsi-directory-connector (47.4-1) stable; urgency=medium

  * No public changes

 -- uib GmbH <info@uib.de>  Mon, 11 Oct 2021 09:54:00 +0000

opsi-directory-connector (47.2-1) stable; urgency=medium

  * Bugfix:  fix error log

 -- uib GmbH <info@uib.de>  Fri, 08 Oct 2021 14:24:35 +0000

opsi-directory-connector (47.1-1) stable; urgency=medium

  * Bugfix:  dn description if group name exists in opsi

 -- uib GmbH <info@uib.de>  Thu, 16 Sep 2021 13:21:03 +0000

opsi-directory-connector (47.0-1) stable; urgency=medium

  * Feature:  --dry-run with --delete-clients
  * Feature:  new start option: delete-clients

 -- uib GmbH <info@uib.de>  Tue, 22 Jun 2021 13:55:05 +0000


-------------------------------------------------------------

opsi-utils (4.2.0.139-1) stable; urgency=medium

  * Bugfix:  added postinst fix for SSL library incompatibility of SLES15-X

 -- uib GmbH <info@uib.de>  Thu, 18 Nov 2021 15:50:46 +0000

opsi-utils (4.2.0.138-1) stable; urgency=medium

  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Mon, 15 Nov 2021 12:11:03 +0100

opsi-utils (4.2.0.137-1) stable; urgency=medium

  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Mon, 08 Nov 2021 18:38:22 +0100

opsi-utils (4.2.0.136-1) stable; urgency=medium

  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Thu, 04 Nov 2021 19:20:13 +0100

opsi-utils (4.2.0.135-1) stable; urgency=medium

  * Bugfix:  fixed opsiwakeupclients jsonrpc connection check

 -- uib GmbH <info@uib.de>  Wed, 03 Nov 2021 16:42:39 +0100

opsi-utils (4.2.0.134-1) stable; urgency=medium

  * Improvement:  updated python-opsi to 4.2.0.249 (fixed opsi-package-updater behaviour on flat repositories)
  * Improvement:  prohibit accidently registering the confserver as depot at itself, import fix in opsi-python

 -- uib GmbH <info@uib.de>  Wed, 13 Oct 2021 13:05:06 +0200

opsi-utils (4.2.0.133-1) stable; urgency=medium

  * No public changes

 -- uib GmbH <info@uib.de>  Mon, 11 Oct 2021 12:22:48 +0200

opsi-utils (4.2.0.132-1) stable; urgency=medium

  * Bugfix:  removed legacy logger calls, minor cleanup

 -- uib GmbH <info@uib.de>  Mon, 11 Oct 2021 10:33:47 +0200

---------------------------------------------------------------

opsipxeconfd (4.2.0.21-1) stable; urgency=medium

  * Improvement:  Update python-packages
  * Improvement:  Use new licensing info if available

 -- uib GmbH <info@uib.de>  Mon, 15 Nov 2021 10:39:41 +0100

opsipxeconfd (4.2.0.20-1) stable; urgency=medium

  * Improvement:  arm64 build

 -- uib GmbH <info@uib.de>  Wed, 22 Sep 2021 14:21:32 +0200


Antworten