Déploiement de nouvelles machines via PXE

Ce forum est destiné au support entre utilisateurs de logiciel OPSI
Antworten
guillaume
Beiträge: 31
Registriert: 19 Feb 2019, 18:08

Déploiement de nouvelles machines via PXE

Beitrag von guillaume »

Bonjour à toutes et à tous,

Je souhaite déployer mes nouvelles machines au travers du réseau via PXEBoot.
Actuellement les OS des machines sont installées manuellement et j'installe le client OPSI et les applications via OPSI. A cette heure tout fonctionne parfaitement !

Cependant dans quelques semaines je vais réinstaller et/ou installer plusieurs machines et je voudrais automatiser via le réseau l'installation de l'OS, des drivers et des applications.

J'ai tenté mais sans succès de booter sur le réseau mais j'ai l'erreur : PXE-53 no boot filename received, j'ai relu plusieurs fois la documentation OPSI officielle en me disant que j'avais mal lu ou mal compris mais je n'ai pas trouvé ce qui pouvait provoquer cette erreur.

Pour information voici mon infrastructure :
  1. 1 serveur DHCP externe
  2. 2 serveurs DNS local primaire et secondaire
  3. 1 serveur OPSI
Sur le serveur OPSI :
  • Service TFTP-HPA démarré
  • tous les ports nécessaires sont ouverts sur les parefeux
  • Le parefeu du serveur OPSI est arrêté pour pouvoir éliminer une des options possible
Sur le serveur OPSI dans le dépot Windows 10 :
  • Dans /var/lib/opsi/depot/win10-x64 j'ai changé les droits sur les dossiers installfiles et winpe récursivement
  • J'ai copié le contenu du winpe/media sur mon ordinateur dans le winpe
  • J'ai donné des droits étendus (trop je le sais) afin de voir si cela provenait d'un problème de droit sur les fichiers
Si vous avez besoin de plus de détails faites moi signe.

Merci de m'éclairer j'ai très certainement oublié une chose mais ca ne me saute pas aux yeux, je suis preneur de toute idée pour résoudre cela !!
Benutzeravatar
r.roeder
uib-Team
Beiträge: 511
Registriert: 02 Jul 2008, 10:08

Re: Déploiement de nouvelles machines via PXE

Beitrag von r.roeder »

Bonjour:

J'ai maintenant vu votre question.

Si on n'est pas répondu: Je pense que le problème est la configuration du serveur DCHP. Il faut poser une valeur pour le serveur opsi comme boot server (option 66) et le fichier de boot, l' option 67, pour donner l'adresse a l'ordinateur démarrant

Peut-être c'a vous aide encore

Rupert
opsi support - uib gmbh
For productive opsi installations we recommend maintainance + support contracts which are the base of opsi development.


Wondering who's using opsi? Have a look at the opsi map: http://opsi.org/opsi-map/.
guillaume
Beiträge: 31
Registriert: 19 Feb 2019, 18:08

Re: Déploiement de nouvelles machines via PXE

Beitrag von guillaume »

Bonjour,

Merci pour la réponse, pouvez vous me dire ou je dois modifier ces valeurs ? Dans quel fichier ?
Il faut poser une valeur pour le serveur opsi comme boot server (option 66) et le fichier de boot, l' option 67, pour donner l'adresse a l'ordinateur démarrant
Pour information mon serveur DHCP n'est pas un serveur Windows.

Merci,
Bon week-end.

Guillaume
Benutzeravatar
SisterOfMercy
Beiträge: 1255
Registriert: 22 Jun 2012, 19:18

Re: Déploiement de nouvelles machines via PXE

Beitrag von SisterOfMercy »

You need to edit the dhcpd.conf file (I think). It depends on your specific dhcp implementation.
If you are using a linux as dhcp server, you are probably using the isc dhcp server. This might be located at /etc/dhcp/dhcpd.conf

Find out what you are using, and copy the file here (exclude any private information). You would also need to give us the ip address of the opsi server.
(also please show /etc/opsi/opsipxeconfd.conf from the opsi server)
Bitte schreiben Sie Deutsch, when I'm responding in the German-speaking part of the forum!
Antworten