Rocky & alma Linux supported in opsi 4.2 testing along with other package updates

Antworten
Benutzeravatar
m.radtke
uib-Team
Beiträge: 1080
Registriert: 10 Jun 2015, 12:19

Rocky & alma Linux supported in opsi 4.2 testing along with other package updates

Beitrag von m.radtke »

Dear opsi users

CentOS 8 will not be supported for long. Therefore we worked on Alma and Rocky support for our CentOS enthusiasts.
Hereby we officially release Rocky and Alma support in opsi 4.2 testing. In Addition there are also netboo packages with this release for these distributions.

We also release updated packages in opsi 4.2, to provide the support for these distributions.

Additionally new opsi-(linux/mac)client-agents are released today.

Updated packages in testing:

Linux Netboot:
alma8 4.2.0.1-2
rocky8 4.2.0.1-2

Linux Localboot:
l-opsi-server 4.2.0.5-1
opsi-linux-client-agent 4.2.0.6-1

Windows Localboot:
opsi-client-agent 4.2.0.12-1

macos Localboot:
opsi-mac-client-agent 4.2.0.5-1

opsi Server Pakete:
opsiconfd 4.2.0.203-1
opsipxeconfd 4.2.0.20-1
opsi-utils 4.2.0.130-1
redis-timeseries 1.4.10.1

With regards from the opsi team
Mathias

Changelogs:

Code: Alles auswählen

opsi-mac-client-agent (4.2.0.5-1) testing; urgency=low

  * updated opsiclientd to 4.2.0.92
  * updated opsi-deploy-client-agent to 4.2.0.14
  * updated oca-installation-helper to 4.2.0.4
  * changed installation of custom files to be executed on every setup.

-- Nils Doerrer <n.doerrer@uib.de> Wed, 22 Sept 2021 16:00:00 +0100

opsi-linux-client-agent (4.2.0.6-1) testing; urgency=low

  * updated opsiclientd to 4.2.0.92
  * updated opsi-deploy-client-agent to 4.2.0.14
  * updated oca-installation-helper to 4.2.0.4

-- Nils Doerrer <n.doerrer@uib.de> Fri, 03 Sept 2021 16:00:00 +0100

opsi-client-agent (4.2.0.12-1) stable; urgency=low

  * Update opsiclientd to 4.2.0.92

-- Nils Doerrer <n.doerrer@uib.de> Wed, 22 Sep 2021 15:51:00 +0100

opsi-client-agent (4.2.0.11-1) stable; urgency=low

  * Update opsiclientd to 4.2.0.91

-- Jan Schneider <j.schneider@uib.de> Wed, 22 Sep 2021 08:51:00 +0100

opsi-client-agent (4.2.0.10-1) stable; urgency=low

  * Update opsiclientd to 4.2.0.90

-- Jan Schneider <j.schneider@uib.de> Tue, 21 Sep 2021 07:15:00 +0100

opsipxeconfd (4.2.0.20-1) stable; urgency=medium

  * Improvement:  arm64 build

 -- uib GmbH <info@uib.de>  Wed, 22 Sep 2021 14:21:32 +0200
 
 opsiconfd (4.2.0.203-1) stable; urgency=medium

  * Bugfix:  arm64 pam workaround
  * Bugfix:  logger reload (stderr,file)

 -- uib GmbH <info@uib.de>  Wed, 22 Sep 2021 13:21:55 +0000

opsiconfd (4.2.0.202-1) stable; urgency=medium

  * Improvement:  Update python-opsi

 -- uib GmbH <info@uib.de>  Tue, 21 Sep 2021 13:44:12 +0000

opsiconfd (4.2.0.201-1) stable; urgency=medium

  * Improvement:  Update python-opsi

 -- uib GmbH <info@uib.de>  Tue, 21 Sep 2021 10:32:02 +0000

opsiconfd (4.2.0.200-1) stable; urgency=medium

  * Improvement:  add arm64 build

 -- uib GmbH <info@uib.de>  Mon, 20 Sep 2021 10:00:23 +0200

opsiconfd (4.2.0.199-1) stable; urgency=medium

  * Improvement:  New defaults for session-lifetime and max-session-per-ip
  * Improvement:  Do not keep zsync2 sessions

 -- uib GmbH <info@uib.de>  Thu, 16 Sep 2021 16:28:32 +0200

opsiconfd (4.2.0.198-1) stable; urgency=medium

  * No public changes

 -- uib GmbH <info@uib.de>  Thu, 16 Sep 2021 10:45:42 +0200

opsiconfd (4.2.0.197-1) stable; urgency=medium

  * Improvement:  Update python-opsi

 -- uib GmbH <info@uib.de>  Thu, 16 Sep 2021 09:21:42 +0200

opsiconfd (4.2.0.196-1) stable; urgency=medium

  * Improvement:  Update python packages
  * Bugfix:  Delete session on backend_exit
  * Improvement:  Update python-opsi

 -- uib GmbH <info@uib.de>  Wed, 15 Sep 2021 15:31:25 +0200

opsiconfd (4.2.0.195-1) stable; urgency=medium

  * Improvement:  Update python-opsi
  * Bugfix:  Check if log file exists before rotate
  * Improvement:  Answer with jsonrpc 2.0 response if client sends jsonrpc 2.0 request

 -- uib GmbH <info@uib.de>  Thu, 02 Sep 2021 15:39:27 +0200
 
 opsi-utils (4.2.0.130-1) stable; urgency=medium

  * Improvement:  Update python-opsi

 -- uib GmbH <info@uib.de>  Tue, 21 Sep 2021 12:33:06 +0200

opsi-utils (4.2.0.129-1) stable; urgency=medium

  * Bugfix:  package build copy of opsi-util confs
  * Improvement:  arm64 build

 -- uib GmbH <info@uib.de>  Mon, 20 Sep 2021 17:28:13 +0200
 
alma8 (4.2.0.1-2) testing; urgency=low

  * forked from centos8

 -- Mathias Radtke <m.radtke@uib.de> Mon Sep 13 14:42:00 2021 +0100
 
 rocky (4.2.0.1-2) testing; urgency=low

  * forked from centos8

 -- Mathias Radtke <m.radtke@uib.de> Mon Sep 13 14:42:00 2021 +0100
 
 l-opsi-server (4.2.0.5-1); testing; urgency=low

  * added Rocky Linux 8 support
  * added Alma Linux 8 support

 -- Mathias Radtke <m.radtke@uib.de> Mon, 13 Sep 2021 16:40:00 +0200
 
 
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.
Antworten