Updates for opsi 4.1 in stable and testing

Benutzeravatar
n.wenselowski
uib-Team
Beiträge: 3104
Registriert: 04 Apr 2013, 12:15

Updates for opsi 4.1 in stable and testing

Beitragvon n.wenselowski » 08 Feb 2019, 10:39

Dear opsi users,

updates have been released for opsi 4.1 in stable & testing.

With this release SLES12SP4 is officially supported.

The update to python-opsi 4.1.1.58-1 contains changes to the hardware audit configuration.
Therefore we recommend to execute the following commands after updating:

Code: Alles auswählen

opsi-setup --update-mysql
service opsiconfd restart


In the testing branch server components have been updated as a reaction to the expired Java Webstart support.
Support for Java Webstart has been removed from opsiconfd.
As an replacement there is now a standalone installer for Linux distributions.
Such an installer has been around for Windows for some time.
We are looking forward to your feedback!


Updated packages in stable:

Linux netboot packages:
  • sles12sp4 4.1.0.0-1

Linux localboot packages:
  • l-opsi-server 4.1.1.9-2
  • l-opsi-server-migrate 4.1.2-2
  • opsi-linux-client-agent 4.1.0.11-1.opsi

Server packages opsi 4.1:
  • python-opsi 4.1.1.58-1
  • opsi-linux-bootimage 20181213-1


Updated packages in testing:

Server packages opsi 4.1:
  • opsi-server 4.1.1.7-1
  • opsiconfd 4.1.1.18-1
  • opsi4ucs 4.1.1.9-1

Linux localboot packages:
  • l-desktop 4.1.0.2-1


With kind regards

Niko Wenselowski


PS: Changelogs:

Code: Alles auswählen

python-opsi (4.1.1.58-1) stable; urgency=medium

  * Re-release 4.1.1.57 due to some merge problems.

 -- Niko Wenselowski <niko@stellar>  Fri, 18 Jan 2019 16:36:48 +0100

python-opsi (4.1.1.57-1) stable; urgency=medium

  * OPSI.Util.Task.ConfigureBackend.DHCPD: Default path for dhcpd config set
    to /etc/dhcp/dhcpd.conf.
  * Added module OPSI.Util.Task.ConfigureBackend.ConfigDefaults.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Fri, 18 Jan 2019 16:19:30 +0100

python-opsi (4.1.1.56-1) testing; urgency=medium

  * OPSI.Backend.OpsiPXEConfd: _collectDataForUpdate: Changed first parameter
    to client ID instead of getting the value from a ProductOnClient.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Tue, 08 Jan 2019 17:40:47 +0100

python-opsi (4.1.1.55-1) testing; urgency=medium

  * OPSI.Backend.OpsiPXEConfd: Caching data will now work as expected
    when changing PXE templates of a product.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Tue, 08 Jan 2019 17:12:53 +0100

python-opsi (4.1.1.54-1) stable; urgency=medium

  * OPSI.Util.Task.Backup: Do not show a message for an unused backend
    when running in auto mode.
  * OPSI.System.Posix & OPSI.System.Windows: refactored getDiskSpaceUsage.
  * OPSI.System.Windows: Make code more consistent with the other modules.
  * OPSI.Util.Task.InitializeBackend: supplied an __all__.
  * OPSI.Util.Task.InitializeBackend and OPSI.Util.Task.Rights use the
    BackendManager in contextmanager style.
  * OPSI.Util.Repository: Make code more consistent with the other modules.
  * opsihwaudit.conf: Accept NICs with 10GB+ throughput.
  * OPSI.Sytem.Posix: removed support for dhcp3 dhclient.leases file.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Fri, 07 Dec 2018 13:37:00 +0100


Code: Alles auswählen

opsi-linux-client-agent (4.1.0.11-1) stable; urgency=medium

* opsi-script 4.12.0.35
* opsi-script-starter 4.1.0.3:
* new function ismounted(mountpoint)
* after mount check not only exit code but also with ismounted

-- d.oertel <d.oertel@uib.de> Thu, 18 Oct 2018 15:00:00 + 0100

opsi-linux-client-agent (4.1.0.10-2) stable; urgency=medium

* updated opsi-deploy-client-agent to 4.1.0.1.

-- Niko Wenselowski <n.wenselowski@uib.de> Thu, 10 Jan 2019 18:10:57 +0100

opsi-linux-client-agent (4.1.0.10-1) stable; urgency=medium

* added SLES12SP4 support

-- Mathias Ratdke <m.radtke@uib.de> Thu, 3 Jan 2019 08:22:00 +0100


Code: Alles auswählen

l-opsi-server (4.1.1.9-2); testing; urgency=low

* sles12sp4: corrected opsi-server installation

-- Mathias Radtke <m.radtke@uib.de> Fri, 4 Jan 2019 10:00:00 +0100

l-opsi-server (4.1.1.9-1); testing; urgency=low

* sles12sp4 support added

-- Mathias Radtke <m.radtke@uib.de> Thu, 3 Jan 2019 10:00:00 +0100

l-opsi-server (4.1.1.8-2); testing; urgency=low

* opsi 4.1 & UCS: wait a little bit longer for MySQL socket.

-- Niko Wenselowski <n.wenselowski@uib.de> Thu 20 Dec 2018 16:02:54 +0100

l-opsi-server (4.1.1.8-1); testing; urgency=low

* OpenSUSE Leap 15.0 support added

-- Mathias Radtke <m.radtke@uib.de> Thu 25 Oct 2018 08:00:00 +0200


Code: Alles auswählen

l-opsi-server-migrate 4.1.2-2; testing; urgency=low

* checking exitcode when running zypper dup (SLES/openSUSE)

-- Mathias Radtke <m.radtke@uib.de> Thu 10 Jan 2019 10:55:00 +0100

l-opsi-server-migrate 4.1.2-1; testing; urgency=low

* depotserver migration possible
* new property: opsi-migrate-product-updater-configuration

-- Mathias Radtke <m.radtke@uib.de> Mon 12 Nov 2018 10:55:00 +0100

l-opsi-server-migrate 4.1.1-7; testing; urgency=low

* UCS: upgrading to point release max.

-- Mathias Radtke <m.radtke@uib.de> Fri 29 Jun 2018 09:51:00 +0200

l-opsi-server-migrate 4.1.1-5; testing; urgency=low

* setup.opsiscript: corrected SLES repsotirory bug

-- Mathias Radtke <m.radtke@uib.de> Tue 13 Feb 2018 10:41:00 +0100

l-opsi-server-migrate 4.1.1-5; testing; urgency=low

* setupp.opsiscript: removed old opsi41 repo references

-- Mathias Radtke <m.radtke@uib.de> Thu 08 Feb 2018 14:52:00 +0100


Code: Alles auswählen

sles12sp4 (4.1.0.0-1) testing; urgency=low

* forked from sles12sp3

-- Mathias Radtke <m.radtke@uib.de> Wed Jan 2 2019 13:50:00


Code: Alles auswählen

opsi-linux-bootimage (20181213-1) testing; urgency=medium

* kernel 4.19.7
* added uefi module check

-- Mathias Radtke <m.radtke@uib.de> Mon, 10 Dec 2018 12:27:09 +0100

opsi-linux-bootimage (20181112-1) testing; urgency=medium

* kernel 4.18.18
* disabled IPv6

-- Mathias Radtke <m.radtke@uib.de> Mon, 12 Nov 2018 09:53:47 +0100

opsi-linux-bootimage (20181022-1) testing; urgency=medium

* bootimage uses Ubuntu 18.04 (bionic beaver) base

-- Mathias Radtke <m.radtke@uib.de> Thu, 18 Oct 2018 09:45:54 +0200

opsi-linux-bootimage (20181008-1) testing; urgency=medium

* kernel 4.18.12
* added NVIDIA FB support
* added GPU switching support

-- Mathias Radtke <m.radtke@uib.de> Mon, 08 Oct 2018 13:10:48 +0200

opsi-linux-bootimage (20180928-1) testing; urgency=medium

* kernel 4.18.10

-- Mathias Radtke <m.radtke@uib.de> Fri, 28 Sep 2018 15:51:10 +0200

opsi-linux-bootimage (20180924-1) testing; urgency=medium

* kernel 4.17.19
* added DM Raid modules

-- Mathias Radtke <m.radtke@uib.de> Mon, 24 Sep 2018 13:49:06 +0200


Code: Alles auswählen

l-desktop 4.1.0.2-1 ; stable ; urgency=low

  * Only create netplan configuration if no previous configuration exists.

 -- Niko Wenselowski <n.wenselowski@uib.de> Wed, 29 Jan 2019 15:04:25 +0100


Code: Alles auswählen

opsiconfd (4.1.1.18-1) stable; urgency=medium

  * Overview page: Added link to opsi configed linux installer.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Fri, 01 Feb 2019 13:51:31 +0100

opsiconfd (4.1.1.17-1) testing; urgency=medium

  * Removed support for serving JNLP for use with Java Webstart.
    Java Webstart is about to removed from Java.
  * Overview page: Link configed installer for Windows.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Fri, 18 Jan 2019 11:59:45 +0100


Code: Alles auswählen

opsi4ucs (4.1.1.9-1) testing; urgency=medium

  * Using the code for edit-config-default from python-opsi.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Fri, 18 Jan 2019 16:58:20 +0100

opsi4ucs (4.1.1.8-1) stable; urgency=medium

  * Java Webstart is deprecated. Pointing the link on the UCS overview page
    to the default opsi server overview page.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Mon, 14 Jan 2019 11:15:57 +0100


Code: Alles auswählen

opsi-server (4.1.1.7-1) testing; urgency=medium

  * Using the code for edit-config-default from python-opsi.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Fri, 18 Jan 2019 16:59:57 +0100
opsi development - uib gmbh
For productive opsi installations we recommend support contracts.