CentOS python error solution

Benutzeravatar
SisterOfMercy
Beiträge: 936
Registriert: 22 Jun 2012, 19:18

CentOS python error solution

Beitragvon SisterOfMercy » 07 Jan 2019, 14:51

I was updating the opsi servers and came across this error with yum:

Code: Alles auswählen

looking for ('/bin/python', None, (None, None, None)) as a requirement of opsiconfd.noarch 0:4.1.1.16-2.2 - u
opsiconfd-4.1.1.16-2.2.noarch requires: /bin/python
--> Processing Dependency: /bin/python for package: opsiconfd-4.1.1.16-2.2.noarch
Searching pkgSack for dep: /bin/python
--> Finished Dependency Resolution
Dependency Process ending
Depsolve time: 8.535
Error: Package: opsiconfd-4.1.1.16-2.2.noarch (opsi41)
           Requires: /bin/python
           Removing: python-2.7.5-69.el7_5.x86_64 (@updates)
               Not found
           Updated By: python-2.7.5-76.el7.x86_64 (base)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


I solved this by running: yum update python
After this the normal yum update works again.
Just a small headsup to other CentOS/RHEL users.
Bitte schreiben Sie Deutsch, when I'm responding in the German-speaking part of the forum!