Cant install hwaudit

Maksvell
Beiträge: 11
Registriert: 23 Dez 2017, 11:38

Cant install hwaudit

Beitragvon Maksvell » 26 Dez 2017, 13:11

Hello!

Trying to install hwaudit and getting error.
https://imgur.com/3yfnvQ7

And in log lifes getting Error to:

Code: Alles auswählen

(0)       [4] [Dec 23 22:01:04] Failed to read opsi modules file '/etc/opsi/modules': [Errno 2] No such file or directory: u'/etc/opsi/modules' (Backend.py|421)
(1)       [5] [Dec 23 22:01:04] Application 'opsi-script 4.11.6.15' on client '192.168.4.148' did not send cookie (workers.py|183)
(2)       [5] [Dec 23 22:01:04] New session created (session.py|77)
(3)       [5] [Dec 23 22:01:04] Authorization request from adminuser@192.168.4.148 (application: opsi-script 4.11.6.15) (workers.py|213)
(4)       [5] [Dec 23 22:01:06] Session 'eA5YcX9eEB5oKsp7QsJ5H2NeTWO3H05I' from ip '192.168.4.148', application 'opsi-script 4.11.6.15' deleted (Session.py|225)
(5)       [2] [Dec 23 22:01:06] Traceback: (Logger.py|757)
(6)       [2] [Dec 23 22:01:06]   File "/usr/lib/python2.7/dist-packages/OPSI/Service/Worker.py", line 292, in _errback
(7)           failure.raiseException()
(8)        (Logger.py|757)
(9)       [2] [Dec 23 22:01:06]   File "/usr/lib/python2.7/dist-packages/twisted/internet/defer.py", line 577, in _runCallbacks
(10)          current.result = callback(current.result, *args, **kw)
(11)       (Logger.py|757)
(12)      [2] [Dec 23 22:01:06]   File "/usr/lib/python2.7/dist-packages/opsiconfd/workers.py", line 278, in _authenticate
(13)          raise OpsiAuthenticationError(u"Forbidden: %s" % error)
(14)       (Logger.py|757)
(15)      [2] [Dec 23 22:01:06]      ==>>> Opsi authentication error: Forbidden: Backend authentication error: Backend authentication error: PAM authentication failed for user 'adminuser': ('User not known to the underlying authentication module', 10) (Worker.py|294)

Any idea why?
I'm using Administrator account and he is in the opsiadmin group.

Benutzeravatar
ngbr
Ex-uib-Team
Beiträge: 130
Registriert: 27 Sep 2010, 11:41

Re: Cant install hwaudit

Beitragvon ngbr » 27 Dez 2017, 10:30

Hi Maksvell,

whats your python-opsi Version ?

-
Andre
---
hoping to help :)

if your problem was solved, pls mark this thread as 'SOLVED'. thank you .

-- no PN support --

Andre

Maksvell
Beiträge: 11
Registriert: 23 Dez 2017, 11:38

Re: Cant install hwaudit

Beitragvon Maksvell » 27 Dez 2017, 20:25

Hi!

Em I guess 2.7 python version on opsi server.

Maksvell
Beiträge: 11
Registriert: 23 Dez 2017, 11:38

Re: Cant install hwaudit

Beitragvon Maksvell » 28 Dez 2017, 22:04

Anyone have an idea how to fix the problem?

Benutzeravatar
n.wenselowski
uib-Team
Beiträge: 3120
Registriert: 04 Apr 2013, 12:15

Re: Cant install hwaudit

Beitragvon n.wenselowski » 02 Jan 2018, 11:29

Hi,

see my suggestions here regarding the restarts of the service.


Bye

Niko

PS: Moved to english forums
opsi development - uib gmbh
For productive opsi installations we recommend support contracts.