error installing to actual hardware!

zero0ne
Beiträge: 13
Registriert: 10 Jul 2008, 03:30

error installing to actual hardware!

Beitragvon zero0ne » 14 Aug 2008, 19:28

When i boot up the server install CD this is what happens:

the CD portion itself runs fine. It installs it and then reboots the PC and looks to be fine.

after the reboot when it starts to load linux i get this:

Code: Alles auswählen

begin:  waiting for root filesystem... ...
Done.
           Check root= bootarg cat /proc/cmdline
           or missing modules.  devices: cat /proc/modules ls /dev
ALERT! /dev/hda2/ does not exist. dropping to a shell!

Busybox v 1.1.3 (Debian 1:1.1.3-4) built in shell (ash)
enter 'help' for a list of built-in commands.

/bin/sh: can't access tty: job control turned off
(inittramfs)


any ideas?

zero0ne
Beiträge: 13
Registriert: 10 Jul 2008, 03:30

Re: error installing to actual hardware!

Beitragvon zero0ne » 14 Aug 2008, 19:31

above that, I noticed that it showed up as hdb1 and hdb2 where the CD-ROM and HD are attached / detected.

I am guessing I will need to edit a config file somewhere (probably multiple times) for this to work every time i restart it?

which file and where would be the next question if my guess above is correct.

Devien
Beiträge: 1
Registriert: 27 Aug 2008, 12:27

Re: error installing to actual hardware!

Beitragvon Devien » 27 Aug 2008, 12:32

hello,
i've the same problem. Do someone know how to fix this problem?

Benutzeravatar
d.oertel
uib-Team
Beiträge: 3286
Registriert: 04 Jun 2008, 14:27

Re: error installing to actual hardware!

Beitragvon d.oertel » 29 Aug 2008, 10:04

Hi,

there are some problems between the harddisk handling in the newer boot kernel of the cd and the older Debian Kernel of the installed system.
The boot kernel see all hard disks as e.g. sda the old one works with the difference between hda/sda.
We tried to fix these problem but it may fail on some hardware.
The problem will vanish (we hope) when we change to debian lenny.

In the mean time you may
- install the bas Debian or Ubuntu System by your self
- use other hradware
- use our virtual machine

Does this help ?

detlef oertel
opsi support - uib gmbh

For productive opsi installations we recommend support contracts.
http://www.uib.de
http://www.opsi.org

michel
Beiträge: 1
Registriert: 14 Nov 2008, 08:02

Re: error installing to actual hardware!

Beitragvon michel » 14 Nov 2008, 08:38

Hello,

i've had the same problem, but in my case "/dev/sda2" does not exist.

Code: Alles auswählen

    begin:  waiting for root filesystem... ...
    Done.
               Check root= bootarg cat /proc/cmdline
               or missing modules.  devices: cat /proc/modules ls /dev
    ALERT! /dev/sda2/ does not exist. dropping to a shell!

    Busybox v 1.1.3 (Debian 1:1.1.3-4) built in shell (ash)
    enter 'help' for a list of built-in commands.

    /bin/sh: can't access tty: job control turned off
    (inittramfs)


I fixed it by editing the boot argument to "/dev/hda2".
-> kernel /boot/vmlinuz-2.6.18-6-486 root=/dev/hda2 ro

now it works fine.

nice weekend
michel

Fitzcarraldo
Beiträge: 7
Registriert: 05 Mai 2009, 11:28

Re: error installing to actual hardware!

Beitragvon Fitzcarraldo » 05 Mai 2009, 11:34

michel hat geschrieben:I fixed it by editing the boot argument to "/dev/hda2".
-> kernel /boot/vmlinuz-2.6.18-6-486 root=/dev/hda2 ro

Thank you, Michel!

I've had the same problem when booting the VMware client in VirtualBox 2.2.2 PUEL. After editing the boot arguments in grub it works fine now.

Gernot