Problem with UEFI Modules

o.ferre
Beiträge: 55
Registriert: 19 Nov 2010, 13:58
Wohnort: LYON - France

Problem with UEFI Modules

Beitragvon o.ferre » 01 Okt 2020, 14:36

Hi,

with the new version of opsi-linux-bootimage (20200506-1), I've got a problem with the module UEFI :
"uefi module is not unlocked - aborting".
I thinhk I had the same problem with previous version of opsi-linux-bootimage.
Actually, I use opsi-linux-bootimage version 20180813. But new drivers are not incorporate to this boot image.

(opsi version 4.1 on debian jessie)

thanks for the help
Olivier
O.Ferre
ENS de Lyon

Benutzeravatar
m.radtke
uib-Team
Beiträge: 955
Registriert: 10 Jun 2015, 12:19

Re: Problem with UEFI Modules

Beitragvon m.radtke » 01 Okt 2020, 15:12

Hi

can you provide a log where I can check it?

basically what the bootimage does: it checks the backend for modules and realmodules and parses the output and looks for uefi in it. As long as it is not false, it should work.
You can also send me your output from

Code: Alles auswählen

opsi-admin -d method backend_info

via mail m.radtke@uib.de
So I can check it against the implemented code

regards
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

o.ferre
Beiträge: 55
Registriert: 19 Nov 2010, 13:58
Wohnort: LYON - France

[SOLVED] Re: Problem with UEFI Modules

Beitragvon o.ferre » 02 Okt 2020, 10:40

Hi,
with the help of Mathias, I see my mistake !!
The uefi module file was named modules.asc (in /etc/opsi) ! perharps a bad download from email client.
I renamed the file modules and everithing seems good !
thanks to Mathias,

best regards,
Olivier
O.Ferre
ENS de Lyon