Unable to see files in Depot from Windows machines

mmikelas
Beiträge: 2
Registriert: 19 Jun 2020, 17:52

Unable to see files in Depot from Windows machines

Beitragvon mmikelas » 19 Jun 2020, 17:57

Followed the Getting started guide for v4.1 and installed on CentOS7... everything went fine, no errors. But when I'm attempting to install the opsi client agent from any remote Windows machine, I see the folder structure in the network share, but see none of the files that I see exist in the same directory on the Opsi host machine.

What am I missing?

Benutzeravatar
SisterOfMercy
Beiträge: 1196
Registriert: 22 Jun 2012, 19:18

Re: Unable to see files in Depot from Windows machines

Beitragvon SisterOfMercy » 22 Jun 2020, 02:11

Try :
# opsi-setup --set-rights

Check to see if selinux is in permissive mode for now:
# sestatus
Set to permissive for current session:
# setenforce 0
Install package to see selinux errors in /var/log/messages:
# yum install setroubleshoot-server
Permanently set selinux to permissive:
# vi /etc/selinux/config
SELINUX=permissive

Or you could try selinux booleans, but I have not fully checked that all out:
# setsebool -P samba_export_all_rw on
Bitte schreiben Sie Deutsch, when I'm responding in the German-speaking part of the forum!

mmikelas
Beiträge: 2
Registriert: 19 Jun 2020, 17:52

Re: Unable to see files in Depot from Windows machines

Beitragvon mmikelas » 22 Jun 2020, 15:05

Thank you!

It's was selinux set in enforcement mode.

The second I ran setenforce 0 - I saw the files immediately appear in a session I had open on a Win7 box.

So I set selinux permanently to permissive and am now eagerly looking to start leveraging OPSI to make the overall management of the guests in my home lab much more streamlined.