UEFI install getting stuck on HP workstation/laptops

ttblum
Beiträge: 71
Registriert: 23 Jun 2017, 14:18
Wohnort: Cleveland, Ohio USA

UEFI install getting stuck on HP workstation/laptops

Beitragvon ttblum » 29 Mär 2018, 17:16

Hello,

I am able to unattended install Windows 10 OK (win10-x64) on different models of Dell and HP worksations using an Opsi UEFI license.

However, when I deploy to HPs it boots to the following screen after Windows installs showing:

Code: Alles auswählen

X:\windows\system32>c:\opsi\startnet.cmd
The system cannot file the the path specified.

X\windows\system32>


https://prnt.sc/iy2rkm

I am able to deploy to Dell workstation and laptops OK, it boots straight to Windows at this point.

ttblum
Beiträge: 71
Registriert: 23 Jun 2017, 14:18
Wohnort: Cleveland, Ohio USA

Re: UEFI install getting stuck on HP workstation/laptops

Beitragvon ttblum » 29 Mär 2018, 17:49

If I go into BIOS and select:

Main-->Apply Custom Defaults and Exit

it then boots into an HP logo screen with 'Configuring devices 46%' etc. and boots up normally.

Benutzeravatar
m.radtke
Beiträge: 607
Registriert: 10 Jun 2015, 12:19

Re: UEFI install getting stuck on HP workstation/laptops

Beitragvon m.radtke » 30 Mär 2018, 12:13

Hi
does your machine have an NVME or M.2 drive?
If yes, ist the storage driver integrated into your WinPE?
This is the most common cause for this error

Cheers
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

ttblum
Beiträge: 71
Registriert: 23 Jun 2017, 14:18
Wohnort: Cleveland, Ohio USA

Re: UEFI install getting stuck on HP workstation/laptops

Beitragvon ttblum » 30 Mär 2018, 15:28

Hello,

The HP EliteBook 840 G4, EliteDesk 800 G3 TWR, and EliteDesk 800 G3 SFF all have the same NVMe controller:

Samsung NVMe SSD Controller SM961/PM961 controller

We are using the WinPE provided by Opsi:

https://download.uib.de/abo/winpe_uefi

Benutzeravatar
m.radtke
Beiträge: 607
Registriert: 10 Jun 2015, 12:19

Re: UEFI install getting stuck on HP workstation/laptops

Beitragvon m.radtke » 03 Apr 2018, 11:36

Hi

this WinPE does not have the specific NVME drivers.
You will have to integrate them yourself.

We will talk about an update of the WINPE in the next developer meeting. Afterwards we will most probably update it.

Cheers
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

Benutzeravatar
SisterOfMercy
Beiträge: 917
Registriert: 22 Jun 2012, 19:18

Re: UEFI install getting stuck on HP workstation/laptops

Beitragvon SisterOfMercy » 10 Mai 2018, 02:07

There could also be an issue with your bios and boot order. I have something like that.

The installation goes fine, but then it reboots into the same opsi temporary PE. If I then go into the bios and set the hard drive priority to windows boot manager it will work fine.
Windows 10 might fall back on the default NVMe driver, I'm not sure.

So the question is, does the first part of the windows setup work correctly?
Bitte schreiben Sie Deutsch, when I'm responding in the German-speaking part of the forum!