driver scripts fails

Benutzeravatar
SisterOfMercy
Beiträge: 1169
Registriert: 22 Jun 2012, 19:18

Re: driver scripts fails

Beitragvon SisterOfMercy » 28 Sep 2020, 12:25

bobzbobz hat geschrieben:All new packages are now installed.
The problem still persists.


Sorry, I am a moron. Opsi-utils is of course a package that is not updated via opsi-package-manager, but via the package manager of your distro. Could you please update those too?
Bitte schreiben Sie Deutsch, when I'm responding in the German-speaking part of the forum!

bobzbobz
Beiträge: 149
Registriert: 30 Nov 2012, 10:41
Wohnort: Denmark

Re: driver scripts fails

Beitragvon bobzbobz » 28 Sep 2020, 12:37

Newest OPSI-utils is installed. We also tried a reinstall.
The problem still persists.
Please help others by sharing your scripts on the OPSI-Wiki.

Benutzeravatar
wolfbardo
uib-Team
Beiträge: 1186
Registriert: 01 Jul 2008, 12:10

Re: driver scripts fails

Beitragvon wolfbardo » 28 Sep 2020, 14:43

What is the Output of

Code: Alles auswählen

python -V


regards,
Bardo Wolf


opsi remote-workshops

https://uib.de/de/support-schulung/schulung/

Basis
22.-25.6.2020
14.-17.9. 2020

Einführung in die Software-Paketierung
25.-26.8. 2020

opsi support by uib gmbh

http://www.uib.de

bobzbobz
Beiträge: 149
Registriert: 30 Nov 2012, 10:41
Wohnort: Denmark

Re: driver scripts fails

Beitragvon bobzbobz » 28 Sep 2020, 14:45

Python 2.7.17
Please help others by sharing your scripts on the OPSI-Wiki.

Benutzeravatar
SisterOfMercy
Beiträge: 1169
Registriert: 22 Jun 2012, 19:18

Re: driver scripts fails

Beitragvon SisterOfMercy » 30 Sep 2020, 21:31

I haven't gotten a clue :(
Can you run this:

Code: Alles auswählen

opsi-setup --init-current-config
Bitte schreiben Sie Deutsch, when I'm responding in the German-speaking part of the forum!

bobzbobz
Beiträge: 149
Registriert: 30 Nov 2012, 10:41
Wohnort: Denmark

Re: driver scripts fails

Beitragvon bobzbobz » 01 Okt 2020, 11:49

That command gave me this output:
[5] [Oct 01 11:47:08] Creating opsi base (SQL.py|498)
[5] [Oct 01 11:47:08] Setting up default values. (ConfigurationData.py|81)
[5] [Oct 01 11:47:09] Finished setting up default values. (ConfigurationData.py|89)

[4] [Oct 01 11:47:09] You have an old depot directory present. Using /opt/pcbin/install is depracted, please use /var/lib/opsi/depot instead. (InitializeBackend.py|185)
[5] [Oct 01 11:47:09] Configuring client user pcpatch (opsi-setup|146)
[5] [Oct 01 11:47:09] Creating RSA private key for user pcpatch in '/var/lib/opsi/.ssh/id_rsa' (opsi-setup|160)
[5] [Oct 01 11:47:09] Setting rights on directory '/var/lib/opsi/.ssh' (Rights.py|117)
Please help others by sharing your scripts on the OPSI-Wiki.

Benutzeravatar
SisterOfMercy
Beiträge: 1169
Registriert: 22 Jun 2012, 19:18

Re: driver scripts fails

Beitragvon SisterOfMercy » 02 Okt 2020, 21:05

bobzbobz hat geschrieben:That command gave me this output:
[5] [Oct 01 11:47:08] Creating opsi base (SQL.py|498)
[5] [Oct 01 11:47:08] Setting up default values. (ConfigurationData.py|81)
[5] [Oct 01 11:47:09] Finished setting up default values. (ConfigurationData.py|89)

[4] [Oct 01 11:47:09] You have an old depot directory present. Using /opt/pcbin/install is depracted, please use /var/lib/opsi/depot instead. (InitializeBackend.py|185)
[5] [Oct 01 11:47:09] Configuring client user pcpatch (opsi-setup|146)
[5] [Oct 01 11:47:09] Creating RSA private key for user pcpatch in '/var/lib/opsi/.ssh/id_rsa' (opsi-setup|160)
[5] [Oct 01 11:47:09] Setting rights on directory '/var/lib/opsi/.ssh' (Rights.py|117)


I noticed you were using /opt/pcbin/install, that is why I asked for the package versions. I was wondering if you were on an old version. After this command the driver script still doesn't work, right?
Does the directory /usr/lib/python2.7/site-packages/OPSI exist and does it have files?
Bitte schreiben Sie Deutsch, when I'm responding in the German-speaking part of the forum!

bobzbobz
Beiträge: 149
Registriert: 30 Nov 2012, 10:41
Wohnort: Denmark

Re: driver scripts fails

Beitragvon bobzbobz » 12 Okt 2020, 13:42

Yeah the scripts still dont work after the init-command.

The folder "site-packages" does'nt exist in the path /usr/lib/python2.7
Please help others by sharing your scripts on the OPSI-Wiki.

Benutzeravatar
SisterOfMercy
Beiträge: 1169
Registriert: 22 Jun 2012, 19:18

Re: driver scripts fails

Beitragvon SisterOfMercy » 12 Okt 2020, 21:40

bobzbobz hat geschrieben:The folder "site-packages" does'nt exist in the path /usr/lib/python2.7


Either it is in a different location, because you're on ubuntu and I was looking at my own CentOS installation, or your python environment is buggered. Have you already tried reinstalling all python packages?
Bitte schreiben Sie Deutsch, when I'm responding in the German-speaking part of the forum!

bobzbobz
Beiträge: 149
Registriert: 30 Nov 2012, 10:41
Wohnort: Denmark

Re: driver scripts fails

Beitragvon bobzbobz » 13 Okt 2020, 12:18

We think the problem is finally solved..
The scripts were calling python 3.x in the first line.
This was changed and now it seems to work.

Thank you for your help.
Please help others by sharing your scripts on the OPSI-Wiki.