Unsupported 16-bit application when installing OPSI agent on Windows 10 1709

rmtevesjr
Beiträge: 55
Registriert: 12 Jul 2012, 14:57

Unsupported 16-bit application when installing OPSI agent on Windows 10 1709

Beitragvon rmtevesjr » 07 Feb 2018, 00:17

Hi,
Does anyone encountered this error in Windows 10 1709 build? Unsupported 16-bit application when installing the agent. The program or feature "\??\c\opsi.org\tmp\opsi-winst\winst32.exe cannot start or run due to incompatibility win 64-bit versions of Windows. Please contact the vendor to ask if 64-bit Windows version is available".
Thanks

Benutzeravatar
n.wenselowski
Beiträge: 2772
Registriert: 04 Apr 2013, 12:15

Re: Unsupported 16-bit application when installing OPSI agent on Windows 10 1709

Beitragvon n.wenselowski » 07 Feb 2018, 11:41

Hi

opsi-script (aka. opsi-winst) is 32bit and probably we currently do not have plans to make it a 64bit application as we do not see that we would gain any benefits from this.
But it being detected as 16bit is something new for me :shock:

What version of opsi-winst are you using?
Did you already try to update it to the latest version?


Kind regards

Niko
Kein Support per DM!
_________________________
opsi support - uib gmbh
For productive opsi installations we recommend support contracts.

rmtevesjr
Beiträge: 55
Registriert: 12 Jul 2012, 14:57

Re: Unsupported 16-bit application when installing OPSI agent on Windows 10 1709

Beitragvon rmtevesjr » 12 Feb 2018, 06:15

Hi Niko, we are using Winst version 4.11.6.11 / OPSI 4.0.7. I haven't tried to use the updated version. Should I download the agent from repository and install it? Is there a need update the server component? Thanks.

Benutzeravatar
n.wenselowski
Beiträge: 2772
Registriert: 04 Apr 2013, 12:15

Re: Unsupported 16-bit application when installing OPSI agent on Windows 10 1709

Beitragvon n.wenselowski » 19 Feb 2018, 14:49

Hi,

rmtevesjr hat geschrieben:Should I download the agent from repository and install it?

Absolutely!
This should be your first attempt in fixing if something is wrong with our components ;)

rmtevesjr hat geschrieben:Is there a need update the server component?

Probably no need but it never hurts having the latest version ;)


Bye

Niko
Kein Support per DM!
_________________________
opsi support - uib gmbh
For productive opsi installations we recommend support contracts.