Problem mit tftp und named pipes

hifstore
Beiträge: 9
Registriert: 21 Apr 2016, 10:39

Problem mit tftp und named pipes

Beitragvon hifstore » 13 Dez 2017, 16:54

Hallo,

wir haben folgendes Problem: PXE-Boot findet nie die named pipes die nötig wären für OS-Installation, aber der Rest funktioniert komischerweise...

Ich habe dann fogendes versucht: mit eine simplen tftp client (tftpd64 unter windows) kann ich alle Dateien in /tftpd/linux/pxelinux.cfg laden, ausser eben die named pipes, da gibt es den tftp Fehler "Error #1: File not found"

opsi-set-rights auch gemacht. An SELinux gedacht, aber das kann es nicht sein, denke ich, denn die anderen Dateien gehen ja.

Hier das Verzeichnis:

Code: Alles auswählen

[root@opsi-server pxelinux.cfg]# ls -Z .
prw-rw-r--. opsiconfd pcpatch system_u:object_r:tftpdir_t:s0   01-50-9a-4c-55-53-d5
lrwxrwxrwx. opsiconfd pcpatch unconfined_u:object_r:tftpdir_t:s0 default -> default.menu
-rw-rw-r--. opsiconfd pcpatch system_u:object_r:tftpdir_t:s0   default.menu
-rw-rw-r--. opsiconfd pcpatch system_u:object_r:tftpdir_t:s0   default.nomenu
-rw-rw-r--. opsiconfd pcpatch system_u:object_r:tftpdir_t:s0   elilo.conf
-rw-rw-r--. opsiconfd pcpatch system_u:object_r:tftpdir_t:s0   elilo.efi
-rw-rw-r--. opsiconfd pcpatch system_u:object_r:tftpdir_t:s0   elilo-x86.efi
-rw-rw-r--. opsiconfd pcpatch system_u:object_r:tftpdir_t:s0   install
-rw-rw-r--. opsiconfd pcpatch system_u:object_r:tftpdir_t:s0   install3264
-rw-rw-r--. opsiconfd pcpatch system_u:object_r:tftpdir_t:s0   install-elilo-x64
-rw-rw-r--. opsiconfd pcpatch system_u:object_r:tftpdir_t:s0   install-elilo-x86
-rw-rw-r--. opsiconfd pcpatch system_u:object_r:tftpdir_t:s0   install-x64


opsipxeconfd habe ich neu gestartet, auch die ganze Maschine, aber das Problem bleibt.

OS ist CentOS 7. OPSI Version 4.0.7.45

Ich habe beobachtet, dass wenn die Pipes erstellt werden, sie dem User root gehören. Ein opsi-set-rights tut das dann richtig machen, so wie man es oben sieht. Vieleicht hat es etwas mit dem Problem zu tun.

Kennt jamand dieses Problem und kann weiter helfen? Wo würde man die Log-Meldungen zum tftpd finden?

Vielen Dank
Gruss
Fabrizio

hifstore
Beiträge: 9
Registriert: 21 Apr 2016, 10:39

Re: Problem mit tftp und named pipes

Beitragvon hifstore » 14 Dez 2017, 10:58

So, ich habe das Problem doch noch selber gelöst. ;) Es liegt am verhalten von SElinux auf Centos 7

Eigentlich ist die Standard-Policy für tftp ok, die Contexts für tftpd und für das Verzeichnis /tftpboot stimmen ebenfalls. Für "normale" files funktioniert es problemlos, aber nicht für target type: fifo_file, also gerade für die hier benötigten named pipes :? Offensichtlich unterscheidet SElinux das, wieso weiss ich nicht...

Lösung: erstelle eine angepasste Policy und aktiviere diese:

Code: Alles auswählen

ausearch -c 'in.tftpd' --raw | audit2allow -M my-intftpd
semodule -i my-intftpd.pp


Gruss
Fabrizio


Zurück zu „Freier Support“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast