opsi client agent startet zu spät bzw. garnicht

weener
Beiträge: 8
Registriert: 02 Aug 2017, 17:54

Re: opsi client agent startet zu spät bzw. garnicht

Beitragvon weener » 22 Aug 2017, 18:10

Danke für Eure Hilfe. Wir werden das kurzfristig mal testen...

rat
Beiträge: 264
Registriert: 01 Jan 2015, 12:40

Re: opsi client agent startet zu spät bzw. garnicht

Beitragvon rat » 23 Aug 2017, 10:12

Guten Morgen

Bei mir geht es seit gestern auch (nicht) mehr.

Der Login ist kurz gesperrt (ohne dem opsi-logo), er installiert nichts und wenn ich die Dienste kontrolliere, dann läuft der Dämon nicht (ist aber auf automatisch gestellt). Bis Vorgestern hats funktioniert.

Zuerst dachte ich an die Hardware, meine drei HP 8300er machen eigentlich immer irgendwas etwas anders :o Ich habe jedoch vor ca 2 Wochen ein paar HP 7900 mit genau diesem Image betankt, die laufen und die vier von gestern laufen auch nicht. :cry:

Eine Neuinstallation des Client-Agents (manuell) brachte keine Änderung

Client: Win10x64 1703

Opsi auf Ubuntu 16.04,inklusive aller Updates und den client-agent auf die 19er



UPDATE: Ein paar gehen doch. Beim ersten Mal anmelden wird man gefragt, ob der PC im Netz gefunden werden soll -> ja -> Neustart und er tut, bei zwei wurde ich nicht gefragt, die tun (noch) nicht.

Nächstes Update: "Jetzt hauts ma des Hei owa". Einen der nicht funktionierenden habe ich mir geholt, steht seit gestern neben mir und hat nicht weitergetan. Jetzt habe ich mich um die anderen gekümmert und in der Zwischenzeit hat er getan was er tun sollte :o Lief aber die ganze Nacht, abgesehen von ein paar von mir gemachten Neustarts, durch :o

Benutzeravatar
n.wenselowski
uib-Team
Beiträge: 3195
Registriert: 04 Apr 2013, 12:15

Re: opsi client agent startet zu spät bzw. garnicht

Beitragvon n.wenselowski » 23 Aug 2017, 12:36

Hi,

rat hat geschrieben:Der Login ist kurz gesperrt (ohne dem opsi-logo), er installiert nichts und wenn ich die Dienste kontrolliere, dann läuft der Dämon nicht (ist aber auf automatisch gestellt). Bis Vorgestern hats funktioniert.

Von der Beschreibung her eher ein anderes Problem, da in diesem Thread der opsiclientd läuft.
Bitte mal den Vorschlägen unter Service Abhängigkeit: opsiclientd Dienst in Windows 10 nicht gestartet folgen.


Gruß

Niko

Code: Alles auswählen

import OPSI

weener
Beiträge: 8
Registriert: 02 Aug 2017, 17:54

Re: opsi client agent startet zu spät bzw. garnicht

Beitragvon weener » 24 Aug 2017, 08:53

weener hat geschrieben:Wir werden das kurzfristig mal testen...

...haben wir nun gemacht. In unserer Testumgebung hat es auf Anhieb funktioniert. Alles wieder "wie früher".
Werden das ganze jetzt mal in die Produktivumgebungen bringen.

Vielen Dank!

Michael

Benutzeravatar
n.wenselowski
uib-Team
Beiträge: 3195
Registriert: 04 Apr 2013, 12:15

Re: opsi client agent startet zu spät bzw. garnicht

Beitragvon n.wenselowski » 24 Aug 2017, 12:18

Hallo Michael,

weener hat geschrieben:
weener hat geschrieben:Wir werden das kurzfristig mal testen...

...haben wir nun gemacht. In unserer Testumgebung hat es auf Anhieb funktioniert. Alles wieder "wie früher".
Werden das ganze jetzt mal in die Produktivumgebungen bringen.

Danke für die Rückmeldung!


Viele Grüße

Niko

Code: Alles auswählen

import OPSI

RogerSik
Beiträge: 14
Registriert: 26 Mär 2015, 10:52

Re: opsi client agent startet zu spät bzw. garnicht

Beitragvon RogerSik » 10 Okt 2017, 16:42

Bei mir hat diese Agent Version leider nicht geholfen. Habe hierzu (mit Logs) einen neuen Thread aufgemacht.
viewtopic.php?f=7&t=9589
Zuletzt geändert von n.wenselowski am 10 Okt 2017, 16:54, insgesamt 1-mal geändert.
Grund: Link verweist nun auf offizielle Adresse des Forums.

ThomasA
Beiträge: 29
Registriert: 14 Feb 2018, 09:35
Wohnort: Dresden

Re: opsi client agent startet zu spät bzw. garnicht

Beitragvon ThomasA » 09 Mai 2018, 17:12

Hallo,

sorry für das Hervorholen des alten Threads, aber leider tritt das Problem bei mir jetzt auf mindestens einem Client unter Windows 10 1709 ebenfalls auf.
Da ich hier den 4.0 stable Zweig einsetze, läuft auch opsi-client-agent 4.0.7.24-3. Da sollte das Problem doch eigentlich nicht auftreten?
Hier mal das Loginblocker.log, vielleicht hat ja jemand einen Hinweis auf die Ursache.

Gruß
Thomas


Code: Alles auswählen

[5] 2018-05-09 16:49:50 ------------------------------------------------------------------------------------
[5] 2018-05-09 16:49:50 START OpsiLoginBlocker
[5] 2018-05-09 16:49:50 ------------------------------------------------------------------------------------
[5] 2018-05-09 16:49:50 Getting config from registry
[5] 2018-05-09 16:49:50 LoginBlockerLogLevel is: 5
[5] 2018-05-09 16:49:50 Read LoginBlockerLogDir from Registry and switch to Logfile 'c:\opsi.org\log'
[5] 2018-05-09 16:49:50 According to LoginBlockerLogDir Logfile='c:\opsi.org\log\opsi_loginblocker.log'
[5] 2018-05-09 16:49:50 LoginBlockerStart is: 1
[5] 2018-05-09 16:49:50 LoginBlockerTimeoutConnect is: 120 seconds
[5] 2018-05-09 16:49:50 Config read from registry.
[5] 2018-05-09 16:49:50 handleLogfileAging started.
[5] 2018-05-09 16:49:50 Check logfile age: 9.5.2018 - current date: 9.5.2018
[5] 2018-05-09 16:49:50 ------------------------------------------------------------------------
[5] 2018-05-09 16:49:50 Keep current logfile.
[5] 2018-05-09 16:49:50 ------------------------------------------------------------------------
[5] 2018-05-09 16:49:50 OS Version: 10.0 (unknown version)
[5] 2018-05-09 16:49:50 Filtering credential providers
[5] 2018-05-09 16:49:50 Registry: start of opsiclientd service is enabled, waiting for service to start ...
[5] 2018-05-09 16:49:50 Service opsiclientd is running (SERVICE_RUNNING).
[5] 2018-05-09 16:49:51 Stop blocking!
opsi Version 4.1 - MySQL Backend - WAN Extension - Directory Connector

Benutzeravatar
d.oertel
uib-Team
Beiträge: 3278
Registriert: 04 Jun 2008, 14:27

Re: opsi client agent startet zu spät bzw. garnicht

Beitragvon d.oertel » 09 Mai 2018, 17:24

Hi,

wie sieht es mit dieser (Testing) Version vom opsi-client-agent aus:
https://download.uib.de/opsi4.0/testing/opsi-v407/products/localboot/opsi-client-agent_4.1.0.0-4.opsi

Bitte um Rückmeldung

Danke

d.oertel
opsi support - uib gmbh

For productive opsi installations we recommend support contracts.
http://www.uib.de
http://www.opsi.org

ThomasA
Beiträge: 29
Registriert: 14 Feb 2018, 09:35
Wohnort: Dresden

Re: opsi client agent startet zu spät bzw. garnicht

Beitragvon ThomasA » 11 Mai 2018, 14:16

Hallo,

leider werde ich frühestens in einem Monat Zeit für einen Test haben - sorry.
Was mir aber jetzt schon aufgefallen ist, dass es bei dem betroffenen Client inzwischen scheinbar auch wieder normal funktioniert.
Was zwischendurch, als es nicht funktioniert hat, allerdings mal auftauchte waren Windows Updates die installiert wurden. Seitdem scheint es wieder zu klappen.

Gruß
Thomas
opsi Version 4.1 - MySQL Backend - WAN Extension - Directory Connector