[SOLVED] UEFI-Boot: near line 4: Unknown option

mercutio
Beiträge: 11
Registriert: 26 Jan 2017, 08:35

[SOLVED] UEFI-Boot: near line 4: Unknown option

Beitragvon mercutio » 26 Jan 2017, 08:39

Guten Tag,
ich habe Probleme das UEFI-Boot in opsi einzurichten.
Ich bin gemäß Handbuch Punkt 9.4 vorgegangen.

Es kommt beim UEFI-Boot zu folgender Meldung:

near line 4: Unknown option
forcing interactive mode due to config file error(s)
ELILO boot:.............


Kann mir jemand einen Tip geben woran es liegen könnte?
Vielen Dank!

Aktuelle Umgebung:
DHCP-Server Windows Server 2012 R2

067 Name der Startdatei Standard /tftpboot/linux/pxelinux.0 Richtlinienname: PXE BootFile Legacy BIOS
067 Name der Startdatei Standard /tftpboot/linux/pxelinux.cfg/elilo.efi

Richtlinienname: PXE BootFile Legacy BIOS
Bedingung: Herstellerklasse ist gleich Legacy BIOS
Optionen 067 - Zeichenfolge: /tftpboot/linux/pxelinux.0
Zuletzt geändert von mercutio am 08 Mai 2017, 15:26, insgesamt 3-mal geändert.

Benutzeravatar
m.radtke
uib-Team
Beiträge: 758
Registriert: 10 Jun 2015, 12:19

Re: UEFI-Boot: near line 4: Unknown option

Beitragvon m.radtke » 26 Jan 2017, 09:27

Hi

Tritt der Fehler beim normalen booten auf? Was sind für Festplatten verbaut? Normal/SSD oder NVME/M2?
Oder beim Versuch PXE zu booten?

Sind die Clients im Configed als UEFI Clients markiert?
Was gibt denn das Syslog auf dem Opsi Server aus?

Gruß
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

mercutio
Beiträge: 11
Registriert: 26 Jan 2017, 08:35

Re: UEFI-Boot: near line 4: Unknown option

Beitragvon mercutio » 26 Jan 2017, 12:13

Hallo,
ich möchte ein Notebook von PXE booten und ein Netboot-Produkt installieren.
Es handelt sich um ein Notebook Fujitsu Lifebook E756.
Als Festplatte ist eine SanDisk SD7TB6S-256G-1016 (SSD 256GB) verbaut.
Das Problem tritt auf, wenn ich von PXE boote.
Den Client habe ich am opsi-Server angelegt.
Hier habe ich den DNS-Namen eingetragen und die IP-Adresse,die vom DHCP-Windows-Server vergeben wurde.
Ebenfalls habe ich den Haken "Uefi Boot" gesetzt.
Das Feld "opsi-MAC-Adresse" habe ich frei gelassen.

Einträge syslog:
Jan 26 09:59:26 hornopsi01 in.tftpd[13419]: connect from 172.27.1.110 (172.27.1.110)
Jan 26 09:59:26 hornopsi01 atftpd[13419]: Advanced Trivial FTP server started (0.7)
Jan 26 09:59:26 hornopsi01 atftpd[13419]: Serving /tftpboot/linux/pxelinux.cfg/elilo.efi to 172.27.1.110:1703
Jan 26 09:59:26 hornopsi01 atftpd[13419]: Serving /tftpboot/linux/pxelinux.cfg/elilo.efi to 172.27.1.110:1704
Jan 26 09:59:27 hornopsi01 atftpd[13419]: Serving /tftpboot/linux/pxelinux.cfg/AC1B016E.conf to 172.27.1.110:1705
Jan 26 09:59:27 hornopsi01 atftpd[13419]: Serving /tftpboot/linux/pxelinux.cfg/AC1B01-x86_64.conf to 172.27.1.110:1706
Jan 26 09:59:27 hornopsi01 atftpd[13419]: Serving /tftpboot/linux/pxelinux.cfg/AC1B01.conf to 172.27.1.110:1707
Jan 26 09:59:27 hornopsi01 atftpd[13419]: Serving /tftpboot/linux/pxelinux.cfg/AC1B-x86_64.conf to 172.27.1.110:1708
Jan 26 09:59:27 hornopsi01 atftpd[13419]: Serving /tftpboot/linux/pxelinux.cfg/AC1B.conf to 172.27.1.110:1709
Jan 26 09:59:27 hornopsi01 atftpd[13419]: Serving /tftpboot/linux/pxelinux.cfg/AC-x86_64.conf to 172.27.1.110:1710
Jan 26 09:59:27 hornopsi01 atftpd[13419]: Serving /tftpboot/linux/pxelinux.cfg/AC.conf to 172.27.1.110:1711
Jan 26 09:59:27 hornopsi01 atftpd[13419]: Serving /tftpboot/linux/pxelinux.cfg/01-fc-08-4a-6a-04-11 to 172.27.1.110:1712
Jan 26 09:59:27 hornopsi01 atftpd[13419]: Serving /tftpboot/linux/pxelinux.cfg/elilo-x86_64.conf to 172.27.1.110:1713
Jan 26 09:59:27 hornopsi01 atftpd[13419]: Serving /tftpboot/linux/pxelinux.cfg/elilo.conf to 172.27.1.110:1714
Jan 26 09:59:54 hornopsi01 atftpd[13419]: Serving /tftpboot/linux/pxelinux.cfg/elilo.efi to 172.27.1.110:1926
Jan 26 09:59:54 hornopsi01 atftpd[13419]: Serving /tftpboot/linux/pxelinux.cfg/elilo.efi to 172.27.1.110:1927
Jan 26 09:59:54 hornopsi01 atftpd[13419]: Serving /tftpboot/linux/pxelinux.cfg/AC1B016E.conf to 172.27.1.110:1928
Jan 26 09:59:54 hornopsi01 atftpd[13419]: Serving /tftpboot/linux/pxelinux.cfg/AC1B01-x86_64.conf to 172.27.1.110:1929
Jan 26 09:59:54 hornopsi01 atftpd[13419]: Serving /tftpboot/linux/pxelinux.cfg/AC1B01.conf to 172.27.1.110:1930
Jan 26 09:59:54 hornopsi01 atftpd[13419]: Serving /tftpboot/linux/pxelinux.cfg/AC1B-x86_64.conf to 172.27.1.110:1931
Jan 26 09:59:54 hornopsi01 atftpd[13419]: Serving /tftpboot/linux/pxelinux.cfg/AC1B.conf to 172.27.1.110:1932
Jan 26 09:59:54 hornopsi01 atftpd[13419]: Serving /tftpboot/linux/pxelinux.cfg/AC-x86_64.conf to 172.27.1.110:1933
Jan 26 09:59:54 hornopsi01 atftpd[13419]: Serving /tftpboot/linux/pxelinux.cfg/AC.conf to 172.27.1.110:1934
Jan 26 09:59:54 hornopsi01 atftpd[13419]: Serving /tftpboot/linux/pxelinux.cfg/01-fc-08-4a-6a-04-11 to 172.27.1.110:1935
Jan 26 09:59:54 hornopsi01 atftpd[13419]: Serving /tftpboot/linux/pxelinux.cfg/elilo-x86_64.conf to 172.27.1.110:1936
Jan 26 09:59:54 hornopsi01 atftpd[13419]: Serving /tftpboot/linux/pxelinux.cfg/elilo.conf to 172.27.1.110:1937
Jan 26 10:04:54 hornopsi01 atftpd[13419]: atftpd terminating after 300 seconds
Jan 26 10:04:54 hornopsi01 atftpd[13419]: Main thread exiting


Vielen Dank!

Benutzeravatar
m.radtke
uib-Team
Beiträge: 758
Registriert: 10 Jun 2015, 12:19

Re: UEFI-Boot: near line 4: Unknown option

Beitragvon m.radtke » 26 Jan 2017, 15:33

natürlich musst du eine mac adresse eintragen damit der TFTP-Server auch weiss welchem Client er welche Konfiguration schicken soll

Gruß
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

mercutio
Beiträge: 11
Registriert: 26 Jan 2017, 08:35

Re: UEFI-Boot: near line 4: Unknown option

Beitragvon mercutio » 26 Jan 2017, 15:41

PERFEKT FUNKTIONIERT!

Danke!!!!

Benutzeravatar
m.radtke
uib-Team
Beiträge: 758
Registriert: 10 Jun 2015, 12:19

Re: UEFI-Boot: near line 4: Unknown option

Beitragvon m.radtke » 26 Jan 2017, 16:22

Freut mich das es klappt.
Ändere den ForenTopis doch bitte in [SOLVED] TITEL sodass klar ist dass dieses Problem gelöst ist.

gruß
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

Benutzeravatar
SisterOfMercy
Beiträge: 1016
Registriert: 22 Jun 2012, 19:18

Re: [SOLVED] UEFI-Boot: near line 4: Unknown option

Beitragvon SisterOfMercy » 28 Jan 2017, 00:55

I have had this problem too.
I only tried it with a computer that needed uefi boot because of the nvme drive.

elilo.conf is this by default:

Code: Alles auswählen

default=local

label=local
root=/dev/sda1 


Is this trying to start from the first drive when there's nothing to do like the normal opsi pxe boot?
Is there at all a bootmenu possible with elilo?
Bitte schreiben Sie Deutsch, when I'm responding in the German-speaking part of the forum!

Benutzeravatar
m.radtke
uib-Team
Beiträge: 758
Registriert: 10 Jun 2015, 12:19

Re: [SOLVED] UEFI-Boot: near line 4: Unknown option

Beitragvon m.radtke » 08 Mai 2017, 15:17

The problem you are ecountering is the following:

the pxe boot soent get a pipe and then loads the default, as in MBR Boot the default.menu.
Elilo is different, compared to syslinux.
On syslinux you can say

Code: Alles auswählen

localboot 0


to boot the local drive
This is different in elilo.
Elilo doesn't specify a dynamic localboot. One always has to specify the boot drive, in this case

Code: Alles auswählen

/dev/sda1

If you only use elilo for these NVME devices you should change the line conainint sda1 to the following

Code: Alles auswählen

/dev/nvme0np1


Otherwise you would have to change the boot order to boot from disk instead of pxe

Cheers
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

Benutzeravatar
m.radtke
uib-Team
Beiträge: 758
Registriert: 10 Jun 2015, 12:19

Re: [SOLVED] UEFI-Boot: near line 4: Unknown option

Beitragvon m.radtke » 24 Okt 2017, 08:33

Hi

eine Neuigkeit zu dem Thema.
Ich habe ein wenig mit elilo gespielt und wohl eine Lösung bereit.
Der Timeout bei elilo ist per default unendlich. Den habe ich nun auf 2 Sekunden gesetzt. Auf einer unserer Testmaschinen mit NVME meckert elilo zwar das irgendwas an der Config kaputt ist und nun der interaktive Modus gestartet wird. Nach 2 Sekunden wird aber der nächste Boot Eintrag aus dem UEFI genommen.

Ich denke das würde vielen von euch mit NVME Geräten helfen.

Gruß
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

ahcsas
Beiträge: 17
Registriert: 20 Jun 2011, 09:28

Re: [SOLVED] UEFI-Boot: near line 4: Unknown option

Beitragvon ahcsas » 24 Nov 2017, 13:14

Hallo,

wir haben das gleiche Problem. Nun habe ich mal timeout=2 in die elilo.conf geschrieben, dies hatte jedoch keine Auswirkung?

Die komplette Datei sieht nun so aus:

Code: Alles auswählen

timeout=2
default=local
label=local
root=/dev/sda1


Wo liegt der Fehler?
Und weil's thematisch passt: Ist es angedacht, auch bei UEFI-Boot ein Bootmenü wie beim klassischen PXE-Boot bereitzustellen?

Danke!
Viele Grüße
Sascha