pxe boot klappt nicht

rat
Beiträge: 264
Registriert: 01 Jan 2015, 12:40

pxe boot klappt nicht

Beitragvon rat » 24 Feb 2015, 16:50

Ich schon wieder :o :)

Nachdem ich jetzt die Installation komplett umgebaut habe, Debian habe ich runtergeschmissen 8-) dafür Ubuntu 14.04 Server installiert ;) und die Installation ist komplett durchgelaufen, :shock: so ganz ohne ein einziges Problemchen :o komme ich jetzt nicht weiter.

Ich bin nach dem Handbuch vorgegangen und habe jetzt den opsi-server fertig und die Installationsdateien von Win7-64bit eingespiellt set-rights ist auch gemacht, services neu gestartet und der Client hängt bei
PXE-E53: No boot filename received
Das Bootfile liegt unter /tftpboot/linux
Das File /tftpboot/linux/pxelinux.cfg/01-MacAdresse gibt es auch
label opsi-install
kernel-install
append initrd ..........

Was könnte jetzt schuld sein?
Zuletzt geändert von rat am 25 Feb 2015, 10:37, insgesamt 1-mal geändert.

Benutzeravatar
SisterOfMercy
Beiträge: 1213
Registriert: 22 Jun 2012, 19:18

Re: pxe boot klappt nicht

Beitragvon SisterOfMercy » 24 Feb 2015, 17:10

Try to disable selinux.
Bitte schreiben Sie Deutsch, when I'm responding in the German-speaking part of the forum!

rat
Beiträge: 264
Registriert: 01 Jan 2015, 12:40

Re: pxe boot klappt nicht

Beitragvon rat » 24 Feb 2015, 18:42

SELinux isn't installed and 'service apparmor teardown' doesn't make a different

Benutzeravatar
SisterOfMercy
Beiträge: 1213
Registriert: 22 Jun 2012, 19:18

Re: pxe boot klappt nicht

Beitragvon SisterOfMercy » 24 Feb 2015, 19:31

Is the DHCP server correctly configured?
Bitte schreiben Sie Deutsch, when I'm responding in the German-speaking part of the forum!

rat
Beiträge: 264
Registriert: 01 Jan 2015, 12:40

Re: pxe boot klappt nicht

Beitragvon rat » 24 Feb 2015, 20:16

I think so

My dhcpd.conf looks like:

ddns-update-style none;

option domain-name "my.domain";
option domain-name-servers "router-ip", 8.8.8.8;

default-lease-time 6000;
max-lease-time 72000;
authoritative ;

log-facility local7;

subnet 192.168.X.0 netmask 255.255.255.0 {
range 192.168.X.100 192.168.X.200;
option routers 192.168.X.254;
group {
next-server 192.168.X.248;
filename "linux/pxelinux.0";
}
}
use-host-decl-names on;




that's all

The subnet is from my net, the lease time is longer than default and the rest is originaly.
Zuletzt geändert von rat am 24 Feb 2015, 21:30, insgesamt 3-mal geändert.

Benutzeravatar
SisterOfMercy
Beiträge: 1213
Registriert: 22 Jun 2012, 19:18

Re: pxe boot klappt nicht

Beitragvon SisterOfMercy » 24 Feb 2015, 20:55

/etc/dhcp/dhcpd.conf contains these lines?

Code: Alles auswählen

filename "linux/pxelinux.0";
next-server opsi-ipaddress;


Firewall ports on the opsi-server are open?
Bitte schreiben Sie Deutsch, when I'm responding in the German-speaking part of the forum!

rat
Beiträge: 264
Registriert: 01 Jan 2015, 12:40

Re: pxe boot klappt nicht

Beitragvon rat » 24 Feb 2015, 21:03

I looked in the /var/lib/dhcp/dhcpd.leases, the MAC-Address from the Client was there with a time in the afternoon. Now i removed this file and there are only other client, but not the "opsi install client". :( If tested the network cable, it's ok. It's the same configuration witch worked three weeks ago.

karni
Beiträge: 193
Registriert: 08 Okt 2009, 14:07

Re: pxe boot klappt nicht

Beitragvon karni » 25 Feb 2015, 09:36

Der client kriegt pxelinux.0 nicht - der tftp Server findet die Datei wahrscheinlich nicht.

Es ist seltsam boot und config in zwei vershiedene Verzwichnisse. Ich glaube es soll dasselbe Verzeichnis für beides sein.
"Das Bootfile liegt unter /tftpboot/linux
Das File /tftpd/linux/pxelinux.cfg/"

Schau die logs messages/daemon.log
Schau welches Verzeichnis "root" für den tftp server ist.
Unter Debian ist /etc/inetd.conf
tftp dgram udp wait nobody /usr/sbin/tcpd /usr/sbin/in.tftpd --tftpd-timeout 300 --retry-timeout 5 --mcast-port 1758 --mcast-addr 239.239.239.0-255 --mcast-ttl 1 --maxthread 100 --verbose=5 /tftpboot/

Ich tippe das "root" Verzeichnis stimmt nicht. Ubuntu/tftpd haben ein anderes verzeicnis als "root"
Schau ob /tftpd/linux/pxelinux.0 existiert und das config von tftp server auf /tftpd/ zeigt

rat
Beiträge: 264
Registriert: 01 Jan 2015, 12:40

Re: pxe boot klappt nicht

Beitragvon rat » 25 Feb 2015, 10:04

Das bootfile liegt unter /tftpboot/linux/
Die Zeile in /etc/inetd.conf stimmt überein, nur steht bei mir kein abschließender Slash, ich habe ihn jetzt einmal hinzugefügt
Das daemon.log finde ich nicht
Den Ordnernamen (tftpboot) habe ich falsch geschrieben, ich habe es ausgebessert :(



Danke für die Hilfen

karni
Beiträge: 193
Registriert: 08 Okt 2009, 14:07

Re: pxe boot klappt nicht

Beitragvon karni » 25 Feb 2015, 11:51

Ich glaube der CLient erreicht den tftp Server nicht...
Schau im /var/log/daemon.log, bei mir steht:
Feb 25 11:23:14 atftpd[12275]: Serving pxelinux.0 to client-IP:2073

Wenn nicht, kriegt der tftp server kein request.

http://www.symantec.com/business/suppor ... =TECH10532
ignoriere 1 und 11 aber alle andere Möglichkeiten können zutreffen