update auf 4.0.5

klausvoelpel
Beiträge: 28
Registriert: 16 Dez 2009, 11:48

update auf 4.0.5

Beitragvon klausvoelpel » 20 Jan 2015, 07:59

Hallo Forum

(habe das schon mal gepostet aber versehentlich im englischen Forum)

ich habe das Problem das nachdem ich das update auf 4.0.5 gemacht habe der configed (version 4.0.5) sich von meinem Desktop pc nicht mehr mit dem Server verbindet.
Fehlermeldung: Dieser Konfigeditor benötigt einen opsi -server mindestens der Version 4.0.5 (gefunden opsi-server mit versiopn 4.0.3.1)

das Update habe ich mit:
aptitude update
aptitude upgrade
opsi-product-updater -i -vv
opsi-setup --set-rights
und einem Neustart gemacht.

Der Prozess lief ohne Fehlermeldung durch

da in den Releasenotes zum Update des Servers sonst nichts drinsteht weiss ich da Momentan nicht weiter.

wie kann ich denn den server so updaten das er sich mit dem neuen configed wieder verbindet

viele Grüsse
Klaus Völpel

klausvoelpel
Beiträge: 28
Registriert: 16 Dez 2009, 11:48

Re: update auf 4.0.5

Beitragvon klausvoelpel » 20 Jan 2015, 08:06

noch eine kleine Ergänzung:

[ing-lxs30]-NEU:/home/adminuser> dpkg -l | grep opsi
ii opsi-atftpd 0.7.dfsg-4 amd64 advanced TFTP server - opsi version with pcre, fifo and max-blksize patches
ii opsi-configed 4.0.5.1.8-1 all OPSI config editor
ii opsi-depotserver 4.0.5.11-1 all opsi depotserver configuration package
ii opsi-linux-bootimage 20140919-2 all opsi linux bootimage
ii opsi-utils 4.0.5.6-2 all opsi utils
ii opsiconfd 4.0.5.2-1 all opsi configuration service
ii opsipxeconfd 4.0.5.3-6 all opsi pxe configuration daemon
ii python-opsi 4.0.5.15-1 all opsi python library


also hier scheint alles in Ordnung zu sein aber ich kann mich nicht mit dem 4.0.5 configed verbinden

vg
klaus

Benutzeravatar
ueluekmen
uib-Team
Beiträge: 1892
Registriert: 28 Mai 2008, 10:53

Re: update auf 4.0.5

Beitragvon ueluekmen » 20 Jan 2015, 10:47

Hi,

kann es sein, dass du nach dem Update noch ein opsi-backup eingespielt hast?

Guck mal bitte in die Datei:

Code: Alles auswählen

/etc/opsi/version


wenn da 4.0.3.1 drinsteht, schreib da mal 4.0.5.15 rein und speicher ab.

Dann solltest du den opsiconfd noch mal neustarten und nochmal versuchen dich zu verbinden.
opsi support - uib gmbh
For productive opsi installations we recommend support contracts.
http://www.uib.de

klausvoelpel
Beiträge: 28
Registriert: 16 Dez 2009, 11:48

Re: update auf 4.0.5

Beitragvon klausvoelpel » 20 Jan 2015, 14:36

/etc/opsi/version <- da stand wirklich das falsche drin


jetzt gehts

vielen Dank

Klaus Völpel

Benutzeravatar
ueluekmen
uib-Team
Beiträge: 1892
Registriert: 28 Mai 2008, 10:53

Re: update auf 4.0.5

Beitragvon ueluekmen » 20 Jan 2015, 14:57

Hallo Klaus,

danke für die Rückmeldung. Wir haben ein Ticket dazu aufgemacht, damit das im opsi-backup gefixed wird.
opsi support - uib gmbh
For productive opsi installations we recommend support contracts.
http://www.uib.de