Installation opsi-client-agent fehlerhaft

ChrisBe3
Beiträge: 8
Registriert: 29 Feb 2012, 12:58

Re: Installation opsi-client-agent fehlerhaft

Beitragvon ChrisBe3 » 05 Mär 2012, 11:55

Hi,

Die Sektion ist auskommentiert. :roll:

Kann mir wirklich keiner einen Tipp geben wo ich suchen kann und wo ich eine FM auslesen kann?!?
Windows logs brachten nichts, Opsi Logs auch nicht.

Viele Grüße Chris

uncle_scrooge
Beiträge: 596
Registriert: 21 Feb 2012, 12:03
Wohnort: Mainz

Re: Installation opsi-client-agent fehlerhaft

Beitragvon uncle_scrooge » 05 Mär 2012, 13:52

Ich weiß nicht, ob es bei der Win7-Installation genauso ist, aber unter Server 2008 räumt OPSI nicht richtig auf, und läßt unter c:\tmp einen Hort an Informationen zurück.

Wenn dem bei Dir auch so ist, sollte sich dort unter anderem eine Datei postinst.scripts finden.
Diese sollte die Zeile '50_opsi-client-agent.cmd' enthalten.
Wenn vorhanden, sollte es auch eine opsi-client-agent.log und ggfs. eine opsi-client-agent.err geben.
Die wiederum können Aufschluß darüber gehen, was ggfs bei der Installation schief gelaufen ist.

Benutzeravatar
wolfbardo
uib-Team
Beiträge: 1157
Registriert: 01 Jul 2008, 12:10

Re: Installation opsi-client-agent fehlerhaft

Beitragvon wolfbardo » 05 Mär 2012, 18:08

Wenn bei der Windows 7 Installation der opsi-client-agent nicht automatisch installiert wird, so liegt es in der Regel an der angepassten

Code: Alles auswählen

custom\unattend.xml


Zur Reparatur folgendermassen vorgehen:

- custom\unattend.xml umbenennen und durch opsi\unattend.xml.template ersetzen
- Installation testen
- sukzessive eigene Anpassungen wieder einbauen ohne dass der Mechanismus zur Installation des opsi-client-agent bzw. der postinst-Scripte kaputtgeht

Gruss
Bardo Wolf


!!! ANMELDEN !!! opsi-Konferenz in Mainz am 02. / 03. März 2020 https://opsiconf.org

opsi workshops

https://uib.de/de/support-schulung/schulung/

Basis
23.-26.3.2020


opsi support by uib gmbh

http://www.uib.de

firephaser
Beiträge: 17
Registriert: 13 Mär 2011, 10:54

Re: Installation opsi-client-agent fehlerhaft

Beitragvon firephaser » 18 Nov 2012, 18:46

Hallo,

ich habe mich am Wochenende an Windows 7 unattend gewagt. Installation funktioniert und die eingegebenen Daten über die Properties werden angenommen. Ich hatte erst eine eigene unattend.xml und custom erstellt, da aber viele Parameter, wie lokal User und auch Opsi-Agent, nicht funktionieren, habe ich den obigen Tip befolgt.

Copy der unattend.xml von opsi nach custom , Rechte gesetzt und noch einmal neu installiert. Leider wird der Opsi-Client einfach nicht installiert. Was kann ich noch testen????

Gruß

Benutzeravatar
koepkek
uib-Team
Beiträge: 228
Registriert: 11 Jan 2012, 11:27

Re: Installation opsi-client-agent fehlerhaft

Beitragvon koepkek » 19 Nov 2012, 09:48

Hallo

die Win7 Installation läuft ansonsten komplett durch?

Bitte mal in die postinst.log auf dem Client schauen

c:\tmp\postinst.log

gibt es im selben Verzeichnis eine opsi-client-agent.log

Gruß
Karsten Köpke
opsi support - uib gmbh
For productive opsi installations we recommend support contracts.
http://uib.de
http://opsi.org

firephaser
Beiträge: 17
Registriert: 13 Mär 2011, 10:54

Re: Installation opsi-client-agent fehlerhaft

Beitragvon firephaser » 20 Nov 2012, 18:39

Es gibt auf dem Client nach der neuinstallation kein c:\tmp Verzeichnis.

Benutzeravatar
koepkek
uib-Team
Beiträge: 228
Registriert: 11 Jan 2012, 11:27

Re: Installation opsi-client-agent fehlerhaft

Beitragvon koepkek » 23 Nov 2012, 10:01

Hallo

bitte mal unter
/var/lib/opsi/depot/win7-abc/opsi ls -l
das Ergebnis sollte so aussehen
insgesamt 2476
-rw-rw---- 1 opsiconfd pcpatch 57 23. Mär 2011 diskpart.txt
-rw-rw---- 1 opsiconfd pcpatch 1920054 21. Aug 2008 opsibg.bmp
-rw-rw---- 1 opsiconfd pcpatch 159848 20. Feb 2009 opsimbr.exe
-rw-rw---- 1 opsiconfd pcpatch 353636 24. Jun 15:58 opsinetmount.exe
-rw-rw---- 1 opsiconfd pcpatch 1244 30. Nov 2010 postinst.cmd
drwxrwx--- 2 opsiconfd pcpatch 4096 18. Sep 17:24 postinst.d
-rw-rw---- 1 opsiconfd pcpatch 40960 16. Jul 2007 SetWallpaper.exe
-rw-rw---- 1 opsiconfd pcpatch 811 8. Aug 2008 SetWallpaper.txt
-rw-rw---- 1 opsiconfd pcpatch 798 21. Aug 2008 UAC_off.reg
-rw-rw---- 1 opsiconfd pcpatch 17116 31. Okt 2011 unattend.xml.template

in der postinst.cmd wird das c:\tmp Verzeichnis erzeugt

Gruß
Karsten Köpke
opsi support - uib gmbh
For productive opsi installations we recommend support contracts.
http://uib.de
http://opsi.org

firephaser
Beiträge: 17
Registriert: 13 Mär 2011, 10:54

Re: Installation opsi-client-agent fehlerhaft

Beitragvon firephaser » 23 Nov 2012, 15:19

Sieht gleich aus:

Code: Alles auswählen

-rw-rw---- 1 opsiconfd pcpatch   40960 2007-07-16 14:16 SetWallpaper.exe
-rw-rw---- 1 opsiconfd pcpatch     811 2008-08-08 13:40 SetWallpaper.txt
-rw-rw---- 1 opsiconfd pcpatch 1920054 2008-08-21 13:23 opsibg.bmp
-rw-rw---- 1 opsiconfd pcpatch     798 2008-08-21 17:47 UAC_off.reg
-rw-rw---- 1 opsiconfd pcpatch  159848 2009-02-20 14:53 opsimbr.exe
-rw-rw---- 1 opsiconfd pcpatch    1244 2010-11-30 16:29 postinst.cmd
-rw-rw---- 1 opsiconfd pcpatch      57 2011-03-23 15:35 diskpart.txt
-rw-rw---- 1 opsiconfd pcpatch   17116 2011-10-31 10:01 unattend.xml.template
drwxrwx--- 2 opsiconfd pcpatch    4096 2012-07-15 11:43 postinst.d

Benutzeravatar
koepkek
uib-Team
Beiträge: 228
Registriert: 11 Jan 2012, 11:27

Re: Installation opsi-client-agent fehlerhaft

Beitragvon koepkek » 30 Nov 2012, 12:04

Hi

Das spricht jetzt dann doch noch dafür das irgendwas an dem Paket defekt ist. Ich würde nochmal die unattend.xml kopieren. Wenn das nicht hilft, nochmal das win7.opsi-Paket auf dem Server installieren. Vielleicht hat die unattend.xml im opsi-Verzeichnis auch schon was abbekommen.

Gruß Karsten Köpke
opsi support - uib gmbh
For productive opsi installations we recommend support contracts.
http://uib.de
http://opsi.org

firephaser
Beiträge: 17
Registriert: 13 Mär 2011, 10:54

Re: Installation opsi-client-agent fehlerhaft

Beitragvon firephaser » 17 Dez 2012, 00:22

Ich konnte nun den Fehler finden.

In den Installationsdateien der Win7 war noch ein unattend... enthalten, so dass nach einem Reboot diese zog. Einfach gelöscht und schon funktioniert es.